Inactive [MECH] FalseBook 0.96alpha - CraftBook for Bukkit,85++ICs, Gates, Minecarts / MC1.4.6

Discussion in 'Inactive/Unsupported Plugins' started by GeMoschen, Mar 5, 2011.

  1. Offline


    FalseBook - Your CraftBook for Bukkit

    Current version: v0.96alpha
    Minecraft: 1.4.6

    Show Spoiler

    • supported Permissionplugins
      • bPermissions
      • bukkitPermissions
      • Essentials GroupManager
      • Permissions
      • PermissionsEx
      • SuperPerms
      • Vault (still in development)
    • uses the syntax of CraftBook for better compatibility
    • implements over 85 Integrated Circuits (ICs)
    • implements [Lift Up] & [Lift Down]
    • toggleable ...
      • ... bridges
        • undestroyable
      • ... doors
        • undestroyable
      • ... gates
        • undestroyable
      • ... areas
    • a lot of fancy features for minecarts
      • collect and deposit items from chests to minecarts
      • make furnaces which refill themselfs with minecarts
      • program carts to take only specific items out of chests
      • craft things out of a chest with a minecart
      • lift up & down for minecarts!
    • chatsystem with different chat-channels to clean up the normal chat
    • toggleable...
      • netherrack (with fire)
      • pumpkins
      • glowstone <-> another block (even if minecraft itself has the glowstonelamp now...)

    Minecart Blocktypes:
    Show Spoiler

    • BenchOut : Iron-Ore
    • Booster 2x : Gold-Ore
    • Booster 8x : Gold-Block
    • Brake-Block 25% :Gravel
    • Brake-Block 50% : Soulsand
    • Burn : Iron-Ore
    • ConstantSpeed-Block : Iron-Block
    • Craft : Iron-Ore
    • Deposit / Collect : Iron-Ore
    • Eject-Block : Coal-Ore
    • Emitter-Block : Lapis Lazuli Ore
    • Reverse-Block : White wool
    • Station-Block : Obsidian
    • Sort-Block : Netherrack
    • Teleport-Block : Lime wool
    • Program-Cart : Lapis Lazuli
    • Programmed Deposit-Block : Blue wool

    Other Features:
    Show Spoiler

    • Bridge (FalseBookBlock.jar)
    • Doors (FalseBookBlock.jar)
    • Gates (FalseBookBlock.jar)
    • Toggle Netherrack Fire (FalseBookExtra.jar)
    • Toggle Pumpkins (FalseBookExtra.jar)
    • Toggle Soulsand to Glowstone and back (my addition) (FalseBookExtra.jar)
    • ToggleAble Areas (Experimental):

      Define the area with the "Wooden Hoe" (use rightclick)
    • /farea <areaname> -> Adds an Area
    • /delfarea <areaname> -> removes an Area
    • /listfarea -> Lists all Areas
    • /fareatoggle <areaname> autosave -> toggles the autosave function of an area. Autosave = save blocks, when toggling the area off.
    • /fareatoggle <areaname> protect -> toggles the protection of an area. ON = Area is only destroyable/buildable to users with permission: falsebook.destroy.blocks
    • /fareaallow <areaname> id[:subid] -> will add/remove the blocktype from the toggleable blocks of this area. Default: all blocks will be toggled.
    • (FalseBookBlock.jar)

    Important Note:
    You must copy ALL jar-Files over the old ones (all files have been changed) !
    The "Package_..."-Files must go into "plugins/FalseBook/ICPlugins/"

    Download FalseBook 0.96alpha for Minecraft 1.4.6

    FalseBook Wiki - Work in progress

    YouTube-Channel with Videos

    Donations are welcome if you wish to support me


    Attached Files:

    cevio, Artem-s86, Dereku and 67 others like this.
  2. Offline


    Cant seem to figure this out. Making a bridge only allows 3 wide but in my config i have max 5 wide.
    I have tried


    With no luck. Mine updating the wiki with common bridge/gate formats please? All i can find is the advance IC stuff.
  3. Offline


    I can confirm the above issues.

    Bridge issues, and no redstone triggering bridges.
  4. Offline


    It's a bug with one of the latest Bukkit-Builds. It will try to unload the same chunks in every tick again and again and again... Bukkit needs to fix it.

    lol, sry but you have seen that I haven't read anything 'til now.. just change your AppleDropChance to 0.0 in the

    Take a look at " > Packages > Block > Bridges" ...

    Will look into it. Have you installed LWC? If so: is the sign private? If so: You need to make it non-private or set respectLWCProtections to false in

    I'll fix that! thanks :)
  5. Offline


    Hmm the chunk issue was not however happening on 0.92.3
    I have also reverted back to this version and all is perfectly fine - while on 0.93 chunks simply dont unload.
    This is very important as 0.93 pretty much renders the server useless. (We get a big amount of traffic)
  6. Offline


    mhh.. 0.92.3 is not having this issue. I'll look into that and fix it :)
  7. Offline


    Thank you very much :D
  8. Offline


    hey guys i like to report a Bug in 0.93 Version ( UNIX only )

    i have a plain Falsbook installation and the plugin have some problems to create the config files in the Falsebook folder.

    The Files are not stored in the directory because only in the microsoft-world we use a BACKSLASH to select a Folder.
    The rest of the World ... UNIX.. and the Internet (http,ftp and many more) use a normal FORDWARDSLASH! ^^

    nice bug ;)
    it is not Critical, it affects only the inital file-generation.
    efstajas and Pyker like this.
  9. Offline


    This bug will be fixed with the next release!
  10. Offline


    Bug: Lifts do NOT work beyond the old map height.

    Example: Place a [Lift Up] sign somewhere below the old map height limit. Place a [Lift Down] sign above the old map height. The [Lift Up] will NOT work, but the [Lift Down] will.
  11. Offline


    Do [Craft] signs in FalseBookCart not work in 0.93alpha, or is it just unfinished or something? I'm using #2052 and I get this:

    2012-03-10 12:38:13 [SEVERE] Could not pass event VehicleMoveEvent to FalseBookCart
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.EntityMinecart.G_(
        at net.minecraft.server.World.entityJoinedWorld(
        at net.minecraft.server.WorldServer.entityJoinedWorld(
        at net.minecraft.server.World.playerJoinedWorld(
        at net.minecraft.server.World.tickEntities(
        at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.NullPointerException
        at org.bukkit.craftbukkit.inventory.CraftInventoryCrafting.setResult(
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPreCraftEvent(
        at net.minecraft.server.CraftingManager.craft(
        at com.bukkit.gemo.FalseBook.Cart.Blocks.Craft.Execute(
        at com.bukkit.gemo.FalseBook.Cart.Blocks.MultiBlock.Execute(
        at com.bukkit.gemo.FalseBook.Cart.CartWorldSettings.executeMechanic(
        at com.bukkit.gemo.FalseBook.Cart.FalseBookCartVehicleListener.onVehicleMove(
        at sun.reflect.GeneratedMethodAccessor18.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        ... 10 more
    Another server I'm on uses #2034 and it's not working either.
  12. Offline


    Both bugs will be fixed with the next release.
  13. Offline


    I have a suggestion for a new ic!

    You know how the item vanish works? Maybe a mob despawning one. I know i need one of those.

    Also. Is there any API for creating ic packs?? Or anything... I would love to work on custom ic's
  14. Offline


    Not on :(
  15. Offline


    the permissions dont seem to be woking for the cart related stuff, 1.2.3 beta bild and Bpermissions everythingk wrks jsut fine so far
  16. Offline


    Let me know when you need the permission stuff with Vault tested again :)
  17. Offline


    I'm run the new FalseBook version on the 1.2.3-R0.1 bukkit beta (Build #02034).

    With following plugin's:


    All runs in good status for a beta build...

    The only thing who makes some troubleshoots its the Falsebook
    Ok it works.... more or less.....
    The transmitter/receiver works just horrible...... sometimes i can create one of this IC
    and many many othertimes i have to restart the gameserver,
    because the "run in good status" go lost without a trace and then.... nothing from thoose FBook features works.
    /reload crashing the FalseBook & AuthMe completly out many times.

    The transmitter/receiver problem is with connecting from MC1110 to MC0111
    I has make some "experiments" with this last night on my server and i have recognize that there are troubleshoots
    if 2 or more transmitter/receiver networks are in the same area or nearby. i have tried more then 100 variables for the name of those networks (in the 3. line of the sign) but it doesnt work (or better it just works one time during a test periode over more then five hours.

    The Troubleshoots comes more heavy if i create an experimental transmitter/receiver controlled "Gate"
    or some transmitter/receiver controlled MOB spawners. Extremly if there are more then one transmitter/receiver controlled things in a near area.

    So please give me some help or fix this fast i need this on my public server for our PVP/MOB Arena :)

    An other thing is that i have some more bukkit servers running on my root for different people....
    all has the same problem that only "OP's" can use or create lifts or bridges if the normal player should get access we have to redpower those features so then can everybody use it. We have search with more then 3 people for an cleary permission to integrate those futures for all players on our servers but we find nothing.

    An other hot problem is the redpower controlled lighting Glowstone......its a nice features in theorie but its the worst server killer i've ever seen ...for a few weeks a friend has create
    an "Club/Discotheke" with many strobe like "flakering" Glowstones.
    The Server runs with more then 8 GB DDR3 RAM on a OC i7k sandy bridge @ 4,0GHZ but since the beat geos on in this club is playing on this server a lag lag lag lag laggy matter.And if a unpowered glowstone/soulsand is emplaced in the bottom there is "no clip" @ the soulsand(unpowered glowstone)
    I have fix this a little bit by changeing the Block ID of the unpowered Glowstone to Netherreck or something but its still to heavy for my root :)

    and sorry for my horrible english it sux i know....
  18. Offline


    please make the option to only have the bridges gates and stuff
  19. Offline


    this options are already there!
    just navigate to your /minecraft_bukkit/plugins/FalseBook/%%YOURWORLD%%/
    folder and edit the 3 files within.

    Its simple to use only a part of Falsebook.
  20. Offline


    Redstone doesn't toggle the doors, bridges and gates anymore as it did before. What is wrong? (Currently using the 1.2.3 version)

    nevermind. It was that LWC plugin. Got it fixed

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  21. Offline


    nice okay thanks ill defenility use it now! :D
  22. Offline


    heyho, I'm currently looking for a plugin that switches the power status of the new redstone lamps from off by defaut to on by default. Is that possible with this plugin?
  23. Offline


    i had some serious lag issues today with 50 online, disabling falsebook reduced server load by over 50%, dont know what your plugin in this release is doing, but there is some issues there.

    ps running cb beta 1.2.3
  24. Offline


    Not sure if this was ever suggested before but could bridges and doors be altered to allow patterns?
    Example lets say Stone and Cobblestone are the used blocks and are both set to allowed in the properties.

    Stone: [1]
    Cobble: [2]

    Making a 3 blocks wide bridge like this:


    Or even this:

    I would allow some fancier looking doors and bridges =)
  25. Offline


    Moin gemoschen ich kriege immer wenn ich ein MC1241 oder MC1240 create eine fehlermeldung im log außerdem funktioniert das IC dann auch nicht wäre cool wenn du mir helfen würdest.
    at net.minecraft.server.MinecraftServer.w(
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    at com.bukkit.gemo.FalseBook.IC.ExecutionEvents.ICExecutionEvent.Execute(
    at com.bukkit.gemo.FalseBook.IC.ICs.worldedit.MC1240.Execute(
    java.lang.NoSuchMethodError: net.minecraft.server.EntityArrow.a(DDDFF)V
    05:48:51 [WARNING] Task of 'FalseBookIC' generated an exception
    PS: die log ist Falschrum ich weis;)
  26. Offline


    Just wondering why the commandsender IC doesn't send commands properly through the console?, when i run the command i want through the console it works, but the commandsender IC fails.?
  27. Offline


    CB2060 and the FalseBook here for 1.2.3 No IC's Works I have existing Delayers from 1.1 but when I re place the sign with and put [MC2100] on second line it does not even register that I placed the sign. Lifts and things work besides fact they only work from 0-128 but I know that's being fixed in next release.

    Strange Seems to be working again I replaced the jars with fresh ones and it works but file sizes did not change I swore I was using latest ones to begin with.
  28. Offline


    the config files are being generated outside of their subdirectories in linux

    ie: world\ is actually a file named "world\" in the root fallsebook directory and not in the FalseBook/world directory.

    falsebook is looking for these files and is not finding them.

    2012-03-12 09:56:36 [INFO] [FalseBookBlock] Enabling FalseBookBlock v0.93alpha
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] Error while reading file: plugins/FalseBook/world/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] regenerated file: plugins/FalseBook/world/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] Error while reading file: plugins/FalseBook/world_nether/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] regenerated file: plugins/FalseBook/world_nether/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] Error while reading file: plugins/FalseBook/world_the_end/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] regenerated file: plugins/FalseBook/world_the_end/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] Error while reading file: plugins/FalseBook/world/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] regenerated file: plugins/FalseBook/world/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] Error while reading file: plugins/FalseBook/world_nether/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] regenerated file: plugins/FalseBook/world_nether/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] Error while reading file: plugins/FalseBook/world_the_end/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] regenerated file: plugins/FalseBook/world_the_end/
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] 0 Doors successfully loaded.
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] 0 Areas loaded.
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] 0 Bridges successfully loaded.
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] 2 Cauldrons successfully loaded.
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] 3100 Books loaded!
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] 0 protected gateblocks successfully loaded.
    2012-03-12 09:56:36 [INFO] [ FalseBook Block ] FalseBookBlock v0.93alpha by GeMo enabled
    i also noticed that a Falsebook directory with 3 empty subdirectories has been created in the server root directory.
  29. Offline


    Thanks for this plugin! This is the best plugin what i used ever! ;D
  30. Offline


    same here looks like a problem with "\" being used instead of "/" on linux when generating the files and paths
  31. Offline


    SAME ISSUE.. helpz.. :'(

Share This Page