Inactive [MECH/EDIT] LyTreeHelper v2.5.1 - LyTreeHelper 3 is coming!

Discussion in 'Inactive/Unsupported Plugins' started by DarkLiKally, Mar 7, 2011.

  1. Offline


    LyTreeHelper v2.5.1 - LyTreeHelper 3 is coming!

    LyTreeHelper is now on BukkitDev!

    I've started developing version 3 of LyTreeHelper.
    I will rewrite the whole project and add some really cool new features! :)

    If you're interested in helping me out developing this plugin, please contact me ;).

    You can find the new changes and the whole changelog for 3.0 on github (Link below).

    I've found back to the bukkit forum after a long stressful time and have read the many requests for an update of LyTreeHelper.
    So I decided to try to update (maybe rewrite?) LyTreeHelper, but I can't do it alone. I need some help.

    If you want to take part in the development process of LyTreeHelper, please let me know.
    If you have no programming knowledge, you can just make feature suggestions, just post them in this thread or create a ticket on Github.

    Thank you for your support, help and for using my plugin.

    Planned for LyTreeHelper 3:
    (Under Progress - Maybe 70 % done) - Rewrite the whole plugin
    (60 % Done) - Custom world populator (add custom trees saved in the MCEdit schematic format and insert them only in specific biomes, e.g. palms on beaches)
    (Done) - New simple and highly configurable configurations system
    (Done)- Enhanced permissions system (using Vault, same for economy)
    - Some more developers? :) I can't do it alone, because I've only a few hours in the evening to develop
    (Done) - Switch to Maven

    Download the latest version of LyTreeHelper from (02/06/2011 16:46 GMT +1)
    (Or this direct link)

    LyTreeHelper Features

    • Custom drop features - LyTreeHelper lets you add custom drops to leaves (Maybe, sticks? :) )
    • Full customizable drop system - Adjust the drop chances for each drop (apples, golden apples, leaves, saplings, ...)
    • Timed apple drops - Apples falling from trees? Yes, you can have this feature ;)
    • Easy to handle multiworld-support - Each world has it's own configuration file, which settings overrides the global settings, so you can setup LyTreeHelper for each world with your custom settings
    • Tree destruction - Cut that damn trees by destroying the ground connection
    • Powerful forest and tree generator - LyTreeHelper comes with a powerful great generator for forests and trees, you can generate every kind of tree or forest in minecraft
    • Full permission support - You can use each permission system which is supported by Vault (
    • Full economy support - You can use any economy system supported by Vault (, so let your members pay for destructing trees at one hit
    • Custom world populator - LyTreeHelper's powerful world populator uses MCEdit schematic files to populate your world(s) with custom trees, e.g. palms, only in specific biomes (e.g. palms on beaches)
    • Mob Spawn in trees after destruction - Harvesting whole trees by removing the ground connection is great, but too easy? Let creatures spawn inside the chopped tree

    Github repository:

    You can find the changelog on github, simply open CHANGELOG.txt.

    Having Trouble?

    Use the Issure Tracker on Github.
    Hiramas, Phaedrus and Flobi like this.
  2. Offline


    This also auto-replants saplings, right?
  3. Offline


    Hi All!
    Having trouble with the leaf decay... placing leaves that are too far away from a log (while leaf-decay is off) results in the instant destruction of the leaves and tons of "server overloaded" messages (even if only one leaf is destroyed).
    Tested with the lates rec. build (#860) and LTH 2.5.1 on a server with no plugins (I set up a new one to try if it would work). Leaf decay is off, fast leaf decay is off.
    Update: Had to take the plugin out, doing what I just described is totally crashing the server even after restarting, but I am able to precise this a little: I am not absolutely sure but it seems like this is caused by placing leaves in mid-air without any blocks around.
    Have fun,

  4. Offline


    @rbos @DJAddi I'll take a look at the code tonight and see what I can do to fix these issues. DJAddi, if I understand it right it only happens when you "place" leaf blocks far away from the trunk?

    @CoolOppo It doesn't look like it. I'll see what I can do to re-introduce this feature though. I know DarkLiKally took it out because of a bug, but other plugins are doing it successfully now, so it might be fixed.
  5. Offline


    I tried a few things with other world editing tools (plugins and singleplayer mods) and yes, it seems like placing a leaf block without connection to other blocks causes its instant destruction (btw: the drops work correctly if it gets destroyed).
    Have fun,

  6. Offline


    I will add functionalities to the algorythm so that it cancels the destruction if there is no leave in the tree or conencted to a log
  7. Offline


    could you add a command to turn it off, like when i made a tree and i misplaced a log it took it all down XD
  8. Offline


    I am working on some new commands, like mammoth trees, a tree brush (you can paint trees/forests from far away on the map), editor sessions (it enables you to undo commands while you are logged in the same session or to disable/enable lytreehelper for yourself in this session) and some more new features (e.g. auto plant a sapling)
  9. Offline


    Can u help me? I can post anything other then the prob because idk what's cause it. in my permission i have

    But yet on that group it doesnt let them destroy a tree? D: what other permission do they need?

    - lytreehelper.destroyall
    - mywarp.warp.basic.list
    - mywarp.warp.basic.welcome
    - mywarp.warp.basic.delete
    - mywarp.warp.basic.createprivate
    - mywarp.warp.basic.createpublic
    - mywarp.warp.basic.warp
    - localshops.manager.set.owner
    - localshops.manager.set
    - localshops.manager.remove
    - localshops.manager.move
    - localshops.manager.destroy
    - localshops.manager.create
    - localshops.manager.add
    - mywarp.warp.soc.*
    - localshops.user.sell
    - wolfpound.use
    - craftbook.mech.ammeter.use
    - craftbook.mech.light-switch
    - craftbook.mech.gate
    - craftbook.mech.cauldron
    - craftbook.mech.bookshelf.use
    - craftbook.mech.bridge
    - craftbook.mech.elevator
    - craftbook.mech.elevator.use
    - OwnBlocks.add
    - OwnBlocks.use
  10. Offline


    Which version of craftbukkit, lytreehelper and permissions are running on your server?

    If you're using Permissions 3.x, the latest recommended Craftbukkit build, I think there are some bugs with Permissions, I've no time at the moment to test it, but I run a Server with craftbukkit #860 and Permissions 2.7.3 (I think) and all features work as expected, but I will test it with the latest permissions and some colleagues today.

    Thank you for your report! :)


    I've checked it and it works perfectly, craftbukkit #860, latest permissions and latest lytreehelper.

    If you're switched from the older permissions to 3.x, have you updated the permissions files? there are huge changes between the versions.

    or try - 'lytreehelper.destroyall' (for alle your permissions) instead of - lytreehelper.destroyall
  11. Could you make a separate download for leaves decay? Thats the only thing i wanted.
  12. Offline


    I second this post. I'm looking for a simple mod that only disables leaf decay. There is one in existence but it simply doesn't work and the developer doesn't seem to provide any information on it or reply to his thread.
  13. Offline

    Geoff Winans

    Is LyTreeHelper supposed to catch player-placed logs?

    A user of mine was trying to build a log frame (log, log:1 and log:2 tried). Each time he busted the ground-connecting block, all the blocks attached to it broke off.

    This may be an important thing to look for/track in some way.
  14. Offline


    At the moment I don't plan to provide downloads for single features.

    The next version includes a check for leaves-blocks, so that the destruction stops if there is no leaves-block in the set of blocks.
    If you know how to build LyTreeHelper, you can build the version from github, the changes to destroy only with leaves-blocks are already pushed
  15. Offline


    14:26:25 [SEVERE] java.lang.NullPointerException
    14:26:25 [SEVERE]       at net.darklikally.LyTreeHelper.commands.CommandLyforestdb.handle(CommandLyforest
    14:26:25 [SEVERE]       at net.darklikally.LyTreeHelper.LyTreeHelperCommands.onCommand(LyTreeHelperComman
    14:26:25 [SEVERE]       at org.bukkit.command.PluginCommand.execute(
    14:26:25 [SEVERE]       at org.bukkit.command.SimpleCommandMap.dispatch(
    14:26:25 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    14:26:25 [SEVERE]       at net.minecraft.server.NetServerHandler.handleCommand(
    14:26:25 [SEVERE]       at
    14:26:25 [SEVERE]       at net.minecraft.server.NetServerHandler.a(
    14:26:25 [SEVERE]       at net.minecraft.server.Packet3Chat.a(
    14:26:25 [SEVERE]       at net.minecraft.server.NetworkManager.b(
    14:26:25 [SEVERE]       at net.minecraft.server.NetServerHandler.a(
    14:26:25 [SEVERE]       at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    14:26:25 [SEVERE]       at net.minecraft.server.MinecraftServer.h(
    14:26:25 [SEVERE]       at
    14:26:25 [SEVERE]       at
    This is what I get when trying to use /lyforestdb list. CB 860 LyTreeHelper 2.5.1
  16. Offline


    Thank you for the report. I will fix it for the next release.
  17. Offline

    Jazy Lopez

    I seem to be having a problem, My craftbukkit is the lates build (935 or something) and I have latest permissions 3.x and mcmmo. When I destroy the bottom block of the tree it doesnt destroy it SOMETIMES, it looks like a random thing that occurs 1 out of 3 times. Not sure why it is but I've tried all senarios and it turns out the same... I don't think I have any plugins that may be interfering
    I also have WorldEdit and WorldGuard

    Please help or update, Love the Plugin though
    Thanks :D
  18. Offline


    No console errors?

    I much prefer your /bigtree command to others. Is it possible to make a birch bigtree? Or is that something that would have to be from the minecraft engine native? We just really like the birches best.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  19. Offline

    Jazy Lopez

    Nope... But it seems to be happening with trees that were in the server before the plugin or something similar, because when I plant a tree, use bone meal, then chop it the plugin kicks in perfectly every time...
  20. Offline


    Whoops, now it is happening here. We are running 935. Is this supposed to work if Residence is installed? No big deal if not, since I can't get it to work for all users anyway. Will do more testing. Had to try to chop a few trees, but none of them dropped, all weren't touching anything but ground, and only one was inside a residence.
  21. Offline

    Jazy Lopez

    Alright I tested somemore with other secnarios and the plugin works fine (Note: I have the tree radius at 50). Although if there are 2 or more trees touch each other, it will not pop till you chop the bottom of all of them OR chop the bottom of one and break the leaves touching the others. Also if the tree's leaves are touch tall_grass/a flower the tree won't pop till those leaves touch are destroyed.

    So technically the plugin is working fine, it just needs to run some checks in the code for those things since they are the only thing preventing trees from poping

    :D Great Plugin!! [diamond][diamond][diamond]
  22. Offline


    The check for flowers/mushrooms/tall_grass are already inthe code for 3.0 (see github ;) ).

    It is possible that the tree destruction stops because the maximum tree size check triggers. In this case (if you need it) increase the max-tree-size but read the warnings in the config first!
    Currently I'm using the tree algorythms from minecraft itself, but I'm currently working on some new tree algorythms like mammoth trees and something that way.
    If you wish, I will add an algorythm for a big birch. Thank you for your suggestion.
  23. Offline

    Jazy Lopez

    When you say maximum tree size, do you mean put the maxradius to 0? or something like 100?
  24. Offline


    Changelog Update 1.7
    so we don't need the LyTreeHelper feature more :)
  25. Offline


    No, max-tree-radius and max-tree-size are different things ;) tree radius means the radius around the chopped block and tree size means the max amount of blocks a tree can have.
  26. Offline


    Has this been updated for 1.7_02?
    I started with it yesterday and found this plugin is amazing.
  27. Offline

    Jazy Lopez

    Works perfectly with 1.7_02 :D
  28. Offline


    how do i make it so all player can cut down a tree by taking out its supports
  29. Offline


    Auto-plant Dropped Saplings would be great as an option :)
  30. Offline


    I would love that :D
  31. Offline


    i'm still having spamming issues with your Problem.
    2011-07-07 07:13:52 [SEVERE] Could not pass event BLOCK_BREAK to LyTreeHelper
        at net.minecraft.server.ChunkProviderServer.getChunkAt(
        at org.bukkit.craftbukkit.CraftWorld.getChunkAt(
        at org.bukkit.craftbukkit.CraftWorld.getBlockAt(
        at org.bukkit.craftbukkit.block.CraftBlock.getRelative(
        at net.darklikally.LyTreeHelper.LyTreeHelperBlockListener.destroyTreeWoodOnly(
        at net.darklikally.LyTreeHelper.LyTreeHelperBlockListener.destroyTreeWoodOnly(
        at net.darklikally.LyTreeHelper.LyTreeHelperBlockListener.destroyTreeWoodOnly(
        at net.darklikally.LyTreeHelper.LyTreeHelperBlockListener.destroyTreeWoodOnly(
    and so on (about 1k Lines or so).

    Chopping a 4 Wood high tree without any sidearms.

    max-tree-size: 1600
    max-tree-radius: 0
    enable-high-stack-size: off

    Any ideas on this issue?

    CB: This server is running Craftbukkit version git-Bukkit-0.0.0-904-g9277096-b953jnks (MC: 1.7.2)
    LyTH: [LyTreeHelper] LyTreeHelper 2.5.1


Share This Page