Inactive [MECH/DEV] ItemCraft 1.6.6 - Support for client mods in Bukkit [1060/1000]

Discussion in 'Inactive/Unsupported Plugins' started by asdaarg, May 3, 2011.

  1. Offline




    ItemCraft is a Bukkit mod that allows adding new item and block types, crafting and furnace recipes, and custom tree generators and more. Using a Modloader and SettingsGUI interface it allows subplugins known as ICPlugins to be loaded to support client mods. ICPlugins can be created by translating a client mod using the ICTranslator ICplugin. Using a ModloaderMP interface (ported by krnlyng/liar) it allows porting multiplayer mods to bukkit.

    • Add more Block types
    • Add more Item types
    • Add more Entity types
    • Add more TileEntity types
    • Add more Crafting recipes
    • Add more Smelting recipes
    • Add more Tree generators
    • Ported ModLoader interface
    • Ported ModLoaderMP interface
    • Fake GUIAPI Settings interface
    • Startup file for configuring plugins and making simple blocks and items

    Installation & Usage:
    • Back up your world(s). Just in case.
    • ItemCraft.jar goes in same folder as craftbukkit
    • IC plugins go into ItemCraft/ICPlugins folder under craftbukkit. (folder is autocreated the first time)
    • uncomment (remove #) in front of all plugins you want to use in plugins.ics (autocreated in ItemCraft/ICScript)
    • Make sure you have the recommended version of craftbukkit in the title - since this is a mod of that version in particular.
    • Delete/rename the META-INF folder inside craftbukkit-0.0.1-SNAPSHOT.jar (Use some decent zip program (e.g. 7zip) that can do it.)
    • All players on the server needs to have the client mods installed
    • If you use the 16 bit entity id packet mod (in case you use new entites (only ICMCreatures need it)), All players need (flan's unofficial) ModLoaderMP client mod
    • All players also need the 16 bit entity id packet mod (overwrites a ModLoaderMP's class so make sure ModLoaderMP is installed first) in case you use new entites (only ICMCreatures need it) If decide not to use the packet mod, you can turn it off putting this in your startup file: false setEntityIDPacketMod
    • Sometimes you get block/item ID conflicts, between plugins. You then need to set the conflicting ids in the startup script using setID command: example. They have to be set before the plugin that uses them is loaded. Note also that there is typically a props file on the clientside you have to edit the ids on to be the same as well.
    • To start:
      • Windows:
        java -Xmx1024M -Xms1024M -cp ItemCraft.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
      • Others:
        java -Xmx1024M -Xms1024M -cp ItemCraft.jar:craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
      IF You do not understand how to install this follow THIS link! Also Try:

      ItemCraft Forum
      ItemCraft Wiki


      Installation instructions changed since 1.5

      For Minecraft 1.7.3

      Inofficial ItemCraft update by Syrome1.6.6 (#1060)
      ItemCraft 1.6.5 (#1000)
      QwertyPower files (ICSGlass, ICFancyPack addons and more...)
      o4kapuk 16 bit packet mod Does not work without (flan's unofficial) ModLoaderMP client mod.
      ICKSlopes - support for Kaevator SuperSlopes
      ICNTrees - support for Nandonalt's Trees mod. Details regarding use Ignore ScotTools or you will have problems breaking various blocks
      ICFancyPack - support for ChocolateySyrup's FancyPack unofficial update for 1.7.3 mod Details regarding use of potted plants IDs and settings
      User ported mods list maintained by icephantom

      For Minecraft 1.6.6

      ItemCraft 1.4.5
      ItemCraft 1.5.1 (for use with planes)

      ItemCraft 1.3.5 (for CB #818)
      ICSGlass - support for ChocolateySyrup's Stained Glass unofficial update for 1.6.6 mod
      ICFancyPack - support for ChocolateySyrup's FancyPack unofficial update for 1.6.6 mod Details regarding use of potted plants Also be sure to read: Release notes Does not work well and not at all with the newest FancyPack update(v6) Wait until client is stable.
      ICKSlopes - support for Kaevator SuperSlopes
      Usage notes
      ICNTrees - support for Nandonalt's Trees mod. Details regarding use
      ICMCreatures - Support for DrZhark's Mo's Creatures
      16 bit entity id packet mod
      User ported mods list maintained by Asymetrikon

      Dev tools:
      ICTranslator - How to use

      Source and old versions

      ICScript documentation

      Frequently Asked Questions

      Tutorial on how to make your own blocks also list of block and item IDs in most popular mods.

      Suggestions of mods to port
      Vote here not in this thread anymore (it gets lost in all the other stuff)

      Reporting errors:
      • Read known issues - don't report those.
      • State the version of CB, ItemCraft and ICPlugin(s) you have problems with
      • If your client crashes, start the client from command line so that you get the error report.
      • Make sure the mod(s) works in SSP First before you report any errors here.
      • You are more likely to get a response if you describe the problem in more detail and do some testing yourself first of under what circumstances it occurs
      • Do not ask for uploads of minecraft.jar.
      • Do not pm me.
      • If you have problems installing, you are likely doing something wrong. Make sure you've followed the instructions exactly, read the FAQ and Wiki. If that doesn't work you can always ask in the thread, while I will likely not reply, there are others who can help you with your problem. But at least try to get it working yourself first.

      That said, I want to thank all who have helped users with their problems. In particular special thanks to icephantom and Asymetrikon for their big efforts in this. Also a special thanks to xeronut for being generally helpful.

      Changelog: (open)

      • Inofficial update by Syrome to support CB #1060 and ModloaderMp v1.7.3v4.
      • Added changes by krnlyng/liar to support buildcraft
      • Inofficial updated by Qwertypower to support CB #1000
      • Fixed Generators not working since ModLoaderMP merged.
      • Added option to turn off packet230 being sent to clients: false setPacket230OnLogin
      • @QwertyPower's unofficial update to 1.7.2 and 1.7.3.
      • Fixed issues with ICPlugins not being able to use ModLoader methods obtained through relection.
      • Merge with @krnlyng/liar's translated vesion of SDK's ModLoaderMP
      • Added dummy method RegisterTileEntity to fake modloader.
      • Added dummy methods AddArmor and getUniqueSpriteIndex to fake modloader.
      • ItemCraft commands are now loaded automatically and can be used in init.ic
      • Fixed nonesense message when parsing a string and EOF is found after escape character.
      • Platform independent line breaks of autocreated files
      • added some stuff in the autocreated file
      • Fixed unupdated mod causing problems for other plugins accessing the enum's constants for new block ids 1.6.
      • Removed spam on use command
      • Fixed java method invocation
      • Added javamethod invocation of declared methods
      • Fixed pop removing 2 elements off stack
      • putsetting command, allowing editing settings using new script
      • putvar and getvar commands allowing use of variables in scripts
      • added if command, conditional execution of closures
      • ishidden, isCustomType and getCustomType commands
      • exec command, allowing execution of closures. Acts as function calls.
      • while command, for while-loops, execution of closures.
      • Annotation of non-standard methods allowing correction of semantics during parsing with methods that manually alter type info. (needed for for loops, and various stack commands (such as popall, push, pull,dup, casting, getvar, all that do not have a static type signature) to have any usefulness beyond execution using GUI.
      • added casts
      • Fixed setEntityIDPacketMod demanding a this pointer.
      • Fixed boolean constants missing.
      • Updated to CB #860
      • GUI is now off by default
      • Fixed illegal access of Item constructor and other methods
      • 16 bit Entity Id Packet mod can now be turned off
      • Added file loading functions that use filename rather than file class for Fileman, for use with Janino
      • Fixed intellisense being screwy, showing previous context
      • Fixed castability test of primitive types to primitive types being screwy
      • Fixed selected method in context view not being visible (scrolled down/up to).
      • Fixed array bounds error
      • added intellisense (context box showing sorted list of all applicable methods in context at cursor position, as well as selecting the one closest matching)
      • added tooltips showing documentation both in command box and in the context (list) box
      • added getmaterial method to get Minecraft's materials
      • added documentation to most methods.
      • removed some obsolete methods
      • renamed some methods
      • remove NAME: spam on classloaderlclass, 1,2,3 4.. spam and vs: spam
      • fixed classloaderlclass leaving junk on stack
      • fixed getconstructor (?)
      • fixed right square bracket without left square bracket not resulting in parse error
      • fixed parse to fail due to right bracket not yielding an array type
      • removed autocreate double spam
      • ics extension changed to ic (conflicting with korganizer and iCalendar)
      • moved plugins into plugins.ic (since it now doesn't execute "use" until it parsed the whole file, it doesn't
      • recognize ItemCraft functions in init.ic)
      • added setID
      • added back support for old file format using includeold
      • fixed execution of abstract script calling providing arguments in wrong order
      • ICScript is now completely converted into postfix
      • Completely rewritten script parsing and execution code
      • Math functions should work now
      • Scripts Are not executed until fully parsed
      • ICS now support direct invokation of java functions when no ICS function matches a call
      • ICS now support arrays
      • ICS now support closures (for later support for menus, functions, loops, conditionals)
      • Parser produces Abstract code that runs much faster, than when having to parse each time to execute code.
      • Pre 1.0-style startupfile scripts are no longer supported (for now)
      • Warning of Block loss with prompt to quit CB on any error during parsing
      • Warning of Block loss with prompt to quit CB if startup script file was not found and was autocreated. This way you can have it autocreate it safely without having to worry about loss of blocks during upgrade.
      • Detailed error reports during both parsing with line number and column and during execution.
      • added simple math functions
      • added basic string and character functions
      • fixed methods popping more than one element
      • fixed dup not duplicating
      • added primitive classes
      • added parsing of primitives as primary commands
      • added parsing of strings as primary commands
      • fixed identifier after a string being misparsed
      • fixed popup menus not working in windows
      • added methods to get icplugins and their classloaders
      • added methods to get constructors and invoke them
      • Implemented new functional script language ICScript
      • Implemented GUI
      • inclusion of files (so you can split up startupfile in smaller files)
      • loading plugins on the fly
      • executing any script commands on the fly using GUI
      • exploring variables and functions of objects in GUI
      • invoke any functions, private or public, on any class loaded in IC/ICPlugins/minecraft/CB/any bukkit plugins
      • Built in text editor (was going to be for editing java code)
      • Removal of blocks, entities and items, even on the fly
      • Adding new blocks, entities and items on the fly
      • Specify what entities spawn in what biomes and how frequently.
      • Customizable programmable menus per node type in GUI
      • IC now retrieves version number both for plugins and itself automatically and reports it when plugins are loaded
      • fixed mimic having target object mimic itself.
      • fixed invokation on wrong object when interacting with mimiced block
      • fixed setint setting a string and not an int
      • fixed case sensitivity of block parameters
      • fixed some other bugs related to block parameters
      • no more commas assigning multiple values in block parameters (because I'm lazy)
      • Mobs that are unspawnable don't crash the server anymore
      • Added new startupfile commands: blocks and entites
      • Added new startupfile commands: setbool, setint, setfloat, setdouble, that allows changing the settings of mods that use GUIAPI (nandonalt trees and mo's creatures)
      • fixed various bugs with craft command in startup script
      • removed debug spam on id command
      • fixed comments causing "unknown commands" in startup file
      • cleaned up unnecessary stuff from error report
      • fixed skip skipping over the next line too
      • Implemented modloader removespawn (could that have anything to do with the watermob problem?)
      • fixed unknown command spam on empty lines
      • fixed some bugs with craft command in startup file manager.
      • Fixed kicked when horse throws you off because of accessing protected field
      • Fixed problems adding recipes, tile entites, entites using API.
      • added items command for debug purposes
      • added a copy of spawncreatures to the mod, no idea if that will solve the issue with sharks crashing server.
      • Mimic feature of block allows block to mimic other blocks, fully or in some respect (useful to customize blocks beyond the fixed values from startup file)
      • back to start from craftbukkit folder; its no longer a plugin
      • IC plugins go into ICPlugin folder now in craftbukkit folder. These are to avoid problems caused by plugins being reloaded by CB
      • usedefaults on by default
      • fix item 0 is not valid item spam
      • implemented Modloader getUniqueEntityId,RegisterEntityID,setPrivateValue
      • implemented various SettingsGUI widgets facades, and SettingFloat, SettingsMulti
      • script pauses when error occurs to avoid startup with wrong settings
      • Items are also registered as dummy, to avoid error spam by other plugins
      • Modloader world generator interface for normal type worlds implemented
      • Barebones fake GUIAPI interface that loads default settings (might add ability to modify options through startup later)
      • Added fix for blocks not having dummy material in ICFancyPack that inherit the Block class directly
      • Dummy id changed to 255
      • Added support for Entities in API
      • Added support for adding mobs to biome spawnlist in API
      • Added support for adding tilentities in API
      • Added fake modloader for to interface with translated mod plugins
      • Added more detailed output when plugin loading fails.
      • Backward incompatible update to 766
      • Added ability to set data on input items in crafting recipe
      • Added ability to comment in startup file with #
      • Added more error handling.
      • Fixed unable to craft out of nonblocks
      • Added more error handling
      • Partial support for GUIs
      • Mod for custom tree generation
      • Custom Tree generation API
      • Custom Tree generation startup file instructions:tree,treebiome and biometreedensity
      • Added mod of org.bukkit.Material to accomodate new block types, should reduce at least some errors other plugins have.
      • Fixed Item id being offset by 256
      • Fixed startup script created Blocks not being added to item list
      • Added more error handling
      • Fixed ItemCraft not starting because of spaces in the path on windows machines
      • Fixed regexp error on windows when starting as plugin
      • More error handling added
      • Fixed freeze when adding new block properties using startup script
      • Now doubles as plugin, so you can start it as a plugin rather than a mod
      • Startup file autocreation
      • loud startup file instruction- prints out more info at startup
      • a whole lot more error handling
      • fixed bug not being able to load any other plugin that KSlopes.jar (what am I thinking)
      • Most if not all simple constant Block properties now definable from the startup file.
      • Better error handling
      • More complete Block API
      • Syntax correction
      • Initial Release
      • Made compatible with IC 1.0
      • Syntax correction
      • More information on startup
      • Fixed slopes and corners dropped having wrong data.
      • Initial Release
      • Introduced options to change settings and IDs
      • Disabled new bookshelves
      • Updated for 1.7.3
      • Fixed another NPE on startup
      • Fixed NPE on startup
      • Updated to unofficial version of 1.6.6
      • changed class path for flower, cactus and reed
      • Fixed not able to place in potted plants
      • Fixed blockcycler interaction
      • Added potted plants
      • Initial Release
      • Updated to 1.7.3
      • Fixed static construction of objects problem
      • Fixed no tree generation
      • updated to 1.6.6
      • fixed clicking on bananacake blocks, fruit leaves
      • fixed using fertilizing
      • fixed activating banana cake
      • Initial Release
      • Updated to 1.6.6
      • Made everything public and even added a public ()V constructor in water mob class (no idea if that will solve it though)
      • Says its loaded on startup when its loaded
      • Initial Release
      16 Bit Entity ID Packet Mod
      • Supports both 16 bit and 8 bit servers
      • Initial Release
      • Fixed conflict with glass bug
      • Initial Release
      • Fixed no output on windows machines.
      • More informative about files to translate not being found.
      • Made it tolerate there being no file separator at the end of retroSource.
      • Removed some spam.
      • Added checks that make sure you have all the necessary maps specified, when you translate.
      • Initial Release
      • Update to 1.7.3
      • Initial Release

      Donate (Not necessary but appreciated)
  2. I have tried what you said - obviously you have done more testing than me because you are correct - the direction of the road matters, only north / south works, the other direction will not speed you up, but hey, something I can live with. It works well otherwise.

    As for the change in ID's, I think its Notch's update with trapdoors and shrubs that may have caused this issue - there is no way to get your blocks back that I know of. Some users have been saying they've seen trapdoors where they had fancypack blocks before. I think its 'bite the bullet' time and accept that its time for a rebuild.

    OK, I've managed to recreate this problem - it appears to be being caused by the fact that you are not running
    ICKSlopes on your server, but you do appear to have successfully installed it on your client.
    You can check which Itemcraft plugins are running when you start your bukkit server by looking at the following lines :

    01:05:39 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-827-
    g57d9687-b867jnks (MC: 1.6.6)
    01:05:39 [INFO] class com.asdaarg.bukkit.itemcraft.ICS
    01:05:39 [INFO] ItemCraft 1.3.8
    >01:05:39 [INFO] class com.asdaarg.bukkit.itemcraft.ItemCraft
    01:05:39 [INFO] ItemCraft: ICKSlopes 0.1 Loaded.
    01:05:39 [INFO] ItemCraft: ICFancyPack 0.2.5 Loaded.
    01:05:39 [INFO] ItemCraft: ICSGlass 0.1.1 Loaded.
    01:05:39 [INFO] ItemCraft: ICNTrees 0.1.3 Loaded.
    01:05:39 [INFO] Preparing level "world"

    In this example, the server is running Itemcraft 1.3.8 and mods ICKSlopes, ICFancypack, ICSGlass and ICNTrees. If your server is not running ICKSlopes, then when you craft a slope, it appears in your crafting box for a split second and then dissappears - which appears to be your problem.
    To correct this please look in the Itemcraft\ICScript folder for the file called 'plugins.ic'. Open it with notepad (assuming Windows user here) and take out the '#' from the beginning of each line containing the name of the plugin you wish to use.
    The below example showing the contents of the 'plugins.ic' file, will allow the server to run ICKSlopes, ICFancypack, ICSGlass and ICNTrees.

    ## Uncomment Plugins you want to use:
    "ICKSlopes.jar" plugin
    "ICFancyPack.jar" plugin
    "ICSGlass.jar" plugin
    #"ICMCreatures.jar" plugin
    "ICNTrees.jar" plugin
    #"ICJanino.jar" plugin
    #"ICJode.jar" plugin

    Your post show that you are running bukkit build #816 with Itemcraft 1.3.8 -Itemcraft requires a minimum of bukkit #818, however, Itemcraft 1.3.8 is recommended to run with bukkit build #860 which you can download FROM HERE.

    Please click on the download link for the files you need for the trees mod.​

    Inside this zip file are 3 files.​
    Please place the plugins.ic and the oldscript.ic into your ItemCraft\ICScripts folder on your server overwiting whats there (or make a backup of your existing plugins.ic file first if you wish).​
    Place the MoreTrees.props file into your %appdata%\.minecraft folder on your client (assuming you are using Windows). If using Linux, put it in the same folder as where your minecraft.jar file is.​

    The settings in the plugins.ic and the MoreTrees.props files are set up to run ONLY the Trees mod and already contain the settings needed, If you are running other Itemcraft mods, the you will need to edit the plugins.ic file and remove the # from the beginning of each line which contains the name of the mods you are using.​
    The oldscript.ic file is used with the Mo creatures mod and allows setting changes to which creatures will spawn, and how often. If you are using Mo Creatures, this file has been edited so that Werewolves and Ogres appear as well as many of the other creatures. If you are not using Mo creatures, then you don't really need this file, but it won't do any harm if you put it in the folder anyway.​

    As a bonus, I've also included settings in the oldscript.ic file for the Sequoia tree and the Eucalyptus tree to grow much taller than standard setting - huge trees ! You can edit this file for the tree height you want if you wish. Fertilizer also works with these settings.​
    If you want to see the big trees, you will have to generate a new world with these settings active on your server.
    Here's a couple of screenshots of a really, really BIG Sequoia Tree generated using the current settings in the oldscript.ic file :​

    Have fun !!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  3. Offline


    Do you have AdminCmd running? If you can craft a trapdoor, but cannot do "/i 96", then you're seeing what I'm seeing: client crash. I tracked that down to a bit of code in AdminCmd. I downloaded the source and fixed it, but have not posted in that thread to let the author know. May be later.
  4. I have been tring to generate this problem, but so far, I haven't been able to reproduce. I'm running all the ItemCraft plugins except Mo Creatures at the moment (it does run, I've temporarily disabled it for the moment - a couple of Ogres really trashed my house - great fun, but left me nowhere to live) and I am unable to see the slowdown you talk about. I've tried it on a test server running 64bit windows + 64bit java and another server running 32bit windows + 32bit java - the results are the same for the client, there is virtually no difference in frame rate between the 2. So if you are running Mo creatures with Fancypack, turn that off for a test & see how you get on.

    Have you managed to download the file you were after ? If not, please let me know which file you are after & I'll provide a link in my next post to you.

    See my post #1921 which should hopefully have what you are after - although it talks about trees, it also contains a Mo Creatures file ready to go !

    Horses are known not to work 100%, but I have successfully put a saddle on one and tamed a horse, but once tamed, you can't steer it, and if you attempt a dismount, you usually get kicked from the server. All known problems, currently there is no fix for this.
    Even with an altered config, water mobs currently don't spawn, but if you look at my post #1921 in this thread, hopefully you will find the information you are after.

    Currently, I know of no way to make this plugin only active on a single world - whilst it may be possible to add a config to achieve this, I don't think such an option is available at the present time.

    Ogres broke my entire house apart letting a couple of werewolves in the rubble of my house to rip me apart (great fun) - nothing left except a small part of wall, so not sure of whats causing your problem here.

    Please see my post no. #1919 in this thread - it should assist with your problem.

    Please see my post no. #1919 in this thread which hopefully will assist with your problem.

    I've been tring to reproduce this - so far, I haven't been able to. Could you supply your bukkit build number and Itemcraft verion, and kslopes version (client and serverside) -and I'll try & see if I can recreate. - thanks.

    There is a post several pages back about the complex issue surround why horses don't work. However, I'd rather have @asdaarg work on including other mods that work with this plugin, rather than concentrating on fixing the hourses. He did put out some information in the post for anyone wishing to have a go at fixing the problem - I don't think there have been any takers though.

    The file to edit is : craftbukkit-0.0.1-SNAPSHOT.jar
    All you do is delete the META-INF folder from within this file.
    If after you have deleted this folder and you try and run your server it comes up with invalid jar file, then whatever you used to edit the file has corrupted the jar.
    I will assume you are a windows user and you used winrar - if thats the case, please try editing the file with 7zip - AVAILABLE HERE.

    Fingers crossed you have better luck.

    If you have a look at my post number #1921 then hopefully you will find what you are looking for.

    The only other possible problem is if you have had an older version of Fancypack installed and you've upgraded to the newer version. If so, please have a look at my post #1834 on THIS page. Which contains information about how to fix this.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  5. Offline


    Nah, i am not on windows, maybe that is the porblem, i am on a mac. And i know what i need to do, but i need a good snapshot.jar whitout the META-INF folder, can some1 maybe upload it please?

    and icephantom, still thanks for help :D
  6. Someone posted a test server set up ready to go a few pages back - I can't find it at the moment, but I downloaded it myself in case I needed it. It was set ready to go with ItemCraft as far as I know. I haven't tested it myself, but no-one said it didn't work - you are welcome to try it & see how you get on, although you will still need a program capable of dealing with a .zip file to open it

    - by the way, further down the download page for 7zip, there is a mac version available.
    Joeyderijk likes this.
  7. Offline


    Also, if you have a ton of bunnies make sure you disable the ICMcreatures plugin and restart the server. have everyone Log back in that was around the darn bunnies. You should get a ton of Skipping Id bunny notices in your server log. Then shut the server back down change bunnies to 0 in oldscript.ic, reactivate ICMCreatures and breathe a sigh of relief. Another issue I have had is that there was an additional plugin.ic in the itemcraft.jar folder that is not necessary and will cause you to by pass your oldscript.ic. I am no expert but this is how I got rid of my rodent issue.
  8. Offline


    i installed itemcraft like you said to and deleted the META-INF but when i try to login to the server minecraft goes black and closes.
  9. Offline


    Thanks for these nice plugins for the bukkit server.
    I wanna try it, but now i still install it, because for me it is not so easy -.-""
    Your installation-guide is difficult to understand. I read the wiki-installation guide and yours to understand all steps.
    To start:
    • Windows:

      java -Xmx1024M -Xms1024M -cp ItemCraft.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
    • Others:

      java -Xmx1024M -Xms1024M -cp ItemCraft.jar:craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkilödl
    I think it would be better, if you write:
    Now create a start.bat with the following text and replace the old one.

    Also I would add a clear guide how to use the tree and the slopes plugin together.
    I still searching what startup file is meant in the post (#476) I found or there I should put the discribed new created one.

    I also found in two posts a lot of commands for the startup-file and in another posts how the commants really work. Thats very confusing. Maybe you can make a clear guide for that in one post.

    EDIT: Finally i used now the files from icephantom post number #1921. And now the server work.

    I hope you add more guides to original update post of the itemcraft post or the faqs.

    Nice greetings Motoko2020
  10. Offline


    hello i tryed to set the spawn for the animals like for horse set to 10 and sharks to 10 but i have no sharks and no horse try changing it but no luck try new world and the old script.ic
    can someone please help get ICMCreatures to work
  11. Offline


    Thank you very much. It's all better now. The trees are great. But I have another question except this time about MoCreatures. How do I Limit how many Cats spawn or lower how tough they are? Let me know if this doesn't make sense.
  12. i would love this on my server
    is there possible to make this the way : when player joins game he downloads and sets stuff ready automatic?
    coz i dont want to command my server players to download and install these all..
  13. Offline


    Thx icephantom, but now i have a second problem... when i craft a slope then my Minecraft client freeze and i disconnect from my own Server without an error... Can someone help me?

    i have found 1 craft bug
    sloped ceiling
    sloped floor
    sloped angle
    ceiling angle
    slanted corner
    ceiling slanted corner
    oblique slope
    Inverted oblique slope
    slopes intersection
    inverted Slopes intersection

    BUGGY on my Minecraft:

  14. Offline


    For the potted plants i have made what asdaarg said but it doesn't work. flower appear but desapear after less than one second. Any idea why it doesn't work for me?
  15. Offline



    CB: 860
    Itemcraft: 1.3.8
    Kslopes client: 1.6.6
    Kslopes server: ICKSlopes 0.1

    It happens to all players online, and all can see it, so i assume it is not a clientside bug in rendering.

    You might need to set a couple of the blocks to have the error occur.



    Above you can see a row of slopes that are only half rendered. Interesting is the selection cube, this is only half size as well.


    This happened after i set the torch to the brickstone - the closest 2 slopes changed shape to the correct shape. Selection cube looks good as well.


    And after togling the fly mode, the block selection cube looks like this. It's only selecting half of the slope.

    If u need anything else, please ask. Thx for looking into it.


  16. Offline


    Thanks, you're a life saver. :D
  17. Offline


    There's no reason that clientside bugs can't occur for all at the same time. If you can reproduce this bug, try loading the world in SSP and see if it occurs there too.
  18. Offline


    Still doesnt work for me ;(
    maybe i cant use it, because i am on a Mac?
  19. Offline


    Tried that with a copy of the world the screenshots are taken from. No errors / glitches at all.

    It only happens with Itemcraft / CB.


  20. Offline


    I've found that installing this since the 1.0 rearranging has been streamlined quite a bit - I've not had one issue with getting this to work as intended, aside from my first real setup on 766/803. Also, I've not seen the issues with KSlopes as listed above - in fact the only hitch I've seen with any of the plugins wasn't ItemCraft's problem at all; a few recipes got removed from the FancyPack (fences, Mossy Cobblestone) that the fellow maintaining it mentioned he was reintroducing in the near future, in addition to a few feature changes/adjustments. Hopefully these edits are easy to mirror on ItemCraft's end of things - this really is a great collection of mods. :) Thanks for all your work!

    Also, I read a couple pages ago that there was something of a translation issue with getting mods ported to ItemCraft, and no real coding knowledge was needed to do the work required to fix it. I can offer some help with this, as I've a fairly healthy amount of spare time. What must I do to help?
  21. Offline


    thanks icephantom, im still having difficulties ive used the craftbukkit build you linked me to and i have put all the itemcraft stuff into the craftbukkit, when i try to run the server with start.bat and the code given on page 1 for windows i get a black command prompt screen flash for half a second (im guessing telling me it is corrupt)
    so i changed my editing tool from WinRar to 7zip as you recommended but i still run into the same problems with the black screen flashing.
    any solution to this problem is greatly appreciated :)

    EDIT: btw ive deleted the META-INF using 7zip
  22. OK, before I began tests, I looked on the Kslopes forum thread, and the problem does exist on SSP - please CLICK HERE to goto the page displaying the issue (2nd post on the page - a few screenshots to).
    The person posting is using an ATI graphics card on Linux. Since you say all your clients are having the issue at the same time, it is unlikely to be down to the type of Graphics card or O/S, so I assume that the issue is with Kslopes itself, which means we will have to wait for the author to acknowledge there is a problem & he brings out an update / fix. Unfortunately, there will be nothing @asdaarg can do since the issue is not with ItemCraft

    In your Start.bat file (or whatever name you've given to your .bat file), add a second line on its own :


    Just that - pause. When you restart using your bat file, after the error occurs, instead of the window dissappearing, it'll stay there and you can see what it says - please post what it says.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  23. Offline


    C:\Users\jordan\Desktop\servertake10>java -Xmx1024M -Xms1024M -cp ItemCraft.jar;
    craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
    'java' is not recognized as an internal or external command,
    operable program or batch file.
    Press any key to continue . . .
  24. There were 2 possibilities in development to do just this - one called Dyncraft, the other called Pogic
    It would appear that Dyncraft development has come to a halt. I'm not aware that anything has been done on it for a while now.
    The Pogic thread is part of this forum, although the developer is currently doing another project and has put this project 'on the backburner', so it may be a while before further development.

    So, in short, there is currently nothing available to fulfill your request - its all down to manual labour at the moment - sorry.

    OK, a common problem - I'm going to take a risk here and hope you have updated your java to the latest version (6 build 26). Add this line to your start.bat file :
    "C:\Program Files\Java\jre1.6.0_26\bin\"java -Xmx1024M -Xms1024M -cp ItemCraft.jar;
    craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main

    If you have 64bit windows with 32 bit java, try this :
    "C:\Program Files (x86)\Java\jre1.6.0_26\bin\"java -Xmx1024M -Xms1024M -cp ItemCraft.jar;
    craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main

    If neither of these work, it is possible that either your java is loaded in a different location entirely, or you haven't downloaded the latest version - available HERE.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  25. Offline


    i recently formatted my drives, im pretty sure i never re-installed jdk :L

    EDIT: can't find the path specified :((
  26. There is no reason that horses won't spawn - however, currently there is a known problem with ALL water mobs - they don't spawn at all. My post at the top of this page (or alternatively HERE) contains some files which may assist you - although it talks about trees, it also contains a Mo Creatures file already edited and ready to go. Please be aware that horses also do not work 100% - i.e. you are not able to train them currently.

    If you are using the JDK version of java rather than the JRE version then try the following :

    "C:\Program Files\Java\jdk1.6.0_26\bin\"java -Xmx1024M -Xms1024M -cp ItemCraft.jar;
    craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main

    If you have 64bit windows with 32 bit java, try this :
    "C:\Program Files (x86)\Java\jdk1.6.0_26\bin\"java -Xmx1024M -Xms1024M -cp ItemCraft.jar;
    craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
    If neither of these work, open up your 'C' drive, goto your Program Files directory and see if it has a Java Directory at all ?
    Download the latest Java JDK from HERE.
    Also - the " marks are important and have to be there !

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  27. Offline


    im pretty sure i need to assign a path for the jre im using jre now to simplify things
    you dont perhaps know how to do this ?? :L
  28. You haven't told me your O/S - but with what you have posted, I can assume Win 7 or Server 2008 ?
    If so, open up your control panel, double-click on 'System', look for 'Advanced system settings' and click on it. On the dialogue box that opens up will be a button marked 'Environment Variables', click on that. In the bottom of 2 boxes, called 'System Variables', scroll down the list of items untill you see 'Path'. Click on it to highlight it, then click on the 'Edit' button. Go to the end of the line, type in a ; and then paste in your full current java path.
    You may need a computer restart to bring this into effect.
  29. Offline


    How did you get this to work without meta-inf? I can't get it to rename with 7-zip If i can repeat what you did then maybe modloadermp and planes mod would become bukkit compatible.....?
  30. Offline


    I have a problem, and i think its the same as Jordan137's... I'm using JRE... When im typing in the text in the start.bat file and run it i get the same message:

    C:\Users\elgiganten\Desktop\bukkit>java -Xmx1024M -Xms1024M -cp ItemCraft.jar;
    craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
    'java' is not recognized as an internal or external command,
    operable program or batch file.
    Press any key to continue . . .

    And when i put in the:

    "C:\Program Files (x86)\Java\jre1.6.0_26\bin\"java -Xmx1024M -Xms1024M -cp ItemCraft.jar;
    craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main

    it's acting all wierd and there is a lot of text about java, i think it is different commands or something :p
    and the it just says:

    C:\Users\elgiganten\Desktop\bukkit>java -Xmx1024M -Xms1024M -cp ItemCraft.jar;
    craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main

    can someone help me??
  31. Apologies, but a little more information required : 'How did you get THIS to work' - are you refering to the client file 'minecraft.jar' or the server file 'Craftbukkit.jar' ?
    You can't get 'IT' to rename with 7zip - does this refer to the META-INF folder within the bukkit jar file ? If so, could you let us know which Operating system you are using - i.e. Windows 7, Apple Mac, Linux.
    Your last line regarding the 2 mods, it is unlikely they will be compatable with Multi-Player without having a server-side file for ItemCraft to load, so just renaming or deleting the META-INF does not magically make SSP mods work with bukkit.

    This is not easy since there are so many versions of java, and it also depends on if you are using 64bit or 32 bit.
    Anyway, If you look at this screenshot HERE.
    The arrow points to the 'address bar' which I click on to highlight the whole line and then I can copy / paste it - my path to java would be :
    C:\Program Files\Java\jdk1.7.0\bin

    - because this is where my java.exe file is.
    If you can find your java.exe file on your system, and copy / paste the path from the address bar into a post, using your previous post, I'll create a start line for you.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016

Share This Page