Inactive [MECH/DEV] ItemCraft 1.6.6 - Support for client mods in Bukkit [1060/1000]

Discussion in 'Inactive/Unsupported Plugins' started by asdaarg, May 3, 2011.

  1. Offline

    asdaarg

    ItemCraft
    Version:1.6.6
    [​IMG]

    Description:

    ItemCraft is a Bukkit mod that allows adding new item and block types, crafting and furnace recipes, and custom tree generators and more. Using a Modloader and SettingsGUI interface it allows subplugins known as ICPlugins to be loaded to support client mods. ICPlugins can be created by translating a client mod using the ICTranslator ICplugin. Using a ModloaderMP interface (ported by krnlyng/liar) it allows porting multiplayer mods to bukkit.

    Features:
    • Add more Block types
    • Add more Item types
    • Add more Entity types
    • Add more TileEntity types
    • Add more Crafting recipes
    • Add more Smelting recipes
    • Add more Tree generators
    • Ported ModLoader interface
    • Ported ModLoaderMP interface
    • Fake GUIAPI Settings interface
    • Startup file for configuring plugins and making simple blocks and items

    Installation & Usage:
    • Back up your world(s). Just in case.
    • ItemCraft.jar goes in same folder as craftbukkit
    • IC plugins go into ItemCraft/ICPlugins folder under craftbukkit. (folder is autocreated the first time)
    • uncomment (remove #) in front of all plugins you want to use in plugins.ics (autocreated in ItemCraft/ICScript)
    • Make sure you have the recommended version of craftbukkit in the title - since this is a mod of that version in particular.
    • Delete/rename the META-INF folder inside craftbukkit-0.0.1-SNAPSHOT.jar (Use some decent zip program (e.g. 7zip) that can do it.)
    • All players on the server needs to have the client mods installed
    • If you use the 16 bit entity id packet mod (in case you use new entites (only ICMCreatures need it)), All players need (flan's unofficial) ModLoaderMP client mod
    • All players also need the 16 bit entity id packet mod (overwrites a ModLoaderMP's class so make sure ModLoaderMP is installed first) in case you use new entites (only ICMCreatures need it) If decide not to use the packet mod, you can turn it off putting this in your startup file: false setEntityIDPacketMod
    • Sometimes you get block/item ID conflicts, between plugins. You then need to set the conflicting ids in the startup script using setID command: example. They have to be set before the plugin that uses them is loaded. Note also that there is typically a props file on the clientside you have to edit the ids on to be the same as well.
    • To start:
      • Windows:
        Code:
        java -Xmx1024M -Xms1024M -cp ItemCraft.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
      • Others:
        Code:
        java -Xmx1024M -Xms1024M -cp ItemCraft.jar:craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
      IF You do not understand how to install this follow THIS link! Also Try:

      ItemCraft Forum
      ItemCraft Wiki


      Downloads:

      Installation instructions changed since 1.5

      For Minecraft 1.7.3

      Inofficial ItemCraft update by Syrome1.6.6 (#1060)
      ItemCraft 1.6.5 (#1000)
      QwertyPower files (ICSGlass, ICFancyPack addons and more...)
      o4kapuk 16 bit packet mod Does not work without (flan's unofficial) ModLoaderMP client mod.
      ICKSlopes - support for Kaevator SuperSlopes
      ICNTrees - support for Nandonalt's Trees mod. Details regarding use Ignore ScotTools or you will have problems breaking various blocks
      ICFancyPack - support for ChocolateySyrup's FancyPack unofficial update for 1.7.3 mod Details regarding use of potted plants IDs and settings
      User ported mods list maintained by icephantom

      For Minecraft 1.6.6

      ItemCraft 1.4.5
      ItemCraft 1.5.1 (for use with planes)

      ItemCraft 1.3.5 (for CB #818)
      ICSGlass - support for ChocolateySyrup's Stained Glass unofficial update for 1.6.6 mod
      ICFancyPack - support for ChocolateySyrup's FancyPack unofficial update for 1.6.6 mod Details regarding use of potted plants Also be sure to read: Release notes Does not work well and not at all with the newest FancyPack update(v6) Wait until client is stable.
      ICKSlopes - support for Kaevator SuperSlopes
      Usage notes
      ICNTrees - support for Nandonalt's Trees mod. Details regarding use
      ICMCreatures - Support for DrZhark's Mo's Creatures
      16 bit entity id packet mod
      User ported mods list maintained by Asymetrikon


      Dev tools:
      ICJanino
      ICJode
      ICTranslator - How to use

      Other
      Source and old versions


      ICScript documentation

      Frequently Asked Questions

      Tutorial on how to make your own blocks also list of block and item IDs in most popular mods.


      Suggestions of mods to port
      Vote here not in this thread anymore (it gets lost in all the other stuff)

      Reporting errors:
      • Read known issues - don't report those.
      • State the version of CB, ItemCraft and ICPlugin(s) you have problems with
      • If your client crashes, start the client from command line so that you get the error report.
      • Make sure the mod(s) works in SSP First before you report any errors here.
      • You are more likely to get a response if you describe the problem in more detail and do some testing yourself first of under what circumstances it occurs
      • Do not ask for uploads of minecraft.jar.
      • Do not pm me.
      • If you have problems installing, you are likely doing something wrong. Make sure you've followed the instructions exactly, read the FAQ and Wiki. If that doesn't work you can always ask in the thread, while I will likely not reply, there are others who can help you with your problem. But at least try to get it working yourself first.

      That said, I want to thank all who have helped users with their problems. In particular special thanks to icephantom and Asymetrikon for their big efforts in this. Also a special thanks to xeronut for being generally helpful.

      Changelog: (open)

      ItemCraft:
      v1.6.6
      • Inofficial update by Syrome to support CB #1060 and ModloaderMp v1.7.3v4.
      v1.6.5
      • Added changes by krnlyng/liar to support buildcraft
      v1.6.4
      • Inofficial updated by Qwertypower to support CB #1000
      v1.6.3
      • Fixed Generators not working since ModLoaderMP merged.
      v1.6.2
      • Added option to turn off packet230 being sent to clients: false setPacket230OnLogin
      v1.6.0,1.6.1
      • @QwertyPower's unofficial update to 1.7.2 and 1.7.3.
      v1.5.1
      • Fixed issues with ICPlugins not being able to use ModLoader methods obtained through relection.
      v1.5
      • Merge with @krnlyng/liar's translated vesion of SDK's ModLoaderMP
      v1.4.5
      • Added dummy method RegisterTileEntity to fake modloader.
      v1.4.4
      • Added dummy methods AddArmor and getUniqueSpriteIndex to fake modloader.
      v1.4.3
      • ItemCraft commands are now loaded automatically and can be used in init.ic
      v1.4.2
      • Fixed nonesense message when parsing a string and EOF is found after escape character.
      • Platform independent line breaks of autocreated files
      • added some stuff in the autocreated file
      v1.4.1
      • Fixed unupdated materials.java mod causing problems for other plugins accessing the enum's constants for new block ids 1.6.
      v1.4
      • Removed spam on use command
      • Fixed java method invocation
      • Added javamethod invocation of declared methods
      • Fixed pop removing 2 elements off stack
      • putsetting command, allowing editing settings using new script
      • putvar and getvar commands allowing use of variables in scripts
      • added if command, conditional execution of closures
      • ishidden, isCustomType and getCustomType commands
      • exec command, allowing execution of closures. Acts as function calls.
      • while command, for while-loops, execution of closures.
      • Annotation of non-standard methods allowing correction of semantics during parsing with methods that manually alter type info. (needed for for loops, and various stack commands (such as popall, push, pull,dup, casting, getvar, all that do not have a static type signature) to have any usefulness beyond execution using GUI.
      • added casts
      v1.3.8
      • Fixed setEntityIDPacketMod demanding a this pointer.
      v1.3.7
      • Fixed boolean constants missing.
      v1.3.6
      • Updated to CB #860
      • GUI is now off by default
      v1.3.5
      • Fixed illegal access of Item constructor and other methods
      v1.3.4
      • 16 bit Entity Id Packet mod can now be turned off
      • Added file loading functions that use filename rather than file class for Fileman, for use with Janino
      v1.3.3
      v1.3.2
      • Fixed intellisense being screwy, showing previous context
      • Fixed castability test of primitive types to primitive types being screwy
      • Fixed selected method in context view not being visible (scrolled down/up to).
      v1.3.1
      • Fixed array bounds error
      v1.3
      • added intellisense (context box showing sorted list of all applicable methods in context at cursor position, as well as selecting the one closest matching)
      • added tooltips showing documentation both in command box and in the context (list) box
      • added getmaterial method to get Minecraft's materials
      • added documentation to most methods.
      • removed some obsolete methods
      • renamed some methods
      v1.2.2
      • remove NAME: spam on classloaderlclass, 1,2,3 4.. spam and vs: spam
      • fixed classloaderlclass leaving junk on stack
      • fixed getconstructor (?)
      • fixed right square bracket without left square bracket not resulting in parse error
      • fixed parse to fail due to right bracket not yielding an array type
      v1.2.1
      • removed autocreate double spam
      • ics extension changed to ic (conflicting with korganizer and iCalendar)
      • moved plugins into plugins.ic (since it now doesn't execute "use" until it parsed the whole file, it doesn't
      • recognize ItemCraft functions in init.ic)
      • added setID
      • added back support for old file format using includeold
      • fixed execution of abstract script calling providing arguments in wrong order
      v1.2
      • ICScript is now completely converted into postfix
      • Completely rewritten script parsing and execution code
      • Math functions should work now
      • Scripts Are not executed until fully parsed
      • ICS now support direct invokation of java functions when no ICS function matches a call
      • ICS now support arrays
      • ICS now support closures (for later support for menus, functions, loops, conditionals)
      • Parser produces Abstract code that runs much faster, than when having to parse each time to execute code.
      • Pre 1.0-style startupfile scripts are no longer supported (for now)
      • Warning of Block loss with prompt to quit CB on any error during parsing
      • Warning of Block loss with prompt to quit CB if startup script file was not found and was autocreated. This way you can have it autocreate it safely without having to worry about loss of blocks during upgrade.
      • Detailed error reports during both parsing with line number and column and during execution.
      v1.1
      • added simple math functions
      • added basic string and character functions
      • fixed methods popping more than one element
      v1.0.3
      • fixed dup not duplicating
      • added primitive classes
      • added parsing of primitives as primary commands
      • added parsing of strings as primary commands
      v1.0.2
      • fixed identifier after a string being misparsed
      v1.0.1
      • fixed popup menus not working in windows
      • added methods to get icplugins and their classloaders
      • added methods to get constructors and invoke them
      v1.0
      • Implemented new functional script language ICScript
      • Implemented GUI
      • inclusion of files (so you can split up startupfile in smaller files)
      • loading plugins on the fly
      • executing any script commands on the fly using GUI
      • exploring variables and functions of objects in GUI
      • invoke any functions, private or public, on any class loaded in IC/ICPlugins/minecraft/CB/any bukkit plugins
      • Built in text editor (was going to be for editing java code)
      • Removal of blocks, entities and items, even on the fly
      • Adding new blocks, entities and items on the fly
      • Specify what entities spawn in what biomes and how frequently.
      • Customizable programmable menus per node type in GUI
      • IC now retrieves version number both for plugins and itself automatically and reports it when plugins are loaded
      v0.8.5
      • fixed mimic having target object mimic itself.
      v0.8.4
      • fixed invokation on wrong object when interacting with mimiced block
      v0.8.3
      • fixed setint setting a string and not an int
      v0.8.2
      • fixed case sensitivity of block parameters
      • fixed some other bugs related to block parameters
      • no more commas assigning multiple values in block parameters (because I'm lazy)
      v0.8.1
      • Mobs that are unspawnable don't crash the server anymore
      v0.8
      • Added new startupfile commands: blocks and entites
      • Added new startupfile commands: setbool, setint, setfloat, setdouble, that allows changing the settings of mods that use GUIAPI (nandonalt trees and mo's creatures)
      v0.7.5
      • fixed various bugs with craft command in startup script
      v0.7.4
      • removed debug spam on id command
      • fixed comments causing "unknown commands" in startup file
      • cleaned up unnecessary stuff from error report
      • fixed skip skipping over the next line too
      v0.7.3
      • Implemented modloader removespawn (could that have anything to do with the watermob problem?)
      • fixed unknown command spam on empty lines
      • fixed some bugs with craft command in startup file manager.
      v0.7.2
      • Fixed kicked when horse throws you off because of accessing protected field
      v0.7.1
      • Fixed problems adding recipes, tile entites, entites using API.
      • added items command for debug purposes
      • added a copy of spawncreatures to the mod, no idea if that will solve the issue with sharks crashing server.
      v0.7
      • Mimic feature of block allows block to mimic other blocks, fully or in some respect (useful to customize blocks beyond the fixed values from startup file)
      • back to start from craftbukkit folder; its no longer a plugin
      • IC plugins go into ICPlugin folder now in craftbukkit folder. These are to avoid problems caused by plugins being reloaded by CB
      • usedefaults on by default
      • fix item 0 is not valid item spam
      • implemented Modloader getUniqueEntityId,RegisterEntityID,setPrivateValue
      • implemented various SettingsGUI widgets facades, and SettingFloat, SettingsMulti
      • script pauses when error occurs to avoid startup with wrong settings
      v0.6.1
      • Items are also registered as dummy, to avoid error spam by other plugins
      v0.6
      • Modloader world generator interface for normal type worlds implemented
      • Barebones fake GUIAPI interface that loads default settings (might add ability to modify options through startup later)
      • Added fix for blocks not having dummy material in ICFancyPack that inherit the Block class directly
      • Dummy id changed to 255
      v0.5
      • Added support for Entities in API
      • Added support for adding mobs to biome spawnlist in API
      • Added support for adding tilentities in API
      • Added fake modloader for to interface with translated mod plugins
      v0.4.4
      • Added more detailed output when plugin loading fails.
      v0.4.3
      • Backward incompatible update to 766
      v0.4.2
      • Added ability to set data on input items in crafting recipe
      • Added ability to comment in startup file with #
      • Added more error handling.
      v0.4.1
      • Fixed unable to craft out of nonblocks
      • Added more error handling
      • Partial support for GUIs
      v0.4.0
      • Mod for custom tree generation
      • Custom Tree generation API
      • Custom Tree generation startup file instructions:tree,treebiome and biometreedensity
      v0.3.5
      • Added mod of org.bukkit.Material to accomodate new block types, should reduce at least some errors other plugins have.
      v0.3.3
      • Fixed Item id being offset by 256
      • Fixed startup script created Blocks not being added to item list
      • Added more error handling
      v0.3.2
      • Fixed ItemCraft not starting because of spaces in the path on windows machines
      v0.3.1
      • Fixed regexp error on windows when starting as plugin
      • More error handling added
      • Fixed freeze when adding new block properties using startup script
      v0.3
      • Now doubles as plugin, so you can start it as a plugin rather than a mod
      • Startup file autocreation
      • loud startup file instruction- prints out more info at startup
      • a whole lot more error handling
      • fixed bug not being able to load any other plugin that KSlopes.jar (what am I thinking)
      v0.2
      • Most if not all simple constant Block properties now definable from the startup file.
      • Better error handling
      • More complete Block API
      • Syntax correction
      v0.1
      • Initial Release
      KSlopes:
      v0.1.3
      • Made compatible with IC 1.0
      v0.1.2
      • Syntax correction
      • More information on startup
      v0.1.1
      • Fixed slopes and corners dropped having wrong data.
      v0.1
      • Initial Release
      ICFancyPack:
      v0.3.2
      • Introduced options to change settings and IDs
      v0.3.1
      • Disabled new bookshelves
      v0.3
      • Updated for 1.7.3
      v0.2.5
      • Fixed another NPE on startup
      v0.2.4
      • Fixed NPE on startup
      v0.2.3
      • Updated to unofficial version of 1.6.6
      v0.2.2
      • changed class path for flower, cactus and reed
      v0.2.1
      • Fixed not able to place in potted plants
      • Fixed blockcycler interaction
      v0.2
      • Added potted plants
      v0.1
      • Initial Release
      ICNTrees
      v0.1.4
      • Updated to 1.7.3
      v0.1.3
      • Fixed static construction of objects problem
      • Fixed no tree generation
      v0.1.2
      • updated to 1.6.6
      v0.1.1
      • fixed clicking on bananacake blocks, fruit leaves
      • fixed using fertilizing
      • fixed activating banana cake
      v0.1
      • Initial Release
      ICMCreatures
      v0.1.2
      • Updated to 1.6.6
      v0.1.1
      • Made everything public and even added a public ()V constructor in water mob class (no idea if that will solve it though)
      • Says its loaded on startup when its loaded
      v0.1
      • Initial Release
      16 Bit Entity ID Packet Mod
      v0.2
      • Supports both 16 bit and 8 bit servers
      v0.1
      • Initial Release
      ICSGlass
      v0.1.1
      • Fixed conflict with glass bug
      v0.1
      • Initial Release
      ICTranslator
      v0.1.4
      • Fixed no output on windows machines.
      v0.1.3
      • More informative about files to translate not being found.
      v0.1.2
      • Made it tolerate there being no file separator at the end of retroSource.
      • Removed some spam.
      v0.1.1
      • Added checks that make sure you have all the necessary maps specified, when you translate.
      v0.1
      • Initial Release
      KSlopes:
      v0.1.1
      • Update to 1.7.3
      v0.1
      • Initial Release

      Donate (Not necessary but appreciated)
     
  2. Offline

    asdaarg

    ICMCreatures updated.
     
    zlipperypete likes this.
  3. Offline

    zlipperypete

    Great work =)
     
  4. Offline

    srthd

    w
    o
    n
    g
    i
    n
    n
    u
    r
    r
    e
    v
    r
    e
    s
    e
    h
    t
    t
    o
    g
    k
    o
    ok got the server working with 818 and ic 1.3.5 got all mods installed on the client and they work on solo and have pm 16 bit on there but get this error oin the server log when i try to log in. and it wont let me in my server very confused dont know what the issue is wierd if u ask me
    class com.asdaarg.bukkit.itemcraft.ICS
    2011-06-07 17:59:21 [INFO] ItemCraft 1.3.5
    2011-06-07 17:59:21 [INFO] class com.asdaarg.bukkit.itemcraft.ItemCraft
    2011-06-07 17:59:21 [INFO] Preparing level "world"
    2011-06-07 17:59:21 [INFO] Preparing start region for level 0
    2011-06-07 17:59:22 [INFO] Preparing spawn area: 69%
    2011-06-07 17:59:23 [INFO] CartDispense v0.5 - By Vlad Cazan
    2011-06-07 17:59:23 [INFO] [RealTeleporter] version [0.02] (tickleman) loaded
    2011-06-07 17:59:23 [INFO] Done (0.160s)! For help, type "help" or "?"
    2011-06-07 17:59:50 [SEVERE] java.lang.NoSuchFieldError: aE
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.EntityLiving.<init>(EntityLiving.java:77)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.EntityHuman.<init>(EntityHuman.java:55)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.EntityPlayer.<init>(EntityPlayer.java:35)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.ServerConfigurationManager.a(ServerConfigurationManager.java:161)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:82)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:74)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.Packet1Login.a(SourceFile:43)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:40)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:404)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:314)
    2011-06-07 17:59:50 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-06-07 17:59:50 [SEVERE] Unexpected exception
    java.lang.NoSuchFieldError: aE
    at net.minecraft.server.EntityLiving.<init>(EntityLiving.java:77)
    at net.minecraft.server.EntityHuman.<init>(EntityHuman.java:55)
    at net.minecraft.server.EntityPlayer.<init>(EntityPlayer.java:35)
    at net.minecraft.server.ServerConfigurationManager.a(ServerConfigurationManager.java:161)
    at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:82)
    at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:74)
    at net.minecraft.server.Packet1Login.a(SourceFile:43)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
    at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:40)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:404)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:314)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422
     
  5. Offline

    WeedFreak

    CONSOLE: This server is running Craftbukkit version null (MC: 1.6.6)
    CONSOLE: class com.asdaarg.bukkit.itemcraft.ICS
    CONSOLE: ItemCraft 1.3.5
    CONSOLE: class com.asdaarg.bukkit.itemcraft.ItemCraft
    CONSOLE: Error executing script file: plugin: threw com.asdaarg.bukkit.itemcraft.ScriptMan$CustomError: IOException:[com.asdaarg.bukkit.itemcraft.ICUtil.pluginYML(ICUtil.java:35)
    CONSOLE: Press Ctrl+C to quit
    CONSOLE: Press any other key to start CB anyway. Warning: This may remove blocks supported by plugins that were not loaded!

    I Use CB b818 on an MCMyAdmin Server, and i dont know where the problem is .. i tested different things but my Server stops anytime on this message, i dissabled the GUI - dont work too

    Thx for your Help

    Greetz
     
  6. Offline

    zlipperypete

    Whats the download link for 1.3.5? the one in the main post here gives me 1.3.4
    The download provided under install on the wiki gives the good 'ol pressure-pad crash, so unknown version there.
    Creatures fails to load with 1.3.4 at least.

    Edit:
    Yep i suspected it, but figured "naaaaaah.. couldnt be..", re-downloaded in firefox and all is good =)

    And creatures mod loaded successfully. :)
     
  7. Offline

    Zachatack20

    Hey! That same thing happened to me! my browser wasnt properly refreshing and so it was still downloading 1.3.4... i went to a different computer and it was fine. i suggest either doing that or restarting your comp :)
     
    zlipperypete likes this.
  8. Offline

    Asymetrikon

    Creatures works. Only the Water Creatures are still hiding themselves. :D
    Only thing is that some Items from Creatures produce player interact errors with other Plugins. I noticed this when leftclicking with a Tigertooth in my Hand.
    Thanks for all your Work and fast Updates. :)

    Edit: Looked again. Only Plugin showing Errors is Voxelsniper. But its just the annoying spam in the Console. Nothing wrong with the Plugin itsself.
     
  9. Offline

    Zachatack20

    Haha, it was infuriating yesterday! i had no idea what was happening, today i finally got it working haha :D

    Edit: oh yea, quick question, does anyone know if the horses are fixed?
     
  10. Offline

    Spycoclown

    Code:
    17:36:03 [INFO] This server is running Craftbukkit version null (MC: 1.6.6)
    17:36:03 [INFO] class com.asdaarg.bukkit.itemcraft.ICS
    17:36:03 [INFO] ItemCraft 1.3.5
    17:36:03 [INFO] class com.asdaarg.bukkit.itemcraft.ItemCraft
    17:36:03 [INFO] ItemCraft: ICKSlopes 0.1 Loaded.
    17:36:03 [INFO] ItemCraft: ICMCreatures 0.1.2 Loaded.
    17:36:03 [INFO] Error executing script file: plugin: threw com.asdaarg.bukkit.it                      emcraft.ScriptMan$CustomError: IOException:[com.asdaarg.bukkit.itemcraft.ICUtil.                      pluginYML(ICUtil.java:35)
    com.asdaarg.bukkit.itemcraft.ItemCraft$Plugin.<init>(ItemCraft.java:42)
    com.asdaarg.bukkit.itemcraft.ICS.plugin(ICS.java:362)
    sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    java.lang.reflect.Method.invoke(Unknown Source)
    com.asdaarg.bukkit.itemcraft.ScriptMan$cmdMetSV.exec(ScriptMan.java:170)
    com.asdaarg.bukkit.itemcraft.ScriptMan$cmdList.exec(ScriptMan.java:97)
    com.asdaarg.bukkit.itemcraft.ScriptMan.load2(ScriptMan.java:1092)
    com.asdaarg.bukkit.itemcraft.ICS.include(ICS.java:305)
    sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    java.lang.reflect.Method.invoke(Unknown Source)
    com.asdaarg.bukkit.itemcraft.ScriptMan$cmdMetSV.exec(ScriptMan.java:170)
    com.asdaarg.bukkit.itemcraft.ScriptMan$cmdList.exec(ScriptMan.java:97)
    com.asdaarg.bukkit.itemcraft.ScriptMan.load2(ScriptMan.java:1092)
    com.asdaarg.bukkit.itemcraft.ICInit.init(ICInit.java:124)
    net.minecraft.server.MinecraftServer.init(MinecraftServer.java:133)
    net.minecraft.server.MinecraftServer.run(MinecraftServer.java:288)
    net.minecraft.server.ThreadServerApplication.run(SourceFile:422)]
    17:36:03 [INFO] Press Ctrl+C to quit
    17:36:03 [INFO] Press any other key to start CB anyway. Warning: This may remove                      blocks supported by plugins that were not loaded!
    
    What do i do wrong?
    With ICKlopes everything is fine
    with ICMcreatures everything is fine
    then i try ICNTrees and it dont work

    Code:
    ## Uncomment Plugins you want to use:
    "blockTopiary" 153 setID
    "blockPalmLeaves" 154 setID
    "blockPalmTrunk" 155 setID
    "blockPalmSapling" 156 setID
    "blockBanana" 157 setID
    "blockBananaCake" 158 setID
    "blockLeavesGeneric" 159 setID
    "blockLogGeneric" 160 setID
    "blockLeavesFruit" 161 setID
    "blockAppleFlower" 163 setID
    "blockAppleFFlower" 164 setID
    "blockAppleSapling" 165 setID
    "blockCherrySapling" 162 setID
    "blockVines" 152 setID
    "ICKSlopes.jar" plugin
    #"ICFancyPack.jar" plugin
    "ICMCreatures.jar" plugin
    "ICNTrees.jar" plugin
    
     
  11. Offline

    KayKai

    i need help ...

    19:46:02 [INFO] This server is running Craftbukkit version null (MC: 1.6.6)
    19:46:02 [INFO] class com.asdaarg.bukkit.itemcraft.ICS
    19:46:02 [INFO] ItemCraft 1.3.5
    19:46:02 [INFO] class com.asdaarg.bukkit.itemcraft.ItemCraft
    19:46:02 [INFO] ICMCreatures 0.1.1
    19:46:02 [INFO] ItemCraft: ICMCreatures 0.1.1 Loaded.
    19:46:03 [INFO] Preparing level "world"
    19:46:03 [INFO] Preparing start region for level 0
    19:46:03 [INFO] Preparing start region for level 1
    19:46:04 [INFO] Done (0,092s)! For help, type "help" or "?"
    19:46:04 [SCHWERWIEGEND] java.lang.NoSuchFieldError: bw
    19:46:04 [SCHWERWIEGEND] at net.minecraft.server.EntityCustomWM.u(EntityCustomWM.java:424)
    19:46:04 [SCHWERWIEGEND] at net.minecraft.server.EntityDolphin.u(EntityDolphin.java:176)
    19:46:04 [SCHWERWIEGEND] at net.minecraft.server.EntityLiving.o_(EntityLiving.java:231)
    19:46:04 [SCHWERWIEGEND] at net.minecraft.server.World.entityJoinedWorld(World.java:1071)
    19:46:04 [SCHWERWIEGEND] at net.minecraft.server.WorldServer.entityJoinedWorld(WorldServer.java:56)
    19:46:04 [SCHWERWIEGEND] at net.minecraft.server.World.playerJoinedWorld(World.java:1053)
    19:46:04 [SCHWERWIEGEND] at net.minecraft.server.World.cleanUp(World.java:1030)
    19:46:04 [SCHWERWIEGEND] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:400)
    19:46:04 [SCHWERWIEGEND] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:314)
    19:46:04 [SCHWERWIEGEND] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    19:46:04 [SCHWERWIEGEND] Unexpected exception
    java.lang.NoSuchFieldError: bw
    at net.minecraft.server.EntityCustomWM.u(EntityCustomWM.java:424)
    at net.minecraft.server.EntityDolphin.u(EntityDolphin.java:176)
    at net.minecraft.server.EntityLiving.o_(EntityLiving.java:231)
    at net.minecraft.server.World.entityJoinedWorld(World.java:1071)
    at net.minecraft.server.WorldServer.entityJoinedWorld(WorldServer.java:56)
    at net.minecraft.server.World.playerJoinedWorld(World.java:1053)
    at net.minecraft.server.World.cleanUp(World.java:1030)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:400)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:314)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    what is frong with my server ??
     

    Attached Files:

  12. Offline

    zlipperypete

    Did you remember to place the ICNTrees.jar file in the ICPlugins folder?
    That error is generated if the plugin cannot be found
     
    Spycoclown likes this.
  13. Offline

    elias79

    plugins dont load
     
  14. Offline

    Spycoclown

    Thx,
    I found the problem, ICNTrees had 0kb dont know why but now it works thx
     
  15. Offline

    NeoSniperkiller

    asdaarg, can you try to port buildcraft?


    it's already updated to 1.6.6, but it looks like it supports smp now too​
     
  16. Offline

    elias79

    where do i put the plugins and what is the new startup ?
     
  17. Offline

    Kyle Stilkey

    It would be awesome if you could to an unofficial update for now till the author finally say's something about an update. No one's heard anything nor seen him for sometime.
     
  18. Offline

    elias79

    So what folder do we use now ?
     
  19. Offline

    CuZnDragon

    Can't as the teleport mods require 820 to fix issues with them.
     
  20. Offline

    icephantom

    I've tested this with bukkit #824 - working OK with Kslopes & Mo Creatures - not tried the tree mod yet.
     
  21. Offline

    CuZnDragon

    Definitely an issue with the 16bit entities players mod and craftbukkit 820. Guess I will be playing without ItemCraft for awhile.

    I have ItemCraft with no IC* plugins. I have the 1.6.6 client with only the 16bit files copied in and as soon as I connect to the server I get disconnected. When I run without ItemCraft and player mod I have no issues.

    Why would you be running 824 when it was a build with errors?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Dec 14, 2016
  22. Offline

    Kyle Stilkey

    Have you tried any other builds? They are at like 838 now.
     
  23. Offline

    icephantom

    Works for me !

    No, I didn't realise they'd moved on so much - unfortunately, it'll have to wait until tomorrow now before I can test further.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Dec 14, 2016
  24. Offline

    CuZnDragon

    Tried it with craftbukkit 823 and did the same thing but gave an error on the client this time...

    Internal Exception: java.io.IOException: Received string length longer than maximum allowed (21248 > 64)
     
  25. Offline

    elias79

    Explain please.
     
  26. Offline

    icephantom

    Just run some very quick tests - there is a method-change above bukkit#824 that stops ItemCraft loading, I'll have time for further testing tomorrow, but up to now, I've tried #826,#828,#830 and #838 and none of these will load.
    So for the time being, if #824 is bugged, I've tried bukkit #823, and thats working - I can log in and things seem OK, however a 1 min. test is not enough to say its going to be 100%, #824 seems to be the highest you can go before this plugin breaks.
     
  27. Offline

    zlipperypete

    Can't really expect non-recommended builds to be supported though
     
  28. Offline

    icephantom

    Code:
    Code Error 1 :
    
    java.lang.NullPointerException
            at mx.a(SourceFile:465)
            at jj.a(SourceFile:62)
            at pb.b(SourceFile:279)
            at mx.a(SourceFile:119)
            at vp.a(SourceFile:44)
            at net.minecraft.client.Minecraft.k(SourceFile:1226)
            at net.minecraft.client.Minecraft.run(SourceFile:720)
            at java.lang.Thread.run(Thread.java:732)
    A string length error using this plugin usually indicates files missing on the client. The server is probably OK, and since I've just tested #823 (albeit a quick test), I can log in OK.
    I have run some tests earlier and You can run Itemcraft with Kslopes installed serverside, and the client will still connect if the only thing they have installed clientside is the 16bit entity. They won't be able to craft any kslope blocks, but they can play.
    If you install ItemCraft on your bukkit with no mods serverside and no mods clientside you'll get the Code Error 1 above.
    To cure this error, you only need to install the 16bit entity mod. That's the link, the lower one - below the 1.6.6 mods, below the Dev tools, and in the 'Other' section at the top of this page in the initial post. The two files go into the root of your minecraft.jar file.
    If you install Kslopes & Mo creatures serverside, you won't be able to join the server until you install 16bit entity, modloader, kslopes, guiapi, audiomod and Mo Creatures clientside files, otherwise, you'll receive a similar error as in the codebox above.
    I've yet to try the trees mod.
    [Edit]
    Really hope the dev goes for the unofficial fancypack update. I've only got 1.6.6 running on my test server - would love to have it 'live'

    Interestingly, Mo Creatures files don't get put into the minecraft.jar on this release. All the other mods do.
    You just copy the mo creatures zip file into your .minecraft directory, then assuming you have winrar installed (windows users), you right-click the file and choose 'Extract Here'. This will extract the folders directly into your .minecraft folder.
    It's different, but it definately works. !!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Dec 14, 2016
  29. Offline

    CuZnDragon

    I have my normal craftbukkit (820 or 823) with ItemCraft 1.3.5 and other mods but I have all the plugins commented out on plugins.ic.

    On the 1.6.6 client all I have is the jj.class and mx.class copied into the jar and removed the META-INF folder.

    When I connect with 820 it just disconnects the client, no error messages on server or client.
    When I connect with 823 it just disconnects with the error that I posted in message 1448.

    I don't get the Code Error 1: at all

    I am running this all on linux with the 64bit java.

    That's because modloader will now auto load mods in the .minecraft/mod folder as long as they don't change any of the minecraft files.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Dec 14, 2016
  30. Offline

    elias79

    Not true, it hangs.
     
  31. Offline

    s20dan

    Thankyou for your continued hard work on this asdaarg.
    This was my most anticipated mod for 1.6.6 ;)
    I had some issues with the previous version with certain blocks not destroying correctly, but everything is running very smoothly now.

    That would be the folder CraftBukkit you can see in your server directory.
    Its all documented further up.

    How messy. I just placed them into the minecraft.jar and haven't had any problems.
     

Share This Page