[MECH] CraftBook - Redstone bridges, gates, minecarts, ICs, more [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 27, 2011.

  1. Offline


    CraftBook adds a number of original gameplay elements to Minecraft from switchable bridges to elevators to gates (including flood gates)! It also has redstone support, allowing you to wire up pumpkins and use integrated circuits!

    Some cool stuff people made last year:

    • Mechanisms
      • Bridges
      • Doors *not yet ported*
      • Gates
      • Elevators
      • Cauldrons
      • Light switches
      • Readable bookshelves
      • Toggle areas (advanced toggle doors and bridges)
      • Hidden switches
      • Custom block drops
      • Apple tree drops
      • Bookshelf drops
      • MORE!
    • Redstone
      • Integrated circuits
      • Programmable logic chips
      • Redstone pumpkins
      • Redstone netherstone
      • Ammeter
      • MORE!
    • Minecart features
      • Booster blocks
      • Brake blocks
      • Reverse blocks
      • Ejector blocks
      • Chest-storage minecart transfer blocks
      • Station blocks
      • Sort blocks
      • Message announcer block
      • Minecart dispensers
      • Change minecart behavior
      • MORE!

    CraftBook is being developed again, although by someone else. Get the latest downloads here: http://dev.bukkit.org/server-mods/craftbook/

    [​IMG] (CraftBook is open source!)
    kazeen, dragon8510, Jaein and 45 others like this.
  2. Offline


    I used your plugin, I got the "You don't have the permission to use that" error. I tried everything on this topic: unofficial builds, giving to my users permissions I didn't wanted them to have... But I tried, really, during two or tree days to resolve these problems.

    Finally, I got tired. So I simply removed your plugin from my server. Guess what ? I got these error, again and again. I removed all of my plugins, I get this fucking annoying message. I finally tried to copy my map and start another server (completely blank, no plugins, CraftBukkit by default), and... I get this error. So, that's all, my map is fucked up.

    So, I hope you could understand that... For other peoples, please, update this plugin. It's great, really, I enjoyed when it worked... But now, I simply lost my map and my server, so please, do something.

    (And don't tell me "try this" or "try that", I tried everything which is write in this topic...)
  3. This happens to my players in certain areas, are you sure it's Craftbook (which i haven't used yet).
  4. Offline


    It's broke. I'm running CB818 and this is on version 766. Update it, please?
  5. Offline


  6. Offline


    Craftbook release version 140 is working here on CraftBukkit 860 with essentials 2.3.3 (worldedit 4.6 is not an enabled plugin, just the jar being in the server root folder, since it's know to conflict with essentials atm).

    Notice: craftbook.mech.cauldron has been added as a permission for all users as a workaround for the well known ""You don't have the permission to use that" error.

    Only other plugins i'm running is dynmap 0.18 (and BukkitComat r14 for a fix in my McMyAdmin)

    Not until they make config files for the bukkit port

    i dunno about the bridge, sounds quirky to me, but the properties files is something from Hmod and hasn't yet been implemented in the bukkit version(s)

    When the server starts, does the console tell you craftbook is working? Is there a worldedit jarfile on your server? are permissions set for usage of gates? and is the [Gate] text on the 2nd line of your sign?

    Area toggling & Hidden switches not yet implemented afaik

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  7. Can you please update it for Craftbukkit 860?? (Minecraft 1.6.6)
    I need this Plugin >-<
  8. Offline


    i want alpha 3 naw :DD
    anyway great work on porting the ic`s i use craft book in my server for making many things :)
  9. Offline


  10. Offline


    yes i have that, in my server as i right click on it he says that he moved and i see nothing :(
  11. Offline


    Any error messages on the server console after using the Gate sign? Using any other plugins?

    Oh great now i'm getting this myself in my server log:
    java.lang.NoClassDefFoundError: com/sk89q/bukkit/migration/PermissionsResolverManager

    T_T has anybody found a fix for this yet?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  12. Offline


    i have more plugins as i op a sing right click do say they from who they is so maybe that is the problem? (if i have a bed english say it and sorry i from holland ( dutch (netherland))
  13. Offline


    I think you might have the same problem as me, either way until i fix my own craftbook, i don't think i can help :-(
  14. Offline

    Tommy James

    how do i make the bridge extend out farther? i looked up hmod but thaits not for bukkit. Please help!
  15. Offline


  16. Offline


    Every time any of my players doing anything, like placing block, they get a message "You don't have permission to do this". I'm 100 % sure it is this plugin that causes it. They can do everything they have permission to but it's pretty annoying to get the message. I would be really happy if someone helped me. //Fr34km4n
  17. Offline


    Add craftbook.mech.cauldron to their permissions.
    Fr34km4n likes this.
  18. Offline


    sk89q should really add and highlight in to the original post xD
  19. Offline


    no its going good nog i place a lever by the sing and he go up and down :D
  20. Offline


    Does this by any chance work with cb860?
  21. Offline


    Yes it does.

    Craftbook relies on WorldEdit, as long WE is up to date (it is) Craftbook will work for 99% sure.
  22. Offline


    Oh sick thanks!!

    I don't think its working, some of the simple door functions won't work!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  23. Offline


    I use it, it works.
    Doors are not implemented yet as can be read int he first post.
    The bukkit port of Craftbook is only partially complete. Bridges and gates work, a good set of ICs is already working as wel. I dont know about the minecarts because I dont use those
  24. Offline


    i have the same problem, whenever they place a block, they get the message 'you don't have permission to use this'. and yes i've added craftbook.mech.cauldron to their permissions. im 100% sure this is coming from this cause i have this plugin, not in the plugins folder, and they don't get the message. and i have done the same thing with permissions, (i deactivated it), and they still get the message.

    permissions 3.0
    CB latest build

            default: true
                prefix: '&b[Visitor]'
                suffix: ''
                build: true
                - 'jobs.join.Miner'
                - 'jobs.world.world'
                - 'commandbook.who'
                - 'commandbook.spawn'
                - 'towny.wild.build'
                - 'towny.wild.destroy'
                - 'towny.town.new'
                - 'towny.town.claim'
                - 'towny.spawntp'
                - 'towny.publicspawntp'
                - 'lwc.protect'
                - 'colorme.list'
                - 'colorme.self'
                - 'jobs.join.Hunter'
                - 'jobs.join.Farmer'
                - 'jobs.join.Builder'
                - 'jobs.join.Digger'
                - 'jobs.world.world_Nether'
                - 'iConomyChestShop.shop.create'
                - 'iConomyChestShop.shop.buy'
                - 'IconomyChestShop.shop.sell'
                - 'iConomyChestShop.command.iteminfo'
                - 'mcmmo.motd'
                - 'mcmmo.regeneration'
                - 'mcmmo.commands.ability'
                - 'mcmmo.commands.myspawn'
                - 'mcmmo.commands.setmyspawn'
                - 'mcmmo.ability.woodcutting'
                - 'mcmmo.ability.mining'
                - 'mcmmo.ability.axes'
                - 'mcmmo.ability.excavation'
                - 'mcmmo.ability.swords'
                - 'mcmmo.ability.unarmed'
                - 'mcmmo.ability.herbalism'
                - 'mcmmo.skills.mining'
                - 'mcmmo.skills.excavation'
                - 'mcmmo.skills.unarmed'
                - 'mcmmo.skills.herbalism'
                - 'mcmmo.skills.swords'
                - 'mcmmo.skills.axes'
                - 'mcmmo.skills.woodcutting'
                - 'towny.wild'
                - 'mcmmo.skills.repair'
                - 'mcmmo.skills.taming'
                - 'mcmmo.skills.archery'
                - 'mcmmo.skills.acrobatics'
                - 'craftbook.mech.cauldron'
            default: false
                prefix: '&9[Citizen]'
                suffix: ''
                build: true
                - Default
                - 'nocheat.speedhack'
                - 'nocheat.flying'
                - 'nocheat.moving'
                - 'commandbook.return'
            default: false
                prefix: '&c[Admin]'
                suffix: ''
                build: true
                - Citizen
                - 'commandbook.time'
                - '-commandbook.spawnmob'
                - 'commandbook.weather'
                - 'commandbook.weather.thunder'
                - '-commandbook.say'
                - '-commandbook.bans.ban'
                - '-commandbook.bans.unban'
                - '-worldeditselect'
                - '-reloadwe'
                - 'commandbook.give'
                - 'commandbook.more'
                - 'commandbook.give.other'
                - 'commandbook.give.infinite'
                - 'commandbook.give.stacks'
                - 'commandbook.give.stacks.unlimited'
                - 'commandbook.teleport'
                - 'commandbook.teleport.other'
                - 'commandbook.clear'
                - 'commandbook.kick'
            default: false
                prefix: '&4[OWNER]'
                suffix: ''
                build: true
                - '*'
  25. Offline


  26. Offline


    an error occured while enabling. i downloaded craftbookmechanisms 3.0 on that page and renamed to CraftBookMechanisms.jar

    [SEVERE] Error occurred while enabling CraftBookMechanisms v3.0-SNAPSHOT (Is it up to date?): com/sk89q/craftbook/AbstractMechanic
    java.lang.NoClassDefFoundError: com/sk89q/craftbook/AbstractMechanic
    an error occured while enabling,
  27. Offline


    Im having the same fuckin problem. Ppl on my srver right click on anything and it says "You do not have oermission to us this to
  28. Offline


    Give them the craftbook.mech.couldron permission.
  29. Offline


    I can't find craftbook.properties or any config file. Help.
  30. Offline


    plugins/Craftbook/<config files are here>

    Permissions are located in the config files for your permissions plugin.

    Bukkit doesn't use .properties files like hMod did, unless the plugin author decided to code them themselves. Personally I like YAML way better.
  31. Offline


    i dun know if this was mentioned or i didnt read anyhting but the monster spawning thing is not working
    i have permissions mod and im admin with '*' so i do
    [MC1200] second line
    Pig third line
    its says spawing thing created and i power it up nothing happens plz help
    nvm i was doing it in a world edit region with mob-spawning off but how do i make it so that only a certain area in the region can spwn?? i tried to make a new region and set parent as the region and tryed /region flag pork(the new region name) mob-spawning allow
    but it still doesnt work any way to do this??? thnx

Share This Page