[MECH] CraftBook - Redstone bridges, gates, minecarts, ICs, more [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 27, 2011.

  1. Offline


    CraftBook adds a number of original gameplay elements to Minecraft from switchable bridges to elevators to gates (including flood gates)! It also has redstone support, allowing you to wire up pumpkins and use integrated circuits!

    Some cool stuff people made last year:

    • Mechanisms
      • Bridges
      • Doors *not yet ported*
      • Gates
      • Elevators
      • Cauldrons
      • Light switches
      • Readable bookshelves
      • Toggle areas (advanced toggle doors and bridges)
      • Hidden switches
      • Custom block drops
      • Apple tree drops
      • Bookshelf drops
      • MORE!
    • Redstone
      • Integrated circuits
      • Programmable logic chips
      • Redstone pumpkins
      • Redstone netherstone
      • Ammeter
      • MORE!
    • Minecart features
      • Booster blocks
      • Brake blocks
      • Reverse blocks
      • Ejector blocks
      • Chest-storage minecart transfer blocks
      • Station blocks
      • Sort blocks
      • Message announcer block
      • Minecart dispensers
      • Change minecart behavior
      • MORE!

    CraftBook is being developed again, although by someone else. Get the latest downloads here: http://dev.bukkit.org/server-mods/craftbook/

    [​IMG] (CraftBook is open source!)
    kazeen, dragon8510, Jaein and 45 others like this.
  2. Is craftbook coming back or not ?
  3. Offline



  4. Offline


    Actually we can donate. O:
  5. Offline


    Lol no one can answer my help? thx...
  6. Offline


    Tight +2000 coding exp for you
  7. Offline


    FYI this Dev has been busy building Bukkit itself and has had little time to maintain his plugins, since he's helping to you know, enable Bukkit to exist at all. Some users think they know everything.
  8. Offline


    I don't think I know everything but I do know that rules were put in place for a reason. This nose-in-the-air dev can't even follow the rules everyone else has to follow. Let one of us post a plug-in using the + sign and a moderator is all over us telling us we can't do it. It's one thing to be part of a dev team but those rules apply to that dev team as well as us

    Let me see you put a + sign in one of your plug-ins and let's see what happens.
  9. Offline


    (vent) I'm just tired of running 2 plugins with 11+ .jar files just to fill in where CraftBook has left off so long ago. Having to check daily if they or any part of the other plugins have changed or been updated and rearranging all transportation systems to be able to work is and has been a very large task. FPS drops drastically around areas with high concentrations of ICs, among countless other past problems happening with the makeup solutions. Our server relied very heavily on this plugin for tons of builds and transportation from the beginning. (/vent) sk89q, when you're done with your two weeks, please do what you can to update and fully implement everything back into CraftBook. We all need you. ;)
  10. Offline


    THANKS! everything works except for the hidden switches..... I've looked them up and as far as i know i'm doing everything right but they just don't do anything. a solution would be appreciated. but isn't SUPER necessary
  11. please update the plugin there are to many bugs..
  12. Offline


    Is this updated to 1.5_01 servers? I'm not really sure.
  13. Offline


    That was asked several times on the last pages. On my server (CB744) it works without any problem. Some people use it with 766 and it works, too.
  14. Offline


    sk89q posted on his blog that he is away for two weeks and major updates are coming soon for CraftBook when he returns. He just hasn't been releasing anything because he's been too busy to test it to see if it's test-release quality. You haven't been abandoned, fear not.
  15. Offline


    Hey guys,
    I have a problem with the gates, they just won't work with redstone circuits. Is this not yet implented or am I doing something wrong? Tried to give the input from all horizontal directions
  16. Offline


    get this @ startup, my gates doesn't work anymore (other things i didn't use)
    2011-05-14 15:30:06 [SEVERE] com/sk89q/bukkit/migration/PermissionsResolverManager loading CraftBookCommon v3.0-alpha2 (Is it up to date?)
    java.lang.NoClassDefFoundError: com/sk89q/bukkit/migration/PermissionsResolverManager
        at com.sk89q.craftbook.bukkit.BaseBukkitPlugin.onEnable(BaseBukkitPlugin.java:72)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:676)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:249)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:131)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:109)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:218)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:205)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:145)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:260)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.ClassNotFoundException: com.sk89q.bukkit.migration.PermissionsResolverManager
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        ... 11 more
  17. Offline


    hidden switches and minecart deposit/collect don"t work 740 and 766

    what about everyone else?
  18. Offline


    Hey all,
    Everynow and then my lifts in a tower stop working. I dont get any errors or notification in the console. I have an up lift and then a down lift directly next to it. they both traverse 3 floors. Could it be either not enough memory or the lifts to close or is it something else?
  19. Offline


    all works fine...
    you have xfire, and i can helf you.
    tip: put the redstoneline 1 stone under the Sign

    here 3 screens:
  20. Offline


    I am getting this error as well.
  21. Offline


    are mine-cart collectors depositors working can anyone tell me how to set it up-maybe i did it wrong
  22. Offline


  23. My friends cant use the signs for some reason
  24. Offline


    Does this work with the 677 version?
  25. Offline


    i don't think so maybe why don't you try it
  26. Offline


    It works at 766 for me.

    Yesterday I did had a curious error (could not pass event CHUNK_UNLOAD to craftbook Circuitsjava....blahblah).
    But that happened only twice in a row, and I could not reproduce it.
    Whole error:
    Show Spoiler

    2011-05-15 16:49:34 [SEVERE] Could not pass event CHUNK_UNLOAD to CraftBookCircuits
    	at com.sk89q.craftbook.MechanicManager.unload(MechanicManager.java:368)
    	at com.sk89q.craftbook.MechanicManager.unload(MechanicManager.java:354)
    	at com.sk89q.craftbook.bukkit.MechanicListenerAdapter$MechanicWorldListener.onChunkUnload(MechanicListenerAdapter.java:301)
    	at org.bukkit.plugin.java.JavaPluginLoader$41.execute(JavaPluginLoader.java:478)
    	at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    	at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:289)
    	at net.minecraft.server.ChunkProviderServer.unloadChunks(ChunkProviderServer.java:220)
    	at net.minecraft.server.World.doTick(World.java:1450)
    	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:363)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)

    I'd say its safe to use, make sure you have the latest Craftbukkit RB & WorldEdit.

    Slightly off-topic:
    Oh, you might want to know Essentials exploded in my face last Saturday, WG puked out a load of errors, so I removed Essentials, problem solved. To bad Commandbook + 3 other plugins still cant fully make up for the lost functionality (gotta love that /rocket command though).
  27. Offline


    hmm, how to use the draw.js ?
    when i type "/cs draw.js image.jpg" i get the message: "script does not exist: ./craftscripts/draw.js

    i found the syntax somewhere, but now i can't find it anymore and the wiki doesn't mention it at all -.-
  28. Offline


    Lol gave everyone craftbook.* permissions people still cant make elevator signs.
  29. Offline


    for some reason with CB766 and latest craftbook if i don't assign the craftbook.mech.cauldron permission anyone without it gets a "you don't have permission to use this" error message every time people place blocks. no one is prevented from building despite the error message.
  30. Been like that for two weeks, development on this seems to have halted, sadly :(
  31. Offline


    really? weird i have had craftbook for some time it's only started doing this today out of the blue lol and it seems like the author will be taking this back up in a week or so

Share This Page