[MECH] CraftBook - Redstone bridges, gates, minecarts, ICs, more [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 27, 2011.

  1. Offline

    sk89q

    CraftBook adds a number of original gameplay elements to Minecraft from switchable bridges to elevators to gates (including flood gates)! It also has redstone support, allowing you to wire up pumpkins and use integrated circuits!

    Some cool stuff people made last year:




    Features:
    • Mechanisms
      • Bridges
      • Doors *not yet ported*
      • Gates
      • Elevators
      • Cauldrons
      • Light switches
      • Readable bookshelves
      • Toggle areas (advanced toggle doors and bridges)
      • Hidden switches
      • Custom block drops
      • Apple tree drops
      • Bookshelf drops
      • MORE!
    • Redstone
      • Integrated circuits
      • Programmable logic chips
      • Redstone pumpkins
      • Redstone netherstone
      • Ammeter
      • MORE!
    • Minecart features
      • Booster blocks
      • Brake blocks
      • Reverse blocks
      • Ejector blocks
      • Chest-storage minecart transfer blocks
      • Station blocks
      • Sort blocks
      • Message announcer block
      • Minecart dispensers
      • Change minecart behavior
      • MORE!
    Download

    CraftBook is being developed again, although by someone else. Get the latest downloads here: http://dev.bukkit.org/server-mods/craftbook/

    [​IMG] (CraftBook is open source!)
     
    kazeen, dragon8510, Jaein and 45 others like this.
  2. Offline

    PeterPAwN

    http://craftbook.sk89q.com/wiki/Usage

    stations will come with alpha 3
     

  3. Yes, I think I have experienced the same bug in another way.
    I constructed a home spawn with a pressure plate connected to 4 nether bloodstones.
    Worked perfectly until another player TPd to me and tried the pressure plate. After this, the fire won’t stop burning. Still the same thing if I rebuild the construction.
    Now to the funny part, I had an admin looking at it and when he used his magic carpet the dirt around his carpet got deleted, this does not happen anywhere else.

    Also if I now build a bridge in this area it won’t work.
    Building a few blocks away and it works perfectly

    So far as I can see it’s an old chunk sized 16*16 area that is affected by this.
     
  4. Offline

    MiKegamer

    hi.
    i use bukkit build 493 (downloaded 1 or 2 days ago)
    and today i downloaded craftbook here today.
    the server worked fine.
    after i installed craftbook i got an error message at server start.
    i don't know why i get the error, maybe you can help me.
    i just copied the 4 .jar files from the "craftbook-3.0-alpha1.zip" into the plugins folder of bukkit.
    did i do anything wrong?

    here the error: Click
     
  5. Offline

    david elson

    Have you tryed getting the latest version of world edit
     
  6. Offline

    MiKegamer

    eeeeh no ^^
    i did not need worldedit to use craftbook on hey0 ... so i thought it would be the same here.
    but i will try it. thanks
     
  7. Offline

    Jobsti

    I've got very very often the problem, that CraftBook says "destination is obstructed",
    but many of the lifts are old and worked with CraftBook from heyo or the SignLift Plugin.
     
  8. Offline

    fnullerbasse

    @sk89q When will the new update come out ? :D
     
  9. Offline

    NotYetRated

    Has anyone gotten redstone powered bridges/gates to work? I cant seem to get it....
     
  10. Offline

    evangds

    yup. just ran a line of redstone into the face of the sign and it started switching with the current.
     
  11. Offline

    DoomBunnyPwn

    Does this stop water flow with redstone?
     
  12. Offline

    MiKegamer

    hi. now i installed the newest worldedit, and craftbook.
    no error messages so far :)
    but the lift does not work.

    i created a [Lift Up] and a [Lift Down] sign as i always did in hmod,
    i can use the lift up, but i CAN'T use lift down :-(
    when i click on the lift down sign, nothing happens
     
  13. Offline

    Uniltiranyu

    Its works fine on my server, but none of the IC's work
     
  14. Offline

    Kingjarrad

    Thanks
     
  15. Offline

    Racha

    Why Bridge are not working for me? ;( How to set up them?
     
  16. Offline

    okami13

  17. Offline

    Nuinbot

    You can check the link below for not only how to use CraftBook features, but also what is and isn't working with 1.3. Please read it before posting here.

    http://craftbook.sk89q.com/wiki/Usage
     
  18. Offline

    FilipT

    I got some sugggestions for your amazing plugin! :)
    Movement Sensor
    Place a block under your rails, that will get power the redstone under it, if Movecart rode on it.

    Item Sensor
    Dunno if possible, but still.
    If is item detected on it, it places the item inside the chest next to the it!
    Now you can make one-way chests even easier!
     
  19. Offline

    ATmegaRed

    i have another problem... is it possible, that the plugin changed the crafting recipe for storage carts?
     
  20. Offline

    newyorkdaily

    ALOT of things are still being ported over from hmod to craftbukkit. Hmod does not work the same way so it takes a little more time and is a little harder for the developer team to port stuff over.
     
  21. Offline

    FilipT

    Nope, plugin can't change crafting recipes. :)
    It's Cart + Chest.
     
  22. Offline

    1994mat

    My bridge wont put blocks back when redstone is off, How do I edit the setting (There was an setting with HMod, I can't find any craftbukkit.yml or something like that
     
  23. Offline

    kaotic

    I'm running into a small issue where boosters work weather or not I have Redstone power to them. I set up a small circut and turn the lever off but the booster is still boosting carts. any ideas?
     
  24. Offline

    hash

    Not implemented yet. I was working on carts earlier tonight though and someone else just picked up where I left off, so I'd say there's a goodly chance it'll be done within a few days.

    Also, you mean "whether", darling, not "weather". Consider the following: http://theoatmeal.com/comics/misspelling
     
  25. Offline

    kaotic

    You are indeed correct on my misspelling, I knowingly typo'd it and mistakenly trusted the built in spell check's first suggestion as correct.

    But thanks for the update, I'll get the newer files in a few days and keep playing with my creations.
     
  26. Offline

    3kman

    This might be a stupid question but is it possible to make a room with furniture etc and then have something saving this as it.
    So if i put alot of say sand in the room, I can easily with a button just reset the room as it was?
    I'm making abit of escapecraft on a smp server so I was wondering if this is possible, It could also work with //set air in the room. :p
     
  27. Offline

    AFakeman

    When I try (w/ the latest version (developer snapshot)) CB, it launches normaly and enables, but I can't use any scheme.
     
  28. Offline

    Andre_9796

    22:05:03 [SCHWERWIEGEND] Could not pass event BLOCK_RIGHTCLICKED to CraftBookMec
    hanisms
    java.lang.NullPointerException
    at net.minecraft.server.BlockSign.a(BlockSign.java:109)
    at net.minecraft.server.World.k(World.java:369)
    at net.minecraft.server.World.h(World.java:344)
    at net.minecraft.server.World.f(World.java:317)
    at net.minecraft.server.World.e(World.java:293)
    at org.bukkit.craftbukkit.block.CraftBlock.setTypeId(CraftBlock.java:127
    )
    at com.sk89q.craftbook.mech.Gate.toggleColumn(Gate.java:261)
    at com.sk89q.craftbook.mech.Gate.recurseColumn(Gate.java:223)
    at com.sk89q.craftbook.mech.Gate.toggleColumn(Gate.java:266)
    at com.sk89q.craftbook.mech.Gate.recurseColumn(Gate.java:223)
    at com.sk89q.craftbook.mech.Gate.toggleGates(Gate.java:111)
    at com.sk89q.craftbook.mech.Gate.onRightClick(Gate.java:284)
    at com.sk89q.craftbook.MechanicManager.dispatchBlockRightClick(MechanicM
    anager.java:108)
    at com.sk89q.craftbook.bukkit.MechanicListenerAdapter$MechanicBlockListe
    ner.onBlockRightClick(MechanicListenerAdapter.java:97)
    at org.bukkit.plugin.java.JavaPluginLoader$20.execute(JavaPluginLoader.j
    ava:259)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    a:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    ava:255)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:493)
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:76)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)


    What is causing this error, its when i right click a sign with [GATE] then the gate toggles and the error comes.then the gate is "half closed" that means some of the fences arent moved
     
  29. Offline

    IpwndU

    :( I can't get anything to work, none of the signs work. I've tried everything, it says:

    (
    21:06:21 [INFO] CraftBookCommon 3.0-alpha1 enabled.
    21:06:21 [INFO] CraftBookCircuits 3.0-alpha1 enabled.
    21:06:21 [INFO] CraftBookMechanisms 3.0-alpha1 enabled.
    21:06:21 [INFO] CraftBookVehicles 3.0-alpha1 enabled.

    )
    and it still doesn't work :(

    i have a mac OS 10.5.8
    i have [Permissions] version 2.5 Phoenix
    and WorldEdit 4.1
    please help
     
  30. Offline

    Myrrdin

    I need to disable the books, but there is no longer a config file anywhere to be found. When will one be created for this plugin?
     
  31. Offline

    evangds

    the world may never know, but you could start out by editing the file with wut the books will say. you can change it to either be blank or just have one very short line of text.
     

Share This Page