[MECH] CraftBook - Redstone bridges, gates, minecarts, ICs, more [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 27, 2011.

  1. Offline


    CraftBook adds a number of original gameplay elements to Minecraft from switchable bridges to elevators to gates (including flood gates)! It also has redstone support, allowing you to wire up pumpkins and use integrated circuits!

    Some cool stuff people made last year:

    • Mechanisms
      • Bridges
      • Doors *not yet ported*
      • Gates
      • Elevators
      • Cauldrons
      • Light switches
      • Readable bookshelves
      • Toggle areas (advanced toggle doors and bridges)
      • Hidden switches
      • Custom block drops
      • Apple tree drops
      • Bookshelf drops
      • MORE!
    • Redstone
      • Integrated circuits
      • Programmable logic chips
      • Redstone pumpkins
      • Redstone netherstone
      • Ammeter
      • MORE!
    • Minecart features
      • Booster blocks
      • Brake blocks
      • Reverse blocks
      • Ejector blocks
      • Chest-storage minecart transfer blocks
      • Station blocks
      • Sort blocks
      • Message announcer block
      • Minecart dispensers
      • Change minecart behavior
      • MORE!

    CraftBook is being developed again, although by someone else. Get the latest downloads here: http://dev.bukkit.org/server-mods/craftbook/

    [​IMG] (CraftBook is open source!)
    kazeen, dragon8510, Jaein and 45 others like this.
  2. Offline


    Booster blocks were kinda buggy for me at first. I made one and jumped on it, no boost. My friend then jumped on the minecart after me and he was boosted. Worked after that, so not sure why it didn't work right away.
  3. Offline


    Oh yeah. Got our 50% of fun in Minecraft back!
  4. Offline


    hä ? what u mean ?
  5. Offline


  6. Offline


    the title, while it doesn't state that nothing else works, but does give good reason to believe at least some IC's don't work, lists the main current working features of craftbook:
    bridges, gates, and minecarts.

    in addition there are also elevators and toggle-able netherrack/jack-o-lanterns.
  7. Offline


    well, obviously he is frustrated for no reason, but i understand cuz i don't think the title itself was screaming that they dont work yet, and if they did then im oblivious to, but if u looked at his blog it would say they aren't ported yet, but he hopes to have them up by the end of the week.
    --- merged: Mar 7, 2011 9:35 PM ---
    it's ok everyone has a reason for posting, but yes they do not work yet, but he recently announced that he hopes to have them up by the end of the week
    --- merged: Mar 7, 2011 9:39 PM ---
    its people who waste there time insulting other people for having problems like you that make absolutely no sense in my eyes
  8. Offline


    so it will works in the next days ? :D
  9. Offline


    that's all we know.
  10. Offline


    he is gonna try to get them to work in the next few days, and i hope he is successful, but there is no guarantee.
  11. Offline


    I actually have some news about that. I spent a few hours in an extended debugging session with a very helpful user, and we got some results that were really... Interesting, shall we say?

    There seem to have been some builds of bukkit/craftbukkit in which signs weren't always fully recognized as such. They'd show up in clients with text and so on, but generate absolutely no events in CraftBook. Under a little more examination it turned out they weren't detectable as sign blocks at all in other plugins like VoxelSniper, either.

    This weirdness might be why some of you folks out there report having gates and bridges from your own hmod world working, but new ones won't: signposts from worlds just ported to bukkit for the first time don't have this problem, while any sign placed in bukkit does (and actually, it's a little funnier than that -- signs in locations that had signs when you ported it work, so you can destroy the old sign and place a new one there and it still works even when a new one right next to it doesn't). I didn't directly observe any instances of this being correlated to chunk loading/unloading, but it wouldn't surprise me if it is somewhere (I'm guessing this whole thing comes from a bug in Entity serialization in craftbukkit).

    This issue definitely shows up under craftbukkit build 440. I have no idea how extant it is, but in the case I examined in detail the issue went away with upgrading craftbukkit. Hope this helps anyone out there having trouble (though as a heads up, you all may soon be required to update to a very recent build of craftbukkit in order to use ICs anyway).
  12. Is this incompatible with minecart mania? If so, is there any way to get everything BUT the minecart stuff? My mods worked really hard on our transit system.
  13. Offline


    it works, just don't get the craftbookvehicles.jar file
  14. Offline


    The problem is that we use #491, and this still not works correctly.
    I'm going to upgrade again !

    Edit ; with latest build, this is working correctly.
  15. Offline


    Hey, this might be a bit noobish, but will glowstone on/off support be added?

  16. Offline


    I doubt it as glowstone doesn't have an on and an off state like torches (normal and unpowered red for on and off), pumpkins (pumpkin and jack-o-lantern for off and on) or netherrack (fire or no fire) so i don't think it's really possible without using a totally different block for the off state.
  17. Offline


    i recommend downloading ONLY the recommended builds because of craftbukkit's fragile ability to be screwed up badly due to its open source license (no offense to the bukkit team i think its a wonderful thing to have open source license on such a major project)
  18. Offline


    That's your prerogative and you can recommend whatever you want... but I just told everyone quite plainly that there's a major bug in something marked as a recommended build until quite recently, it's a bug that's already been fixed, and it's a bug that will completely prevent folks from having CraftBook as well as a potentially vast array of other plugins work correctly or even predictably. Builds like 440 may have been marked as recommended, but if you sit and have an off the record chat with folks on the bukkit team, 440 is nonetheless considered significantly out of date, most bugs in it are of no real interest, and the first thing they'd tell you is update, regardless of whether or not your current build was marked as recommended at some point.
  19. Offline


    New things ...
    Finnally, the bug is here again ! I really don't understand. This morning, I could log out, log in and use bridges perfectly. Now, same bug than before ; when you log out in front of a bridge and log in again, the bridge can be used one time and then does not respond anymore.

    But, if you teleport yourself elsewhere (with no players) and construct a bridge, it will work. until you log out ...

    So, I think than once a bridge has been loaded (a player comes near it) , it should not been unload (ie, there is no one near the bridge and chunk are unloaded) because reload the bridge is not done correctly.
  20. Offline


    It's a triggered issue of some sort, and it's affecting a lot of plugins. Minecart Mania, WormHoleXTreme and others.
    The issue seems to be linked to the following two bugs
  21. Offline


    Minecart boosters (via redstone) and launchers (via redstone) aren't working for me at all in the latest recommended build.

    Kinda defeats the whole purpose of the plugin for me :/
  22. Offline


    yea i know, and 440 is not recommended build anymore, 493 is
  23. Offline


    520 is latest recommended ;)
  24. Offline


    really? hmm that's cool i guess.
  25. Offline


    well i keep getting this error! i read the past threads, and maybe because i have pulsars on my map! and ALOT of them!

    2011-03-09 16:44:26 [SEVERE] Could not pass event REDSTONE_CHANGE to CraftBookMechanisms
    java.lang.NoSuchMethodError: com.sk89q.worldedit.blocks.BlockType.isRedstoneBlock(I)Z
    at com.sk89q.craftbook.bukkit.MechanicListenerAdapter$MechanicBlockListener.onBlockRedstoneChange(MechanicListenerAdapter.java:174)
    at org.bukkit.plugin.java.JavaPluginLoader$28.execute(JavaPluginLoader.java:299)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:255)
    at net.minecraft.server.BlockRedstoneWire.a(BlockRedstoneWire.java:110)
    at net.minecraft.server.BlockRedstoneWire.g(BlockRedstoneWire.java:40)
    at net.minecraft.server.BlockRedstoneWire.a(BlockRedstoneWire.java:284)
    at net.minecraft.server.World.k(World.java:369)
    at net.minecraft.server.World.h(World.java:348)
    at net.minecraft.server.World.f(World.java:317)
    at net.minecraft.server.World.b(World.java:302)
    at net.minecraft.server.BlockRedstoneTorch.a(BlockRedstoneTorch.java:112)
    at net.minecraft.server.World.a(World.java:1534)
    at net.minecraft.server.World.g(World.java:1433)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:348)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)

    can u fix it?
  26. Offline


    make sure you are running the most up to date version of WorldEdit (beta 8 i believe).
    i updated and it fixed it.
  27. Offline


    world edit 8 beta? wouldn't that be unstable! hence, i shall try it! i will report back in 10 mins
  28. Offline


    you made my day[​IMG]
  29. Offline


    Thanks great mod . Will be awsome when a few bugs are sorted out
    Having alot of trouble with elevators saying destination is obstructed for no reason
  30. Offline


    ya that's a known bug (or at least a widely reported one). you just need to make sure that the destination has a vertical space of 3 blocks or more.
  31. Offline


    Hey! i got a problem with Station block it wont stop the minecart.
    i have checked everything to the video tutorial and tried everthing still wont work
    using obsidan 49 as in config

    bukit 493
    craftbook 3.0
    world edit 4.0 beta 8

Share This Page