[MECH] Archers v1.0 - Advanced Archery [1.5R0.1]

Discussion in 'Archived: Plugin Releases' started by 1337, Apr 27, 2011.

  1. Offline


    Archers (Reborn) - Made by [1337]
    I - Introduction
    Archers, makes archery way more powerful and fun! It has a big list of special arrows who can be enabled/disabled easily with Permissions.
    Here is a quick list of its possibilities:
    • Powerful Arrows Light things up with Fire and Lighting arrows, Blow things up with TNT arrows, morph monsters, and the mighty Nuke arrow
    • Fun Arrows generate new trees, make mobs fly up and teleport
    II - Download
    III - Installation and configuration
    • Check the Permission nodes below:
      • Code:
        archers.bow.(arrow name) - Needed to fire the bow
    IV - Usage
    It is really easy. If you type /arrow a list with available arrows will pop up, if you need more information. Just type /arrow (arrow name), and you can see what ammo it uses, and what you too enable it. Also if you dont have permission for a arrow it shows up red, if you do have permission it shows up green

    V - Final note
    Suggestions, Questions or bug reports: Post them in this Thread!
    You can also post, what you want to be updated first. That would also really help me :)
  2. Offline


    He may be online,but he said to me he is quiting bukkit.this is a quote from him on skype:
    [5/14/2011 7:57:42 PM] jack: What your not working on archers anymore?
    [5/14/2011 7:58:13 PM] TechGuard: Not really
  3. Offline


    [SEVERE] Could not pass event PLAYER_INTERACT to Archers
    java.lang.NoClassDefFoundError: com/nijiko/permissions/PermissionHandler
    at TechGuard.x1337x.Archers.pListener.onPlayerInteract(pListener.java:68)
    at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.java:280)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:289)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:162)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:133)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:496)
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.ClassNotFoundException: com.nijiko.permissions.PermissionHandler
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 14 more

    that comes up in the server window when i try to fire an arrow and the arrow doesnt fire, with tnt arrow sometimes if i log off and back on the explosions are there though...:(

    srry about the bold writing...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  4. Offline


    Do you have permissions?
    Show me the text that comes up when Archers are enabled
  5. Offline


    i Watched 1337´s github and see they are currently coding v 2.1 when can we exspect the release??
  6. Offline


    [Archers : 2.1] Permission system not detected! Disabling..
    2011-05-19 05:29:32 [INFO] [Archers : 2.1] Disabled!
    2011-05-19 05:29:32 [INFO] [Archers : 2.1] Bukkit version is the recommend version for Archers
    2011-05-19 05:29:32 [INFO] [Archers : 2.1] Made by TechGuard and x1337x Enabled!

    And no i don't have permissions, do you need it?

    Permissions is required! If you don't have it, sorry, you really need it.

    oh sorry, i thought it said:
    Permissions is not required! If you don't have it you really don't need it.
    How do i configure permissions, to make anyone be able to use archers?

    I got it working now!!!

    Great plugin by the way

    now this comes up when viewing ammo for sniper

    [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'arrow' in plugin Archers v2.1
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:278)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:682)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:645)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:639)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.NullPointerException
    at TechGuard.x1337x.Archers.Commands.ArrowCommand.onCommand(ArrowCommand.java:47)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    ... 12 more

    is sniper arrow working???

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  7. Offline


    Would it be possible to use leftclick to cycle through arrow types? Having to type a command all the time is pretty annoying. This was done for spells on the AetaPriest plugin so I figure it's possible to do for this as well.
  8. Offline


    You got the OP! Congratulations!
  9. Offline


    LOVE this plugin! I especially like the feature you didn't mention: If you don't give any permissions, the player can't use a bow. Not sure if its a bug but please keep it like that, not hard to add normal bow to default for those who want it :p
    (We have various Races and I only want Rangers using a bow not the rest..)

    Only suggestion: Configurable Cooldowns? and maybe an option to change the blocks we use to select our arrow; Ice, Redstone Ore and Webs aren't possible to get in the game naturally (I've spawned them for a "Ranger Selection Room" but players want runes in their houses)

    Also, maybe a slightly clearer guide, I didn't understand it until I watched the video. I was sitting there clicking a sheep with a wool block in my hand and shouting WHY YOU NO FLY until I decided to look a little harder :p Maybe its just me?
  10. Offline


    is it a bug that when i shoot arrows it makes the contactsound and then they act like another persons arrows (jumpy)? this seems to be them hitting me and then trying to fix themselves or something as when i move this doesnt happen but they can be quite jumpy compaered to the earlier review :/ cant be a problem with server power. were on diamond tier brohost


    it also seems to not allow me to see certain arrow types for instance when i type /arrow torch

    an internal error appears. :/ ill find it in the logs
  11. Offline


    Hi there, getting these errors:

    [COLOR=rgb(0, 0, 0)]2011-05-20 03:57:14 [SEVERE] Could not pass event PLAYER_INTERACT to Archers[/COLOR]
    [COLOR=rgb(0, 0, 0)]java.lang.NullPointerException[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at TechGuard.x1337x.Archers.pListener.onPlayerInteract(pListener.java:73)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.java:280)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:289)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:162)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:207)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:526)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at net.minecraft.server.Packet15Place.a(SourceFile:57)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)[/COLOR]
    [COLOR=rgb(0, 0, 0)]	at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)

    I have literally just put the plugin on, and got rid of the hashes in the arrows.ammo file

    bukkit 766 and latest archers
  12. Offline


    Thats why then,you need the #'s deleate you config files and restart your server

    Should be,is the sniper arrow there in the config file?

    Its done,I just got control of the op so i will be updating the link now :p

    ok main download link updated to 2.1 :D sorry i havnt been getting back to people lately, the op move seemed to break my alerts :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  13. Offline


    So what are the new arrow types? :D downloading now

    Got it, first bug found was in the config, you'd put:
    #Torch arrow

    so it was just charging one arrow and nothing else. Changing to:

    #Torch arrow

    fixed it to also charge one torch :p
    (I doubt its possible but could the arrow also emit light when its flying for this type? as if you literally just fired a torch..)

    Also, I've always thought a few of the types had misleading names (for example Fly, which doesn't make you fly.. maybe Throw?) - one example would be Steal, which is more Disarm?
  14. Offline


    oh my god, im an idiot. i thought you had to un-hash the arrow types to enable them ^^

  15. Offline


    Is this a new version, dare I hope that it now has the craft permission thingy in it? If so, what is the permission I should be using for it?

    Thanks for keeping this going!

  16. Offline


    Oh its not the new version,its the 2.1 with the sniper arrow and stuff,i just moved it into the main post :p
  17. Offline


    Ah OK! Just can't wait for this feature so I can enable the plugin on my server and start selling bows :)


  18. Offline


    Hi 1337,

    This plug in looks awesome, but I'm having the darnedest time getting it to work right. Let me give you some back ground first. I have permissions, and I know how to use permissions. I am trying to run this on my Clanforge Multiplay server. I am the Admin and an Op. I have also given the default group the permissions "archers.bow.*" and "archers.arrow".

    Okay I have version 2.1, and it is installed. When I log on to my server, and I fire my arrow, it makes the noise and takes away an arrow, but it doesn't do any effect. Also, my arrow doesn't show or exist in the world, and when I log out and log back in, I get my arrows back. Now to me it sounds like a permissions error, but I'm the admin and I have all commands, and I am also an Op.

    Another issue is that when I try the command /archers help, or the other two, I get "An internal error has occurred while attempting to perform this command"

    Do you have any insights on these issues?

  19. Offline


    Could you show me the inside of your ammo.ammo file?
  20. Offline


    Do you mean arrow.ammo file? If so, it's posted below. If not, I don't know what file that is...

    #The right order:
    #Arrow names:
    #Lines witch start with the # symbol, will be ignored!
    #Normal Arrow
    #Ice Arrow
    #Fire Arrow
    #TNT Arrow
    #Thunder Arrow
    #Monster Arrow
    #Thrice Arrow
    #Zombie Arrow
    #Tree Arrow
    #Pig Arrow
    #Zeus Arrow
    #TP Arrow
    #Fly arrow
    #Torch arrow
    #Steal arrow
    #Sniper arrow
  21. Offline


    Did you miss my post, or are you not willing to add this feature?
    It was the ability to cycle between arrow types by punching air with the bow.
    If you don't wanna do it, please respond stating so at least.
  22. Offline



    Dude, I love this plugin, it's awesome, can't wait to test it out. I'm afraid, though, that people on the same faction will teamkill each other and such like that. Can you put in a feature where it won't work if you and the target are both in the same 'faction', or a certain group? Similar to this plugin: GroupPvP

    Hopefully you can implement it without breaking the code too badly,

  23. Offline


    Normal-Arrow-Damage: 4
    Normal-Arrow-Speed: 1

    that is my config file, but no it isn't in the ammo file either.
  24. Offline


    Ok then deleate the files inside the archers folder then restart your server :D

    What so removing the need to hit blocks?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  25. Offline


    Thanks it works now, small config file though, you should combine it with the arrow.ammo, it doesnt make sence having a file with 4 lines, it dont know java though so i may be wrong
  26. Offline


    The config file will be replaced next update,with a new one that has config for all the arrows
  27. Offline


    Yea, perhaps having a config for two modes of switching between arrows.
  28. Offline


    Added to TODO :D

    Does anyone have a server using this that i can come on? i would love to be able to use it cause i dont realy use it for fun :D
  29. Offline


    You could come to mine but it's an RPG PvP server, so you'd need to be an archer and would only be able to kill the thief clan members, plus most players are from us, so it's only active during us daytime/evening. Tell me if you're still interested, I'll set your group to archer.
  30. Offline


    People of the same faction will teamkill each other? What's wrong with them?
  31. Offline


    Don't remove it :O Maybe just let us choose which method: I like the idea that someone has to carry more than one bow to have more than one arrow type, limits their food amounts ;)

    @m5k - did you realise you can configure a bow to an arrow type, then get a second bow and set that to another one? I didn't see it on any walkthroughs, worked it out by accident... just another way of "cycling" through bows.
    Someone could probably make a really simple client side mod, that detects what bow type a bow is set to and puts a little icon above it, just as an add-on to help :p

Share This Page