[MECH] Archers v1.0 - Advanced Archery [1.5R0.1]

Discussion in 'Archived: Plugin Releases' started by 1337, Apr 27, 2011.

  1. Offline


    Archers (Reborn) - Made by [1337]
    I - Introduction
    Archers, makes archery way more powerful and fun! It has a big list of special arrows who can be enabled/disabled easily with Permissions.
    Here is a quick list of its possibilities:
    • Powerful Arrows Light things up with Fire and Lighting arrows, Blow things up with TNT arrows, morph monsters, and the mighty Nuke arrow
    • Fun Arrows generate new trees, make mobs fly up and teleport
    II - Download
    III - Installation and configuration
    • Check the Permission nodes below:
      • Code:
        archers.bow.(arrow name) - Needed to fire the bow
    IV - Usage
    It is really easy. If you type /arrow a list with available arrows will pop up, if you need more information. Just type /arrow (arrow name), and you can see what ammo it uses, and what you too enable it. Also if you dont have permission for a arrow it shows up red, if you do have permission it shows up green

    V - Final note
    Suggestions, Questions or bug reports: Post them in this Thread!
    You can also post, what you want to be updated first. That would also really help me :)
  2. Offline


    Can someone help me?
    I CANNOT get permissions to work. Can someone post theirs (the text from it)? I just need it to be so that the admins can use all the arrows.
  3. Offline


    in your admin group under permissions add

    - archers.bow.*

    make sure its formatted just like the other permissions around it
  4. Offline


    how does lightning arrow look like? And how is it different from the zeus arrow?
  5. Lighting: When the arrow lands a Lightning strike will come down from the sky to there.
    Zeus: When the arrow lands: tnt and lightning blows up that place.
  6. Offline


    Would it be possible to add in web shooting?

    Great mod by the way.
  7. Offline


    Could you remove the part with hittin' items
    cuz i dont't want to hit TNT for TNT Arrow.
    It will be better just to type /arrow TNT
  8. Offline


    Webs don't do anything do they? I will start later adding that
  9. Offline


    A web cube slows movement when you walk through it, so it could be useful to slow enemies at a distance. By the way, I guess this was already mentioned, but having to hit blocks to activate the mode is quite annoying. Well, at least each bow stays activated with each arrow, so you can have multiple bows. Oh, and I can't get the fire arrows to work, because I can't seem to hit a fire block...
  10. Offline


    how can i get a arrow type because i type in /arrow thunder and it says i have to left klick on redstone ore but when i do that with my pickaxe or with ym bow o with the arrow nothign happpened
  11. Offline


    I came across the same problem as tommy99: Hitting the redstone block with any mouseclick (while holding the bow, of course) does not change the arrow to a thunder arrow, even though /arrow thunder states that redstone ore must be hit to activate thunder arrows. Other arrows, like the tp, fire and normal arrows, do work for me.

    Also, a web-arrow, which creates a web block on impact, would indeed be useful. I guess it would require either strings, or a web block in order to be used.

    Anyway, this plugin has made the art of archery far more enjoyable and useful! In the server I use, the arrow range multiplier has been set to 10000 or so, and it takes around 12 minutes for the arrow to hit you after shooting it directly upwards. You guys did a great job here!
  12. Please change text "To activate it, left click:" with "To activate it, left click with bow on:"
    Its really confusing for new users to figure it out.

    Otherwise Great Plugin !
  13. Offline


    they will slow you down by alot, maybe you could make it deploy a 3x3 square of webs so you can slow people coming at you and/or make it easier to shoot them with other arrows :)
  14. Offline


    any one moaning about the block clicking I am starting work on a command based version but it won't be releases unless tech agrees with it as he has the download host and not me
  15. Nope, I don't agree with it. I will add a new config file very soon, what will help you all.
  16. Offline


    Me neither, it's a fun and innovative way to select the arrows you want to shoot. Please don't change it to commands.

    HEH-REM, I'm still here, please don't say they should follow the request.
    The real question is, why are you so insistent on giving us commands? It's a really lazy way of choosing the arrows you want to fire.

    To make it clear, this is mainly TechGuard's plugin, he made the basic source and both 1337 & TechGuard add new arrow types and fix bugs.
    1337 abandoned the originally requested plugin, to go and help TechGuard with this awesome plugin.

    Wrong ^

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
    anon likes this.
  17. I think that is a good explaination.
  18. Offline


    I don't understand. I'm rather new to this tho.

    I have set permissions according to:

            default: true
                prefix: ''
                suffix: ''
                build: true
                - '*'
                - 'WeatherControl.*'
                - 'archers.arrow'
                - 'archers.bow.*'
            group: Admins
    And when i logon to my server and i try to use TNT i do /arrow TNT
    The response i get is a white text saying: /arrow [arrow name]
    I've tried every single arrow name...
    What am i doing wrong?
  19. Offline


    Don't add the new permission nodes. The Admins group have all permissions by default (look at the '*').

    EDIT: Forgot to mention that you should not set the Admins group to default.
    It makes everybody who is not defined in a group an admin.
    Aramillio likes this.
  20. Offline


    Edit1: removed clutter

    how about making different stacks of arrows type defined instead of the bows? then you could designate a 'quiver' slot to select which type of arrow. I could abandon my command request for this.
  21. Offline


    Ehm hey i got a bug i think i have a photo here as you can see the arrows dont show and nothing works exept when i shoot it says bow material normal but when i write/arrow nothing happens

    Attached Files:

  22. Offline


    Please fix that skeleton arrow bug. The console spam makes me sad ;_;
  23. Offline


    and i play SMP
  24. Offline


    are you the admin of the server? what does your permissions look like?

    from what youre describing, it sounds like you arent the admin, and whoever installed the plugin didnt give you the permission - archers.bow.normal

    i had a similar problem where people i didnt want to use the different arrows, couldnt fire any arrows because i hadnt given them that permission.
  25. omfg, I love this guy :) He can explain things very well

    But pleas don't argue on this thread :)

    Well you act like this: OMG.. add my stupid requests!! .. Else i'm not going to use it!! *Then trying to find a way to .. annoy him?

    (TechGuard: So what if you don't use it, a lot of other people want it: 600 downloads already)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
    Aramillio likes this.
  26. Offline


    Please don't apologise, me and my server-users love this one way more than the originally requested plugin, I love TechGuard's version!
    What exactly you mean with the arrow/quivers?
  27. Offline


    Well, i tried to have it set to false - but it seems i can't do anything then. And no plugin seems to be working. But i'm using Mindcraft 1.5_02 along with the latest release of CraftBukkit.

    And in the console all the plugins are being loaded.

    This is my world.yml config: http://pastebin.com/K3fynPJg
    It's verified by Onlune YAML Parser.

    But i'm still not Admin.

    When i run the server i get the following:

    19:10:31 [INFO] Starting minecraft server version Beta 1.5_02
    19:10:31 [INFO] Loading properties
    19:10:31 [INFO] Starting Minecraft server on
    19:10:31 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-700-
    gf3ae4c3-b733jnks (MC: 1.5_02)
    19:10:31 [INFO] Preparing level "world"
    19:10:31 [INFO] Preparing start region
    19:10:32 [INFO] [Permissions] (Phoenix) was Initialized.
    19:10:32 [INFO] [Archers : 1.0] Made by [TechGuard, x1337x] Enabled!
    19:10:32 [INFO] [Permissions] version [2.7.1] (Phoenix)  loaded
    19:10:32 [INFO] [WeatherControl] Loaded configuration for world 'world'
    19:10:32 [INFO] [WeatherControl] version 0.4.4 is enabled!
    19:10:32 [INFO] Done (0,062s)! For help, type "help" or "?"
    I hope i have provided enough information so that you could see the problem here.

    Best regards,
  28. Offline


    Well, first of all, I see that you've set two groups to default, which means that people who are not defined to a group join both Default and Admins, which is impossible. Try to set Default to false and Admins to true.
    Not quite sure why it would not work when you already are in Admins, but two default groups just don't work.
  29. Offline


    So i have this now:

    I added this plugin: http://forums.bukkit.org/threads/ad...h-lightning-multiworld-permissions-740.13931/

    And when i do /wrath strike pastebin i get : "You do not have permission..."

    I don't get it...
  30. Offline


  31. Offline


    I think the block-clicking arrow selection is a great idea, and is one of the reasons this plugin is as good as it is. The quiver slot method is a good alternative, but I feel commands would ruin it.
    Aramillio likes this.

Share This Page