[MECH] AntiCreeper v4.5 - Creeper (and other explosion) controls [1.4.7-R1.0]

Discussion in 'Archived: Plugin Releases' started by Rothens, Jun 7, 2011.

  1. Hey, everyone, updated this in 3.3.0 to add enderman nerfing abilities. Please visit dev.bukkit.org for details.

    Also, if you've downloaded 3.2.0 or later and have tried to turn off player damage, but still see players getting 0.5-3 hearts or even death when hugging the creeper, this is a bug in Bukkit. I have reported it and it's reported to be fixed in 1.1.-R.8 but not yet in the mainline of code.
     
  2. Ok, 1
    It's now been fixed and released in 1.2.4. I tested it in 1.1R8 and assume the fix still works.

    FYI, I've been working on fire controls as a new feature.
     
  3. Offline

    LycaonX

    Are you going to update this for 1.2.5?

    Also, would you be a bit more clear when you say "Works with the latest recommended build"? Your post was last edited on November 13, 2011 so I've no clue WHAT version your plugin is actually supported on.
     
  4. Yes, this has been updated, but I don't have rights to this forums page from the original author (Rothens). He did give me right to edit the plugin page on dev.bukkit, so please go there to get the latest.
     
  5. Hey everyone, just uploaded 3.3.2 on dev.bukkit.org or you can try it from here. If you have tried setting
    Code:
    .entitydamage=false
    (yeah, there's other plugins that do that, but I've tried it during testing) and doesn't seem to work, this should fix it. Note that it is only effective if you have nerfed or are filtering block damage.
     
  6. Offline

    Rothens

    okay I'm back :) filbert66 sorry for not responding. Do You still need the permission? :)
     
  7. Yes, it would be nice to be able to edit the first post and title for this forum topic.
     
  8. Offline

    Rothens

    hm... I don't know gow to give permissions here :S
     
  9. Hey, thanks for updating the first post. Only thing left is to update the topic title with latest version of plugin and Bukkit build. This is per the new guidelines for plugin postings. Most concerned about the provision there that they may mark the plugin as outdated if the title doesn't reflect a recent Bukkit version. Something like:
    [MECH] AntiCreeper v3.3.2 - Creepers only damage players [1.2.5-R1.0]
     
  10. Offline

    thiagobrez

    So, i want Tnt to explode and ghast fireballs to explode too, how can i do that?
    ty :)
     
  11. Check out example configurations and detailed explanation on dev.bukkit.org. Default config file that comes in ZIP is configured to nerf creepers, TNT, and fireballs. That means damage players, but not blocks. If you want to only nerf creepers, change nerf_tnt/fireball.damageblocks to true.
     
  12. Offline

    wide1337

    It works.Thx^^
     
  13. Offline

    thiagobrez

    thanks :)
     
  14. Offline

    ThatchyDylan

    Thanks for the plugin! I really needed this because even tho I have torches around my house/inside creepers spawn in them, I had to re-build it 4 times... thanks!
    - [sheep] Dylan
     
  15. Offline

    Noctusxx

    Я поставил , но криперы все равно взрывают територию..
    Что делать?
    И как проверить работает ли он?
     
  16. Sorry, don't speak Russian. Above is Google's translation to English.

    Can you send me your Anticreeper/config.yml file? And confirm the version of Bukkit and AntiCreeper? Also may wish to refer to example configurations and explanations on http://dev.bukkit.org/server-mods/anticreeper/pages/new-configuration/
     
  17. Offline

    pumakid98

    does not work 4 me i spawn creeper to see if it works but still BOOM explode i hate [creeper] when im building :'(

    plz help

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 16, 2016
  18. Check out example configurations and detailed explanation on dev.bukkit.org. Default config file that comes in ZIP is configured to nerf creepers, TNT, and fireballs. That means damage players, but not blocks. If you want to make them not damage you or the stuff you're building as well, add to your config.yml:

    Code:
    nerf_creeper:
      damageblocks: false
      entitydamage:
        toplayer: false
        toitem: false
        topainting: false
     
  19. Offline

    pumakid98

    THX u so much :D
     
  20. Offline

    jasonrobin

    [diamond] BIG THANKS for This it works great and is very easy. :) [diamond] [diamond] [diamond][diamond][diamond]
     
  21. How to prevent Enderman from picking up blocks?
     
  22. Check out example configurations and detailed explanation on dev.bukkit.org. Specifically, just set the following in your config.yml:

    Code:
    nerf_endermen:
      blockliftok: true
    
     
  23. Offline

    John_Schmidt_

    Can you add an option to disable only fire on things please? Thanks for your time and plugin.
     
  24. You could try my other plugin, AntiFire. It won't stop fire from starting from explosions, but it can prevent blocks being destroyed by it, and defaults to preventing fire spreading at all.

    I could try to come up with a way to prevent TNT from starting anything on fire. Last time I tried, it didn't work.



    Got fire control working [fixed since version 3.6]. Will post new version, updated for 1.3.1, soon, after I add it back for nerfed explosions too.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 16, 2016
  25. Offline

    deadspaceXD

    Hey Rothens, i've a problem with the plugin :( it doesn't work, tnt explode and there's blockdamage

    nerf_tnt:
    damageblocks: false
    blocklist: 46

    why doesn't work it ? please help me out ;)
     
  26. Please complete a ticket on dev.bukkit.org with requested information, including your config.yml and desired behavior. Most common problem is the the world names under nerfed_worlds don't match.
     
  27. Offline

    John_Schmidt_

    Hi. I have a small request. Would you consider adding the option to stop chain reactions from tnt? Thanks for your time. Here, free cake: [cake] :cool:
     
  28. John, already have this feature. Check out the "No TNT Chains" sample config. Or just add 46 to your nerf_tnt.blocklist (assuming you haven't set nerf_tnt.whitelist true).
     
  29. Offline

    John_Schmidt_

    Ok thanks. But my name isn't John, by the way. I took that username from a song. John, Jacob Jingleheimer Schmidt... That name is my name too!
     
  30. Offline

    HIDEaNDSEK

    When 1.4.2 update will come to this plugin ?

    It's too AWSOME !!!![diamond]
     

Share This Page