[MECH] Adminium v1.1.3 - Destroy and Place Bedrock [953]

Discussion in 'Inactive/Unsupported Plugins' started by yoft, Apr 30, 2011.

  1. Offline


    Adminium - Destroy and Place Bedrock [bedrock], old school style.
    Version: v1.1.3

    Remember in Classic when OPs could place and destroy bedrock?
    Now you can do it in Beta too!

    • Place Bedrock
    • Destroy Bedrock
    • Permissions support
    Source Code

    bedrock.place - Allows players to place Bedrock.
    bedrock.break - Allows players to destroy Bedrock.
    bedrock.* - Allows players to do both.
    Version 1.1.0 - May 27th
    • Permissions is no longer a requirement, it will fall back on OPs
    Version 1.0.1 - May 1st
    • Release
    Digi likes this.
  2. Offline


    Tried this mod, could not get it to work. Running with permissions, admins @ bedrock.*, players @ bedrock.place, everyone is able to place and no one can break. Check capitalization on permissions, perhaps?

    Admitting this could be my problem and not the mod's.

    Very interested in simple bedrock mod.
  3. Offline


    There is a glitch that means you have to hit another block and drag onto the bedrock, I'll fix it soon.
  4. Offline


    Hmm. Does this have Permissions as a requirement, or can OPs just use it?
  5. BedrockControl?
  6. Offline


    I'd Like to know this as well.
  7. Offline


    I'm not entirely sure how Permissions deals with it, I'll get back to you when I have time to look into it.
  8. Offline


    I think you missed what was asked. He asked if you NEED permissions to actually use the plugin. Or if you can default it to ops only.
  9. Offline


    Do not work for me, do I need a tool ?

    Edit : In fact it only don't work if I start clic on the bedrock but if I start anywher before that works.

    Thank you, nice plug ;)
  10. Offline


    ^ This
  11. Offline


    I'm a bit busy with school stuff at the moment I'll find out in a few days.

    This is a bug I noticed after releasing it. Same as last answer ^^^ :)
  12. Offline


    Works great!
    It'll be even better one the "click-and-drag" glitch is fixed.

    One other glitch I notice is that it crashes with the use of "Delete Blocks v.0.3" and gives me the error:
    10:51:20 [SEVERE] Could not pass event BLOCK_DAMAGE to Delete Block
    	at org.bukkit.craftbukkit.inventory.CraftItemStack.getMaxStackSize(CraftItemStack.java:124)
    	at org.bukkit.craftbukkit.inventory.CraftInventory.firstPartial(CraftInventory.java:207)
    	at org.bukkit.craftbukkit.inventory.CraftInventory.addItem(CraftInventory.java:227)
    	at me.sebastian.BP.BPBlockListener.giveItem(BPBlockListener.java:53)
    	at me.sebastian.BP.BPBlockListener.onBlockDamage(BPBlockListener.java:23)
    	at org.bukkit.plugin.java.JavaPluginLoader$26.execute(JavaPluginLoader.java:358)
    	at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    	at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:257)
    	at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockDamageEvent(CraftEventFactory.java:180)
    	at net.minecraft.server.ItemInWorldManager.dig(ItemInWorldManager.java:87)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:433)
    	at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    	at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    If I have the Delete block command (/delete) turned on in order to be able to break blocks instantly and then delete a block of bedrock... it freezes, crashes, and shows this error in the server terminal.

    Link to other plugin: "Delete Blocks v.0.3"
  13. Offline


    Thanks, I'll have a look.
  14. Offline

    fregaPT I steal plugins as my own

    But ...
    I'm waiting for the source code :D
  15. Offline


    I'm still REALLY busy with school :( barely have time to come on here, I'll put it up and PM you when I can.
  16. Offline


    @Zombtastic @Vega @Alunaris
    Okay, the "click-and-drag" glitch was minecraft not the plugin and is now fixed in 1.6.4 :D

    @Zenithas @Manbeast77
    As of the new version, permissions is no longer required, but can still be used. :)

    Source code is now up :)

    Sorry it took so long to get to these things and thanks for the feedback :)
  17. Offline


    Hey, cool. Glad you took he time to get back with us. Will test today, and let you know the results.

    I'm going to go out on a limb here and assume that you need to be running the 1.64 version of the MC server for this to work. I'm running the latest CB build, but not the latest minecraft because of the bugs. Unless there's a super sneaky way to get rid of the blocks I'm unaware of, I can't get rid of the blocks I place.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  18. Offline


    I used 1.6.4, yes, but it SHOULD still work on older builds. I'm not sure when the bedrock targeting was fixed though :/
    Can you try and explain the problem you're having? I didn't really understand it :/
  19. Offline


    Ok, I guess the best way of figuring this out is this: How exactly do you delete the bedrock? I have tried right clicking, mining, using a stick, all of the usual ways to get rid of blocks.
  20. Offline


    try clicking on another block and dragging onto the bedrock, that's what I had to do when using older versions of the client.
  21. Offline


    Worked with 818 but fails now with 860. I hope there will be an update because I love this mod. :)
  22. Offline


    I wanted to use bedrock as an additional layer to a wall/ roof/ floor for something important. (rather than having to rely on worldguard)

    Hope this gets updated.
  23. Offline


    What else did you want added?
  24. Offline


    Drackbolt said "I hope there will be an update" so I assumed it wasn't working with the current version. As for features, it's fine the way it is. :]
  25. Offline


    It works fine with the current version :)
  26. I just hit "like" because of the title =) awesome.

    Also, if it works fine with 953 you should edit the title because people may omit it without reading the comments.
  27. Offline


    Thanks for reminding me :)
  28. Offline


    the title should also be editted to [MECH] instead of [Mech]
  29. Offline


    what am i doing wrong? ive set permissions but /bedrock.place and /bedrock.break wont work ingame
  30. bedrock.place and bedrock.break are permission NODES, you set them in groups.yml, they're not commands.

    You break bedrock by hitting it and you place bedrock by giving bedrock to yourself (that's possible even without plugin).

Share This Page