java.netBindException: Cannot assign requested address: JVM_Bind

Discussion in 'Bukkit Help' started by JayzaSapphire, Feb 28, 2012.

Thread Status:
Not open for further replies.
  1. server-ip= (blank) is the same as server-ip=localhost
    sryz mate but u just have to put it there if it doesnt work
     
  2. Well actually it's not the same, cause the server starts with localhost. Anyone else wanna help?
     
  3. well what does this mean then?
     
  4. When you run the snapshots, that now run a server for singleplayer, the server isn't listed until you enable it. So there is the button in the options menu where you can make your single player world public, so it works like lan. My problem is that i can't start that server because it doesn't connect to anything, and i can't specify the ip (unless someone adds that in) so i cannot start the local in-game server for snapshots, and i cannot define an ip for it to connect to either.
     
  5. er what snapshots?
     
  6. craftbukkit? in general
     
  7. Well i still need help fixing this problem -.-
     
  8. well im off to bed now ill b thinking about this while i sleep lol
     
  9. Offline

    TnT Retired Staff

    If you are getting "cannot bind to port" with the server-ip= line blank, then you have another service listening on port 25565.
    Multiple ways to address this - easiest is to reboot your system and do nothing else other than starting your server (and only one server).

    If you're running the snapshot as well and you get that problem, its because the snapshots allow you to run a local server that will listen on port 25565.
     
  10. It's not the problem of binding to the port, it's the problem of binding to the address, nothing is wrong with the port at all.

    Bump.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 24, 2016
  11. Error: Failed to bind to port


    Error: Friends are unable to connect?


    Error: Friends are now unable to connect... but could X time ago!

    Source: http://forums.bukkit.org/threads/troubleshooting-common-problems-with-solution.44590/
     
  12. Seriously will someone listen to me?!?!?!

     
  13. This is a common problem.
     
  14. It's not actually, otherwise it'd be solved already...
     
  15. lol we can c that

    n probs not cause no one +bukkit staff have solved it and im sure they can read

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 24, 2016
  16. It would be nice if someone was willing to see the fact that this isn't some other error that everyone else has -.-
     
    Axe2760 likes this.
  17. i am seeing that thats y i don no how to solve it
     
  18. This error seems to mimic the error when people try to use their external ip to start the server, because the server knows that it exists and doesn't timeout, but it also doesn't connect to it.
     
  19. are you using a snapshot?
     
  20. No, this error happens whenever i try to start my minecraft server without listing an ip, i wanna fix this so i can use in-game snapshot servers.
     
  21. You cant use single player snapshots in bukkit 1.2.5 R4
     
  22. You just made no sense, what?
     
  23. YOU CANNOT USE SNAPSHOTS!
     
  24. You made no sense at all still, even on the second time -.-

    In the snapshots it uses the server that is in the minecraft.jar, you can't specify any server or anything, so how exactly would i be using bukkit, and how exactly would that be giving me this error?
     
  25. ^ BUKKIT HELP FORUMS ^
     
    Omnitv likes this.
  26. Well i give up, not gonna get any help on this at all, noone attempts to understand my problem and continues to bring up complete uselessness that has nothing to do with this. TnT lock this or delete it or whatever, it's useless trying to get help.
     
  27. or maybe your on the wrong forums??
     
Thread Status:
Not open for further replies.

Share This Page