Received string length longer than maximum allowed (19 > 16)

Discussion in 'Bukkit Help' started by DoctorBoyd, 16, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    When I try to log in with a username that is 19 characters long, I am unable to do so.

    It says [End of Stream] on the client and [ Received string length longer than maximum allowed (19 > 16)] on craftbukkit.

    I know this is due to my username being too long.

    Is there a way to fix this? or is a fix doable/planned? This is the first I've heard of a username character length limit.

    I'm also wondering why they'd let me create, then sell me, an account that I cannot use online?

    I appreciate any insight. Thanks.

  2. Offline


    i would recommend using build 1060 first off, if that doesn't fix it, check the settings for your login plugin(if you have one, if you don't then i don't know why) and change the maximum name length value.
  3. Well that stinks your options are to join another server, ask the Admin to increase the character limit if they have an auth plugin or buy a new account
  4. Offline


    I tried build#1060 originally and had the same problem. I'm not using any type of login plugin. What ones would you suggest?

    Also. Is this a problem with craftbukkit? or minecraft in general?
  5. Offline


    its craftbukkit i believe.. i would use AuthMe
    Another thing is check you server properties and see if there is anything about the length in there(i doubt it)
    here is the link CLICK FOR GREATNESS
  6. Offline


    Thank you. I'll try it out tomorrow after work and post the results.
    Also, nothing in the properties about name length.
  7. Offline


    please use the reply button, otherwise i cannot see that you replied to me.
  8. Offline


    My apologies. Next time could you please PM me and keep this on topic, thanks.
  9. Offline


    sorry to break it to you, but most threads do end up going off topic. if you don't like it please complain to bukkit and have them enforce a rule about it.

    P.S: it was just a suggestion, sorry for trying to help you...
  10. Offline


    Contact Mojang. Does your account have any spaces in it because there was a bug recently which let users register with spaces, they may have not reset names with spaces or may have just missed you out.

    Either way, contact them and get it sorted ;) (FYI, It will mean a name change)
  11. Offline


    I don't think there's a need to complain to bukkit about enforcing anything :)
    There's no harm in asking someone nicely to keep this on topic. It worked when you asked me nicely to use the reply button :)

    Thank you! I will try to contact them a little later and post the results here.

    Do you know their contact info? I checked the website but didn't see much. Thanks.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: 20, 2016
  12. Offline


    I didn't say it would be easy ;) Try the support page, report your account as hacked, because tbh, it may as well be, you can't use it.
  13. Offline


  14. I have this also with the 1.2.3-r0.2 version of bukkit!
    19:30:42 [SEVERE] Received string length longer than maximum allowed (33 > 32)
    19:30:42 [SEVERE]at net.minecraft.server.Packet.a(
    19:30:42 [SEVERE]at net.minecraft.server.Packet2Handshake.a(SourceFile:17)
    19:30:42 [SEVERE]at net.minecraft.server.Packet.a(
    19:30:43 [SEVERE]at net.minecraft.server.NetworkManager.h(
    19:30:43 [SEVERE]at net.minecraft.server.NetworkManager.c(
    19:30:43 [SEVERE]at
    19:30:43 [INFO] / lost connection
Thread Status:
Not open for further replies.

Share This Page