Issue only with WorldEdit permission in one world

Discussion in 'Bukkit Discussion' started by CyberRocky, Apr 20, 2017.

  1. Offline

    CyberRocky

    PermissionsEx was causing this issue. I uninstalled it and now it works! Problem resolved!

    I'm using Group Manager to make only one world have WorldEdit permissions and couldn't get it to work. I saw an older thread that said to do the following, but it didn't work. I tested this same thing with another plugin permission (for the EasyJetPack), and that worked. Yet WorldEdit still refuses to work. What's going on? This isn't making any sense.

    I removed groups from testworld world as indicated in the config file (only part of it shown):
    Code:
            # Worlds listed here have their settings mirrored in their children.
            # The first element 'world' is the main worlds name, and is the parent world.
            # subsequent elements 'world_nether' and 'world_the_end' are worlds which will use
            # the same user/groups files as the parent.
            # the element 'all_unnamed_worlds' specifies all worlds that aren't listed, and automatically mirrors them to it's parent.
            # Each child world can be configured to mirror the 'groups', 'users' or both files from its parent.
            world:
              world_nether:
              - users
              - groups
              world_the_end:
              - users
              - groups
              testworld:
              - users
    
    I added permission - worldedit.* and - easyjetpack.standard to the testworld world group.yml as indicated below:

    Code:
    groups:
      Default:
        default: true
        permissions:
        - -bukkit.command.kill
        - worldedit.*
        - easyjetpack.standard
    
    Edit: Nevermind! The issue was that I still had PermissionsEx installed and it was conflicting with GroupManager!
     
    Last edited: Apr 20, 2017

Share This Page