Iridium Server Manager - |GUI|Creator|Toolkit|Port Forwarder|

Discussion in 'Bukkit Tools' started by ImminentFate, Jul 16, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Erm.... I keep getting that unable to access jarfile thing. Maybe you can fix that? Other than that, total geenyus
  2. Offline


    you cannot use your ip on the computer that you run the server from. You have to use localhost. Only other people use the ip address to connect to your server

    that means that craftbukkit.jar failed to download during the install process. run the installer again or get it manually

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  3. Offline


    Of course you can connect to your own IP I do it ever day and unless specifically denied by the program (which it isnt) it is always allowed. However as a clarifying point which is what I'm sure you meant... when running a HAMMACHI server you cannot connect to your own IP only the others do that (since this IP is not your REAL IP but the IPX/Fake Local IP) that you give them when using it :) by the way great job ImminentFate :) Can i make the suggestion of Multiverse ? :) (Core/Adventure/Inventories/NetherPortals/Portals/SignPortals) maybe as an option in the setup if so then BAM already setup and there with some default configs for two worlds as something the users can work from to learn setups :)?
  4. Offline


    I installed bukkit as described here, but when I try to run it, a window just pops up and says, "Error: Unable to access jarfile C:\Users\Shane\Documents\CraftBukkit\craftbukkit.jar" Please help, I've been trying to download bukkit for hours, and I'm getting very frustrated...
  5. Offline


    um i downloaded this and it downloaded great its just that when i go to run it it dosnt work it says unable to access jar file can you please help
  6. Offline


    I know that i use localhost to connect to it and it works i checked mi ports again and it's ok!

    But my friends can't connect to it they have the good version of minecraft not crack and i don't use hamachi.

    I readed a loads of pages in this topic and I saw the same problem but, the answers were the sames!

    So please can you help me? I think there is a problem in craftbukkit.jar or there is a problem with my antivir (Avira)

    I have also made a server on that computer with the same connection etc... And it worked!

    Thanks for help!

    That's correct!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  7. Offline


    i am having the same problem and i realy realy want craftbukkit some1 pls help me
  8. Offline


    can you explain to me your exact setup? maybe some small screenshots or at least descriptions include the following

    Boxname your running server on
    IP of this box (not the hammachi one if your using that, sounds like you are not)
    Server port running on this box
    How do you connect to this server using localhost or the IP
    what IP do you use if you use an IP (and what port your putting in)
    What your friends are typing into the connect window when they are adding your server
    If your opening ports on your router which ones are you opening.. (screenshot or type out the line your adding in the window to open them)

    Open that folder is there a craftbukkit.jar file inside there? C:\Users\Shane\Documents\CraftBukkit\ please make sure that (most people dont have extensions turned on) that you did NOT name it craftbukkit.jar.

    The reason for this is (unless you have show file extensions turned on, which im guessing you dont) if you name it craftbukkit.jar it will really be called craftbukkit.jar.jar since by default windows hides ALL extensions to the user.

    if that file is there and you can see .jar but you dont see other files extensions in that directory (.txt .jar .exe .whatever) then RENAME is to not have .jar and try again

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  9. Offline


    I keep getting unable to access Jar File Users\Austin\Roaming\.minecraft\
    What did i do wrong please tell me!
  10. Offline


    Well first of all, I'd like to thank you for replying. I don't think that I named anything incorrectly like that, but I suppose I'm not completely sure. I've uploaded an image of what I've got as far as Craftbukkit, perhaps you can spot the problem yourself? I don't need to port forward anything do I? Or set a static IP address? I made a Minecraft server prior to trying to download Bukkit, but my friend said I should get Bukkit. Thanks for your help. Craftbukkit Troubleshooting.png
  11. Offline


    You have no craftbukkit file in that folder... did you download it sometimes craftbukkit when you start it cant download it and you need to get the latest version on your own :) download it and put it in that directory.

    need a little more info..

    where is your craftbukkit installed to? (where did you put the folder at)
    do you have a craftbukkit file inside your craftbukkit folder? (if not download it and put it there, sometimes it fails to download it for you)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
    Shinobi_Shane likes this.
  12. Offline


    what do i do if i get this message as soon as i double click the craftbukkit icon?

    'java' is not recognized as an internal or external command,
    operable program or batch file.
    Press any key to continue . . .
  13. Offline


    go and download java 7

    if its installed it should be in your path and that error shouldnt happen...
  14. Offline


    Hey, I have a few questions. I was missing the jar file, but i downloaded that and renamed it craftbukkit and worked fine.
    Pail was unable to download, so I tried downloading it again from the Plugins Site, but there was an error which appeared on the commandprompt- and it said "Error occured while enabling Pail. is the plugin up to date?"
    was there something wrong with the download?
    additionally, im missing the server note which allows you to change the things about the server, like this
    is there something wrong with my download? (p.s i have downloaded the server about 8 times already and the same problems occur)

    #Minecraft server properties
    #Date and time of creation of file
    motd=A Minecraft Server
  15. Offline


    Yeah that just about did it haha I just had to download the file and rename it! Thanks a lot for your help! :)
  16. Offline


    Try running as admin is my first guess maybe you have UAC on and its jacking with the install? run the installer as admin right click the exe and run as admin

    the server file should be in the folder it creates, but based on your other stuff not downloading i'm guessing your on windows 7 and trying to put it in a secure folder (program files ... or something like that?)

    more info on where your putting it and what is in the folder right after you do a fresh install please

    NP glad to help :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  17. Offline


    Sorry I haven't been able to help the past couple of days guys, been a hectic time for me. Also, thanks to BamBam4275 for helping out with issues you guys had.
    I may be on and off over the next few days, but generally you may get help from me until next tuesday. I've got assignments and exams to study for, and have a district cross country comp to attend to. So I'm packed for a while. Also, most problems will be sorted if you read a few posts before yours. It's unbelievable how many people ask the same question when the answer is two posts above them.

    Also, leave suggestions as to what you want to see in the installer, like a hub gui or something for easy control. Just remember that if you want plugins added to it I need to obtain the maker's permission first
  18. Offline


    I am running this as an administrator, so I doubt that UAC is messing with my files. As for the folder that I'm installing the download in, it was a folder which I created on my desktop by right clicking on it and clicking New... and selecting folder. From there, i downloaded it by finding that file on my desktop when it asks which folder i want to download it in. I wasnt downloading it in program files. So i probably will try downloading in it in the default folder it gives me (fyi, im using windows vista basic) and i will try running the installer as admin. Thanks for the help
    Edit: I tried running the installer as admin, but it seemed to be no difference. As for the folder that was set as default, I foolishly forgot what it specified for me to download in. So can you tell me what was the default folder? Thanks again.
  19. Offline


    just open your browser and click CTRL-J and it will pop up a window you can open the files you have downloaded and the folder they are in
  20. Offline


    heyy im having issues adding Colour to my name in game...when i downloaded the auto installer it failed to download all the plugins and i had to install each one manually could u help me set it up like u did for the auto install?

  21. Offline


    Ok im a total newb to trying to server host and im only one having problem thats immediate thats annoying- every 2-3 i got to start reclicking to hit something it will pause my game saying saving level. Any way on how to fix this?
    PS: trying to get into hosting my own server as the last one i was on kept getting hacked and griefed so could you give some advice on how to setup a regular backup system and how to reload a backup in case i ever have any such probelems?
    Thanks in advance
  22. Offline


    hello as you can tell from my name i am a complete noob and when i click global download it downloads straight away BUT it says download unsafe and i cant download it so can you up load it to mediafire or something
    thanks in advance

    where is this mediafire page because when i click on the GLOBAL DOWNLOAD it says download not safe has been stoped so can you send me a link to this media fire link

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  23. Offline


    The only plugin i have is bPerms...... :(((( whats goin on???
    i just got 20:00:29 [WARNING] Could not get information about this CraftBukkit version; per
    haps you are running a custom one?: IOException
  24. Offline


    Not sure about your error, but sure, with your hosting I can help. Just use the plugin simply called "Backup" and it will automatically backup your server at regular intervals. It keeps up to twenty copies of your world, so if you encounter an error, just get the backup and replace your world with it

    Never seen that error before :/ maybe it failed to download properly? Try getting craftbukkit.jar manually

    right click the download, hit copy link. That's the dropbox link. I don't have it on mediafire. This is because its easier to update an old installer when its on dropbox, since i just drag it into the folder in my documents and it updates the file on the itnernet

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  25. Offline


    I've used your previous installers which have been great..i notice lots of changes on this version...

    Is the pail and pail plus no longer part of your install...
    May i make a suggestion...i really like the way the old version worked...cause it pretty much gave you a ready to go version without having to download anything...

    Maybe you can do it like before, but with the option to download lastest version that way if we want we can stick with a version already proven to work on the fly with matching plugins like pail and pail plus...

    or go with the latest version available at time of install..

    This installer is great...thank you for the great work.

    PS: Is there a way to have access to make our own version of the that way we can setup a our own installer with our selected plugins...i will like to be able to make an install on demand with essentials and other favorite plugins.

  26. Offline


    I double-clicked the craft bukkit desktop icon and the cmd window came up and said:

    'java' is not recognized as an internal or external command,
    operable program or batch file.
    Press any key to continue...
    saromon50 likes this.
  27. Offline


    Whenever I double click CraftBukkit, it says:
    Unable to access jarfile C:Users\User\Appdata\Roaming\CraftBukkit\CraftBukkit.Jar
    press any key to continue...
    I'll try to fix it on my own, but if you can, please help.

  28. Offline


    I am getting the same issue as him. please help :)
  29. Offline


    Unfortunately, due to bukkit restrictions I am no longer allowed to have it as a part of the package. This is because of a (reasonable) possibility that a packaged jar file could be tampered with. By forcing it to download from bukkit, this ensures that the end user only receives the intended file. However, I am working on this. I am making an Operator Panel for users to access many simple tasks from. This will include downloading the files, checking for updates and getting configurations. It is kind of ready for release, but I want to fine tune a few things before I launch it.
    As for your customisation request, I did start it a while ago, but stopped when I decided it would be bad to just get the hard work of other devs and just have it slapped into a million installers floating around. The plugins that are included in this have had permission for use obtained from the devs.
    However, if you look in the installer, there is room for more tabs. I may add customization options to it to allow you to choose the plugins you want. I will seek permission from various devs who make rpg mods, economy plugins and more. If I go this way, the plus side will be that everything will be set up, including permission handling and configuration. The downside is that if you want another plugin (maybe BOSEconomy) and I have something else (maybe iConomy) you won't get the option for that.
    I take permission for usage seriously, so I won't get five economy plugins for the package. I will select one and that will be it. On the other hand, it may seem harsh to force a user into one plugin, but by all means, they can switch after if they want.

    Damn, that was a long post!

    In the meantime, here's an image of the panel and its awesome preceding splash screen:

    Hopefully, I have this fixed in the next release. I should send it out within the next couple of hours.

    update is out! Please post any bugs/glitches/errors, as this is early dev for it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
    GhostTrail likes this.
  30. Offline


    Well I tried to download the installer + oportator and that didn't work :( it just kept saying that there has been a problem and closed the program. however the plain installer worked fine, but I was still unable to start the server. when i would double click the craft bukkit launcher on my desktop I would get this: 'java' is not recognized as an internal or external command, operable program or batch file. Press any key to continue- - -

    please help :)
Thread Status:
Not open for further replies.

Share This Page