Invalid plugins.yml

Discussion in 'Plugin Development' started by Exs, Sep 2, 2019.

  1. Offline

    Exs

    Hello!
    I try to make my own plugins but i have this error:
    Could not load 'plugins/FightCube.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:158) ~[gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:138) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at org.bukkit.craftbukkit.v1_14_R1.CraftServer.loadPlugins(CraftServer.java:348) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at org.bukkit.craftbukkit.v1_14_R1.CraftServer.reload(CraftServer.java:784) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at org.bukkit.Bukkit.reload(Bukkit.java:585) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:27) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:148) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchCommand(CraftServer.java:689) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchServerCommand(CraftServer.java:675) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at net.minecraft.server.v1_14_R1.DedicatedServer.handleCommandQueue(DedicatedServer.java:406) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at net.minecraft.server.v1_14_R1.DedicatedServer.b(DedicatedServer.java:371) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:927) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:781) [gbinvl_craftbukkit-1.14.4-R0.1-SNAPSHOT.jar:git-Bukkit-9c887d4] at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212] Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml

    My plugins.yml :
    Code:
    main: net.exs.FightCube.FightCubeMain
    nom: FightCube
    version: 1.0
    auteur: Exs
    description: Un exemple de plugin
    commandes:
        start:
        description: un exemple de commande
        utilisation: /start
    Some one can found what is wrong ?
    thanks.
     
    Last edited by a moderator: Sep 2, 2019
  2. Offline

    timtower Moderator Moderator

    @Exs Name of the file should be plugin.yml, not plugins.yml
    And your nodes are in French, not in English.
     
    Tommy_T0mmY likes this.
  3. Offline

    Exs

    oki thank i don't notice that !
     
  4. Offline

    Strahan

    Also your spacing is wrong in the commands. That plugin.yml will have commands start, description and utilisation the way you have it setup. Sub items need to be indented beneath the parent level.
     

Share This Page