Invalid Plugin.yml

Discussion in 'Plugin Development' started by spherz, Mar 26, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    please help!!!!!!! my console keeps saying
    26.03 19:48:49 [Server] INFO at org.bukkit.craftbukkit.v1_5_R2.CraftServer.dispatchServerCommand(
    26.03 19:48:49 [Server] INFO at org.bukkit.craftbukkit.v1_5_R2.CraftServer.dispatchCommand(
    26.03 19:48:49 [Server] INFO at org.bukkit.command.SimpleCommandMap.dispatch(
    26.03 19:48:49 [Server] INFO at org.bukkit.command.defaults.ReloadCommand.execute(
    26.03 19:48:49 [Server] INFO at org.bukkit.Bukkit.reload(
    26.03 19:48:49 [Server] INFO at org.bukkit.craftbukkit.v1_5_R2.CraftServer.reload(
    26.03 19:48:49 [Server] INFO at org.bukkit.craftbukkit.v1_5_R2.CraftServer.loadPlugins(
    26.03 19:48:49 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    26.03 19:48:49 [Server] INFO at
    26.03 19:48:49 [Server] INFO org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
    26.03 19:48:49 [Server] SEVERE Could not load 'plugins/ctplugin.jar' in folder 'plugins'
    im not sure why. this is my first time trying to make a plugin but i cant figure out what im doing wrong!!!!
    i will upload a zip of all my files. please take a look and see if you can help me.
    P.S. - im not sure what this plugin will do yet. im just trying to get something to load so i can see if im on the right track :)

    Attached Files:

  2. Offline


    Can we see your plugin.yml?
  3. Offline


    spherz Also, that is not the WHOLE stacktrace, please post the WHOLE stacktrace, and your plugin.yml..
  4. Offline


    This is enough of the stacktrace to find a solution:
    This suggests that there is something spelled wrong or missing in the description in the plugin.yml of the plugin "ctplugin", maybe a wrong character or a tabulator character.
  5. Offline


    ill copy and paste all files for you
    name: Ct Plugin
    main: com.spherzcreative.ctplugin.CtPlugin
    version: 1.5.1
    package com.spherzcreative.ctplugin;


    public final class CtPlugin extends JavaPlugin {


    (the is in a package called com.spherzcreative.ctplugin)
    and i also have the bukkit api there too. im following the wiki exactly.
    my file upload didnt work with the first post i made

    i put the info in a reply

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 31, 2016
  6. Offline


    That's your problem, I think, add ( to plugin.yml ) description: Spherz plugin
  7. Offline


    i added that and tested it and it still says invalid plugin.yml
    this is the console :
    27.03 07:02:28 [Multicraft] Skipped 78 lines due to rate limit (30/s)
    27.03 07:02:24 [Server] INFO at org.bukkit.craftbukkit.v1_5_R2.CraftServer.dispatchServerCommand(
    27.03 07:02:24 [Server] INFO at org.bukkit.craftbukkit.v1_5_R2.CraftServer.dispatchCommand(
    27.03 07:02:24 [Server] INFO at org.bukkit.command.SimpleCommandMap.dispatch(
    27.03 07:02:24 [Server] INFO at org.bukkit.command.defaults.ReloadCommand.execute(
    27.03 07:02:24 [Server] INFO at org.bukkit.Bukkit.reload(
    27.03 07:02:24 [Server] INFO at org.bukkit.craftbukkit.v1_5_R2.CraftServer.reload(
    27.03 07:02:24 [Server] INFO at org.bukkit.craftbukkit.v1_5_R2.CraftServer.loadPlugins(
    27.03 07:02:24 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    27.03 07:02:24 [Server] INFO at
    27.03 07:02:24 [Server] INFO org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
    27.03 07:02:24 [Server] SEVERE Could not load 'plugins/ctplugin.jar' in folder 'plugins'

    i tried to even change the package name to a unique name (not like com.soemthing.something.etc.) but nothing changed still not loading. by any chance could anyone setup a template (liek the basic thing) with just a unique package name not com.blahblahblah (that works) so i can see what it is supposed to look like so i can try to match it with mine to see where i went wrong?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 31, 2016
  8. Offline


    A template ?

    This is my template for basic plugins.
    1. package;
    3. import org.bukkit.Bukkit;
    4. import org.bukkit.command.Command;
    5. import org.bukkit.command.CommandSender;
    6. import org.bukkit.event.Listener;
    7. import;
    9. public class Debug extends JavaPlugin implements Listener
    10. {
    11. public void onEnable()
    12. {
    13. Bukkit.getServer().getPluginManager().registerEvents(this, this);
    14. }
    16. public void onDisable()
    17. {
    18. }
    20. public boolean onCommand(CommandSender sender, Command command, String label, String[] args)
    21. {
    22. return false;
    23. }
    24. }

    My template plugin.yml
    name: Debug
    version: 1.0
    author: Chloe-chan
    description: -no desc-
  9. Offline


    Just a note that the Plugin.yml is case sensitive.
    (not the inside just the name)
    so dont use: Plugin.YML use: plugin.yml
  10. Offline


    when i make the class file, if the name of the plugin is ctplugin (note case for everything) can the main class file be names CtPlugin or does it HAVE to be ctplugin?

    if my plugins name is ctplugin (note case) can the main .java file be or no? im also gonna try something different to check if that works

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 31, 2016
  11. ctplugin != CtPlugin
  12. Offline


    i just figured it out i reread through the whole thing again. i realized i forgot to EXPORT it into a jar so thats where i went wrong!! THANKS SO MUCH EVERYONE FOR YOUR CONSIDERATE HELP!!!!!
Thread Status:
Not open for further replies.

Share This Page