Internal Server Error

Discussion in 'Bukkit Help' started by Racha, Jan 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Sometimes when I try to do something, like getting some dirt or something, I got Internal Server Error
    And in the console it says:
    2011-01-20 17:16:08 [WARNING] Failed to handle packet: java.lang.NullPointerExce
    at net.minecraft.server.ItemStack.a(
    at net.minecraft.server.InventoryPlayer.a(
    at net.minecraft.server.EntityPlayer.a(
    at net.minecraft.server.Block.a(SourceFile:389)
    at net.minecraft.server.ItemInWorldManager.a(

    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    at net.minecraft.server.NetworkManager.a(SourceFile:232)
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
    at net.minecraft.server.MinecraftServer.h(

    Somebody know what is the problem? :(

    /Sorry for my bad english :)
  2. Offline


    Same question I ask everyone who posts an error without anything else:

    What OS/Version (x86 or x64)? What java version (x86 or x64)? What build are you running? What have you tried already to fix it?
  3. Offline


    x86 i think.. i'm not sure, but.. :D
    I Dont know, but I think -x86 ;D
    Latest.. dowloaded before 10 minutes.
    Nothing, because I dont know how ;D
  4. Offline


    Are you Windows, Linux, Mac? (I'm guessing windows if you really don't know. Probably XP). In your command prompt, type: java --version

    Also, list what commands you used to run the server, and paste your full server log. What plugins are you trying? Have you tried to just get a vanilla Minecraft server running? Then a vanilla Craftbukkit server? Then adding plugins one by one until you know they all work?

    Have you followed any of the threads: FAQ: How to setup a Bukkit server or How to install Bukkit - Newb Friendly?

    We can only help those who help themselves. If you are one of those people, we can help you.
  5. Offline


    Windows 7 :)
    java --version is only opening a cmd and then closing it, nothing happens.
    What server log? where i can find it?
    Plugins: Authorize,BigBrother,CreeperNerf,ExcessLapis,Guardian,iConomy,LoginMessage,LWC,MCDocs,MyHome,SearchIds,TelePlus,vPlayersOnline,Whitelist,WorldEdit,WorldGuard..
    No i haven't.
    Yes i followed both of them :D

  6. Offline


    You need to open up a command prompt and type it.
    Server logs are located in your main minecraft server directory. server.log.

    Your first task - strip out all those plugins, and try again. If you still get that error, then maybe try an older build of CraftBukkit. However, I doubt you'll see that error once you strip out your plugins. Make sure your plugins are up to date - go through all the forums for them and grab the latest version. Then, add plugins one by one (newest versions), and keep trying. You'll eventually either find the plugin that's causing your problem, or you'll find a newer version of the plugin fixed the issue.
  7. Offline


    Server logs are located in your main minecraft server directory. server.log.
    -It's empty :D
    java --version
    -Still nothing.

    Okey I will try to do it, it will be hard because sometimes there is no error.. It shows just sometimes ;/
  8. Offline


    Are you running the GUI, or non gui versions? What error (if any) do you get when you type java -version into the cmd prompt?
  9. Offline


    Where can i find it?
    No error. Just cmd opens and closes. :D
  10. Offline


    Alright, different approach. What file are you double clicking to start your server? Paste the contents of the file.

    Also, in your Windows 7 search, type cmd and hit enter. You will get a command prompt. In there, type the java -version command.
  11. Offline


    @echo off
    java -Xms1024M -Xmx1024M -jar craftbukkit.jar


    java version "1.6.0_22"
    Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
    Java HotSpot(TM) Client VM (build 17.1-b03, mixed mode, sharing)
  12. Offline


    Alright, you are running the GUI. The rest looks good.

    Yes, thank you. You are running one build behind latest (that's not your problem though, but update if you want).

    It looks like everything fine. Just start striping out you plugins and running without any for a while.

    I run the latest CreeperNerf (there is a bug with it and the latest version of Craftbukkit - 107) and ExcessLapis. I haven't seen those errors, but doesn't mean its not those plugins. You will just have to use trial and error - or go through the forums of those plugins in general and see if someone else is having the same error. I doubt its the main CraftBukkit server.
Thread Status:
Not open for further replies.

Share This Page