Inactive [INFO/ADMIN] LogBlock v1.54 - Enderdragon Logging! Tree Grow Logging! [1.4.5]

Discussion in 'Inactive/Unsupported Plugins' started by DiddiZ, Feb 16, 2011.

  1. Offline


    Version: 1.50​
    Find and Backroll those Damn Griefers
    LogBlock release are on DevBukkit:

    LogBlock dev builds:

    Please read the installation guide

    I won't port LogBlock myself to mcAPI. Source code is available, so it shouldn't be to difficult for someone else to do it, also I'm still here. so I can answer questions. If there is more than one willing, that's up to you to handle that.

    The reasons I take this step, are the usual: I quit playing Minecraft about 5 months ago and lastly I was struggling to keep up with updates. The developement of Guardian made slow progress, so I fear it won't be ready to fully replace LB in time.

    Download latest dev build: Jenkins
    View the source code: GitHub
    Table of contents:
    1. Description
    2. Features
    3. Why to use LogBlock
    4. Example command
    5. Older versions
    6. Change log
    7. Todo list / feature requests
    8. Permission nodes
    9. Plugins supporting this
    10. Support the dev
    11. How to post error messages
    12. Advertizing

    LogBlock logs block changes into a MySQL database. Block changes can be placed or destroyed block, explosions, burned blocks, sign text changes, chest access, leaves decay etc.
    It can be used as griefer identification tool, to find out who build a particular building, or even roll back changes by certain players. Other purposes can be e.g: Undoing of forest fires
    All additional features are optional, to keep the database as short as possible. All database actions run in their own threads to avoid server lags.
    The use of permissions plugin (or any clone) is possible, but not necessary.
    Uses Spout for chest logging (but it's fully optional, and there is no need for the client mod at all).

    • Logging for block placing, block braking, fire, explosions, leaves decay, signtexts, lava flow and chest content
    • Very mighty commands system, not only allowing to rollback and redo, but also to tp to blockchanges, delete log ingame etc. Full list of commands.
    • Many parameters for lookup/rollback/redo/tp/clearlog commands: Block changes of one ore more player, in a specific area, in a world edit selection, specific block types only, block changes older or newer that a specific date, destroyed/created block only, in a different world and combinations of all these parameters. Full list of parameters.
    • Rebuilding map after importing a backup (/lb redo)
    • Last parameter to use the parameters of the last command
    • Quick ingame lookup of block history a wood pickaxe or a bedrock block.
    • All commands accessible from console (exept tools :D)
    • Custom queries for tools.
    • Different tool modes (lookup, rollback, redo, writelogfile and clearlog)
    • Saves block data like wool color, log type, torch adjustment, etc
    • Multiworld and multiserver support (some servers sharing the same database)
    • BigBrother log import
    • Loggable super pickaxe plugin (not to confuse with WorldEdit's super pickaxe)
    • API
    • Webstats
    Why to use LogBlock:

    Example commands: (thanks to tha d0ctor, read more about commands here)

    /lb rollback player fire since 1d3h – rolls back fire 1 day 3 hours
    /lb rollback player fire since 1d3h area 15 – rolls back fire 1 day 3 hours within a radius of 15 blocks

    /lb rollback player thad0ctor since 1h - rolls back thad0ctor 1 hour
    /lb rollback player thad0ctor since 1d area 5 – rolls back thad0ctor actions for the last day within 5 blocks
    /lb rollback area 10 since 1h30m - rolls back all modifications within 10 blocks since the list 1 hours and 30 mins
    /lb rollback area 10 before 06.11.2011 - roll back all changes in an area of 1o before June 11th, 2011
    /lb rollback player thad0ctor since 05:36:00 - roll back all changes of thad0ctor since 05:36 (server time)

    Download, Command, Configuration and Details:

    -> Full changelog
    • LogBlock v1.50 # 81 (Dez. 13, 2011)
      Works with CraftBukkit 1.0.1-R1
      • Feature: /lb me shows the total block count
      • Feature: Chest logging without spout
      • Feature: Enderdragon logging
      • Feature: Logging for tree and mushroom grow (thanks to MD5 for the api)
      • Fix: Area param works again with default radius
      • Fix: Rollbacks got slowed down a bit to avoid rare server crashes
      • Fix: If mysql username, password or database only consist of unquoted numbers, LB will read them now
      • Config: World configs changed totally, some names changed and all logging options are now in an own section
    • LogBlock v1.41 #63 (Nov. 15, 2011)
      Works with CraftBukkit recommended build #1337
      • Fix: Players with spawnTools permission are no longer allowed to spawn all tools.
      • Fix: Added a check to avoid "The permission xy is already defined!" errors
    • LogBlock v1.40 #60 (Nov. 09, 2011)
      Works with CraftBukkit recommended build #1337
      • Feature: Custom auto ClearLog
      • Feature: Reduced error spam. Instead of like 40 line of error code, there is now just a warning stating the MySQL con
      • Feature: The queue will now be dumped after 10 tries even when the MySQL server is connected
      • Feature: Custom material names, allows naming custom blocks
      • Feature: LogBlock will now respond to messages when started without MySQL connection
      • Fix: Log import runs now async
      • Fix: Log import errors won't crash the server
      • Fix: Console commands work again
      • Fix: You can now use upper case letter in tool names (I don't know why you even should, but ...)
      • Config: Added, clearlog.enableAutoClearlog in main config. Added materials.yml. Removed clearlog.keepLogDays
      • Permissions: Added 'logblock.spawnTools'
    • LogBlock v1.32 (Oct. 04, 2011)
      Works with CraftBukkit recommended build #1240
      • Feature: Player info logging: firstLogin, lastLogin, onlinetime, ip. No ingame lookup yet.
      • Feature: /lb queuesize to see the current queue size
      • Fix: Door logging logs now also fence gates
      • Fix: Bukkit api break in CB #1191
      • Fix: time restriction works now as intended. Thanks to xrobau
      • Fix: Players with insufficient permissions can't smuggle bedrock from one world to another
      • Config: Added logPlayerInfo
    • LogBlock v1.30 (Sep. 22, 2011)
      Works with CraftBukkit recommended build #1185
      • Feature: Chat lookup /lb chat player diddiz search +admin +sucks +dicks (more info)
      • Feature: Door logging
      • Feature: Dynamic tools, define your own tools
      • Feature: Use since and before to define a timespan
      • Feature: Enderman logging
      • Feature: cake logging (who ate it)
      • Config: Added logEndermen, logCakes and logDoors to world config and moved the tool section in main config.
      • Permissions: logblock.tool changed to and
        logblock.toolblock to
    Todo List:

    Permission Nodes:

    Plugins supporting Logblock:
    List (open)

    When you want to appear your plugin here, tell me about

    Support the developer (that's me :D):
    If you want to support me writing plugins or want to thank me for the plugin/support, you can: Suggest features I missed, report bugs (best with fix :D), donate via PayPal, flattr my plugins, gift me The Witcher 2 (thanks to newyoukdaily), 2x 1GB DDR1 modules (thanks to HonestFlames), or send me the inner life of a laptop or netbook with a broken display (need it to build a model aircraft, so there is no need for parts like display and keyboard).


    How to post error messages:

    I won't aswer questions to general MySQL setup/installation/what is MySQL (there are lots of good tutorials out there, use google)
    Please read the installation guide before asking a question about installation problems.
    Please read the FAQ before posting a error report. It may be solved there.
    In case of rollback or lookup problems: Type /lb savequeue and try again (when it's fixed then, it was a consumer problem, see FAQ)
    When you post error messages, it's important to paste the whole stack trace!

    Newyorkdailys Plugin Support Buisness (open)
    Still can't get LogBlock working, or any other plugin? Are you getting errors in your console and cant figure out why? Newyorkdaily offers Basic/Advanced Plugin support.
    • General/Advanced troubleshooting: FREE!
    • Plugin Installations: 1-2 Plugins - FREE!
    • 3 or More Plugins - $2
    Click on the link below to connect to him now!

    There is a LogBlock irc channel: #logblock at
    You can ask me on skype. My name is 'hawky.diddiz'.
  2. Offline


    DiddiZ thanks for the help! :D

    why does logblock keep making "world" tables, i have replaced everything with the proper worlds names but it keeps making world tables. here is my config: (i guarantee that i overlooked something)
    Code (Text):
    1. tools:
    2.   tool:
    3.     defaultEnabled: true
    4.     mode: LOOKUP
    5.     aliases:
    6.     - t
    7.     params: area 0 all sum none limit 15 desc silent
    8.     leftClickBehavior: NONE
    9.     item: 270
    10.     rightClickBehavior: TOOL
    11.     permissionDefault: 'TRUE'
    12.   toolblock:
    13.     params: area 0 all sum none limit 15 desc silent
    14.     permissionDefault: 'TRUE'
    15.     rightClickBehavior: BLOCK
    16.     item: 7
    17.     mode: LOOKUP
    18.     defaultEnabled: true
    19.     aliases:
    20.     - tb
    21.     leftClickBehavior: TOOL
    22. mysql:
    23.   user: ******
    24.   port: 3306
    25.   password: ******
    26.   host:
    27.   database: ******
    28. logging:
    29.   hiddenBlocks:
    30.   - 0
    31.   logCreeperExplosionsAsPlayerWhoTriggeredThese: false
    32.   logPlayerInfo: true
    33.   hiddenPlayers: []
    34.   logKillsLevel: PLAYERS
    35. consumer:
    36.   timePerRun: 200
    37.   useBukkitScheduler: true
    38.   forceToProcessAtLeast: 20
    39.   delayBetweenRuns: 6
    40. lookup:
    41.   linesLimit: 1500
    42.   defaultTime: 30 minutes
    43.   defaultDist: 20
    44.   linesPerPage: 15
    45. questioner:
    46.   askClearLogs: true
    47.   banPermission: mcbans.ban.local
    48.   askRollbacks: true
    49.   askRedos: true
    50.   askClearLogAfterRollback: true
    51.   askRollbackAfterBan: false
    52. updater:
    53.   checkVersion: true
    54.   installSpout: true
    55. loggedWorlds:
    56. - flatgrass
    57. - flatgrass_nether
    58. - Krosteus
    59. clearlog:
    60.   enableAutoClearLog: false
    61.   auto:
    62.   dumpDeletedLog: false
    63. rollback:
    64.   replaceAnyway:
    65.   - 8
    66.   - 9
    67.   - 10
    68.   - 11
    69.   - 51
    70.   maxArea: 50
    71.   maxTime: 3 days
    72.   dontRollback:
    73.   - 10
    74.   - 11
    75.   - 46
    76.   - 51
    77. version: '1.42'
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  3. Offline


    I have an extremely powerful dedicated server that can handle a lot of work, I was wondering what would be the most ideal settings for me for these. CPU hogging is not much concern to me, my cpu barley breaks 20% during the busiest hours. My que is backed up by 200,000 right now lol. I need to get that queue moving

    delayBetweenRuns: 6
    timePerRun: 100
    forceToProcessAtLeast: 25

    Thanks for the help!
  4. Offline


    Hi, I am writing a web based viewer for the lookup (makes it easier for my husband to police our family server). I have just figured out what the data column holds (the data ids for damage/growth status/colour) but I am still puzzled over the sign text. How can I tell what text is on what line? in-game you get it split up with square brackets ([line1][line2] etc) but in the sql there's no indication of lines.
  5. I get this today. and i have not make me a own plugins......

    Important information on Next Recommended Build

    Hi MineCleric,

    We're cleaning up our code to help us better prepare for the release of Minecraft 1.2. As a result, a lot of old, inefficient and buggy code is being removed and plugins will need to be updated.

    Please check your plugins, find out if the plugin developers have been keeping everything up to date and kindly let them know that they need to update their plugins to make sure they will be ready for R5.
  6. Offline


    How far away are you from releasing a new RB of LB?

    Good to hear you havent given up your plugin development. :) Seems like the other main world logging plugins such as hawkeye and bigbrother has become inactive :/
    With that, how is it going with Guardian, is it anything thats still under development, or put on ice?
    Are you and md_5 the only ones on it now, or have hawkeye and BB authors stopped their plugin development just to focus on Guardian? :confused:
  7. need some help here

    20:54:23 [SEVERE] Could not load 'plugins/Spout.jar' in folder 'plugins': null
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.reload(
    at org.bukkit.Bukkit.reload(
    at org.bukkit.command.defaults.ReloadCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.MinecraftServer.b(
    at net.minecraft.server.MinecraftServer.w(
    Caused by: error in opening zip file
    at Method)
    at java.util.jar.JarFile.<init>(
    at java.util.jar.JarFile.<init>(
    ... 12 more
  8. Offline


    I get no errors with logblock database connection is fine...but nothing is logged =/ idea?
  9. Offline


    08:56:20 [SEVERE] Could not save config to plugins/LogBlock/config.yml plugins/LogBlock/config.yml (Permission denied)
    at Method)
    at de.diddiz.LogBlock.Config.<init>(
    at de.diddiz.LogBlock.LogBlock.onLoad(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(
    at net.minecraft.server.MinecraftServer.init(
    08:56:20 [SEVERE] [LogBlock] Error while loading: plugins/LogBlock/DownTownCity.yml (Permission denied)
  10. Offline


    If it acts the same as a webserver does then you should try ftping in and set permissions on the folder to allow write access
  11. Offline


    Logblock gets disabled on startup, I have no idea how to start it back up again?

    When I do /plugins, Logblock is red. I have set up my MySQL Database correctly.
  12. Offline


    I assume there is a "Get More Output" in the config :)
  13. Offline


    Remove/update spout
    Latest update is really close, but I'll wait for 1.2
    The line delimiter is NUL, so it's basically invisble, but it's there
    I wish I has used newline, but ... :D

    Anyways, if you wand to release it to public, I'd linkt it, as it's most likely usefull for many.
    Local or remote MySQL server?
    If remote, try force 1000, or to get a local MySQL server.
    Otherwise: time 1000, delay 5.
    Check the table names in all three world configs.

    Yup, no depriciated code in dev builds.
    The block changes are most likely still in queue. Flush the queue with /lb savequeue.
    If the queue builds up, you may have to adjust some consumer settings, easiest would be to increase forceToProcess.
    /lb logging
    /lb savequeue
    You mean world.yml?
  14. As soonas i set up the database in the config, restarted, the plugin worked for like 10 mins then world chunks stopped loading... any reason
  15. Offline


    Diddiz, I can't figure out how to make it so that groupmanager, or logblock, disables the bedrock or any type of permission form from Logblock

    My users are able to drop the bedrock, and somehow keep it there.. and honestly its annoying.

    I tried a few things but failed.

    So how do you go abouts fixing this?
  16. Offline


    getting that when i try to use you newest dev build (#106):

    Code (Text):
    1. [...]
    2. 2012-02-25 12:26:22 [INFO] [LogBlock] [LogBlock] Version check: There is a newer version: v1.50
    3. 2012-02-25 12:26:22 [INFO] [LogBlock] [LogBlock] Connecting to [email protected]:mysql://localhost:3306/minecraft...
    4. 2012-02-25 12:26:22 [INFO] [LogBlock] Updating tables to 1.51 ...
    5. 2012-02-25 12:26:22 [SEVERE] [LogBlock Updater] Error:
    6. com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Duplicate column name 'x'
    7.     at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    8.     at sun.reflect.NativeConstructorAccessorImpl.newInstance(
    9.     at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
    10.     at java.lang.reflect.Constructor.newInstance(
    11.     at com.mysql.jdbc.Util.handleNewInstance(
    12.     at com.mysql.jdbc.Util.getInstance(
    13.     at com.mysql.jdbc.SQLError.createSQLException(
    14.     at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    15.     at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    16.     at com.mysql.jdbc.MysqlIO.sendCommand(
    17.     at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    18.     at com.mysql.jdbc.ConnectionImpl.execSQL(
    19.     at com.mysql.jdbc.ConnectionImpl.execSQL(
    20.     at com.mysql.jdbc.StatementImpl.execute(
    21.     at com.mysql.jdbc.StatementImpl.execute(
    22.     at de.diddiz.LogBlock.Updater.update(
    23.     at de.diddiz.LogBlock.LogBlock.onLoad(
    24.     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    25.     at org.bukkit.craftbukkit.CraftServer.<init>(
    26.     at net.minecraft.server.ServerConfigurationManager.<init>(
    27.     at net.minecraft.server.MinecraftServer.init(
    28.     at
    29.     at
    30. 2012-02-25 12:26:22 [INFO] [Spout] Loading Spout v737.
    31. [...]
    ingame im getting that one when somebody logs in:

    Code (Text):
    1. 2012-02-25 12:33:04 [INFO] HoschY1987 [/MYIPHERE] logged in with entity id 690 at ([creative] -18.885740487523513, 77.0, -55.92758558797944)
    2. 2012-02-25 12:33:04 [INFO] WorldEdit: HoschY1987 (in "creative"): we cui
    3. 2012-02-25 12:33:07 [SEVERE] [LogBlock Consumer] SQL exception on UPDATE `lb-players` SET onlinetime = onlinetime + TIMESTAMPDIFF(SECOND, lastlogin, FROM_UNIXTIME('1330169582')) WHERE lastlogin > 0 && playerid = 1;:
    4. com.mysql.jdbc.MysqlDataTruncation: Data truncation: Incorrect time value: '103299' for column 'onlinetime' at row 1
    5.     at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    6.     at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    7.     at com.mysql.jdbc.MysqlIO.sendCommand(
    8.     at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    9.     at com.mysql.jdbc.ConnectionImpl.execSQL(
    10.     at com.mysql.jdbc.ConnectionImpl.execSQL(
    11.     at com.mysql.jdbc.StatementImpl.execute(
    12.     at com.mysql.jdbc.StatementImpl.execute(
    13.     at
    14.     at
    15.     at
    16. 2012-02-25 12:33:11 [INFO] [AuthMe] §cADMIN§f §cHoschY1987§f§c logged in!
  17. Offline


    The updater got stuck, change version in config to '1.51' manually and update to latest dev.
    Set tools.toolblock.defaultPermossions from true to OP.
    Not that I would happen to know, that's new. Are you sure it's caused by LB?
  18. Offline


    i need to know i can change my config file so i can see in chests but how i cant found it
  19. Offline


    DiddiZ What would be the best config for a 20 + server? Please make some comments in the config about what's best to use.. Etc: "Use high numbers for small servers" ;-)

    It's on a other server my MySql is hosted.. It's paid? And there is remote access... I have tried with my server mysql too.. Same problem :)
  20. Offline


    I did. :eek:
  21. Offline


    [LogBlock] Exception in commands handler:
    java.lang.IllegalArgumentException: No parameters specified.
    at de.diddiz.LogBlock.QueryParams.parseArgs(
    at de.diddiz.LogBlock.CommandsHandler.onCommand(
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.handleCommand(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.handle(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(
    at net.minecraft.server.MinecraftServer.w(

    got this randomly

    not sure if it affected anything so far

    using 1.5 for logblock
    by the way, should i also change my lb version on my config file?
    i think last time i saw it said 1.42 ...
  22. Offline


    will this be updated for CB R4 anytime soon??? I noticed it has not recieved updates for awhile and I am now receiving errors for logblock.

    Code (Text):
    1. 5.02 23:10:59 [Server] INFO Read timed out
    2. 25.02 23:10:50 [Server] INFO    at Source)
    3. 25.02 23:10:50 [Server] INFO    at
    4. 25.02 23:10:50 [Server] INFO    at
    5. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.StatementImpl.execute(
    6. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.StatementImpl.execute(
    7. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.ConnectionImpl.execSQL(
    8. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.ConnectionImpl.execSQL(
    9. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    10. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.MysqlIO.sendCommand(
    11. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    12. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    13. 25.02 23:10:50 [Server] INFO com.mysql.jdbc.MysqlDataTruncation: Data truncation: Truncated incorrect time value: '839:14:48'
    14. .02 23:10:50 [Server] INFO    at com.mysql.jdbc.ConnectionImpl.execSQL(
    15. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    16. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.MysqlIO.sendCommand(
    17. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    18. 25.02 23:10:50 [Server] INFO    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    19. 25.02 23:10:50 [Server] INFO com.mysql.jdbc.MysqlDataTruncation: Data truncation: Truncated incorrect time value: '839:14:48'
    20. 25.02 23:10:50 [Server] SEVERE [LogBlock Consumer] SQL exception on UPDATE `lb-players` SET onlinetime = ADDTIME(onlinetime, TIMEDIFF(FROM_UNIXTIME(1330229447), lastlogin)) WHERE playerid = 6;:
  23. Offline


    thanks Diddiz, you solution worked pretty well :)
    DiddiZ likes this.
  24. Offline


    Hi I have just started to get this spamming my console

    2012-02-26 13:44:18 [SEVERE] [LogBlock Consumer] SQL exception on INSERT INTO `lb-Roulworld_MMO` (date, playerid, replaced, type, data, x, y, z) VALUES (FROM_UNIXTIME(1330263752), 15, 10, 49, 0, '-41564', 10, '-215');:
    com.mysql.jdbc.MysqlDataTruncation: Data truncation: Out of range value for column 'x' at row 1
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    at com.mysql.jdbc.MysqlIO.sendCommand(
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    at com.mysql.jdbc.ConnectionImpl.execSQL(
    at com.mysql.jdbc.ConnectionImpl.execSQL(
    at com.mysql.jdbc.StatementImpl.execute(
    at com.mysql.jdbc.StatementImpl.execute(
    at de.diddiz.LogBlock.CommandsHandler$
    at de.diddiz.LogBlock.CommandsHandler$AbstractCommand.<init>(
    at de.diddiz.LogBlock.CommandsHandler$CommandSaveQueue.<init>(
    at de.diddiz.LogBlock.CommandsHandler$
    at Source)

    hoping someone can help me out, plugin has been working fine for ages this only started recently

    Thanks for any Help :D
  25. Hi, I'm getting these errors : /
    Code (Text):
    1. 2012-02-26 08:12:04 [SEVERE] [LogBlock Consumer] SQ exception on UPDATE `lb-players` SET onlinetime = onlinetime + TIMESTAMPDIFF(SECOND, lastlogin, FROM_UNIXTIME('1330261850')) WHERE lastlogin > 0 && playerid = 3952;:
    2. com.mysql.jdbc.MysqlDataTruncation: Data truncation: Incorrect time value: '2664' for column 'onlinetime' at row 1
    3. at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    4. at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    5. at com.mysql.jdbc.MysqlIO.sendCommand(
    6. at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    7. at com.mysql.jdbc.ConnectionImpl.execSQL(
    8. at com.mysql.jdbc.ConnectionImpl.execSQL(
    9. at com.mysql.jdbc.StatementImpl.execute(
    10. at com.mysql.jdbc.StatementImpl.execute(
    11. at
    12. at
    Code (Text):
    1. 2012-02-26 08:57:28 [SEVERE] [LogBlock Consumer] SQ exception on UPDATE `lb-players` SET onlinetime = onlinetime + TIMESTAMPDIFF(SECOND, lastlogin, FROM_UNIXTIME('1330264647')) WHERE lastlogin > 0 && playerid = 3539;:
    2. com.mysql.jdbc.MysqlDataTruncation: Data truncation: Incorrect time value: '205966' for column 'onlinetime' at row 1
    3. at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    4. at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    5. at com.mysql.jdbc.MysqlIO.sendCommand(
    6. at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    7. at com.mysql.jdbc.ConnectionImpl.execSQL(
    8. at com.mysql.jdbc.ConnectionImpl.execSQL(
    9. at com.mysql.jdbc.StatementImpl.execute(
    10. at com.mysql.jdbc.StatementImpl.execute(
    11. at
    12. at
    What's wrong?

  26. Offline


    hey Diddiz,
    I nolonger can check who broke a block but it says it works but when i click a block (With the LB tool)
    Nothing happens but like other commands still work what do i need to change
    Plas respond

    With friendly greets ~Revo
  27. Offline



    Works beautifully, no issues that make it non functional.

    However, recently I've decided to start purging logs when I do rollbacks and have it dump the log to a file. Sadly, It's failed to save it properly, also since the dump missfires the it doesn't wipe the code from the mysql (which is good).

    The error I get say access denied, but all the mysql information is set correctly, otherwise it wouldn't be logging and recalling properly in the first place.

    This is a remote paid for hosting server and with Mysql DB included. Mysql DB and MC Server are not 'localhost' to each other.

    Any ideas?

    Console Error:
    Code (Text):
    1. :
    2. 2012-02-26 20:34:06 [SEVERE] [LogBlock ClearLog] Exception while dumping log:
    3. java.sql.SQLException: Access denied for user 'server2657'@'%' (using password: YES)
    4. at com.mysql.jdbc.SQLError.createSQLException(
    5. at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    6. at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    7. at com.mysql.jdbc.MysqlIO.sendCommand(
    8. at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    9. at com.mysql.jdbc.ConnectionImpl.execSQL(
    10. at com.mysql.jdbc.ConnectionImpl.execSQL(
    11. at com.mysql.jdbc.StatementImpl.execute(
    12. at com.mysql.jdbc.StatementImpl.execute(
    13. at de.diddiz.LogBlock.CommandsHandler$
    14. at de.diddiz.LogBlock.CommandsHandler$AbstractCommand.(
    15. at de.diddiz.LogBlock.CommandsHandler$CommandClearLog.(
    16. at de.diddiz.LogBlock.CommandsHandler$
    17. at
    18. at
  28. Offline


    Hey Lb isnt outputting any info... my sql is running and lb reports no errors on server startup... but i have users on and their destroying/creating blocks but when i run querys i get No results found. I'll keep messing with it but if you could help it'd be much appreciated! thanks in advance!

    EDIT: fixed it sorry for the troubles
  29. Offline


    Really good - Works excellently well on a server I am admin on.
    DiddiZ likes this.
  30. Offline


    Hey im having trouble someone greifed in a world but it says "This World (World Name) isnt logged" Please Help!
  31. Offline


    Add your world to loggedWorlds in lb main config.
    /lb logging
    Check your world configs.
    Can't write the dump files, disable clearlog.dumpDeletedLog.
    Make sure you are running the latest dev build.
    It's an autoupdater fail, set version in config to '1.51' and restart.

    Use the latest dev build.
    The number is just for the autoupdater.

    The error appears when you use "/lb rollback" without further params in LB 1.50
    Wait, what's the issue?
    LB can't connect or the queue builds up?
    If queue, try forceToProcess 1000, else please provide error log.
    And what does "/lb logging" return?

Share This Page