Inactive [INFO/ADMIN] LogBlock v1.54 - Enderdragon Logging! Tree Grow Logging! [1.4.5]

Discussion in 'Inactive/Unsupported Plugins' started by DiddiZ, Feb 15, 2011.

  1. Offline


    Version: 1.50​
    Find and Backroll those Damn Griefers
    LogBlock release are on DevBukkit:

    LogBlock dev builds:

    Please read the installation guide

    I won't port LogBlock myself to mcAPI. Source code is available, so it shouldn't be to difficult for someone else to do it, also I'm still here. so I can answer questions. If there is more than one willing, that's up to you to handle that.

    The reasons I take this step, are the usual: I quit playing Minecraft about 5 months ago and lastly I was struggling to keep up with updates. The developement of Guardian made slow progress, so I fear it won't be ready to fully replace LB in time.

    Download latest dev build: Jenkins
    View the source code: GitHub
    Table of contents:
    1. Description
    2. Features
    3. Why to use LogBlock
    4. Example command
    5. Older versions
    6. Change log
    7. Todo list / feature requests
    8. Permission nodes
    9. Plugins supporting this
    10. Support the dev
    11. How to post error messages
    12. Advertizing

    LogBlock logs block changes into a MySQL database. Block changes can be placed or destroyed block, explosions, burned blocks, sign text changes, chest access, leaves decay etc.
    It can be used as griefer identification tool, to find out who build a particular building, or even roll back changes by certain players. Other purposes can be e.g: Undoing of forest fires
    All additional features are optional, to keep the database as short as possible. All database actions run in their own threads to avoid server lags.
    The use of permissions plugin (or any clone) is possible, but not necessary.
    Uses Spout for chest logging (but it's fully optional, and there is no need for the client mod at all).

    • Logging for block placing, block braking, fire, explosions, leaves decay, signtexts, lava flow and chest content
    • Very mighty commands system, not only allowing to rollback and redo, but also to tp to blockchanges, delete log ingame etc. Full list of commands.
    • Many parameters for lookup/rollback/redo/tp/clearlog commands: Block changes of one ore more player, in a specific area, in a world edit selection, specific block types only, block changes older or newer that a specific date, destroyed/created block only, in a different world and combinations of all these parameters. Full list of parameters.
    • Rebuilding map after importing a backup (/lb redo)
    • Last parameter to use the parameters of the last command
    • Quick ingame lookup of block history a wood pickaxe or a bedrock block.
    • All commands accessible from console (exept tools :D)
    • Custom queries for tools.
    • Different tool modes (lookup, rollback, redo, writelogfile and clearlog)
    • Saves block data like wool color, log type, torch adjustment, etc
    • Multiworld and multiserver support (some servers sharing the same database)
    • BigBrother log import
    • Loggable super pickaxe plugin (not to confuse with WorldEdit's super pickaxe)
    • API
    • Webstats
    Why to use LogBlock:

    Example commands: (thanks to tha d0ctor, read more about commands here)

    /lb rollback player fire since 1d3h – rolls back fire 1 day 3 hours
    /lb rollback player fire since 1d3h area 15 – rolls back fire 1 day 3 hours within a radius of 15 blocks

    /lb rollback player thad0ctor since 1h - rolls back thad0ctor 1 hour
    /lb rollback player thad0ctor since 1d area 5 – rolls back thad0ctor actions for the last day within 5 blocks
    /lb rollback area 10 since 1h30m - rolls back all modifications within 10 blocks since the list 1 hours and 30 mins
    /lb rollback area 10 before 06.11.2011 - roll back all changes in an area of 1o before June 11th, 2011
    /lb rollback player thad0ctor since 05:36:00 - roll back all changes of thad0ctor since 05:36 (server time)

    Download, Command, Configuration and Details:

    -> Full changelog
    • LogBlock v1.50 # 81 (Dez. 13, 2011)
      Works with CraftBukkit 1.0.1-R1
      • Feature: /lb me shows the total block count
      • Feature: Chest logging without spout
      • Feature: Enderdragon logging
      • Feature: Logging for tree and mushroom grow (thanks to MD5 for the api)
      • Fix: Area param works again with default radius
      • Fix: Rollbacks got slowed down a bit to avoid rare server crashes
      • Fix: If mysql username, password or database only consist of unquoted numbers, LB will read them now
      • Config: World configs changed totally, some names changed and all logging options are now in an own section
    • LogBlock v1.41 #63 (Nov. 15, 2011)
      Works with CraftBukkit recommended build #1337
      • Fix: Players with spawnTools permission are no longer allowed to spawn all tools.
      • Fix: Added a check to avoid "The permission xy is already defined!" errors
    • LogBlock v1.40 #60 (Nov. 09, 2011)
      Works with CraftBukkit recommended build #1337
      • Feature: Custom auto ClearLog
      • Feature: Reduced error spam. Instead of like 40 line of error code, there is now just a warning stating the MySQL con
      • Feature: The queue will now be dumped after 10 tries even when the MySQL server is connected
      • Feature: Custom material names, allows naming custom blocks
      • Feature: LogBlock will now respond to messages when started without MySQL connection
      • Fix: Log import runs now async
      • Fix: Log import errors won't crash the server
      • Fix: Console commands work again
      • Fix: You can now use upper case letter in tool names (I don't know why you even should, but ...)
      • Config: Added, clearlog.enableAutoClearlog in main config. Added materials.yml. Removed clearlog.keepLogDays
      • Permissions: Added 'logblock.spawnTools'
    • LogBlock v1.32 (Oct. 04, 2011)
      Works with CraftBukkit recommended build #1240
      • Feature: Player info logging: firstLogin, lastLogin, onlinetime, ip. No ingame lookup yet.
      • Feature: /lb queuesize to see the current queue size
      • Fix: Door logging logs now also fence gates
      • Fix: Bukkit api break in CB #1191
      • Fix: time restriction works now as intended. Thanks to xrobau
      • Fix: Players with insufficient permissions can't smuggle bedrock from one world to another
      • Config: Added logPlayerInfo
    • LogBlock v1.30 (Sep. 22, 2011)
      Works with CraftBukkit recommended build #1185
      • Feature: Chat lookup /lb chat player diddiz search +admin +sucks +dicks (more info)
      • Feature: Door logging
      • Feature: Dynamic tools, define your own tools
      • Feature: Use since and before to define a timespan
      • Feature: Enderman logging
      • Feature: cake logging (who ate it)
      • Config: Added logEndermen, logCakes and logDoors to world config and moved the tool section in main config.
      • Permissions: logblock.tool changed to and
        logblock.toolblock to
    Todo List:

    Permission Nodes:

    Plugins supporting Logblock:
    List (open)

    When you want to appear your plugin here, tell me about

    Support the developer (that's me :D):
    If you want to support me writing plugins or want to thank me for the plugin/support, you can: Suggest features I missed, report bugs (best with fix :D), donate via PayPal, flattr my plugins, gift me The Witcher 2 (thanks to newyoukdaily), 2x 1GB DDR1 modules (thanks to HonestFlames), or send me the inner life of a laptop or netbook with a broken display (need it to build a model aircraft, so there is no need for parts like display and keyboard).


    How to post error messages:

    I won't aswer questions to general MySQL setup/installation/what is MySQL (there are lots of good tutorials out there, use google)
    Please read the installation guide before asking a question about installation problems.
    Please read the FAQ before posting a error report. It may be solved there.
    In case of rollback or lookup problems: Type /lb savequeue and try again (when it's fixed then, it was a consumer problem, see FAQ)
    When you post error messages, it's important to paste the whole stack trace!

    Newyorkdailys Plugin Support Buisness (open)
    Still can't get LogBlock working, or any other plugin? Are you getting errors in your console and cant figure out why? Newyorkdaily offers Basic/Advanced Plugin support.
    • General/Advanced troubleshooting: FREE!
    • Plugin Installations: 1-2 Plugins - FREE!
    • 3 or More Plugins - $2
    Click on the link below to connect to him now!

    There is a LogBlock irc channel: #logblock at
    You can ask me on skype. My name is 'hawky.diddiz'.
  2. Offline


    I am getting this to. I even put the password in '' but it still wouldn't work:

    2011-12-04 23:43:21 [INFO] [LogBlock] Connecting to null@jdbc:mysql://mysqlus3.XXXXXX.XXX:3306/XXXX_clientdb...
    2011-12-04 23:43:22 [SEVERE] [LogBlock] Error while fetching connection:
    java.sql.SQLException: Access denied for user ''@'XX.XXX.XXX.XXX' (using password: YES)
  3. Offline


    I get this error

  4. Offline


    Please help me somebody. I really need logblock but whenever I use a command ingame i get this...

    No database connected. Check your MySQL user/pw and database for typos.Start/restart your mySQL server.

    Anyone know what I should do?
    This is the message on the console...
    07:06:57 [INFO] [LogBlock] Version check: Your version is up to date
    07:06:57 [INFO] [LogBlock] Connecting to username@jdbc:mysql://localhost:3306/minecraft...
    07:06:57 [SEVERE] [LogBlock] Error while fetching connection:
    com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

    The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
    at java.lang.reflect.Constructor.newInstance(
    at com.mysql.jdbc.Util.handleNewInstance(
    at com.mysql.jdbc.SQLError.createCommunicationsException(
    at com.mysql.jdbc.MysqlIO.<init>(
    at com.mysql.jdbc.ConnectionImpl.coreConnect(
    at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(
    at com.mysql.jdbc.ConnectionImpl.createNewIO(
    at com.mysql.jdbc.ConnectionImpl.<init>(
    at com.mysql.jdbc.JDBC4Connection.<init>(
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
    at java.lang.reflect.Constructor.newInstance(
    at com.mysql.jdbc.Util.handleNewInstance(
    at com.mysql.jdbc.ConnectionImpl.getInstance(
    at com.mysql.jdbc.NonRegisteringDriver.connect(
    at java.sql.DriverManager.getConnection(
    at java.sql.DriverManager.getConnection(
    at de.diddiz.util.MySQLConnectionPool.getConnection(
    at de.diddiz.LogBlock.LogBlock.getConnection(
    at de.diddiz.LogBlock.LogBlock.onLoad(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(
    at net.minecraft.server.MinecraftServer.init(
    Caused by: Connection refused
    at Method)
    at com.mysql.jdbc.StandardSocketFactory.connect(
    at com.mysql.jdbc.MysqlIO.<init>(
  5. Offline


    /lb rb player fire area since 1d
    Update CB and tell if the error persists
    Did you grant the privileges?
    CREATE DATABASE minecraft; GRANT ALL ON minecraft TO 'username'@'localhost' IDENTIFIED BY 'password';
    In case of a remote mysql server replace localhost with the ip/domain of the mc server or use '%' as wildcart.
    Get a MySQL database and put its data into LB config.

    Interesting, I thought that was fixed. The null refers to the config ...
    I can't reproduce that, are there other errors before?
    Are you sure about the CB version? (I'm just asking as this error is know to occur from cb#1400 - #1500)
    Strange, indeed. Is this related to/affected by reloads?
  6. Offline


    Now i get this, it says in chat errors, check log.

  7. Offline


    i cant use the command /lb rollback player blackopskid7 area 20 it sais no blocks found rollback aborted when i was testing it and broke blocks then did the rollback nothing happened
  8. Offline


  9. Offline


    I don't use /reload, since Spout doesn't react well to it. This is with typing the "stop" command between tests. Unless logblock does some crazy permissions-caching when it starts up (I'm guessing it doesn't :D ), this almost has to be a craftbukkit issue, so I've got a bug report here:

    If you're able to throw some light on this from a technical perspective, I'd appreciate it.
  10. Offline


    I posted the relevant LB code there

    What command did you use?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  11. Offline


    is it stable now with dev1559 or have it bugs?
  12. Offline


    No know bugs, beside some people reported a npe at server start.
  13. Offline


    all :)

    Only /lb help ,/lb commands and /lb params worked. All others didn.
  14. Offline


    Give an example :D
  15. Offline


    i cant use /lb rollback player blackopskid7 since 30m area 10 it sais searching block changes from 30 minutes 10 blocks from your position in world
    no changes made aborting rollback even though i changed a bunch to test it
  16. Offline


    I have a suggestion, You know how lava and water created cobblestone or obsidian? Well Lb picks up some of it and will fix a bit of it. Other than that there is cobble all over. You should make it so it picks it up better. And waterflow, say it destroys hundreds of torches, well when you do a rollback 10 - 20 torches are fixed. You should just make waterflow and lavaflow more watched.
  17. Offline


    hehe srry bro, like when i make /lb rollback area 30 2h00m, we have tried mannnnyy commands noone works for me or other ops, only the ones below:

    It seems that only /lb help ,/lb commands and /lb params has worked for me, but /lb area hasent and /lb
  18. Offline


    Try 1 day as time spec, may be timezone mismatch
    Hm, last time I updated that was in 1.8 update, was perfect then :D
    But some things may have changed, will have a look this.
  19. Offline


    i get an error instead of wrong command when i type /lb rb tigin88. just crashed my server please help. Did i do something wrong?
    05.12 16:50:48 [Multicraft] Minecraft shut down
    05.12 16:50:48 [Server] INFO #
    05.12 16:50:48 [Server] INFO #
    05.12 16:50:48 [Server] INFO # If you would like to submit a bug report, please visit:
    05.12 16:50:48 [Server] INFO #
    05.12 16:50:48 [Server] INFO # /home/root/multicraft/servers/server3/hs_err_pid26004.log
    05.12 16:50:48 [Server] INFO # An error report file with more information is saved as:
    05.12 16:50:48 [Server] INFO #
    05.12 16:50:48 [Server] INFO # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
    05.12 16:50:48 [Server] INFO #
    05.12 16:50:48 [Server] INFO # V  []  PhaseChaitin::post_allocate_copy_removal()+0x1049
    05.12 16:50:48 [Server] INFO # Problematic frame:
    05.12 16:50:48 [Server] INFO # Java VM: Java HotSpot(TM) 64-Bit Server VM (21.1-b02 mixed mode linux-amd64 compressed oops)
    05.12 16:50:48 [Server] INFO # JRE version: 7.0_01-b08
    05.12 16:50:48 [Server] INFO #
    05.12 16:50:48 [Server] INFO #  SIGSEGV (0xb) at pc=0x00002b50f7adb4c9, pid=26004, tid=1112774976
    05.12 16:50:48 [Server] INFO #
    05.12 16:50:48 [Server] INFO # A fatal error has been detected by the Java Runtime Environment:
    05.12 16:50:48 [Server] INFO #
    05.12 16:50:40 [Server] INFO     at
    05.12 16:50:40 [Server] INFO     at
    05.12 16:50:40 [Server] INFO     at net.minecraft.server.MinecraftServer.w(
    05.12 16:50:40 [Server] INFO     at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    05.12 16:50:40 [Server] INFO     at net.minecraft.server.NetServerHandler.a(
    05.12 16:50:40 [Server] INFO     at net.minecraft.server.NetworkManager.b(
    05.12 16:50:40 [Server] INFO     at net.minecraft.server.Packet3Chat.a(
    05.12 16:50:40 [Server] INFO     at net.minecraft.server.NetServerHandler.a(
    05.12 16:50:40 [Server] INFO     at
    05.12 16:50:40 [Server] INFO     at net.minecraft.server.NetServerHandler.handleCommand(
    05.12 16:50:40 [Server] INFO     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    05.12 16:50:40 [Server] INFO     at org.bukkit.command.SimpleCommandMap.dispatch(
    05.12 16:50:40 [Server] INFO     at org.bukkit.command.PluginCommand.execute(
    05.12 16:50:40 [Server] INFO     at de.diddiz.LogBlock.CommandsHandler.onCommand(
    05.12 16:50:40 [Server] INFO     at de.diddiz.LogBlock.QueryParams.parseArgs(
    05.12 16:50:40 [Server] INFO java.lang.IllegalArgumentException: Not a valid argument: 'tigin88'
  20. Offline


    think u skipped me hehe xD
  21. Offline


    So I tried what you said, and it keeps telling me that player fire hasn't made any block changes... I've done a test where I light some wood on fire, let it burn, and put it out. Then I check to see if I can roll it back using "/lb rb area 5 player fire", but it simply tells me player fire has not made any block changes... :eek:
  22. Offline


    @DiddiZ That was the only error in my log!
    I have NO idea what is causing this, I'm using the latest dev of bukkit, and I also deleted the config / etc.
  23. Offline


    /lb rb player tigin88

    Any message/error log?
    Is fire logging enable in world config?
    Neither me ...
  24. Offline


    @DiddiZ i did everything you said before, and that did fix that issue, but now, i get this error (and it just started happening, about a few hours before this post).
    Heres the error:
    I did delete the skip_network thing. And I don't know anything else I can do. I can login to phpmyadmin and access my mysql.
  25. Offline


    Sometimes when I roll someone back it doesn't roll back everything they did. Also upon rolling them back, it says something like "Successfuly rolled back player bob 270/500 edits" or something like that. Why is it only 270/500?
  26. Offline


    Do you have no password, or is it just no used?
    If latter, put it in single quotes, like: '123'
    What's not rolled back, do you have a screen shot, or something?

    Some blocks were later modified by other players and so don't need bo be rolled back.
  27. Offline


    Yes I have a password. In the config, do you want me to put it in quotes?
  28. Offline


    I just don't get it, I've tried this plugin multiple times since it first came out. BigBrother worked fine for me. Then I wanted this. I tried with mysql installed to host the database off localhost didn't work. I bought some hosting from and made some databases and added them to config.yml, didn't work. I = Sad face.
  29. Offline


    I know this may be beyond the scope of the plugin, but I would like to know if it's possible (even if only in theory).

    If I run my server off a ramdisk and it crashes, can I use lb to redo all the changes since the last backup? For example, if my last backup before the crash was 60 minutes old, could I just use
    /lb redo area 2000 since 1h
    even though it was something I never rolled back?

    Even if the redo is not perfect, it would be better than not getting anything from that hour back.
  30. Offline


    That's what I said :D
    Error messages?
    Of course.
    You don't need area, the whole wotld is selected by default:
    ./lb redo since 1h
    GameFAQsRolo likes this.
  31. Offline


    Ok, sorry I didn't exactly know what you ment, but I did so, then I got the same error as, um like three of my posts ago :p . I deleted skip_networking in my.cnf , and now alls good!
    Thanks for your help, again!
    DiddiZ likes this.

Share This Page