Discussion in 'Inactive/Unsupported Plugins' started by Protected, Apr 13, 2011.

  1. Offline


    Thats awesome! Thanks.
    However i'm trying and trying but doesn't work properly for me.
    Updated config file, went flying and while mid air selected lantern, I did hear the "place block" sound,
    and I saw the block underneath me but I just seem to fall through it.

    Running bukkit #677
    Flight 1.1 (obviously)
  2. Maybe your server lags?
  3. Offline


    It appears not. Tried both online and local server with nothing but the flight mod. Same deal.
  4. Weird... Works in mine. It actually teleports you onto the block after creating it. Anyone else tried it yet?
  5. Offline


    I clearly didn't advert any plugin. I only said they existed.
  6. Offline


    hey guys,
    I tried that plugin but always is try to fly ist get this msg:
    20:49:27 [SCHWERWIEGEND] Exception in thread "Timer-2"
    20:49:27 [SCHWERWIEGEND] java.lang.NoSuchMethodError: org.bukkit.entity.Player.g
    20:49:27 [SCHWERWIEGEND] at net.myshelter.minecraft.Flight.updateFlight(F
    20:49:27 [SCHWERWIEGEND] at net.myshelter.minecraft.FlightEnforcer.run(Fl
    20:49:27 [SCHWERWIEGEND] at java.util.TimerThread.mainLoop(Unknown Source
    20:49:27 [SCHWERWIEGEND] at java.util.TimerThread.run(Unknown Source)
    can you help me???
  7. Sounds like you have an old version of craftbukkit.
  8. Offline


    3 days later...
  9. I have a strict policy of not answering stupid questions. I was hoping it might occur to you that you can try it out in 1 minute rather than wait 3 days for the answer - anyone qualified to run a server for anything would have been able to figure that out. There are only 2 possible answers to your question. Trial and error, you know? Take a risk! Adventure!

    If this post comes out as aggressive, know that it's all in your head. This is me being nice and actually answering you, since you bothered to ask again, plus some light scolding. Yup, I can be much nastier ;)

    So, the answer is... YES!
  10. Offline


    Why doesn't this work for me?
  11. Offline


    Thx for this great plugin. Works for me even with Craftbukkit Build 678.

    Just tried this and its exactly the same for me.
  12. I'll see what I can do to improve it.
  13. Offline


    I'm trying out the plugin..but it's not making the config file..only the permits.dat.

    I want to change the cost/duration
    Can you post a sample of the config file so i can create it manually?
  14. Offline


    same issue as Cowmaster
  15. Offline


    A how to use tutorial

  16. Offline


    GREAT plugin!
  17. New version is out. Config file compatibility broken so make sure you read the top post carefully to learn what you have to change.

    Ninja fix in config options:

    fuel-spend -> no-fuel-spent (meaning inverted; now has to be TRUE for free flight)
    perch-spend -> no-perch-spent (meaning inverted; now has to be TRUE for free perches)

    This makes these two options Permissions-friendly (otherwise things would be free by default when using the Permissions provider). No changes when using the config.yml provider.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  18. Oops, I accidentally broke the config file in the top post yesterday, it's fixed now.
  19. Offline


    I can buy permits, but not fly. Feather in hand, hold shift and nada. Here's what I get in the console. I've looked in the config.yml file for any stray characters or anything and I get nothing using Notepad++.

    cb 740

    2011-05-04 20:11:55 [SEVERE] special characters are not allowed loading Flight v2.0 (Is it up to date?)
    unacceptable character #0 special characters are not allowed
    in "<reader>", position 0
        at org.yaml.snakeyaml.reader.StreamReader.checkPrintable(StreamReader.java:68)
        at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:159)
        at org.yaml.snakeyaml.reader.StreamReader.peek(StreamReader.java:117)
        at org.yaml.snakeyaml.reader.StreamReader.peek(StreamReader.java:106)
        at org.yaml.snakeyaml.scanner.ScannerImpl.scanToNextToken(ScannerImpl.java:964)
        at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:237)
        at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:183)
        at org.yaml.snakeyaml.parser.ParserImpl$ParseImplicitDocumentStart.produce(ParserImpl.java:200)
        at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
        at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
        at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:104)
        at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
        at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
        at org.bukkit.util.config.Configuration.load(Configuration.java:73)
        at net.myshelter.minecraft.flight.Flight.load(Flight.java:90)
        at net.myshelter.minecraft.flight.Flight.onEnable(Flight.java:55)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:632)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:218)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:116)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:94)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  20. Please pastebin the contents of config.yml or attach the file to a post.
  21. Offline


    I wanted to change the permit-material to 266, but no matter what i change the permit-material to, it keeps using diamonds..am i doing something wrong?
  22. If you upgraded to 2.0 make sure you're using the new config file structure (everything inside a flight block) as shown on the top post. Make sure you reload or restart after the changes. If you're using the Permissions P.V.P. in full: true mode, make sure you define the material in Permissions inside an info: block.

    Feel free to pastebin your config files so we can take a look at them.
  23. Offline


    yea..using exact same code u posted..jus changed the permit-material, reloaded..restarted...not using permissions
    also..it doesn't seem to be using up feathers....i can fly forever.
    The older version worked fine..this only started happening with the v2
  24. Offline


    its the code you had posted, the only difference was the indenting of 1 item, no-fuel-spent. Was giving me a block error before.
        #===== FEATURES/PERMISSIONS =====
        #Enable buying of new permits
        can-buy-permit: true
        #Enable flying upwards (SHIFT)
        can-rise: true
        #Enable gliding/soft falls
        can-glide: true
        #Enable perches
        can-perch: true
        #===== FUEL =====
        fuel: 288
        #The fuel material is what brings you the power of flight. By default, of course, it's feathers.
        #Set to true to allow free flight
        no-fuel-spent: false
        #The tick is the minimum time unit of Wings and it lasts 0.25s. By default Wings consumes a feather every 20 ticks (5 seconds).
        #Note: Wings always consumes one feather just to take off; A single feather isn't enough for flying.
        refuel-ticks: 20
        #===== PERCHES =====
        #Perching material, used for creating temporary perches
        perch: 91
        #Set to true to allow free perching
        no-perch-spent: false
        #===== PERMITS =====
        #This is the block ID of the currency used to buy a permit. By default it's diamonds.
        permit-material: 266
        #This is how much of the above a permit costs. By default, 1. Set it to 0 for free permits!
        permit-cost: 1
        #This is how many ticks of flight the permit lasts. When it expires the player stops flying. Immediately.
        #Yup, ticks still last 0.25s. Default, 86400 ticks or 6 hours of flight.
        permit-duration: 57600
        #===== ADVANCED PARAMETERS =====
        #WARNING: Don't change this if you're a coward. Are you feeling lucky?
        #When a player's vertical speed is below this value the plugin considers him to be plunging like a rock to his doom, so if he's
        #holding feathers in his hand he will start GLIDING. This value should be negative, otherwise players will fly up like
        #helium-filled baloons. If you remove gliding players WILL get hurt when they land.
        glide-threshold: -0.3
        #This is the theoretical maximum altitude players can fly to; depending on the other parameters they'll probably never reach this
        #high, but it's important for the formula. Basically, the closer players are to this altitude, the slower they'll fly upwards.
        reference-altitude: 150.0
        #This is how the distance to the reference altitude impacts vertical flying speed (wing flapping). Increase this to make the
        #player rise faster, but be careful here.
        altitude-weight: 0.011
        #If the rising speed falls below this value (too close to reference altitude) the plugin will stabilize the player at that level.
        #Only horizontal flying is possible unless he glides down a little.
        low-hover-vel-threshold: 0.1
        #This is the highest vertical flying speed cap. In other words, players near bedrock will not shoot up like rockets thanks to this.
        high-hover-vel-threshold: 0.6
        #This controls how much weight the horizontal components of the vector resulting from the direction you're looking at impact on your
        #horizontal velocity. Increase to fly faster when you're looking towards the horizon. Set to 0 to disable horizontal flying entirely.
        directional-weight: 0.3
        #This is the horizontal flight speed cap.
        max-horizontal-vel: 0.6
  25. Indentation is important in YAML.
  26. Offline


    Very true.. U might want to then fix your config spoiler as you have no-fuels-spent creating a new block. But that wasn't my issue when u see the console. Its mentioning some special character at position 0 in the reader.
  27. I don't see any. Attach the actual file here.
  28. Offline



    Attached Files:

  29. Still looks ok. Are you sure you're upgrading/modifying in the correct location? And that there aren't two or more copies of the plugin? Are you trying to use Permissions?

Share This Page