[INACTIVE][TP] MyWarp v2.0.1 - native PermissionsEx support - no superperms yet [1337]

Discussion in 'Inactive/Unsupported Plugins' started by flames, Apr 15, 2011.

  1. Offline


    Version: 2.0dev
    Download (JAR / ZIP)
    Source code

    MyWarp is now in development by SpathiZilla, please see here

    MyWarp was made by Taylor Kelly (tkelly), all credits go to him! I forked MyWarp and will provide updates in future, or until tkelly is back. There are no changes in usage or functionality. Just the same commands, same permission nodes and same features. Original description:

    ...is Basic
    Many server admins only want the very basics. MyWarp delivers on that, and still gives the speed and reliability of using a SQLite database.

    By only giving your users permission to mywarp.warp.basic.*, they will only be able to use the very basic commands.

    ...is Social
    However, sometimes your users will demand more. They'll want to make their warps private, invite only specific people to their warps, even give their warp to someone else. MyWarp can do that too.

    Give your users mywarp.warp.soc.*, and they'll be able to do all of that.

    ...is Intelligent
    Sometimes, warps can be long and hard to remember. This is where MyWarp's auto-complete abilities come into play. It tries to find the most applicable match, and sends you there. It only considers warps you have access to, and will not send you somewhere unless it knows it's correct.

    A few examples:
    There are warps: {"Mob Spawner", "Farm", "farm", "tkelly's house", "joe's house"}
    tkelly has access to: {"Mob Spawner", "Farm" "tkelly's house"}
    joe has access to: {"Mob Spawner", "Farm", "farm", "joe's house"}

    No matter who uses /warp spawn, they will be sent to "Mob Spawner"
    If tkelly uses /warp house, he'll be sent to "tkelly's house"
    If joe uses /warp house, he'll be sent to "joe's house"
    If tkelly uses /warp farm or /warp arm, he'll be sent to "Farm"
    If joe uses /warp farm, he'll be sent to "farm"
    But if joe uses /warp arm, it equally matches both "Farm" and "farm", so will send him to neither.

    ...is Sign-full
    Physical interactions with the world is what Minecraft is all about. That's why signs can be used to replace many of the basic commands. For now, you can have a sign warp you to one of your current warps (using the auto-complete). Feel free to suggest more things, and I'll build that in.

    In order to build a warping sign, create a sign with two lines of text (it doesn't matter what specific lines).

    If you don't use the basic permission-set, give your players following nodes:

    ...is Guiding
    Want to make your users work to get to their points of interest? Rather than giving them /warp permission, just give them (mywarp.warp.basic.compass) permission. This will let them /warp point <name> to a given warp, and that'll orient their compass to that warp, allowing them to use their own two legs to get there.

    ...is Restricting
    In addition to the compass restrictions, you can also limit the number of public and private warps users can make. You can find and change these settings in MyWarp.settings.

    Until Bukkit's permissions and groups get fleshed out, this is a global number. However, with another setting in MyWarp.settings, you can allow admins to go around this limit.

    ...is Helpful
    As an server administrator, warps can easily be abused. MyWarp gives you access to be able to visit and modify all the warps.

    Version 2.0dev
    • MySQL support
    • importing warps from warps.db to mysql
    • permissions 3.x
    • removed extremely old artifacts (import of hmod warps)
    • tested and works on CB928
    Version 1.10.7
    • added native support for PermissionsEx
    • fixed namespace
    Version 1.10.6
    • updated for CB786-793
    • updated to Help 3.0 ( not interesting for you until you compile from Lycano's fork on github :p )
    Version 1.10.5c
    • fixed the "Could not pass event PLAYER_INTERACT to MyWarp" error
    Version 1.10.5b
    • updated for CraftBukkit RB #677 (also tested with CB #678)
    • Permissions 2.5.5 or higher (tested with 2.6 and 2.7)
    • added GroupManager support
    • changed update URL where MyWarp downloads sqlite libraries
    kahlilnc, Mtihc, Charant and 5 others like this.
  2. Offline


    @flames or developpers:
    Hi, I am using myWarp for quite a while now. It's an awsome plugin !
    I have some knowledge in Java and wanted to add the possibility, for basic users, to only create and update their own private warp "User's house" but without giving them other rights.
    So I downloaded the source code on github, i acted on the readme instructions to compile myWarp and get the following error when i execute "$ mvn -X clean install" to install myWarp:

    [DEBUG] Could not find metadata me.taylorkelly.help:Help/maven-metadata.xml in c
    entral (http://repo1.maven.org/maven2)
    [INFO] ------------------------------------------------------------------------
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 1.211s
    [INFO] Finished at: Fri Jun 03 12:20:29 CEST 2011
    [INFO] Final Memory: 2M/61M
    [INFO] ------------------------------------------------------------------------
    [ERROR] Failed to execute goal on project MyWarp: Could not resolve dependencies
     for project me.taylorkelly.mywarp:MyWarp:jar:1.10.7: Failed to collect dependen
    cies for [org.bukkit:bukkit:jar:0.0.1-SNAPSHOT (compile), ru.tehkode:Permissions
    Ex:jar:[1.02,) (compile), com.nijikokun.bukkit:Permissions:jar:[2.5.5,) (compile
    ), org.anjocaido:GroupManager:jar:1.0-alpha-5-SNAPSHOT (compile), me.taylorkelly
    .help:Help:jar:[0.2,) (compile)]: No versions available for ru.tehkode:Permissio
    nsEx:jar:[1.02,) within specified range -> [Help 1]
    org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal o
    n project MyWarp: Could not resolve dependencies for project me.taylorkelly.mywa
    rp:MyWarp:jar:1.10.7: Failed to collect dependencies for [org.bukkit:bukkit:jar:
    0.0.1-SNAPSHOT (compile), ru.tehkode:PermissionsEx:jar:[1.02,) (compile), com.ni
    jikokun.bukkit:Permissions:jar:[2.5.5,) (compile), org.anjocaido:GroupManager:ja
    r:1.0-alpha-5-SNAPSHOT (compile), me.taylorkelly.help:Help:jar:[0.2,) (compile)]
    Do I need to install some plugins like PermissionsEx or GroupManager to compile? what is this error with me.taylorkelly.help?
    I'm running on Win7, and the version of my Permissions.jar is 2.7.2 (it's the one i'm running on my Ubuntu Server)
    I hope someone will give me an answer or the myWarp team will update the readme.

  3. hi. mywarp in 818CB error :( please help

    ou sry :-D Fixed :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  4. Offline

    Graham Mathis

    I am having problems with mywarp still...i have permissions 3.1 and mywarp 1.10.7. it detects my warps when i start the server but when i try to actually use them i have no commands to use. i also have essentials and i deleted the warp function from that. is the problem permissions?

    -went back to permissions 2.7.4 and essentials 2.2.22

    -FIXED! i just renamed the mywarp jar to amywarp...tried it earlier and it didnt work...oh well...im happy :D
  5. Offline


    Can you make it possible for people not to be able to make warps in certain worlds?
    i.e you have World1 as a build map where warps are freely allowed and then you have World2 as a factions map where people have to walk to their enemy to fight them rather than just warp

    EDIT: So I tried to set up multiworld with this before I awaited an answer. I made a warp in World2 and then restarted my server on World1. I tried to warp to World2 and the plugin said "World World2 doesn't exist." Any idea where I should go from here to make multiworld work? I'm on 820. (This problem also occurs with MyHome)
  6. Offline


    Got this exception today, imediately after which the server crashed (Bukkit #819):


    To be fair, I also saw a similar exception repeated for a few other addons immediately after (presumably same event), MyWarp was just the first to throw the exception. So I suspect this might be a Bukkit bug, but perhaps this might help in tracking it down or reporting it to the Bukkit folks? (not been around plugins long enough to know what that process might be)

  7. Will the issue with Permissions 3.x be fixed in the near future or is the developer dropping support?
    Just wanted to know, I am patient, but if it isn't, just switching to Essentials' warping.
  8. Offline


    A simple and working workaround is to rename permission ->loaded before "M"yWarp/"M"yHome.

    e.g. aPermissions ( a < m )
  9. Offline


    Renaming permissions worked like a charm. It also fixed a problem, more of a spamming issue, that I was having with CommandBook. Thanks for the info.
  10. Offline


    testing version of mywarp 2.0

    - added mysql support
    - importing warps from warps.db to mysql
    - permissions 3.x should work now (please report if not).
    - removed extremely old artifacts (import of hmod warps)
    - tested and works on CB826

    Special thanks to Spathizilla for MySQL support!
  11. Offline


    Is there a problem with players warping in CB818? I've never had any problems with MyWarp, even with the amount of warping that we do from place to place, until the 1.6 update. Now everytime someone warps they end up in a world hole and have to relog. Not much of an issue but it can get really annoying. I have the same exact problem with MyHome and teleporing to players, and am wondering if the new Minecraft or Bukkit update did something with the Z-axis when instantly traveling from place to place.
  12. Offline


    yep, try latest myhome and mywarp, set loadChunks to true, update craftbukkit to build 826 or later (i know its not RB but its more reliable currently)
  13. Offline


    Alright, thanks I'll try that then. I'm feeling a little uneasy using a non RB of Bukkit, but we'll see how it goes and hopefully nothing will break in the process. =P
  14. Offline


    Upgrade to Bukkit 820. 819 was riddled with bugs and with MyWarp installed it would throw a random error and CRASH the server. They already fixed it in 820 and also had other crashing issues with Essentials, LWC, and a couple more plugins would crash the server also. It was most common by MyWarp though.
  15. Offline


    I was on #823 up until last night (now on #839) and still seeing crashes, although they were much less frequent than when I first reported this issue (on #819). So it's entirely possible what you're reporting is correct, that going 820+ resolves the crasher I linked and that there's other crashers I'm running into now. Certainly the crashes have gone down in frequency so going to 820+ seems like a good thing for anyone else experiencing crashes; hopefully we'll get an 840 series RB soon.
  16. Great plugin, first of all.

    I am wondering if there has been any thought or consideration toward monetizing warps? For example, I have a server that sells warps to players and would love to see MyWarp have this as a native feature.
  17. Offline


    sorry, i dont have the spare time to provide new features and resolve dependencies on foreign plugins (economy and what else). i added mysql support because i needed it for my own server and because Spathizilla provided a very nice way to implement mysql backend which was very simple to port to mywarp. as i stated in the OP
    but feel free to fork and add features :)

    i dont promise anything, but maybe i will add economy support, if i have a free weekend :p
  18. Offline


    Hi :)
    It would be nice if you could add the Testing-Version of MyWarp v2.0 to the first post, so that everybody knows where they can download it ^^


    Epic :)
  19. Offline


    heh, the link to download in OP is already to the 2.0dev since yesterday :p
    just didnt updated thread topic.

    so please test and report.
  20. Offline


    Working fine on my end, everything good. :)
  21. Offline


    Works like charm (even with Permissions 3.x)! Thank you for keeping this up to date!
  22. Offline


    My mywarp is not working , im getting no errors, just the commands wont work
  23. Offline


    I've followed every instruction for the sign-warps, but no matter what, i cant use a sign to warp players around on my server :(
  24. Offline


    I'm using mywarp 2.0 and craftbukkit b860. When I try to use the commands all i get is a message that says "/warp help - Displays the help for MyWarp". Here is a list of all my plugins.

    BigCatch 0.7
    BlocksOnGlass 0.34
    ChairCraft 1.2.2
    CommandBook 1.5.2
    dynmap 0.17
    EasyFlight 0.3
    FenceStack 1.13
    InvinciWolf 1.6.1
    MinecartManiaCore 1.2.8
    MyWarp 2.0
    Permissions 3.1.5
    PluginInfo 0.1.3
    PorteCoulissante 1.2.1
    RetractableBridge 1.3.6
    Sprint 1.3
    Stargate 0.4.8
    WorldEdit 4.6
    WorldGuard 5.0-alpha10
    WormholeXTreme 0.854

  25. Offline


    Hi, I tried (With my clumsy newb-coder skills) to edit this plugin to allow warp-signs to charge X items of Y type for teleporting and place that in a designated chest, but... Uhm, total failure on my part XD. I just wanted to change the onPlayerInteract part in MWPlayerListener, but is there any easy way (or any way) to just change that class? I even tried downloading the source-code, but I suspect it turned into a patchwork of code that didn't work XD.
    So I was wondering if it's possible to request that to be made instead (I think it'd be some considerable amount of time before I'm good enough at this to do it myself >_<).
  26. Offline


    This was my fault. I had a config issue with the new permissions version. My groups.yml was missing "groups:" at the start of the file so I guess no user was getting added to any group and therefore my permissions were completely ignored.
  27. Offline


    Does anyone know of a way to convert over essentials warps? Even if I have to do it 1 by 1? Thanks
  28. Offline

    Kevin Robbens

    Another great warp plugin.
    I can't find a good one that supports an item cost instead of using iconomy (like a goldbar and so on), could you do it?
  29. Offline


    When i do /warp create name or /warp set name
    i get a error that says : Player not found! ?
  30. Offline


    I'd like to know the answer to this as well.
  31. Offline


    thanks for the reports, i will look into the issues you found.

Share This Page