[INACTIVE][TP] MyWarp v2.0.1 - native PermissionsEx support - no superperms yet [1337]

Discussion in 'Inactive/Unsupported Plugins' started by flames, Apr 15, 2011.

  1. Offline


    Version: 2.0dev
    Download (JAR / ZIP)
    Source code

    MyWarp is now in development by SpathiZilla, please see here

    MyWarp was made by Taylor Kelly (tkelly), all credits go to him! I forked MyWarp and will provide updates in future, or until tkelly is back. There are no changes in usage or functionality. Just the same commands, same permission nodes and same features. Original description:

    ...is Basic
    Many server admins only want the very basics. MyWarp delivers on that, and still gives the speed and reliability of using a SQLite database.

    By only giving your users permission to mywarp.warp.basic.*, they will only be able to use the very basic commands.

    ...is Social
    However, sometimes your users will demand more. They'll want to make their warps private, invite only specific people to their warps, even give their warp to someone else. MyWarp can do that too.

    Give your users mywarp.warp.soc.*, and they'll be able to do all of that.

    ...is Intelligent
    Sometimes, warps can be long and hard to remember. This is where MyWarp's auto-complete abilities come into play. It tries to find the most applicable match, and sends you there. It only considers warps you have access to, and will not send you somewhere unless it knows it's correct.

    A few examples:
    There are warps: {"Mob Spawner", "Farm", "farm", "tkelly's house", "joe's house"}
    tkelly has access to: {"Mob Spawner", "Farm" "tkelly's house"}
    joe has access to: {"Mob Spawner", "Farm", "farm", "joe's house"}

    No matter who uses /warp spawn, they will be sent to "Mob Spawner"
    If tkelly uses /warp house, he'll be sent to "tkelly's house"
    If joe uses /warp house, he'll be sent to "joe's house"
    If tkelly uses /warp farm or /warp arm, he'll be sent to "Farm"
    If joe uses /warp farm, he'll be sent to "farm"
    But if joe uses /warp arm, it equally matches both "Farm" and "farm", so will send him to neither.

    ...is Sign-full
    Physical interactions with the world is what Minecraft is all about. That's why signs can be used to replace many of the basic commands. For now, you can have a sign warp you to one of your current warps (using the auto-complete). Feel free to suggest more things, and I'll build that in.

    In order to build a warping sign, create a sign with two lines of text (it doesn't matter what specific lines).

    If you don't use the basic permission-set, give your players following nodes:

    ...is Guiding
    Want to make your users work to get to their points of interest? Rather than giving them /warp permission, just give them (mywarp.warp.basic.compass) permission. This will let them /warp point <name> to a given warp, and that'll orient their compass to that warp, allowing them to use their own two legs to get there.

    ...is Restricting
    In addition to the compass restrictions, you can also limit the number of public and private warps users can make. You can find and change these settings in MyWarp.settings.

    Until Bukkit's permissions and groups get fleshed out, this is a global number. However, with another setting in MyWarp.settings, you can allow admins to go around this limit.

    ...is Helpful
    As an server administrator, warps can easily be abused. MyWarp gives you access to be able to visit and modify all the warps.

    Version 2.0dev
    • MySQL support
    • importing warps from warps.db to mysql
    • permissions 3.x
    • removed extremely old artifacts (import of hmod warps)
    • tested and works on CB928
    Version 1.10.7
    • added native support for PermissionsEx
    • fixed namespace
    Version 1.10.6
    • updated for CB786-793
    • updated to Help 3.0 ( not interesting for you until you compile from Lycano's fork on github :p )
    Version 1.10.5c
    • fixed the "Could not pass event PLAYER_INTERACT to MyWarp" error
    Version 1.10.5b
    • updated for CraftBukkit RB #677 (also tested with CB #678)
    • Permissions 2.5.5 or higher (tested with 2.6 and 2.7)
    • added GroupManager support
    • changed update URL where MyWarp downloads sqlite libraries
    kahlilnc, Mtihc, Charant and 5 others like this.
  2. Offline


    whenever i install this plug-in I cannot use any commands whatsoever whenever I use /warp it just displays use '/warp help for warp commands'
    Other plug-ins I'm using are Essentials (I disabled the warp commands in it), Multiverse and the latest Permissions
  3. Offline


    is there a way to import all Essential warps? I want use yours but most of the warps are under the Earth and on a whole map far far away. This is too much work to set them again. Essential warps are safed in a .yml file.
  4. Offline


    Just a quick question before I break my server: does this support RB 740? As the topic title only says [684-735]?
  5. Offline


    It works fine on #740, yes. :)
  6. Offline


    Could support for coloured (colored ;)) MyWarp signs be added?

    Trying to create a MyWarp sign that says:

    It shows the colours properly (obviously) but I'm guessing MyWarp is not recognising the colour codes.
    Would be awesome if that was added. :D
  7. Offline


    i have a problem. im using plugins my first time. i know how to write the plugins but every time i write /warp create [name] it says that warp does not exist
  8. Offline


    That could happen if you don't have the 'mywarp.warp.basic.createpublic' or 'mywarp.warp.basic.createprivate' permissions.

    Post your permissions config or no one can really help much.
  9. Offline


    group: Admins
    - 'mywarp.warp.basic.createpublic'
    group: Admins
    prefix: 'Moo'
    suffix: 'Cow'
    - 'herp.derp'
    group: Admins

    when i first installed permissions there were no permission line for me so i added it with enter and then pressing space until the - is above the others. is this the problem?!
  10. Offline


    If the group your in (Admins) has the * permission set to the group, you should not put the permission under the user, it can and might very well be conflicting. By default, the group 'Admins' has the * permission node already, which will give you access to every command, try removing the 'mywarp.warp.basic.createpublic' node and try again. :)
  11. Offline


    doesnt work :(
    i have removed the line and at the groups there is the *
  12. Offline


    Hmmm, could you post your whole config? And preferably in the Code box (little { }# symbol thing in the formatting bar, other side of Bold, Italic and Underline)
  13. Offline


    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    #  Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    #  If this file is for your default world (the one in server.properties) then you must
    #  leave copies blank.
    #  Example: copies: Derp    -  This will clone the permissions of the world Derp
    # Make sure to rename this file to the name of the world that is in sever.properties under
    # level-name.  So if it is level-name: world  then this should be world.yml and in the
    # plugins/Permissions directory (ie. plugins/Permissions/world.yml)
    # NOTE: Do not use tabs while editing this document.  Use only spaces.  A good way to avoid
    # doing this is to use Notepad++ and replace the tab with 4 spaces.
            system: default
    # AntiBuild is included with this.  To disable a group from being able to build then
    # set the build: flag to false (build: false).  If you want a group to be able to build
    # then set it to true.
    # Groups can contain inheritance.
    #  To make a group inherit the permissions from another
    #  group simply place the groups name in the "inheritance:" like so:
    #  Example:
    #      inheritance:
    #          - Default
    #  All permissions including the asterisks must be placed in single quotes.
    #  like so:
    #      - 'foo.bar'
    #  Otherwise errors will happen!
    #  Globalized Permission settings:
    #      If a permission contains periods (.) you can denote a globalized parameter:
    #          - 'foo.*'
    #      This will allow you to use all general commands.
    #  Single Asterisk denotes all commands:
    #      - '*'
    #  If you give a group this permissions, do not have the group inherit any permissions
    #  from other groups.  Any users assigned to this group should NOT be given any additional
    #  permissions either.
    #  To exempt a node use the - prefix like so:
    #      - '-foo.bar'
    #  prefix: and suffix: do not do anything on their own.  You need another outside plugin
    #  such as iChat or HeroChat in order for these to do anything.
            default: true
                prefix: ''
                suffix: ''
                build: false
                - 'foo.bar'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Default
                - 'bar.foo'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - '*'
    # Users denote which users are included in which group.
    # TheNo1Yeti is in the Admin group
    # Herpina is a member of the Moderator group but also has access
    # to the herp.derp permissions
    # Derpina is a member of the admin group but does not have access
    # to the derp.derp permission node
    # Users can also have a prefix and suffix as seen with Herpina
            group: Admins
            group: Admins
                prefix: 'Moo'
                suffix: 'Cow'
                - 'herp.derp'
            group: Admins
                - '-derp.derp'
  14. Offline


    :eek: Config looks fine to me, are you using any other plugins? Another plugin such as Essentials will conflict with the '/warp' command, I have not used Essentials before but I believe there is a way to disable Essentials warp features, not 100% sure.

    Also just to make sure, are you reloading your permissions after editing? Either restarting your server, reloading the plugins (I don't like to do this) or using the '/permissions -reload all' command will reload them.
  15. Offline


    Please add iConomy support. I seriously want to start charging for public warps (And possibly private ones as well)
  16. Offline


    Is it possible to give warps to a specific group, instead of having to give it every single user?
    I'm using permissions
  17. Offline


    yes, it works with latest RB and latest build 762.

    if you need iconomy support, go for xWarp.

    Schlumpfpirat, look into private warp feature and how to share private warps to your group.
  18. Offline

    Nick Lozon

    Breaks Help 2.4.1 on CB740.

    I don't have access to server log. =(
  19. Offline


    How do signs work, cause i havent been able to get mine to work,
    i created a warp called city
    Then on a sign i added:
    City Warp
    But nothing happens
  20. Offline


    You need to have this:


    MyWarp must stay on the sign, and <warpname> replaced with the name of the warp you want to teleport to.

    So your sign should look like this:


    Easy as that. :)
  21. Offline


    I tried that but when i right click the sign, nothing happens
  22. Offline


    Did it come up and say that a warp sign had been created? If not, you're doing something wrong, if it did then sometimes it seems to take a bit of time for them to work, logging off and back on again can sometimes get it going.
  23. Offline


    Oh yes, if you're using permissions and aren't under the 'Admins' (or another group with the '*' permission) group, you need to have the 'mywarp.warp.sign.create' to create them, and 'mywarp.warp.sign.sign' to use them.
  24. Offline


    can we get MySQL Support?
    oschaus likes this.
  25. Offline


    It doesn't come up with warp sign created, even though the warp works and i am admin with the '*' in permissions
  26. Offline


    When using Mywarp, I don't know if it has to do with distance of warp or not but it keeps killing my player skin, setting it back to default. I use it I have to go to minecraft.com and reload the custom skin. Any advice? Would appreciate it :)
  27. Offline


    [Server] SEVERE [MYWARP] Could not establish SQL connection. Disabling MyWarp
    What does it mean, if it appears when I just restarting the server for the first time after putting the .jar file into the plugins folder?

    2011-05-10 11:07:07 [SEVERE] [MYHOME]SQLite exception on initialize
    java.sql.SQLException: path to '/home/minecraft/multicraft/servers/server45/plugins/MyWarp/warps.db': '/home/minecraft/multicraft/servers/server45/plugins/MyWarp' does not exist
        at org.sqlite.Conn.open(Conn.java:103)
        at org.sqlite.Conn.<init>(Conn.java:57)
        at org.sqlite.JDBC.createConnection(JDBC.java:77)
        at org.sqlite.JDBC.connect(JDBC.java:64)
        at java.sql.DriverManager.getConnection(DriverManager.java:620)
        at java.sql.DriverManager.getConnection(DriverManager.java:222)
        at me.taylorkelly.mywarp.ConnectionManager.initialize(ConnectionManager.java:15)
        at me.taylorkelly.mywarp.MyWarp.onEnable(MyWarp.java:57)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:632)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:218)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:116)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:94)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    2011-05-10 11:07:07 [SEVERE] [MYWARP] Could not establish SQL connection. Disabling MyWarp
  28. Offline


    Gotta love this plugin, but I'd like a small feature request. Could you make it that you can use the MyWarp signs only if you're not holding anything? Currently everyone uses it while holding dirt or something which is placed down by accident and people end up suffocating upon warping.
  29. Offline


    Using Build #733, I've started getting this error today out of the blue:

    [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin MyWarp v1.10.5c
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:255)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:675)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:638)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:632)
        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.NullPointerException
        at me.taylorkelly.mywarp.Warp.warp(Warp.java:136)
        at me.taylorkelly.mywarp.WarpList.adminWarpTo(WarpList.java:415)
        at me.taylorkelly.mywarp.MyWarp.onCommand(MyWarp.java:358)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
    I literally haven't changed anything (mods, configs, etc) on the server since about last Tuesday, but I've now had to completely disable this plugin as the server crashes every time someone uses the /warp command.
    oO Kad Oo likes this.
  30. Offline


    can you convert warps from essentials (they are in .yml files)?
  31. Offline


    that would be great!

    I just tried to use this plugin for the first time today and got the error:
    15:46:08 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-729-g5ee3f0f-b766jnks (MC: 1.5_02)
    15:46:08 [INFO] Preparing level "world"
    15:46:08 [INFO] Preparing start region
    15:46:08 [INFO] [Permissions] (Phoenix) was Initialized.
    15:46:08 [SEVERE] java.lang.UnsatisfiedLinkError: /tmp/sqlite-3.7.2-libsqlitejdbc.so: /tmp/sqlite-3.7.2-libsqlitejdbc.so: failed to map segment from shared object: Operation not permitted
    15:46:09 [INFO] [MYWARP]: 0 warps loaded
    15:46:09 [INFO] [MYWARP] Permissions enabled using: Permissions v2.7.2
    15:46:09 [INFO] [MYWARP] 'Help' support enabled.
    15:46:09 [INFO] MyWarp 1.10.5c enabled

    Is there somewhere else I can move the sqlite-3.7.2-libsqlitejdbc.so where the plugin will check, or am I best off using something else?

Share This Page