[INACTIVE][TP] MultipleHomes v8! - As many Homes as you wish [1000]

Discussion in 'Inactive/Unsupported Plugins' started by DeathCradle, Feb 8, 2011.

  1. Offline


    MultipleHomes - As many Homes as you wish:
    Version: v0.8
    Tested Bukkit Build: 1000
    Native Permissions Support: Yes! Now Supported!
    Multi-World Support: Yes!

    I may be stopping my MineCraft plugin developments, This is due to me not having time to keep things up to date, Sorry.
    People may use this source, or w/e they must, please yourself.

    This plugin allows you to set how many homes to use via the properties file; While also allowing for quick teleports to your homes or even favourite spots!

    To utilise them you will need to use the commands:
    • /sethome [home-number]
    • /home [home-number]
    • /deletehome [home-number]
    Preview Commands:

    • /home <HomeNumber:HomeName> //Teleport to a set home
    • /sethome <HomeNumber> "<HomeName>" <Description> //Set a custom home, Make sure you include the " around the name
    • /deletehome <HomeNumber:HomeName> //Remove a home
    • /homelist //list your homes
    • /homeinvite <playername> <HomeNumber:HomeName> //invite a player to use your home
    • /homevisit <playername <HomeNumber:HomeName> //Visit a players home
    • /multiplehomes [usage <commandname>] or /mh [usage <commandname>] //into or description of available commands.
    Where '[home-number]' is replaced with the number you wish that home to be as.

    Want to see this Plugin in Action?
    Since this plugin was made for Olympus Minecraft you can come over and join the community and check out this plugin!
    IP Address: login.olympus-mc.net

    To setup this plugin, You can run the plugin on the server for a first time, It will generate What it needs. The files will be located in the plugins folder of Bukkit. It will create a 'MultipleHomes' folder that contains it's properties file, this is what you will need to edit.

    If using GroupManager, Upon first run it will generate more text within the properties file for allowing you to set custom home amount for each group, Defaulted at 5.

    Example (Default config):

    • '/sethome'
    • '/home'
    • '/deletehome'
    • '/sethome 2'
    • '/home 2'
    • '/deletehome 2'

    • Allows you to assign and utilse as many homes as you wish.
    • Also it can be for ANY user that wishes to use it.
    • Configurable Commands
    • Permissions Support (See Nodes below)
    Permission Nodes:

    For use with GroupManager you generally need a node, MulitpleHomes is as 'mh' + (Assigned Command). For example,
    If your MulitpleHomes.properties Home command is set to 'home' (Called as '/home' In-Game), The node will be 'mh.home', Same goes for sethome & delete home. ('mh.sethome', 'mh.deletehome')

    v8 Preview:
    Source: (Outdated, Sorry)
    Version 0.8
        *Updated to #1000
        *Added homelist
        *Added homeinvite and homevisit
    Version 0.7
        *Updated to #740+
    Version 0.6
        *Updated to #617
    Version 0.52
        *Bug Fixes
        *Download link changed
    Version 0.51
        *Added /deletehome
    Version 0.5
        *Fixed up GroupManager Support
    Version 0.4
        *Switched to GroupManager
        *MultiWorld Support?
        *Forgot what 1 bug fix was...
    Version 0.3
        *Supported Permissions. (Works with or without, As with my testing)
        *Changed Console Text.
    Version 0.2
        *Fixed unhandled excpetion with text.
        *Fixed the 'Unknown Console Command' :p
        *Made /sethome & /home configurable
    Version 0.1
        * Initial Release
  2. Offline


    Good news, That works! it seems :D

    Now to add a bit more code for some parts, Mainly groups with their assigned home amount then Multiple Worlds!

    Thanks kazimir
    --- merged: Feb 28, 2011 4:36 PM ---
    There, version 0.4 is updated, Hopefully the multi world side works (As i didn't get to test it), But theoretically it should work (aka in my head it works ;D); As it seems to work :p.
  3. Offline


    Is it possible to run this with MultiVerse and Permissions 2.1, and to have it so players have access to /home in my normal world, but do not have access to /home in the Nether world?

    If so, I'm switching from Simple Home to this plugin today.

    Wait - I just saw the message: "Switched to GroupManager" - Please tell me you didn't stop supporting Permissions?
  4. Offline


    GroupManager supports Permissions ;) (I beleive)

    I'll maybe add in a configurabe 'restrictworld'
  5. Offline


    Could you add support for the permissions plugin again? GroupManager breaks my server.

    Edit: Ok I know I posted this in the GroupManager thread but I'm posting it here two becuase I don't know which plugin is causing the error.

    I can't run GroupManager and MultipleHomes. If I do I get this error.

    2011-03-03 20:44:46 [SEVERE]  org.anjocaido.groupmanager.GroupManager.getData()Lorg/anjocaido/groupmanager/dataholder/DataHolder;  (Is it up to date?)
    java.lang.NoSuchMethodError: org.anjocaido.groupmanager.GroupManager.getData()Lorg/anjocaido/groupmanager/dataholder/DataHolder;
            at org.visualadmin.Groups.getGroups(Groups.java:42)
            at org.visualadmin.Groups.setupGroups(Groups.java:55)
            at org.visualadmin.MultipleHomes.onEnable(MultipleHomes.java:200)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:140)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:426)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:187)
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:79)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:60)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:187)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:174)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:120)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:227)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-03 20:44:46 [INFO] Done (3808772134ns)! For help, type "help" or "?"
  6. Offline


    Why would you remove Permissions support? It's not abandoned, it's being actively maintained by TheYeti and it's up to 2.5.1.
  7. Offline


    I removed it as i could not even get it to work in any way shape or form. Trust me. Nor can i remember saying it's abandoned,

    Well, if nessissary i will give it another go.
  8. Offline


    Alright so it turns out the problem is that MultipleHomes needs to be updated to work with the latest version of GroupManager.
  9. Offline


    When you install the mod it appears to overwrite the home locations that were previously saved. Is it possible to make it so it doesn't do this automatically? Maybe implement during the install it asks if you want to make a new one or use existing?
  10. Offline


    wheres download?
    --- merged: Mar 6, 2011 5:27 AM ---
    --- merged: Mar 6, 2011 5:27 AM ---
    fix'd for download
  11. Invisible


    How would go about setting up this plug-in with Permissions to dis-allow anyone but administrators to use /sethome and /home?
  12. Offline


    So is this plugin going to be updated or should I look for something else?
  13. Offline


    Thar, I beleive that one should work.
  14. Offline


    Thanks for your work, but can we delete a home ? For example, i do /sethome2, but i want to leave this home, can i delete this sethome ?
  15. Offline


    Okay, i just uploaded a version with /deletehome [number], Thanks ;)
  16. Hello, a complete utter, should be simple, request right here.

    Any way for you to add it so that we can define [admins] the amount of HOMES a specific player can set?
  17. Offline


    Suggestion for feature:

    Will it be possible to set names for my homes instead of numbers? In combination with a feature to list my homes it will be mutch more user-friendly to manage and remember al my homes... ?!?
  18. Offline


    For that to happen, i beleive that it would take me to restructure the way the files arew saved, as they are based upon the Max allowed. Which just gave me an idea....hmm

    At the moment i think it's only Groups, I'll have a look into singe users.
  19. Offline


    I tried the latest version of MultipleHomes. It no longer throws an error code and it no longer breaks anything. However now it no longer works period.

    I type /sethome 2

    Server responds saying home 2 was set

    I type /home 2

    Server responds saying home 2 has not been set.

  20. Offline


    For some reason limiting groups isn't working for me. I'm using GroupManager and I set Default to be able to set 1 home, and they're able to set more than that.
  21. Offline


    Does it work with permission 2.5.3 ? thanks for the delet command.
    Ok, it work but all players can use it and i want that one group can only use a /sethome, an other 5 ... It's possible with permission ?
  22. Offline


    Any chance I could get the source of this? I'd quite like to add named homes.
  23. Offline


    Have you enabled GroupManager in Mh's config?

    My plugin uses GroupManager.

    Is there any errors in the console? Seems like it didnt get to write the file/text.

    I'll get around to cleaning it one day, But I may be adding that shortly.
  24. Offline


  25. Offline


    No errors at all.
  26. Offline


    This plugins works great. I did have some console errors caused by a user typo. Thought you might want to know.
    2011-03-15 10:18:59 [SEVERE] java.lang.NumberFormatException: For input string: "2w"
    2011-03-15 10:18:59 [SEVERE]     at java.lang.NumberFormatException.forInputString(Unknown Source)
    2011-03-15 10:18:59 [SEVERE]     at java.lang.Integer.parseInt(Unknown Source)
    2011-03-15 10:18:59 [SEVERE]     at java.lang.Integer.valueOf(Unknown Source)
    2011-03-15 10:18:59 [SEVERE]     at org.visualadmin.Processor.ProcessCommand(Processor.java:88)
    2011-03-15 10:18:59 [SEVERE]     at org.visualadmin.MultipleHomesPlayerListener.onPlayerCommandPreprocess(MultipleHomesPlayerListener.java:23)
    2011-03-15 10:18:59 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader$5.execute(JavaPluginLoader.java:182)
    2011-03-15 10:18:59 [SEVERE]     at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    2011-03-15 10:18:59 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:255)
    2011-03-15 10:18:59 [SEVERE]     at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:637)
    2011-03-15 10:18:59 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:608)
    2011-03-15 10:18:59 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:602)
    2011-03-15 10:18:59 [SEVERE]     at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-03-15 10:18:59 [SEVERE]     at net.minecraft.server.NetworkManager.a(SourceFile:230)
    2011-03-15 10:18:59 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:76)
    2011-03-15 10:18:59 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-03-15 10:18:59 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    2011-03-15 10:18:59 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    2011-03-15 10:18:59 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-15 10:18:59 [INFO] *censored* tried command: loc 2w
    /loc is what I have the command set to since I use another program that uses /home

  27. Offline


    - Having same exact problem as Deltaforce229.
    - No Errors thrown.
    - Home txt files ARE being written
    - Appears to be correct coordinates in txt file
    - added mh.home and mh.sethome to permissions, still uses map default spawn point for home
    - tried changing config file to homecommand=gohome as to avoid conflict with anything else and still comes up with "home (2) not set!"
  28. Offline


    I actually came across the error i beleive, Ill upload a fix shortly (Thats if it's the same one lul, But i expect it to be)
  29. Offline


    I found a bug. I'm not sure if its in your plugin or another plugin conflicting. Users are able to set multiple homes by using letters instead of numbers. However, it says "Home set." in grey text rather than the default text, in red. It sounds like another plugin is conflicting, but yours is the only home plugin I'm giving regular users permission for.
  30. Offline


    Mine is Numbers only, and will try to convert a String to Integer. So if the input contains text, it will use the Integer based upon that text which may not even work.
  31. Offline


    I just tested it out. It is an issue with your plugin, and not a conflict with another plugin. Let me explain what happens. The default group is only allowed to set 1 home, however, they can set a max of two using letters.

    /sethome 1
    /sethome h

    Home 1 will go to the first location and home h will go to the 2nd location, even though the group is limited to 1 home.

Share This Page