[INACTIVE][TP/FUN] NetherGate v0.56 - Just Like Single Player! [803]

Discussion in 'Inactive/Unsupported Plugins' started by NathanWolf, Feb 4, 2011.

  1. Offline


    NetherGate - A plugin that uses multi-world to create a completely automatic Nether experience.

    If you're using Essnetials, go no further.

    Essentials breaks NetherGate in strange and frustrating ways, I'm not going to support it anymore. I'll try and get this resolved by NG beta, at which point I'll remove this message.


    To use NetherGate, drop the required jars in your plugins folder.

    Then you can create and light a portal to travel to the nether!

    Grab elBukkit.zip to get all of my plugins- take out the ones you don't want.

    For more details on NetherGate, or for individual jar downloads, see the NetherGate entry on bukkit's wiki.

    Tip Jar
    If you really love my stuff, and you're feeling generous, I'd more than appreciate a donation.

    Go here if you're interested!

    View changelog on github
  2. Offline


    Heh- that's a shame! That's for trying.

    So, does Essentials have portals? I have no idea why it would be blocking my portals, it doesn't actually use the portals, or does it? Is that Raph's plugin? Maybe I should talk to him :)
    Uh, yeah, I'm certainly not porting my plugins to an entirely different language, thanks! :p

    And if you called it Minecraft 2, you'd get sued. Minecraft 2 will probably be a thing (with or without that name), probably have a mod API built-in, and will definitely be Java.

    So.... yeah, I don't see much future in your MC Server, sorry :(

    Frankly, it is really close. If I hadn't been struggling with permissions (and other, external, personal/professional factors) I really think I'd be ready to call this 1.0 by now.

    Here's a quick list of what's left, off the top of my head:
    • Fix internal permissions, have portal use be OK by default.
    • Schedule player TP with bukkitsched, I'm hoping this will get rid of the "moved wrongly" problem!
    • Improved "find portal location" algorithm- will now look around the target area (as appropriate given fast-travel scales)
    • Better logic for identifying existing portal structures
    • Clean up the portal pairing a bit, though it seems to actually work quite well
    • Modify the portal detection code so that it better "sees" a paired portal
    • Turn fast travel back on, test, probably fix the scaling algorithm again, maybe not?
    Hmm... I think that's about it!

    It does all seem to work really well right now, minus "moved wrongly" and fast travel. If I could get the above working, I'd probably call this 1.0. I'd then go back to work on Spells, mainly, but will have the following additional features in mind:

    • More console commands, including the ability to name and re-target portals by pointing at them
    • Console commands to delete worlds?
    • More permissions, including per-portal permissions (for named portals)
    • .... probably lots of other stuff
    • Portal areas
    Glad you're still enjoying it- it's been a bit of a rocky road lately :)[MERGETIME="1299684630"][/MERGETIME]
    Hi, Throk, I'm whitelisted- you should be able to PM me now.
    Little of both?

    I'm not sure that the bukkit team would consider it a "bug", per se (though I think I would!). I'm hoping to have a work-around in place for 0.53.

    It's pretty useable otherwise, though, IMO- this does not happen every time, certainly.
    Yes, in fact it requires Permissions and PermissionsSupport right now- download PermissionsSupport from the OP.
  3. Offline


    I just added this plugin, I don't use permissions or groups or anything, I'm OP.. but none of the commands are working in game, just in console.. why is that? Also, I managed to create and link the world and nether through the console, but going into the portal I have doesn't do anything. I'm running craftbukkit 493
  4. Offline


    I'm hoping to release a version soon with internal permissions- for now Permissions is required to use portals.
  5. Offline

    Aidan Moseley

    I tried using this but when i use the portal for the first time no portal is made on the otherside and sometimes end up in lava
  6. Offline


    v0.53 Released

    If you're not using Permissions, you should get this version. Update NetherGate.jar and Persistence.jar. More on permissions below.

    I also re-arranged all of the commands. Most notably, all the "world" commands are under "/nether world", and you need "go" to go anywhere. Also, the world type parameter is now required for "/nether world create"- basically, check the help or the OP to see how the new commands look.

    NetherGate now supports an internal permissions system. Most importantly, this re-enables players' ability to use portals by default.

    Other permissions can be set up (without Permissions.jar or PermissionsSupport.jar) by creating a permissions.yml file in "plugins/Persistence". This is not necessary unless you want to be able to use the admin commands, etc- and you're not already using Permissions.

    Here is an example:
    # Defines the "default" profile
    # All players have this profile by default
              go: true
    # Defines the "admin" profile
    # These players can use "/su" to access any command
          su: true
    The "default" profile will be given out to all players. In this case, I've given them the "/nether world go" command- probably not a good idea, in practice.

    The "admin" profile can be assigned using "/grant player PlayerNamer admin". You can set up as many profiles as you want, and assign as many as you want to players and groups.
  7. Offline


    I need help with this. Ive followed the "instructions" as best I can. my plugins folder has

    [minecartmania] [Persistence] and the jar files minecartmaniaautocart, minecartmaniacore, nethergate, persistence.

    I have tried this using a prexisting and creating a whole new world and it doesnt work. When I start the preexisting world bukkit loads all the plugins and then creates a nether spawn area. When creating a new world (deleting the [world] folder) it creates the new world spawn area then creates the nether spawn area.

    When I create a netherportal as per the rules of single player it creates a portal. When I step into the portal....nothing happens. No effect, no error, nothing. Console commands do nothing, they report no error and have no effect at all. Its as though nethergate does absolutly nothing or is not installed even though bukkit clearly created the nether world when I started the server.

    I cannot find any tutorial on how to use nethergate anywhere. This seems extremely complex to run since the console commands dont work and I cant get the plugin to do anything and I cannot find any information on how to install and setup nethergate. Please help.
  8. Offline


    Please update to latest of both Persistence and NetherGate, if you have not (and you ignored the post directly above yours).

    Older versions require Permissions and PermissionsSupport.jar.

    Other than this recent permissions SNAFU, NetherGate requires no setup, which is why the "instructions" are so "light" (no need to be so obnoxious when asking for help, by the way...)
  9. Offline


    I added in the Persistence folder the permissions.yml, using the example you gave,
    # Defines the "default" profile
    # All players have this profile by default
              go: true
    # Defines the "admin" profile
    # These players can use "/su" to access any command
          su: true
    and when I say in console 'grant player playername admin' it's saying Permission profile admin is unknown

    Still running craftbukkit 493, and using the updated plugins.. It also gave me a no permissions defined for nethergate.commands.nether.world.go
  10. Offline


    Hrm... ok, so I couple of things. I just started up with all the recent stuff, and here is what I get:


    You should get the "2 profiles loaded" message on first player login, like you see in there- and hopefully no errors.

    However, I noticed that NG was still reporting 0.43. I also noticed that when I did "/phelp" in-game (as an Admin), I got the following list:

    /nether spawn clean
    /nether world go
    /nether spawn go
    This is almost right- but I didn't give myself "/nether spawn clean" - turns out that was available by default. Whoops!

    Also, I should have "/nether home go" and "/nether home set" by default, too- turns out those were broken.

    So, I fixed all that up, fixed the version number, and re-uploaded 0.43.

    Please re-download (sorry!) and try it again- it should now report 0.43 in the console, and so far is working for me, at least for NetherGate (Spells is not yet converted over...)
  11. Offline


    Ok, I downloaded the plugins again, it still said .52 instead of .53, I looked through your site and found NetherGate - .53.jar so I used that and that showed the updated number

    This is my server output when I logged in, along with my permissions file

    Ususally I get the error I described above, 'no permissions defined for nethergate.commands.nether.world.go'
    but not this time..

    Thanks for being so fast with your replies!
  12. Offline



    Updated to latest version of Nethergate 0.53 and Persistence 0.59

    Still getting:
    13:22:28 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-493-
    g8b5496e-b493jnks (MC: 1.3)
    13:22:28 [INFO] Preparing level "survive"
    13:22:28 [INFO] Preparing start region
    13:22:29 [INFO] Preparing spawn area: 81%
    13:22:29 [SEVERE] Could not load plugins\NetherGate.jar in plugins: null
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NoClassDefFoundError: com/elmakers/mine/bukkit/persistence/
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Unknown Source)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
            ... 8 more
    Caused by: java.lang.ClassNotFoundException: com.elmakers.mine.bukkit.persistenc
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            ... 11 more
    13:22:29 [INFO] [Permissions] version [2.5.4] (Phoenix) was Initialized.
    13:22:29 [SEVERE] Could not load plugins\Persistence.jar in plugins: null
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.util.zip.ZipException: error in opening zip file
            at java.util.zip.ZipFile.open(Native Method)
            at java.util.zip.ZipFile.<init>(Unknown Source)
            at java.util.jar.JarFile.<init>(Unknown Source)
            at java.util.jar.JarFile.<init>(Unknown Source)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
            ... 8 more
    It's worse than before :(

    Do I need to just delete all the persist files and nether world stuff?

    I just removed my Persist folder, and re-ran it... now it works.

    I guess I have to start my Nether world over again. Oh well, the price we pay for cool shit.

    OK so, I managed to get my old world file merged with the newly created one...

    but the gates do not seem to teleport me at all, and commands only work from the server command line... if I try any commands in game I get nothing. I will now add to permissions and see if that works -_-

    Sorry for so many posts, but I added permissions support and commands now work.

    The gate still does not work when you walk in it though, and if you use the command /nether world go "nether" it ports me to some other obscure location I have never been to.... it is "near" my buildings etc in the nether, but in a vastly different location (height/elevation wise) than where the portal would normally lead (I used the command while standing right next to the portal we usually walk through).

    I noticed there is a realign command, but I'm not entirely sure how to use it.

    I feel so stupid right about now :/

  13. Offline


    That just looks like a borked Persistence.jar - does this happen to you every time you download it?

    It should not be a zip file, I'm not sure why it think it is.
    Hm- interesting error! That would be my first ever "client error" from the "internal permissions" system, so that's fun I guess. ;)

    It also means I have to stop telling people to go pound sand with their Permissions issues- I'll definitely help out with the built-in permissions until bukkit permissions are here.

    Can you pastebin your permissions.yml? There must be something wrong with it, but I can't think of what- maybe tabs vs spaces or some other such nonsense?

    No problem on the fast replies- I try to be around when I'm available, and things have been particularly unstable lately, and with the whole new permissions system, I definitely want to be here to help.
  14. Offline



    Yes it ended up being a persist file error.... after removing the persist directory it stopped throwing up that error (which has been happening since I updated to CB493 and Nethergate 0.52).

    As my post explained though, it now works but my world "alignment" is broken and I'm not sure how to fix it. I have made a workaround for now by using MCedit make a pathway from the "new" gate area to the old one.

    Are gates meant to not work when you walk in them at the moment?

    Commands work fine, but walking into a gate does not teleport me (or any other member) to the Nether world.

    Having to use "/nether world go" which yields weird results in destinations... is the world scale set to 1 by default or is it set to 8 now?

  15. Offline


    Ah, I see your issue now!

    Right, you must have set up your portal network when I was "sort of" fast-travelling. This should fix you up, I hope:

    /nether world scale world 1
    /nether world scale nether 1
    Oh, BTW- I watch this thread, which seems to be at least reliable as tagging me, in terms of alerts- so the tag is unnecessary :)
  16. Offline


    OK thanks I'll try that...

    but, are portals meant to work when you walk in them or are we meant to be using only commands at the moment for some reason?

    Thanks again mate for the replies and help.

  17. Offline


    Portals are always meant to work- the only time they weren't working (as far as I know) was while internal permissions was broken- in that case, the plugin was essentially useless without Permissions.jar. But that's all fixed now.

    All of the console commands are optional, they can be completely ignored. I'm only telling you to use the above commands because I thought you wanted to try to align your worlds up over spawn.

    The mapping is going to change for fast travel (1:8) anyway, so you really shouldn't get attached to your portal locations until after NG 1.0.
  18. Offline


    Sure thing.

    I guess I still have a problem of sorts then since walking into a portal doesn't work. I ahve to command it to portal.

    Also, after setting scale to 1, it's still doing some weird stuff... I think I know what I did there though, I may just delete the persistence files once more and try again.

    But yes, portals are not working when I walk in them.

    I am not using the internal permissions, I am using the permissionsupport.jar and using permissions 2.5.4

    Am I still missing something else? I am known to be completely retarded at times. 142IQ and I fail :/

  19. Offline


    Nothing happens.
    For me it just says going to world nether when I type the command.
    Portals do nothing. All other commands work fine.
    Have the dependencies installed.
  20. Offline


    Heh :) Hrm- well, I *think* if you're using Permissions, it should still fall back to the internal defaults if you haven't given yourself permission to portal (meaning you'll really have to deny NetherGate.portal.use rights.....)

    I haven't tried this setup, though. Do you have permission for "NetherGate.portal.use" defined in your permissions file (for all worlds)?
    Does a "nether" world folder get created? Are you using Essentials?
  21. Offline


    Yes I have permissions set to '*' for my usergroup, plus I am an op, etc.

    There is no reason it should be denying me that I can think of... As I said I can use commands to change worlds, just not actual portals. I also tried using the permissions.yml file (internal permissions) to no avail. Again I can use commands but portals themselves do not perform as expected. It's rather bizarre.

  22. Offline

    Tim Yong

    Here's a question of pure ignorance ... (haha) ...

    Is there a way to have a Netherworld underneath the bedrock of an SMP map? I would love to create holes in the bedrock leading to essentially Hell. [​IMG]
  23. Offline


    Op is meaningless at this point- that functionality will probably be phased out completely with bukkit permissions.

    Can you use the "/su" command?

    Portalling is permissions-driven, just like everything else, so it's really not that strange. If a "/nether world go" (without a world parameter) works, then portalling from that world should work just the same, provided you have permission to use portals.

    Hm, well- not exactly :)

    The hacky way to set this up would be to replace your bedrock with portal blocks- so when you "fall through", it tp's you to the nether.

    Alternately, it would not be hard for me to set up tp "rules" other than "walked through a portal" - so, as a for instance, you could define a rule that maps (y < 10) from one world to that same (x,z) location (using the find algorithm for y) in another world.

    That would be an advanced post-1.0 feature, though...
  24. Offline


    Persistence creates a database called nether.db

    Dont see any folders created out side of that.

    I am using essentials plugin.
  25. Offline


    The essentials plugin breaks nethergate, from what I understand. Sorry. :(
  26. Offline


    My permission's file was actually included in my previous pastebin at the bottom after the server error, but here's another link the just my permissions.yml http://pastebin.com/NGfR8MuK

    I'm probably doing something completely wrong, I'm not sure how players get added to permissions.yml or what it means if I have a line like "clean: true" and another "spawn:" I don't know if order matters.. a slightly better tutorial might be helpful?

    Also curious as to the consequences deleting the nether.db or global.db.. can updates break the databases? and what kind of info gets lost if they have to be remade?
  27. Offline


    Thanks! Sorry I missed this the first time. It looks like you've got some YML formatting issues- they're not supposed to be aligned to the colons like that. Each "child" in the hierarchy (hope that makes sense) should just be two spaces out from its parent. It's just like YML for Permissions, more or less...

    Yeah, I know- I link to the leaky article, which is the only "official" documentation for this right now... but better docs are definitely needed :(

    That is an excellent question. If you delete global.db, you should probably also delete nether.db (may not be required). Here is, more or less, what you'll lose:

    • Registered worlds
    • Registered players (any players that have ever visited you are tracked)
    • Players' home locations
    • World scales, centers, targets
    • Your portal network (which doesn't really work right now, that well, anyway)
    • Portal areas, if that was working....
    I think that's about it- it's not really a big deal to delete your data for NetherGate, given the minimal setup required- but some of my other plugins, like CrowdControl (and eventually Spells) are going to have a lot more "essential" data in there...
  28. Offline


    Hey NathanWolf, I like your mods alot, and now I'm curious about adding THE netherworld to my smp server, but I'm a bit confused... Is your netherworld the very same netherworld as in ssp, or is it a close copy? Why exactly don't the regular nether portals from ssp work in smp?

    I just want to create a ssp environment together with my friends, and we're really missing the netherworld. We don't want any of the other fancy stuff, such as fast travel, multiworlds etc. Just the one and only authentic & true, boring-as-it-may-be nether.
    I'm not asking for anything other than knowledge, if you have the time to answer my questions, and maybe point me in the right direction. :)
  29. Offline


    Hi! Thanks for your interest!

    So, basically, mcserver does not (yet) support the nether. I'm assuming it was/is the plan to at some point, but we all know how many releases of SMP have gone by since the Halloween update without any hint of a nether.

    What does work in SMP are the portals- if you build and light a portal, it gets filled with portal blocks just like in SSP- and if you break the frame, the portal breaks, etc. But that's pretty much it- the portals don't really do anything.

    So, NetherGate is a plugin that attempts to fill this gap. I'm using Bukkit's multi-world feature, so you're not limited to a single normal/nether world setup, though that is the default drop-in behavior of the plugin, if you ignore all the console commands.

    As for "how close" it is- I had a detailed post about this above, I should move it to a FAQ (want to add that soon). Basically, it's the same world data, and my ultimate goal (this will be NG 1.0) is to have the portal network "close enough" to carry over back and forth (I have an old SSP nether hub map and corresponding normal world that I will use to test this, when it's ready).

    For right now, you shouldn't get attached to your portal locations, they will move- which is also (one of many reasons) why I'm not auto-creating portals on the other side yet.

    Hope that helps!
  30. Offline


    I uninstalled essentials.

    When I type /nether world go
    It just lists all the catagories inside /nether world in the chat.
    The /su command says its working too.

    I am able to resize a world though.
  31. Offline


    Hrm- that seems very odd! It should auto-create the nether world on first use, and take you there. Do portals work, without essentials installed?

Share This Page