[INACTIVE][TP] Blue Telepads (v0.5.3) - Commandless (and multi-world!) Teleporation [766]

Discussion in 'Inactive/Unsupported Plugins' started by Ne0nx3r0, Apr 18, 2011.

  1. Offline


    Development on this plugin has stopped.

    Blue Telepads - Simple multi-world aware commandless two way teleportation pads [733]:
    Version: v0.5.3

    Setup teleportation pads using a blue lapis block, four double slabs, a sign, and a pressure plate (per pad). Connect them by clicking on each pressure plate with redstone for commandless teleportation.

    Video Tutorial

    • You should click on the pressure plates with redstone to link telepads, not on the signs (since ~v0.3)
    • You can specify the materials for the telepad by editing the "telepad_center" and "telepad_surrounding" config options and specifying an id for those blocks (you can use 0 for anything) <- delete config.yml or just append the options to get them
    • For an unlimited distance, specify 0 as the max distance
    Permissions nodes (if enabled, not by default):


    Download | Source Code

    Usage (open)

    Step 1 - Setup two telepads; fourth line of each sign should be the name for that telepad. (Note, the direction of the sign determines which way players will land when they teleport to that telepad!)
    Step 2 - While holding redstone, click one telepad's pressure plate, then click the other one.
    Step 3 - When you step on one Telepad, you will be sent to the other!

    (Right click on a telepad sign to remove your stored location)

    Version 0.5.3
    • Sign now determines the direction you end up facing
    Changelog: (open)

    Version 0.5.3
    • Sign now determines the direction you end up facing
    Version 0.5.2
    • Added disable_teleport_message flag
    Version 0.5.1
    • Player now lands on the receiving telepad instead of in front of it, and is facing the direction he is when he leaves
    Version 0.5
    • Player now lands on the receiving telepad instead of in front of it, and is facing the direction he is when he leaves
    Version 0.5

    • Added "telepad_center" and "telepad_surrounding" config options, so users can specify the id of the block to be used. 0 = anything
    Version 0.4.1

    • Added 'disable_teleport_wait' true/false option in config.yml; this will disable the 'preparing to send you to' wait time when you step on the telepad.
    Version 0.4

    • Bug fixes here and there
    • Fixed issue with long range telepads not linking
    • You can now reset a telepad for re-linking by breaking the pressure plate on top of it, then clicking on the lapis block with redstone. Then you can relink it!
    Version 0.3.2

    • Fixed a few NPE, also added right clicking on telepads removes the stored location
    Version 0.3.1

    • Changed name line on telepad signs to the 4th line
    Version 0.3

    • Removed water effect, still working multi-world functionality, changed storage method for signs (for multiworld primarily), added permissions/op only support, added max_distance, added config file.
    Version 0.2

    • Added timeout between ports, switched to sync instead of async events
    Version 0.1

    • Initial update

    Do you like this plugin? Click like so I know! ; )
    conrod456, Joriom, Dezarith and 13 others like this.
  2. Offline


    i am using 819, but when i teleport, i end up glitching on top of the other plate. i have the sign underground, and the lapus, slabs, and plate on level with the ground.
  3. Offline


    i have the same issue. random teleport arivals in 818 and glitchy landings in 819.

    other than that though, my new favorite plugin.
  4. Offline

    IX TheDelta XI

    Hey, I really need help. On my server I have multiverse and TelePads, I'm using TelePads to teleport between worlds, it worked fine in 1.5_01 however when I upgraded craftbukkit and my game to 1.6.6 the TelePads, instead of teleporting to eachother, teleported me to the spawnpoint of that world. The telepads that transfer in one world work fine but the spawnpoints in the other worlds are way away for the building and stuff, PLEASE HELP ME! If it helps heres my IP:
  5. Offline


    Hello~ It's a great plugin, we are going to use and keep it on our server instead of /warp system +)
    Please tell me, is this plugin still being updated?
  6. First up: Great idea and, when it worked, it was exactly what I was looking for.

    Secondly: I have a Server with Multiplay and wanted to create a 'hub' system (think Ministry Of Magic fireplaces) in place of the minecart stations I will now have to take down (thanks Notch for a great game... and then removing half the greatness! lol).
    Basic problem; the telepads stop working after a few times and DO NOT work again.
    I've tried taking them down and rebuilding them a few times and this seems to do nothing. I may even be compounding the problem! lol
    Restarting the server does not correct the problem either.
    I have set the distance to 0 as the hub is a long way from anything else so players don't 'stumble upon it' while mining and set the tele-block to obsidian (49) with nothing (0) around it. Are the half blocks really needed??
    Server version: git-Bukkit-0.0.0-766-g3fc0460-b818jnks (818 I'm thinking) Stable-ish for 1.6.6
    Other plugins: Lockette (1.3.8) TimeAnnounce (1.1) DeathTPPlus (1.85) Remote Bukkit (0.1) and obviously BlueTelepads (0.5)

    I am totally willing to help with testing as my server isn't heavily used but would really benefit from this mod working fully.

    P.M me if you want more info or anything. I'll be glad to have this operational.
  7. Offline


    Hi! I'm running a craftbukkit server( I have no clue what release the tutorial I followed just sent me to a link) and I love your plug in but it only works one way......

    I stand on pad 1 and it teleports me to pad 2

    I wait for it to cool down and step on pad 2 to be sent back to pad 1 and it doesn't work. I've tried remaking it but that hasn't helped. Can you assist?
  8. Offline


    hopefully this gets updated soon.
  9. Offline


    Oops, bug report: BlueTelepads bugs my door pressure plates. These are pressure plates sitting on smooth stone sitting on a redstone wire. With BlueTelepads enabled the pressure plates don't activate anymore, so there is no redstone current and my iron doors don't open or close automatically.
  10. Offline


    @ne0nx3r0 it would seen ur perm is broken on the "use" part cb#900 <--- :) 2.7
  11. Offline


    Hi I'm running Craftbukkit build 860 with the follwing mods installed:

    The plug in will work one way sometimes, or sometimes not at all. Can you please help?
  12. Offline


    I tested the plugin on craftbukkit version 860. I think you should update the title. Awesome plugin.
  13. Plugin Now broken on version 926, But that was to be expected i suppose because of the playerevent update.
  14. Offline


    Still works for me. Perfectly
  15. Offline


    Work in 935?
  16. Offline


    Still working for me on 953
  17. Offline


    dam this has stoped WHY!!! its so easey to use
  18. Offline


    my server needs Version 0.3.2, it will not work on 0.5.3....please please. i cant go and change 25 on my server because of the update, i dont even know where they are.


Share This Page