[INACTIVE][SEC] Friendlies v1.2.1: A Permissions-based monster whitelist. [766]

Discussion in 'Inactive/Unsupported Plugins' started by fullwall, Feb 19, 2011.

  1. Offline



    Download the latest: v1.2.1(Requires Permissions)
    Older Versions: v1.2, v1.1, v1.0

    Creepers bugging your server? Skeletons killed you and spiders spawn gank you? Fear the night no more with Friendlies, the monster whitelist. Simply add the desired permission node to the groups you want protected, and the monster will never bother you again. Simple and easy to set up, Friendlies is perfect for those who want the added ambience of monsters without the bother of dying from them.

    • Drag and drop setup - simply edit permissions nodes to use.
    • Stops mobs from attacking you.
    • Multi-world support - now with added customisability.
    • Mobs can attack back if you hit them (must set permissions nodes).

    Permissions nodes are simple and easy to set up.
    Simply use friendlies.[mobtype].ignore to stop monsters from attacking a particular group.
    Use friendlies.[mobtype].ignoreattacks to stop monsters from attacking back once you hit them.
    Use friendlies.[mobtype].* to do both at once!
    Mobtype is the lower case name of the mob you want to stop killing you.
    Multiworld support is like so: place a variable under the info node in your permissions config.yml.
    Simply put the name of each of the worlds you want Friendlies settings to apply to in the variable.
    If a world isn't included, Friendlies settings won't do anything in that world. If you can't be
    bothered putting the variable in, then Friendlies settings will affect all worlds.
    To do per-world friendlies settings - simply use another permissions variable.
    The variable name should be friendlies-perworld-[worldname] - worldname is the world that you want
    to override permissions for.
    Look in the examples spoiler for an example usage.
    Example (open)

    build: true
    friendlies-worlds: world,otherworld,newworld
    friendlies-perworld-otherworld: friendlies.skeleton.ignore,friendlies.creeper.ignore
    friendlies-perworld-world: friendlies.*
    - 'friendlies.creeper.ignore'

    In this example, three worlds are defined for friendlies to apply to - world, otherworld, newworld. In this case, only newworld will use the permissions nodes. Otherworld's friendlies settings are being override, to add skeleton ignoring. Note that to include friendlies settings in the permissions section, you must retype them out.

    In world 'world', every monster will ignore everyone. If I created a new world called, 'aworld', friendlies would not apply unless I added it to friendlies-worlds.

    • v1.2 - added customised multiworld.
    • v1.1 - added multiworld, mobtype.ignoreattacks.
    • v1.0 - initial release.
    As always, post your thanks, suggestions or criticisms (preferably in that order :p).
    Robeya likes this.
  2. Offline


    Oh very nice!
    Will this stop creeper from blowing at you too? Or only normal mob damage?
  3. Offline


    It stops them from targeting you. It's like you don't exist :).
  4. Offline


    Well, if i have * in permissions, all of them ignore me?
    And can you make it like this - If i hit the zombie he will hit me back? Not just ignore me.
  5. Offline

    Don Redhorse

    hmm could you make it configureable differently for different worlds? at least when the world issues has setteled down?

    I would like to run a creative server and a survival world, I think in the future you can decide which world will have mobs and which not... but having mobs in the creative world too could be a nice thing.

    like I said... don't know if you can do that, but I think we also need to wait for the world issues to become fixed first.
  6. Offline


    If you put friendlies.* then yes, everything will ignore you. I could add in multiworld support via a permissions variable... I will try to do the hit back - I did try to do it before, but the monsters forget the target too easily.
    --- merged: Feb 20, 2011 11:32 AM ---
  7. Offline


    Haha, this is awesome! Now I can finally have friendly creepers to hug. :)
  8. Offline


    Hey, i'm getting a message saying it can't find the permissions plugin. I've got the newest version of the exact plugin you link to installed... Any ideas?
  9. Offline


    Can you post your server log?
  10. Offline


    Is it possible to do different mob behavior for different worlds?
  11. Offline


    True, guess I didn't think of that :/. I'll look it up tomorrow.
  12. Offline


    I have friendlies.spider.ignore but spiders still attack everyone.
  13. Offline


    Can you post your config.yml? I'll do some tests tonight.
  14. Offline


  15. Offline


    I'm having the same problem using 'friendlies.*.*' but I think this from the server log is part of the problem.
  16. Offline


    This is pretty good, you can make money out of this plugin, by giving acces to people, who hate those monsters
  17. Offline


    Try redownloading - both issues fixed (hopefully).
    --- merged: Feb 21, 2011 9:56 AM ---
  18. Offline


    Er, I'm not ready to upgrade bukkit until a LOT of plugins get fixed. Will this new version work with CB 357?
  19. Offline


    No. I'll do a special build for you though.
  20. Offline


    Wow! Thanks. :D
  21. Offline


  22. Offline


    Well, now creepers ignore me... but that's not what I configured. Zombies too.
  23. Offline


    Could be a bug with the latest update. I will try to fix tonight. Does 1.1/1.0 work?
    --- merged: Feb 21, 2011 1:40 PM ---
    Also, has your permissions config changed from the one provided before?
  24. Offline


    Tried with 1.0. All the monsters attack, including spiders. Same permissions.
  25. Offline


    I have tested your exact settings on the default world. Spiders don't attack me. Are you on another world name? That may be affecting my results.
  26. Offline


    I assume it's the default world name, "world".
  27. Offline


    Thanks! This was exactly what I was looking for. Everything works on build 405 except ghasts still attack when 'friendlies.ghast.ignore' is in the permissions for any player. Also when the player has a wild card '*' . The ghasts are in a different word but the zombie pig men do as they are told (will never attack with the ignoreattack permission). They definatly got the jump on me XD.
  28. Offline


    Okay, this is really bugging me. If I'm in the admin group on my server, which has permissions as '*', how would I go about disabling 'friendlies.*.*' for myself without having to go through and add permissions one by one, excluding that one?

    Also, for the group that I have 'friendlies.*.ignore' enabled monsters are behaving more like 'friendlies.*.ignoreattack' and I am using v.1.2
  29. Offline


    Those are issues with permissions itself, I believe.
    --- merged: Feb 22, 2011 2:27 PM ---
    I don't think I can stop ghasts since they aren't regarded as monsters :/
  30. Offline


    I'm using GroupManager in place of Permissions.

Share This Page