[INACTIVE][MECH] Quantum Circuits v0.8.3 - Remote control redstone via signs [740]

Discussion in 'Inactive/Unsupported Plugins' started by Ne0nx3r0, Apr 7, 2011.

  1. Offline


    This plugin has been replaced with
    Quantum Connectors


    Quantum Circuits v0.8.3 [733][INACTIVE]

    Simplify redstone designs by remotely controlling your levers with a sign.

    *0.7 - Added "qon" and "qoff" circuits (whenever they receive power, they always turn the receiver on/off respectively)
    *0.6 - Added "qlag/a/b" toggle
    *0.4 - Added quantum toggles, the same usage as quantum circuits, but the first line needs to read "qtoggle", every time it receives power after not having power it will toggle the lever. Great for toggles and memory cells!

    Source Code

    Show Spoiler

    Step 1 - place a lever where you want to remote control
    Step 2 - Holding some redstone click on the lever
    Step 3 - Place a sign with the first line labeled either quantum/qtoggle
    Step 4 - Click on the sign with some redstone to transfer the coordinates
    Step 5 - Whenever the redstone near the sign receives power, your lever will too!

    qlag Usage:
    Show Spoiler

    Same as other toggles, except format is: qlag/a/b, where a = on lag time in seconds, and b = off lag time in seconds

    So, qlag/2/10

    Would create a circuit that turns on two seconds after the sender receives power, and turns off 10 seconds after it loses power.

    Show Spoiler

    Version 0.8.3
    • Bug fix for signs with less than 4 characters
    Version 0.8.2
    • Minor tweaks, [possible] bug fix
    Version 0.8.1
    • Bug fix with 'qon', etc toggling when a circuit is already on
    Version 0.8
    • Mainly tweaks, bug fixes, different flow though.
    Version 0.7
    • Added qon, qoff circuits
    Version 0.6
    • Added qlag circuit
    Version 0.5.1
    • Fixed bug with empty hand throwing a null error
    Version 0.5
    • Added transferring coordinates with redstone
    Version 0.4
    • Added quantum toggles
    Version 0.3
    • Fixed bug with negative XYZ cords
    Version 0.2
    • Added support for signs underneath redstone

    Do you like this plugin? Click like so I know! ; )
  2. Offline


    I get that with the elevator mod aswell, its a shame coz i love both. I use elevator most so had to stop using Quantum.
    I had a control room all setup, like a prison tower controlling all gates and bridges in my town and all lights......


    Thats the plugin, will get you the log when i get back online.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  3. Offline


    James, this is basically my future XD i have a castle and i wanted a control room in one of its basement levels with wireless transmission to every corner of the world XD

    2011-04-20 12:10:37 [SEVERE] Could not pass event REDSTONE_CHANGE to Quantum Circuits
    java.lang.ClassCastException: org.bukkit.craftbukkit.block.CraftBlockState cannot be cast to org.bukkit.block.Sign
    at Ne0nx3r0.QuantumCircuits.QuantumCircuitsBlockListener.onBlockRedstoneChange(QuantumCircuitsBlockListener.java:26)
    at org.bukkit.plugin.java.JavaPluginLoader$31.execute(JavaPluginLoader.java:386)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:257)
    at net.minecraft.server.BlockSign.a(BlockSign.java:118)
    at net.minecraft.server.World.k(World.java:375)
    at net.minecraft.server.World.h(World.java:351)
    at net.minecraft.server.BlockButton.a(BlockButton.java:150)
    at net.minecraft.server.BlockButton.b(BlockButton.java:122)
    at net.minecraft.server.ItemInWorldManager.a(ItemInWorldManager.java:75)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:397)
    at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)

    hope this helps you help us elevator enthusiasts and thanks for a great plugin

    Elevators v1.4.2 [RB #670] is the Elevator plugin i'm using, sorry
  4. Offline


    Thanks; nothing's jumping out at me yet; but maybe taking a look at the code in an editor tonight with some testing will explain it; it -should- be checking to see if it's a sign before trying to cast it that way.

    (in case anyone is feeling froggy before I get home to take a look:
    faces[i] == BlockFace.DOWN &&
    		   bBlock.getFace(faces[i],2).getType() == Material.SIGN_POST
    		|| bBlock.getFace(faces[i],2).getType() == Material.WALL_SIGN
    || bBlock.getFace(faces[i]).getType() == Material.SIGN_POST
    || bBlock.getFace(faces[i]).getType() == Material.WALL_SIGN)
                    if(faces[i] == BlockFace.DOWN){
                        QuantumActivate((Sign) bBlock.getFace(faces[i],2).getState(),event.getOldCurrent(),event.getNewCurrent());
                        QuantumActivate((Sign) bBlock.getFace(faces[i]).getState(),event.getOldCurrent(),event.getNewCurrent());//<- line 26
    I've tweaked how it handles the redstone conditionals a little - let me know if that works for you. I tried my best to make it error while using the elevator plugin, but I'm used to using craftbook elevators, so I'm not sure I did a terribly intensive job testing.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  5. Offline


    i'll have a quick go testing before i set up my elevator again and i'll let you know how i get on, thanks :)

    Edit: okay, tried to recreate the issue but havnt managed so it seems fixed (for me, for now, at least) thanks Neon
  6. Offline


    I pondered whether or not the minor changes I made would actually fix it, but I'm glad to hear at least for now they aren't creeping up. Let me know if you encounter any other problems.
  7. Offline


    I get this error every time redstone has power that passes a sign
    16:15:20 [SEVERE] Could not pass event REDSTONE_CHANGE to Quantum Circuits
    java.lang.ClassCastException: org.bukkit.craftbukkit.block.CraftBlockState canno
    t be cast to org.bukkit.block.Sign
            at Ne0nx3r0.QuantumCircuits.QuantumCircuitsBlockListener.onBlockRedstone
            at org.bukkit.plugin.java.JavaPluginLoader$31.execute(JavaPluginLoader.j
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at net.minecraft.server.BlockSign.doPhysics(BlockSign.java:119)
            at net.minecraft.server.World.k(World.java:383)
            at net.minecraft.server.World.applyPhysics(World.java:359)
            at net.minecraft.server.BlockRedstoneWire.g(BlockRedstoneWire.java:48)
            at net.minecraft.server.BlockRedstoneWire.doPhysics(BlockRedstoneWire.ja
            at net.minecraft.server.World.k(World.java:383)
            at net.minecraft.server.World.applyPhysics(World.java:359)
            at net.minecraft.server.World.update(World.java:331)
            at net.minecraft.server.World.setTypeIdAndData(World.java:315)
            at net.minecraft.server.BlockDiode.a(SourceFile:63)
            at net.minecraft.server.World.a(World.java:1681)
            at net.minecraft.server.World.doTick(World.java:1462)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:361)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  8. Offline


    Are you using the latest version? It seems to me that was an error (line 26, actually) that I was dealing with, but now line 26 is empty.
  9. Offline


    No, I'm on build 684. I plan on updating when there is a stable craftbukkit version out
  10. Offline


    I mean the plugin, are you using 0.8.2? If so, I'll take a look tonight
  11. Offline


    I hope this works with cb 733 because its one of my favorite and most useful plugins.
    Thank you so very much
    Keep up the fantastic work.
  12. Offline


    Thanks, I appreciate that. I semi-tested on 732 last night, but I was also testing my other plugin, and all the plugins I run on my server, so I didn't get too in depth. If anyone does spot any issues let me know and I'm sure they can be resolved.
  13. Offline


    Thanks again you've earned it.
  14. Offline


    Hi , I LOOOOOVE your plugin :D

    for contribute i report this error :
    GRAVE] Could not pass event PLAYER_INTERACT to Quantum Circuits
    java.lang.StringIndexOutOfBoundsException: String index out of range: 4
        at java.lang.String.substring(String.java:1934)
        at Ne0nx3r0.QuantumCircuits.QuantumCircuitsPlayerListener.onPlayerInteract(QuantumCircuitsPlayerListener.java:37)
        at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.java:254)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:257)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:162)
        at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:207)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:529)
        at net.minecraft.server.Packet15Place.a(SourceFile:57)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Its happen when i do a right clic whis redstone on a empty sign
    i have done a right clic whis redstone on a lever before.

    hope this help you for the futur dev ^^

    whis-out my stupid try the plug-in is PERFECT :D

    THX :D
  15. Offline


    @sinkir I've uploaded a new version, should fix this issue
  16. Offline


    Quantum location doesnt seem to transfer to the signs anymore for me. is anyone else experiencing this?

    Edit: Apologies, i was writing [Quantum] on the first line rather than just Quantum.

    Imaginary bug fixed XD
  17. Offline


    I suppose [quantum] would make more sense, heh.
  18. Offline


    I seem to be having two issues:
    • When the block underneath the sign is powered, the sign doesn't count as powered.
    • In the following configuration, the circuit seems to turn on fine, but not off:
       [w]  S
    T   w   w
    Where T is a redstone torch, w is wire, [w] is wire on top of a block (I was using glowstone), and S is the sign. Placing the torch turned the receiver on, but removing it didn't turn the receiver off. Removing the [w] block made it work great.
  19. Offline


    I have a small bug :

  20. This is a constant bugbear for me too. Whilst I don't run the server, I have many gizmos that I am trying to make work with minimal space requirements. Levers that are not activated manually, no longer behave like levers. Until the dev fixes, simply extend the circuit one block, and use a piece of redstone to do the trick, the lever will power the wires, just not anything else, tested with CraftBook signs, FalseBook signs, ICs in both, or the Soulsand/Lightstone features of FB.
  21. Offline


    I'll take a look at the stretching issues; I was originally trying to same some resources by skipping the obscure connected blocks (up north, etc). Also for me at least it works better this way since I can put circuits next to each other if they are one level lower. I'll see what I can do though.
  22. Offline


    I have an idea. Could you make this so it works with doors, too? Like be able to select iron doors and wood doors and have toggle toggle them and set set them? That would be amazing to be able to directly control the doors, and I think it is well within the scope of this plugin.

    Also, maybe add a config to let us change which adjacent blocks can trigger the sign? I sometimes find that it is triggered by too many adjacent blocks.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  23. please update it
  24. Offline


    please make a none ops only version. every one whos not op gets a do not have permissions msg not just for this but whenever they rite click anything with anything. and i dont even have the permissions plugin and it apeirs that this plugin dosnt have permissions. and all the config and plugin.yml file are is just little facts things with no options to change anything. even the class files are weird?. please make it for everyone and not just ops
  25. Offline


    This version is usable by everyone, no permissions, op or otherwise are implemented.
  26. Offline


    then why is it that ever one on my server gets the "you don't have permission to use this" msg and when i take it out they no longer are getting this msg. i love this plugin but there is a problem with it. please dont be one of though high headed jack*** who thinks that they never make mistakes and just look for any problem at all, fix it i'll test and tell you if the prob is gone or not. my server is pron to show all bugs in plugins when in other servers they have something i don't that somehow prevents this msg from constantly appearing any time anyone not op rite clicks anything with anything other then axe spade pickaxe and sword. and no i really dont have any other plugin that gives this msg for any reason. this wouldn't be much of a problem but it basically the same as this other plugin that allows you to "annoy: people by spamming them with the you cant do this and that for everything they do. and no i don't have that plugin either. and you can't tell me i installed it incerrectly because theres only one way to install it unless you got a plugin installer program that can fix this pug in which case just send me link to this plugin and i'll be ^^:):D:)^^. thank for your time.

    i cant spell rite to save my life:p

    wait no it dose it for axes spades pickaxes and swords to :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  27. Offline


    Please don't be one of those naive users who doesn't do any of their own troubleshooting and has such a high sense of entitlement they think because they use something that someone else made it is now that developers personal responsibility to fix any issue that happens on their server.

    I know my code, and even still I took the time to do your homework for you even though I suffer from migraines and I stayed home sick from work today because of it.

    Before I replied I reviewed the entire (albeit small) source code of this plugin to make sure I didn't implement something like what you were talking about (even though I was positive already it doesn't). I didn't feel at the time it was necessary to detail my investigation to you, but more appropriate to be succinct and answer your question. I am sorry if you didn't find my reply to your satisfaction, but your problems are not my fault.


    I tell you what, do me a favor: open each of these links one by one and hit ctrl+f, then look for the word "permission":

    Those files compose the complete source code for this plugin. You'll notice you don't find that word anywhere, because that message is not coming from this plugin.


    Now, that I have explained why your reply was not only unfettered and sophomoric, but largely offensive to plugin developers as a whole... You need to check your other plugins, and see which of them implements this sort of behavior.

    I'll state again and summarize for you: This problem you are having is being caused by something else.

    @iStormUK @sinkir You know I was playing with your bug, but I think it might just be a bug in Bukkit.

    I don't know any other way to activate levers other than what I'm doing.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  28. Hey, it's not a biggie. :) It is well-easy to work around anyway, and for the space saving this gives, one or two blocks of space used, for corrective purposes, is still X-2 less than it would've used

    EDIT: ANy chance this can be adapted to be a SinglePlayer commands plugin too? ;)
  29. Offline


    I am toying around with the idea of a quantum "connector", where the activating block (lever, plate, button, etc) is connected to the other lever via a connecting sign or something. This way you can completely move your redstone works away from your activator.
  30. Offline


    ne0n, I had this problem with permissions pop up right when I installed your plugin. At first, I thought it was yours, but then I did some investigating. It turns out that I had also installed the latest version of craftbook. I don't know if it's some interaction with the two, but craftbook gives the permissions error. After more investigating, I found out that this is in fact a but of CRAFTBOOK and that there is in fact a very simple solution. You need to somehow grant the permission craftbook.mech.cauldron to all users. This could be done with permissions or I heard of some plugin called fake permissions that provides and interface to the standard ops system.

    Anyway, the problem is probably craftbook. Can I have my directly controlled doors now?

    ne0n, I sent a pull request to your github with my attempt at door support, though I'm sure I messed something up in there. Here's hoping levers and buckets are about the same!

    P.S. Thanks for a great plugin. This is the first one I've liked so much that I want to help contribute something.

    Oh. Please ignore my current pull request. I have another version that actually works with iron doors. I just have to work out a few things and add support for wooden doors and trapdoors.

    I sent a new pull request for doors. It's fully bugfixed and tested, and supports iron doors, wood doors, and trapdoors! Enjoy!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  31. Offline


    Sounds pretty cool; I'll take a look at this later today

Share This Page