[INACTIVE][MECH] PistonPlugin v1.3 - Pistons powered by redstone [670]

Discussion in 'Inactive/Unsupported Plugins' started by BasBloem, Apr 10, 2011.

  1. Offline


    PistonPlugin - Pistons powered by redstone
    Version: v1.3

    I saw this plugin as a client sided mod on the minecraft forums, and I really liked it.
    So I decided to make a server sided one!

    Here is a video of me testing it!

    • Push blocks away from the controlblock using redstone!
    • Diamond pushes a maximum of 25 blocks
    • Iron pushes a maximum of 15 blocks
    • Gold pushes a maximum of 10 blocks
    • Config file to change the blocks
    • Obisidian now blocks the push(Bedrock will too, and inventory based objects such as furnaces and chests)


    Version 1.3
    • Added config file
    • Fixed the amount it can push to +1, because it was 9, 14, 24, heheh :D
    • Fixed a weird glitch
    • Disabled redstone from being pushed, because it could messup alot
    • Default blocks are still Gold, Iron, Diamond
    Version 1.2
    • Fixed the whole obsidian thing, heheh :D
    Version 1.1
    • Fixed the thing where it doesn't set the data(Such as wool color)
    • Added bedrock and obsidian to not move, and chest and furnaces, so they won't loose their content etc.
    Version 1.0
    • Initial release!
  2. Offline


    @Monkah , I would assume it's opposite of the redstone current. Try experimenting.
  3. Offline


    It's exactly that. In fact, for anyone wondering, the wire doesn't even have to flow directly into the iron block, meaning its very easy to wire up a long series of pistons in parallel.
  4. Offline


    This is incredible. Thank you for this.
  5. Offline


    can someone make video of it ? pleeease :D i really wanted to see it as a wall mover not, a single brick mover.
    it'll better describe my other question with ease D:
  6. Offline


    Thank you SOOO much for getting this working on Bukkit.

    However, I cant seem to pick up the block in SMP. The pistons work on SP but not on MP. I am able to craft it, but when I attempt to move it to my inventory, the piston block goes back into the crafting square.

    I have Bukkit installed with serveral other running plugins. And have stopped and restarted my server. The PP.jar file is in the plugins folder (and root), but nothing seems to allow me to pickup the block. Also, I read over the thread and it seems as tho it is not a craftable recipe (prolly why I am having my problem). However I watched the video and I may not be seeing where you say what the block value or ID is.

    Thank you again. I love the piston mod.
  7. Offline


    This is NOT the same as the piston mod. This is basically regular gold/iron/diamond blocks that "push" other blocks when given power
  8. Offline


    It works in theory but for some reason restone torches count as two pushes instead of one. Ex: The one with the redstone torch will activate when it's turned on and off, where the redstone wiring will only activate when it's turned on then because the top moved 2 vs 1 on the bottom it makes it uneven.
  9. Offline

    Steve Cole

    I got the moveable bookself to work
    i'm not going to make a video because i don't have the software and i don't want to take a bunch of pictures and post them
    but i have uploaded a worldedit schematic so that you can import it and play with it.

    picture of version one:

    its four blocks tall and the redstone wiring takes up a lot of space

    version 2 (a little more compact, keeps dust to one side)

    version 3 (5 blocks tall)

    you might be able to make one six tall without using a repeater/redstone torch
    but the switch would have to be close to the mechanics.
    the repeaters cause a little lag in the opening and closing of the wall
    so i didn't want to use them.
    you might make a cool effect delaying each row a little so only one row moves at a time kindof like a vault opening or something.
  10. Offline


    It uses the direction the redstone comes from.
    redstone->Piston->push direction

    I sure hope that Notch implements a 'directional input' like when placing diodes repeaters.
  11. Offline

    Steve Cole

    I do have one suggestion:
    make the push blocks only respond to power. meaning if you have a redtorch powering it the block only pushes when the torch goes from off to on, not off to on and on to off.
    this is why a redtorch seems to count for two pushes when you use a button or pressure plate.

    i wanted to make a switch so that i could toggle the wall open or closed.
  12. Offline


    The pig is making a great appearance in your video.

    And, I fell in love with these pistons. Thanks <3
  13. jij ben t nederlands!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! haha lol de eertste nederlander o bkkit
  14. Offline


    DonĀ“t need it, but it looks funny! :)

    [diamond][diamond][diamond], thats it :rolleyes:
  15. Offline


    Could you post the code or add the feature, to change the pushblocks? Otherwise this don't work with "ControllerBlock" and I can't use this.
  16. Offline


    Klets niet, het stikt hier van de Nederlanders :p. We vallen alleen niet zo op omdat we ons allemaal netjes aanpassen en Engels spreken.

    Sorry, Offtopic, but funny.
  17. Offline


    you CANT just steal his mod and make it worse
  18. Offline


    I will soon

    Well, I can, because I did. Wether you like it or not is your opinion ;)
  19. Offline


    I would love to use this but as said before it really needs a config file and upward movement.

    I had an idea for the upward movement by default in minecraft a torch can power a block from underneath like so.


    This function seems to be missing from the bukkit Ispowerd check. (for some stupid reason it is dust)
    How ever is you were to make the changes to bukkit or just code ur own snipet for this plugin you could make the upward direction work when a torch under the block is turned on :).

    Limits to the plugin is that it dose not toss the sand ect like the SSP but hey you cant have every thing can ya.
  20. Offline


    Config file is done, upward movement not, but I need to think of a nice way, because placing a redstone torch under it, could be annoying, but possible. It's easy to add ;)

    Updated to 1.3
  21. Offline


    it has a conflict with redstonechips :/ can u make the blocktypes changeable?
  22. Offline


    They are, as my last post says :)
  23. Offline

    Justin Deguire

    the redstones one above the other works but i find pressure plates need time to process (therfore stand longer) but buttons work fin however the bookcase's top shelf needs a diode for both sides (for sliding bookcase) and one side requires a diode on the secondmost top (this is for a four block high sliding bookcase

    the top block and second block down(after first push) dont want to move hence the diodes
  24. Offline

    Steve Cole

    i don't understand what your saying, i think you are saying that the rows dont move at the same time.
    take a look at my previous post. i created a few examples that can be up to 5 rows tall and all rows move at the same time.
    you don't even need to use repeaters if your switch/button is close enough to the mechanics.
  25. Offline


    you should make it so that when you right click a face of the block, thats the side it pushes, or maybe i dunno how to use it xD
  26. Offline

    Justin Deguire

    this is the initial position with four blocks high no diodes

    this is after activating the right side to push the bookcase

    this point is just showing that the second from the top does not move in unison with the rest this returns to the initial position shortly after

    my concern is that:
    A: the top does not move (tried with 3 blocks high as well)
    B: the second from the top is lagging behind in the movement

    *note i am not complaining as diodes fix the top from not moving but does not move in unison, also I could always build the bookcase taller to have the unison appearance however i would like to make this more compact (couldn't look at your compact design :'( i dont have a program to read schematics files, pictures work nicely though as i copied your design for the sliding bookcase[just used buttons instead of plates])

    edit: just tested using only redstone torches for the bottom most row and it does the same thing(didnt think it would change the outcome but i tested anyway, better to be thorough)
  27. Offline


    So I have Mine Craft Version 1.4 I see in some pictures that they have it working. This mod is for use of version 1.3. How do I get this working? What are the steps that are needed?
  28. Offline


    hey man i got ur message and im righting ur answer here if u dont mind.....

    download the plugin from the top then you just simply drop the .jar file into the Plugins file in your server folder.
    and run ur Server.BAT file. should download all you need and play :)
    if an error comes up saying: Blah blah (check if plugin is out of date?)
    download a new craftbukkit-0.0.1-SNAPSHOT. and then just replace the old one. run ur server once more. and it should work :).

    hope i helped.

    i see that u have said its for 1.3, the only place i see it says that is the VERSION of the plugin...not the game needed. its like a update of the plugin, it'll go up everytime somethings new on it. so mod makers dont have to keep telling people "download this new one" and people say "no ive got it already" but the one he has is an old crappy one without bug fixes etc etc.

    also the lastest bukkit version is im pretty sure it's [670], so if u see any plugins with : [Fun]Awesome plugin!! [670]
    it means its for 1.4_1 of minecraft AND the latest bukkit craftbukkit-0.0.1-SNAPSHOT

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  29. Offline


    What else beside pushing blocks is this gud for?
  30. Offline


    Is there any way that you could make it ignore water/lava blocks when it goes to push? I tried using this to make a water gate (pushing a sand block into the path of water would cause the water to stop flowing), but it seems that if water is there, it will not push.

    Also, any chance you could publish the source on something like Github? Helps for submitting pull requests and bug reports. ^_^

    Otherwise, great plugin!
  31. Offline

    Steve Cole

    I didn't have that problem at all. it could be a problem with the wiring or a conflict with another plugin.
    The worldedit plugin will let you load schematic files (its the plugin i used to create the file)
    and i'm not sure but MCedit can also import schematic files but i don't know if worldedit and mcedit use the same format for their schematic files.

    if you know how to use the redstone simulator
    i recommend setting options to one layer if its your first time using it.

    here is the rdat file and a gif of my newest piston setup, 4 blocks tall and as compact as it can get.
    Gif: http://google.com/search?q=referral+links#/cFYlhXF
    *gif is animated so you might have to download before it will play.
    Rdat: http://google.com/search?q=referral+links#/UPvAhWo

    took some screenshots

Share This Page