[INACTIVE][MECH] InfiniteLava v0.2 - Allows infinite pools of lava [672]

Discussion in 'Inactive/Unsupported Plugins' started by Edward Hand, Feb 20, 2011.

  1. Offline

    Edward Hand

    InfiniteLava v0.2

    In the same way that a 2x2 pool of still water can be used to harvest infinite water buckets, with this plugin enabled you can make lava act similarly.

    Instructions

    Since lava is more viscous, I made it so that at least a 3x3 pool of lava is required. Simply find or make such a pool and remove lava from the centre of the pool and the lava will regenerate. (NB: A cross shape will also work).

    Here is a gratuitous picture of a 3x3 lava pool:
    [​IMG]

    The plugin does not come with command, options or permissions. Just install and go. If people want extra stuff, I can look into implementing it.

    Feature Summary
    • A gap in lava surrounded on all four sides by still-lava regenerates.
    DOWNLOAD LINK:
    http://www.srcf.ucam.org/~eh392/minecraft/InfiniteLava/InfiniteLavav0.2.zip
    (source code is included)

    Change log:
    version 0.1
    • Plugin Released
    version 0.2
    • Bukkit team trying to break everything
     
    Jelle likes this.
  2. Offline

    fullwall

    Nice :). If my computer weren't crashing all the time, I'd put this on my server.
     
  3. Offline

    tips48

    AWESOME! lol...
    --- merged: Feb 20, 2011 11:16 PM ---
    it dosen't seem to work?
     
  4. Offline

    Edward Hand

    It does. I tested it and everything!

    You are taking the lava from the centre of a 3x3 pool, yes?
     
  5. Offline

    tips48

    Well, on CB 403, when:
    lava = F

    FFF
    FFF
    FFF

    OR

    F
    FFF
    F

    When i take from the middle it acts like normal?
     
  6. Offline

    Juze

    Nice, I missed this plugin from hMod. :) Thank you!
     
  7. Offline

    Edward Hand

    This might seem like a stupid question but you did add it to sever.properties didn't you?
    I've tried the version of crafbukkit you gave and its DEFINITELY working.

    Anyone else tried it?
     
  8. Offline

    Juze

    ...what? This isn't hMod. Or do the new Bukkit builds require you to do that? D:
     
  9. Offline

    Edward Hand

    Oh. I've been adding plugins to my server.properties for nothing 0_0
    I feel so stupid now...
     
  10. Offline

    Juze

    Don't worry, we all make mistakes, haha. :D
     
  11. Offline

    Edward Hand

    @aidan matzko
    I don't suppose you have some other plugin nerfing lava flow do you?
     
  12. Offline

    tips48

    WOW! that wasn't stupid... what do you add to the .properties? i feel dumb:p
     
  13. Offline

    Edward Hand

    Read the posts above. I was mistaken [​IMG]
     
  14. Offline

    tips48

    :confused: ok... So why won't this work :( Is there a properties file? or anything i have to change? I am using worldguard, but stopping lava flow isn't true... i don't think
     
  15. Offline

    Edward Hand

    I really wish I knew! I've got worldguard, world edit, essentials and all the normal plugins installed on my test server and its still working just fine. If you want to give it one more shot, you can install this special version I made just for you:
    http://www.srcf.ucam.org/~eh392/minecraft/InfiniteLava/InfiniteLava.jar

    It will output debug stuff to your console that looks something like:
    [COPE][InfiniteLava] STAGE 1 SUCCESSFULL[/CODE]
    If you can keep an eye on your console output as you remove lava from the pool and tell me what the highest stage it gets to is, it should give some clue as to where its going wrong.

    Thanks.
     
  16. Offline

    slinko

    interesting.

    MY SERVER IP IS 192.168.0.100
     
  17. Offline

    Edward Hand

    [facepalm.jpg]
    If you're going to try advertising your server here, at least get the right IP address!!!
    That is an internal IP address. You need your external one.

    http://www.whatsmyip.org/
     
  18. Offline

    slinko

    sorry and thanks
    --- merged: Feb 21, 2011 9:22 PM ---
    boy am i stupid
    it's actually 206.251.3.168
    --- merged: Feb 21, 2011 9:33 PM ---
    is my external supposed to work for my computer or only other people's?
    because i can't make it work with 206.251.3.168 , only with
    192.168.0.100
     
  19. Offline

    Edward Hand

  20. Offline

    slinko

  21. Offline

    tips48

    thats.really.weird... so i downloaded your special version, and guess what? I take lava from the pool, and it dosen't even give me a stage... weird... Where do you put the sources? I tried all on the sides, on the sides and the middle, only the middle, it just dosen't work:(

    Can I look at the source code? Maybe i could find something?

    EDIT: sorry i forgot it was in the zip, ill look at it now...
     
  22. Offline

    Edward Hand

    That means its not even registering a blockflow event 0_o.
    Just check that its outputting "[InfiniteLava] STAGE 1 SUCCESSFULL" when you type 'reload' in console. If so then I really am clueless as to what's happening. If not it means that the plugin is never being loaded (which, unless its outputting some specific error means its not in the plugins folder). If it is in the plugins folder then I'm still clueless.
     
  23. Offline

    Patryk

    Hiya. This addon doesn't seem to work. I am running git-Bukkit-0.0.0-437-g9de610a-b405jnks.
    I don't have any other addons that would interfere with lava. Unless "Better.lava" a minecraft client mod counts. Could that be it?


    I make a 3x3, fill it with 9 lava, and it wont let me pick lava up from the middle at all.

    Also, when I look at the startup (or the server.log), I can't see that InfiniteLava is even being loaded, even though it's in the plugins directory.

    Is it a problem with the newest build, or is it just me? Am I being stupid? That could totally be it.

    Edit: It works. I redid the 3x3 for a third time, and now it works flawlessy. Strange.
     
  24. Offline

    Edward Hand

    Success! Can you confirm that it is working perfectly now? As in, every time?
     
  25. Offline

    Patryk

    Yes. Until I messed it up again by drawing lava from one of the sides, and even refilling it wouldn't make the lava stop flowing, so I have to start over again, and hope it works again. I don't know if that's a problem with the addon, or if it's just general lava misbehaviour.

    Before my clumsiness it worked fine for a while, and helped me farm some obsidian.
     
  26. Offline

    Edward Hand

    I thought I was just going mad. I'm glad its working. For me it's always very well behaved. If you take lava from the side, just put it back (exactly where you got it from) and it should just go back to how it was.
     
  27. Offline

    Patryk

    Yes. That wasn't the first time I messed up, and usually I could fix it. The last time, however, it did not want to do it. But I am sure that's just me being a dummy.

    Either way, made another 3x3 and it works fine. The lava sometimes takes a second to refill, other times it's instant, but it works fine.

    Thanks for this mod! I missed having a proper source of lava, now I can farm obsidian properly again.
     
  28. Offline

    tips48

    since it still dosen't work, im gonna try it with only that plugin.. also, is there any way you could give me the source with an explanation line to line.. so i can look and see if i see anything conflicting with other plugins? Thanks alot for trying to help me :)
     
  29. Offline

    ghundaee

    does it work with 1.3?
     
  30. Offline

    Edward Hand

    Yep. Tested with build 432.
     

Share This Page