[INACTIVE][MECH] DwarfForge v1.7 - Run Furnaces on Lava [1185]

Discussion in 'Inactive/Unsupported Plugins' started by mattmoss, Jun 17, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I'm enjoying this so far. I'll let you know if I have any issues.
    Thanks man. +Follow.
  2. Offline


    Added to todo list.

    Mixing the non-fuel and fuel code was a bit annoying; I'll probably rewrite a bunch of things later, but I think I have an idea about this one. Also added to todo list.

    Will look into it. Thanks.
  3. Offline


    This is very cool. Would this work with double chests?
  4. Offline


    Yes; double-chests are supported.
  5. Offline


  6. Offline


    I love this plugin. Thanks @mattmoss!

    I wish there was a mod like this for single player, but I haven't found one yet...
  7. @mattmoss
    With sidesways stacking (awesome), a height limit of 3 should be enough. Perhaps add sideways limit of 3? Perhaps just put limits in config... :)

    Ive been thinking about logs. Apparantly they are treated as fuel now. Would it be more cost-effective to treat them as a resource instead and then move them back into source chest?
  8. Offline


    Oooo, forgot that logs become charcoal or can be fuel. Hmm... Yeah, I'll take care of that.

    What is the name of that plugin that saves your bucket?

    Version 1.3.1 update:
    Logs are now only used as raw material for making charcoal.
    Also, the buckets are no longer lost, but are placed empty into the output chest (or dropped if not available or no room).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  9. Offline


    Are you able to give furnaces a possibility to share item from a single stack? I mean, for expamle I'm putting 64 cobble to chest, and 21 goes to 1st furnace, 21 goes to 2nd one, and 22 goes to 3rd one?
  10. Will the charcoal end up in input or output chest?
  11. Offline


    I was just thinking about this the other day. Because of the way I track (or don't track) furnaces, this is difficult to do, while easy for the user to manage.

    However, if I only pull one item at a time (rather than one stack), the problem solves itself. And I don't think that would have any significant performance impact, since I'm already doing checks at those times anyway.

    So, yeah, I think I can make it work.

    Right now, the output chest. I didn't want to start adding special check conditions for one case... certainly, at least not until other more important issues are dealt with. So for now, users will just have to move the charcoal from output to input to use it.

    EDIT: Actually, this should be pretty basic to do, so I'll do it now.

    Charcoal will now go to the input chest (if fuel is required to use the forge).
    Also: stacking limits implemented.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  12. Offline


    What about making redstone, toggle a forge on or off. Might be a cool alternative to punching it.
  13. Offline


    But Dwarfs like punching things!
  14. Yes, im not looking for a fully automatic forge thing, but with double chests people are going to leave it unattended and then it would be good if the charcoal moves correctly both to be used and to prevent output to be filled too soon.

    How does it prioritize fuel now? From order its checked or depending on placement in input chest? Cause id love to see it using up the faster (less useful fuels) first. To make room faster in input.

    I think its a good idea, makes sense and also makes switches more useful in game.. Makes it seem more like a machine too. Most importantly it prevents you from accidentally hitting it and turning it off.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  15. Offline


    and other meltable(?)/melting stuff
    You said that its going to be hard to add this thing, could you at least give ETA or smth?
  16. Offline


    Both fuel and raw materials are taken in-order: those in the chest first are taken first. (Sometimes, depending on chest placement, "first" might be the second half of a double-chest before the first half.) It's something I can consider though...

    If you and @Sorken noticed above, I've already implemented moving charcoal to the input bin.

    What other smeltables can be used as fuel? Did I miss something?

    I don't really see much of a point to redstone triggering it. If it's just to have a button/lever, that's pointless. Accidentally hitting it? Just hit it again. (Just like you'd have to hit an accidentally hit button/lever.)

    If there was a particular reason to use redstone to trigger the forge... (and I mean something someone will actually use -- I try not to implement features "just 'cause it'd be cool")... I'd consider it. Right now, I'm not seeing it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  17. LavaForge, but i removed it.. It would be nice to have the bucket remain even if not using a DF tho.

    When using fuel, you cant just hit it again until flame goes out. Unless you fixed that?
  18. Offline


    I should be able to include that.

    No, but it's high up on my list. Like... I'll go look at it now. :D
  19. You have done alot today, dont forget to rest some too :)
  20. Offline


    I work in explosive spurts. Kinda like a [creeper]

    @Sorken, try version 1.4.1, which addresses empty buckets (for all furnaces, not just Dwarf Forges) and toggling a Forge back on while it's still processing remaining fuel.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  21. Offline


    couple of issues:
    if we have dwarf forges side by side activating them causes the client to get a black screen

    lever behind the forge (exactly as shown in the video) does not trigger

    other then that love the plugin

    craft bukkit version RB1000 no console errors
  22. Offline


    The latest version of the Forge plugin removed the lever trigger ability. I may revive that in a later version, but for now, it's gone.

    As for the black screen... try destroying the forges and recreating them. If that still causes a black screen, let me know.

    EDIT: It could be a chest inventory bug as well... while testing, that's usually when I get a black screen. Can you open both chests? If not, break and recreate, try again...
  23. Offline


    This is really good, thanks!

    Could you make the input and output chests an option though?
  24. Offline


    Chests are already optional: just don't place them down.
  25. Offline

    Patrick Crespo

    On my private server, DwarfForge seems to over time eat increasing CPU cycles. Admittedly, I have a slow server (Athlon 64 @1.8GHz, 3GB RAM), but after say... 12 hours of running with this enabled Java eats up ~40% of my CPU as opposed to 5% with no users. As time passes long enough it'll peg at 99% until I have to stop the server and start it up again. The memory usage never really goes above 1GB, although I have the max set at 2GB.

    At the time I had the following plugins enabled (I was trying to isolate which one or ones it was):

    AntiCreeper 2.0
    Cabinet(No Permissions version)
    Permissions 3.1.6

    All on CraftBukkit 1025 with Java 7 (#142)

    I'm still checking to see if any other of the plugins I use exhibit this problem and see if there's a common reason. :)
  26. Offline


    Thanks for the report. My time to work on this stuff now is much reduced, but I'm testing if DwarfForge might be the cause of CPU issues on my server. I'll update here again when I find out more. (And note that I don't have any of the same plugins you used, except an older version of Permissions.)
  27. Offline


    Update: when I removed DwarfForge from my server, my CPU issue went away. So it seems that DF is doing something funky. I'll look into it.
  28. Offline


    Got a permissions issue
    Show Spoiler

    2011-08-13 15:08:23 [INFO] Starting minecraft server version Beta 1.7.3
    2011-08-13 15:08:23 [INFO] Loading properties
    2011-08-13 15:08:23 [INFO] Starting Minecraft server on
    2011-08-13 15:08:23 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-g73697a4-b1000jnks (MC: 1.7.3)
    2011-08-13 15:08:23 [INFO] Preparing level "Miranda-2011-08-05-18-30-24"
    2011-08-13 15:08:23 [INFO] Preparing start region for level 0 (Seed: 93255267451974396)
    2011-08-13 15:08:24 [INFO] Preparing start region for level 1 (Seed: -5221138141431864191)
    2011-08-13 15:08:24 [INFO] Preparing spawn area: 36%
    2011-08-13 15:08:25 [INFO] [GrowingOre] Loaded 0 ores to regrow.
    2011-08-13 15:08:25 [INFO] GrowingOre version 0.6 is enabled!
    2011-08-13 15:08:25 [INFO] [RemoteBukkit] Query running on
    2011-08-13 15:08:25 [INFO] [RemoteBukkit] RCON running on
    2011-08-13 15:08:25 [INFO] [RemoteBukkit] v0.3 Plugin Enabled.
    2011-08-13 15:08:25 [INFO] Appleseed: ShowErrorsInClient=true
    2011-08-13 15:08:25 [INFO] Appleseed: DropInterval=150 seconds
    2011-08-13 15:08:25 [INFO] Appleseed: MaxUncollectedItems=3
    2011-08-13 15:08:25 [INFO] Appleseed: WandItem=wood_hoe
    2011-08-13 15:08:25 [INFO] Appleseed: FertilizerItem=bone_meal
    2011-08-13 15:08:25 [INFO] Appleseed: MinimumTreeDistance=4
    2011-08-13 15:08:25 [INFO] Appleseed: TreeTypes=(golden_apple,apple,cookie,cocoa_beans)
    2011-08-13 15:08:25 [INFO] Appleseed: Permissions 3.0b found
    2011-08-13 15:08:25 [INFO] Appleseed: 2 trees loaded in world Miranda-2011-08-05-18-30-24.
    2011-08-13 15:08:25 [INFO] Appleseed: 0 trees loaded in world Miranda-2011-08-05-18-30-24_nether.
    2011-08-13 15:08:25 [INFO] Appleseed version 0.6.2 is enabled!
    2011-08-13 15:08:25 [INFO] [Permissions] Loaded default permissions
    2011-08-13 15:08:25 [INFO] [Permissions] Using default permissions for world: Miranda-2011-08-05-18-30-24
    2011-08-13 15:08:25 [INFO] [Permissions] Using default permissions for world: Miranda-2011-08-05-18-30-24_nether
    2011-08-13 15:08:25 [INFO] [Permissions] v3.0b (MultiplayCompat) enabled
    2011-08-13 15:08:25 [INFO] [iChat] Found Permissions (v3.0b)
    2011-08-13 15:08:25 [INFO] iChat (v2.3.1) enabled
    2011-08-13 15:08:25 [INFO] [HeroicDeath] enabled.
    2011-08-13 15:08:25 [INFO] [DwarfForge] Restored 0 active Forges.
    2011-08-13 15:08:25 [SEVERE] Error occurred while enabling DwarfForge v1.4.1 (Is it up to date?): tried to access field com.nijikokun.bukkit.Permissions.Permissions.name from class com.splatbang.dwarfforge.DFPermissions
    java.lang.IllegalAccessError: tried to access field com.nijikokun.bukkit.Permissions.Permissions.name from class com.splatbang.dwarfforge.DFPermissions
    at com.splatbang.dwarfforge.DFPermissions.enable(DFPermissions.java:45)
    at com.splatbang.dwarfforge.DwarfForge.onEnable(DwarfForge.java:74)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-08-13 15:08:25 [INFO] [DwarfGear] Version 0.2 enabled.
    2011-08-13 15:08:25 [INFO] [ChopTree] Using Permissions.
    2011-08-13 15:08:25 [INFO] ChopTree 1.23 enabled!
    2011-08-13 15:08:25 [INFO] [BuddyUp] v1.2.1 enabled!
    2011-08-13 15:08:25 [INFO] Tombstone v.1.3.0 is enabled.
    2011-08-13 15:08:25 [INFO] [Tombstone] Using Permissions (v3.0b)
    2011-08-13 15:08:25 [INFO] Lockette version 1.3.8 is being enabled! Yay! (Core version 1.0)
    2011-08-13 15:08:25 [INFO] Lockette: Detected craftbukkit build [1000] ok.
    2011-08-13 15:08:25 [INFO] Lockette: Linked to Permissions plugin version 3.0b
    2011-08-13 15:08:25 [INFO] Lockette: Ready to protect your containers.
    2011-08-13 15:08:25 [INFO] SoggyPumpkins: Good to go!
    2011-08-13 15:08:25 [INFO] BookWorm v1.5 loaded!
    2011-08-13 15:08:25 [INFO] Done (0.190s)! For help, type "help" or "?"
    2011-08-13 15:08:30 [INFO] [BuddyUp] Successfully hooked into Permissions.

    Also when set to
    Permissions: False
    Op only: true
    it is only ops can create or only ops can use?
  29. Offline


    Which permissions system are you using?

    Yes. Both, iirc.
  30. Offline


Thread Status:
Not open for further replies.

Share This Page