[INACTIVE] [MECH/DEV] SpoutBackpack v2.3.6_3 - Give your players a Backpack [1317]

Discussion in 'Inactive/Unsupported Plugins' started by NeatMonster, Aug 10, 2011.

  1. Offline

    NeatMonster

    Please now use BukkitInventoryTools which contains SpoutBackpack.
    This thread is now useless, please don't post any longer on it.
    -----------------------​
    You can find the Bukkit Dev' thread HERE.
    Please use it, this thread will no longer be updated.

    ------------------------​
    SpoutBackpack v2.0.1
    Give your players a Backpack w/ Spout.

    Because pictures / video are always better than thousand words:
    [​IMG]
    [​IMG]
    (Unofficial video by IAMWIN but outdated: v1.9.5)​

    Features:
    • Pressing a key to open your backpack ;
    • Economy widget if you want it ;
    • Not just backpack, workbench too ;
    • Drop on death (configurable) ;
    • Permissions and economy plugins support ;
    • Allow your players to expand their Backpack ;
    • Restictions of upgrades & commands ;
    • Multiworld support with different Backpacks ;
    • Hooks into WorldGuard, MobArena and Jail ;
    • Key and name can be customized ;
    • API for developers ;
    • Backpacks are saved on server ;
    • Works even on reload.
    Requirements:
    • Spout and Spoutcraft - Required to launch and use the plugin.
      Tested with RB #1.0.5.227 of Spout and RB #1.0.5.256 of Spoutcraft.
    • (OPTIONAL) Permissions - Required if you want to customize the size or upgrade.
    • (OPTIONAL) PermissionsBukkit - Required if you want to customize the size or upgrade.
    • (OPTIONAL) PermissionsEx - Required if you want to customize the size or upgrade.
    • (OPTIONAL) GroupManager - Required if you want to customize the size or upgrade.
    • (OPTIONAL) iConomy - Required if you want to upgrade.
    • (OPTIONAL) BOSEconomy - Required if you want to upgrade.
    • (OPTIONAL) Essentials Economy - Required if you want to upgrade.
    • (OPTIONAL) MultiCurrency - Required if you want to upgrade.
    • (OPTIONAL) WorldGuard - Not required but compatible.
    • (OPTIONAL) MobArena - Not required but compatible.
    • (OPTIONAL) Jail - Not required but compatible.
    Configuration:
    Code:
    Widget:
        PositionY: 5
        PositionX: 3
        Enabled?: true
    Permissions:
        UseGroupManager?: false
        UsePermissions?: true
        UsePermissionsBukkit?: false
        UsePermissionsEx?: false
    Backpack:
        Name: Backpack
        Key: B
        Price:
            '45': 40.0
            '36': 30.0
            '18': 10.0
            '54': 50.0
            '27': 20.0
        RegionWhereBackpacksAreDisabled:
        - region1
        - region2
        world:
            Administrators:
                UpgradeSize: 54
                Size: 54
            Players:
                UpgradeSize: 27
                Size: 9
            Guests:
                UpgradeSize: 0
                Size: 0
            InventoriesShare?: true
            Moderators:
                UpgradeSize: 45
                Size: 27
            Joueurs:
                UpgradeSize: 36
                Size: 18
    Workbench:
        Enabled?: true
        Key: W
        NeededInInventory?: false
    Saves:
        Log?: false
        Interval(InMinutes): 5
    
    For PermissionsBukkit and PermissionsEx, you need to add permissions backpack.worldname.groupname. You also need to order your groups in the configuration file (eg. Admins, then Mods, then Players and then Guests). I'm sorry of this but those two plugins doesn't have the methods I need.

    Permissions:
    • backpack.workbench : Allow the player to open a virtual workbench.
    • backpack.nodrop : No drop of the items in the Backpack on death.
    • backpack.clear : Allow the player to clear his own Backpack.
    • backpack.clear.other : Allow the player to clear others inventories.
    • backpack.info.other: Allow the player to show info about others.
    • backpack.upgrade.other: Allow the player to upgrade others' Backpack.
    • backpack.open.other : Open other players' Backpack.
    • backpack.reload : Allow the use of the /backpack reload command.
    • NOTE: If you use OP system, size for not-Op players will be 9 and 54 for OP players.
    Commands:
    • /backpack clear (Player) : Clear your / player's inventory.
    • /backpack info (Player): Show information about your / player's Backpack.
    • /backpack open [Player] : Open player's Backpack.
    • /backpack upgrade [Player]: Upgrade your /player's Backpack.
    • /backpack reload : Reload Backpack's configuration.
    • NOTE: /backpack's alias is /bp.
    Downloads:
    Highly recommended:
    Credits:
    • The portage from BukkitContrib to Spout of this plugin was made by kazimir!
    • All credits go to captainawesome7 for his awesome BCBackpack plugin!
    TO-DO:
    • Permissions support ; DONE IN 1.3
    • Configuration of the key ; DONE IN 1.3
    • Multiple chest sizes ; DONE IN 1.4
    • iConomy integration ; DONE IN 1.6
    • MobArena hook ; DONE IN 1.6.1
    • BOSEconomy support ; DONE IN 1.6.2
    • PermissionsBukkit support ; DONE IN 1.6.3
    • Multiworld support ; DONE IN 1.7
    • Separate inventories ; DONE IN 1.7
    • WorldGuard regions support ; DONE IN 1.7.1
    • GroupManager support ; DONE IN 1.7.2
    • Workbench ; DONE IN 1.8
    • Jail support ; DONE IN 1.8.1
    • Add an option to disable workbench ; DONE IN 1.8.2
    • Restriction on Workbench ; DONE IN 1.8.4
    • Support of Essentials economy ; DONE IN 1.8.5
    • Economy widget ; DONE IN 1.9
    • Command to clear Backpack ; DONE IN 1.9
    • Restrictions on upgrades ; DONE IN 1.9
    • API ; DONE IN 1.9
    • Setting for the widget position ; DONE IN 1.9.2
    • Lookup in others' Backpack ; DONE IN 1.9.2
    • Support for PermissionsEx ; DONE IN 2.0
    • Handle deaths without Spout client ; DONE IN 2.0
    • Upgrade other players' Backpack ; DONE IN 2.0
    • Furnaces.
    Notes:
    • If you put something in your Backpack and close Minecraft by clicking the "X" without closing your backpack, all items you put in since opening your Backpack are lost. That's not a bug - It's a feature to prevent duping.
    API:
    You want to hook into SpoutBackpack? Fine, I have what you need.
    1. Import SpoutBackpack.jar as a library in your project ;
    2. Import me.neatmonster.spoutbackpack.SBHandler ;
    3. In your main class, add this object creation :
      Code:
          public SBHandler spoutBackpackHandler;
    4. Somewhere on your onEnable, add this line :
      Code:
              setupSpoutBackpack();
    5. So, this is the setupSpoutBackpack function :
      Code:
          private void setupSpoutBackpack() {
                                                      if (spoutBackpackHandler != null) {
                                                          return;
                                                      }
                                                      Plugin spoutBackpackPlugin = this.getServer().getPluginManager().getPlugin("SpoutBackpack");
                                                      if (spoutBackpackPlugin == null) {
                                                          return;
                                                      }
                                                      spoutBackpackHandler = new SBHandler();
                                                      return;
                                                      }
    6. To check somewhere in your code if SpoutBackpack is enabled, use :
      Code:
              if (spoutBackpackHandler != null) {
                                            return;
                                     }
    7. And finally to use a method of SpoutBackpack :
      Code:
              spoutBackpackHandler.theMethodYouWant();
      You can find all the methods HERE.
    8. If you need more methods, or if I made a mistake, do not hesitate to contact me.
    Changelog:
    Version 2.0.1
    • PermissionsBukkit & PermissionsEx fix.
    Version 2.0
    • Improved Backpacks' save system ;
    • PermissionsBukkit full support ;
    • PermissionsEx full support ;
    • Bug fix when client doesn't use Spoutcraft ;
    • Upgrade other players' Backpack.
    Other versions (open)
    Version 1.9.5
    Other versions (open)

    • Added methods for the API.
    Version 1.9.4
    • Fixed API.
    Version 1.9.3
    • Removed debug messages.
    Version 1.9.2
    • Setting for the position of the widget ;
    • Command to open other players' Backpack.
    Version 1.9.1
    • New method added to the API.
    Version 1.9
    • Economy widget when you opens your Backpack ;
    • Commands to clear Backpack(s) ;
    • Restrictions on updates ;
    • Creation of an API ;
    • Bug fixes with economy.
    Version 1.8.5
    • Support of Essentials Economy ;
    • Support of MultiCurrency.
    Version 1.8.4
    • Option to only use workbench if you have one in inventory.
    Version 1.8.3
    • No more saves when nobody is online ;
    • Fixed bug on upgrade.
    Version 1.8.2
    • Workbench toggle in the config.
    Version 1.8.1
    • Jail support.
    Version 1.8
    • Now with you can give your players a virtual workbench ;
    • You can close the workbench with the same key ;
    • Now the workbench will not appear when typing in the chat.
    Version 1.7.3
    • GroupManager full support.
    Version 1.7.2
    • GroupManager support ;
    • Permission for drop on death.
    Version 1.7.1
    • You can specify WorldGuard region where Backpacks will be disabled ;
    • More, more, more and more keys.
    Version 1.7
    • New multiworld support ;
    • Separate inventories ;
    • Common inventories ;
    • Reload command ;
    • Smart detection of plugins you've installed ;
    • Some code rewrite = more proper code.
    Version 1.6.3
    • Added PermissionsBukkit support with configuration options.
    Version 1.6.2
    • Support for BOSEconomy, no configuration needed ;
    • More anti-cheat messages and information for users.
    Version 1.6.1
    • Hooks in MobArena : when a player is inside an arena, I can't open his BackPack ;
    • For more security, it checks if iConomy is installed.
    Version 1.6
    • Added iConomy support & /backpack commands, which allow your players to expand their Backpack by paying some iConomy money (configurable in config.yml) ;
    • Minor bug fixes & code cleanup.
    Version 1.5
    • Added support for multiword (see in config.yml).
    • More and more help in the config.yml.
    Version 1.4
    • New permissions for different sizes.
    Version 1.3
    • Closing you backpack will now saves his content.
    • Permissions support.
    • You can now change the key used to open the backpack in the configuration.
    Version 1.2
    • Original version.



    [​IMG]
     
  2. Offline

    kolorafa

    I lost everything in inventory except first line when i join world without bigger backpack with:
    SeparateInventories?: false
    or
    SeparateInventories?: true
    but joined listed in WorldsWhoShareInventories: world that dosn't have permissions for bigger backpack

    So i'm ready to test dev builds :)
     
  3. Offline

    NeatMonster

    But dev' builds aren't ready yet! But I'm working on them at the moment.
    Edit: Okay, code changes are done. Now I need to correct bugs reported. I think you can expect a dev' build for 1 or 2 hours.
    Re-Edit:
    I can't reproduce the bug. Maybe I've corrected it in the dev' version.
    Re-Re-Edit: Development version available HERE. No more permissions backpack.sizeXX and backpack.upgradeXX. See the new configuration file. Please give feedback on upgrades and multiworld issue. Do not use with PermissionsBukkit for the moment.
     
  4. Offline

    Gabriel333

    Do you have problems with PermissionsBukkit? I cant open the Backpack with the BKey ???
     
  5. Offline

    NeatMonster

    No problem with PermissionsBukkit for the moment, but it needs special instructions that I haven't wrote.
    Problem with B key is in dev' version? If yes, delete config.yml, restart server and reconfigure.
     
  6. Offline

    RugRats

    Well when the restart bug is fixed please tell me. I removed this because people were putting the valuables into there backpack and I was doing a lot of maintenance and they just kept losing there items
     
  7. Offline

    NeatMonster

    Please try the dev' version.
     
  8. Offline

    RugRats

    Where is it?
     
  9. Offline

    NeatMonster

    Post #290.
     
  10. Offline

    ShadowDraco

    Installed the dev version, and everything works well (from my testing so far). Thanks for this!
    (Note: New install, plugin generated config.yml)

    Wanted to point out a small bug that I ran into though:
    The workbench portion of the backpack was being opened by the 'W' key.

    Opening the config.yml, I found the following:

    Code:
    Workbench:
        Enabled?: true
        Key: N
    and at the bottom

    Code:
    KeyUsedToOpenTheWorkbench: W
    Changing the option on the bottom line to 'N' corrected it.
     
  11. Offline

    NeatMonster

    Thank you. Bug corrected. I'll update the dev' version soon.

    No bugs with upgrades or multiworld?
     
  12. Offline

    MMZ_TimeLord

    NeatMonster,

    Love the plugin! However, I need some help with permissions. I'm currently using PermissionsEx 1.13 for CB #1000. I have your plugin working correctly as far as the Spout on the server and client and I can open the inventory.

    I have added the permissions node to my user groups, but I am stuck with a 9 slot backpack and can not upgrade.

    Any help in this area would be greatly appreciated.

    My configs are below...

    PermissionsEx permissions.yml (open)
    Code:
    groups:
        default:
            prefix: '&2[D]&f '
            default: true
            options:
                rank: '1000'
            permissions:
            - modifyworld.chat
        Builder:
            prefix: '&2[B]&f '
            permissions:
            - essentials.warp
            - essentials.home
            - essentials.sethome
            - essentials.back
            - essentials.depth
            - essentials.getpos
            - essentials.compass
            - essentials.motd
            - essentials.rules
            - essentials.afk
            - essentials.me
            - essentials.kit
            - essentials.kit.tools
            - essentials.kit.armor
            - essentials.spawn
            - backpack.size27
            - modifyworld.*
            options:
                rank: '900'
        Moderator:
            prefix: '&4[M]&f '
            permissions:
            - backpack.size27
            - essentials.*
            - modifyworld.*
            options:
                rank: '100'
        Admins:
            prefix: '&1[A]&f '
            permissions:
            - backpack.size54
            - -modifyworld.entity.mobtarget.*
            - '*'
            options:
                rank: '0'
    users:
        MMZ_TimeLord:
            group:
            - Admins
        usmcnewbee:
            group:
            - Moderator
        MMZ_Wormy:
            group:
            - Builder
        ravemonger:
            group:
            - Builder
        saladin1980:
            group:
            - Builder
        NastyDwarf:
            group:
            - Builder
        Screwlewse:
            group:
            - Builder
        MNicholson83:
            group:
            - Builder
        linguizic:
            group:
            - Builder
        tigerfox:
            group:
            - Builder
        Magius9:
            group:
            - Builder
        mathsucks:
            group:
            - Builder
        Jopte:
            group:
            - Builder
    
    SpoutBackpack config.yml (open)
    Code:
    NameOfTheBackpack: Backpack
    KeyUsedToOpenTheBackpack: B
    UsePermissions?: true
    UsePermissionsBukkit?: false
    UseGroupManager?: false
    IntervalInMinutesBetweenEachSaving: 5
    LogTheSaves?: false
    EnableTheWorkbench?: true
    KeyUsedToOpenTheWorkbench: N
    NeedsAWorkbenchInYourInventory?: false
    SeparateInventories?: false
    WorldsWhoShareInventories:
    - world1
    - world2
    RegionsWhereBackpacksAreDisabled:
    - region1
    - region2
    UseWidget?: false
    Widget:
        PositionY: 5
        PositionX: 3
    PriceToUpgradeToThe54Backpack: 50.0
    PriceToUpgradeToThe45Backpack: 40.0
    PriceToUpgradeToThe36Backpack: 30.0
    PriceToUpgradeToThe27Backpack: 20.0
    PriceToUpgradeToThe18Backpack: 10.0
    
     
  13. Offline

    robjhak

    ok well iv got a prob i cant seem to get the upgrading to work
    heres all my plugins
    borderguard
    craftbook
    duckshop
    essentials
    getronomic
    iconomy<newest one
    permissions 3. what ever newest one
    lockette
    shop
    wourld edit
    spout

    iv added the upgrade nodes and backpack size 9 node
    because when i add any others it makes my back pack that'

    heres my iconmy config yml

    ............# iConomy 5.0
    # %author Nijikokun <nijikokun@gmail.com>
    # %license GPLv2
    # %copyright Copyright AniGaiku LLC (C) 2010-2011
    ##
    # Setup Notes
    # - Default
    # This node consists of all the 'default' data.
    # - Formatting
    # Allows you to control the output of how you will
    # see the currency in-game with the major/minor features.
    # - Banking
    # Allows users to store money in a seperate location as
    # well as transfer from bank to bank between users
    # - Multiple
    # Allows users to create multiple accounts with banks
    # - Q & A
    # Q: Why?
    # A: Money on hand can be lost, money in banks should not
    # be altered upon plugin specifictions in iConomy 5.0
    # - Interest amount is done in seconds.
    # - Online
    # If only true, only one bank / account will recieve money for that player.
    # If only false, it will go through each bank / account and deposit money.
    # - Announce
    # Sends message each time a player recieves money.
    # - Amount
    # - On
    # Each time interest runs you can either deposit the money into a bank (Interest)
    # or directly into a players holdings (Wage).
    # - Interval
    # - Seconds
    # Basic Table:
    # 1 minute = 60 seconds
    # 1 hour = 1 minute * 60 = 3600 seconds
    # 1 day = 1 hour * 24 = 86400 seconds
    # 1 week = 1 day * 7 = 604800 seconds
    # - Database
    # - Type
    # Can only be h2 or MySQL, no longer supports SQLite.
    # - Settings
    # If you choose h2, only the first two are needed, do not alter MySQL.
    # - MySQL
    # Do not use remote databases from free sites, please use either a
    # remote database from a personal hosted VPS or DEDI or a local
    # database. This will prevent any 'timeout' or 'invalid settings'
    # or 'cannot connect to database' issues. Thank you :)!
    ##

    System:
    Default:
    Currency:
    Major: [ 'Dollar', 'Dollars' ] # Major ([Major].Minor) 1.00 Dollar (With Seperate 1 Dollar)
    Minor: [ 'Coin', 'Coins' ] # Minor (Major.[Minor]) 0.23 Coins (With Seperate 0 Dollars, 23 Coins)
    Account:
    Holdings: 30.0 # Default holdings on hand upon join / creation.
    Bank:
    Name: iConomy # Default Bank Name
    Currency:
    Major: [ 'Dollar', 'Dollars' ]
    Minor: [ 'Coin', 'Coins' ]
    Account:
    Fee: 20.0 # Default cost to register an account
    Holdings: 30.0 # Default initial account holdings
    Formatting:
    Minor: false # Example (true) 0.23 Coins and 1.23 Dollars (false) 0.23 Dollars and 1.23 Dollars
    Seperate: false # Example (true) 1 Dollar, 23 Coins (false) 1.23 Dollars (Only if Minor is true)
    Logging:
    Enabled: false # Logs transactions done inside iConomy only, other plugins must utilize the api. (Logs to SQL)
    Banking:
    Enabled: false
    Accounts:
    Multiple: true
    Interest:
    Enabled: false
    Online: true # Only give to players who are online?
    Announce:
    Enabled: false
    Interval:
    Seconds: 60
    Amount:
    Cutoff: 0.0 # Amount limit to be met until we stop giving interest. (0.0 for no limit)
    On: 'Players' # Banks or Players
    Percent: 0.0 # Percent of holdings to give / take (Negative to take) (Overrides Min/Max)
    Maximum: 1 # (Range) Maximum amount for random in between. (Make Max/Min equal for a flat-rate amount ie: 5/5)
    Minimum: 2 # (Range) Minimum amount for random in between.
    Database:
    Type: 'H2SQL' # H2 or MySQL
    Settings:
    Name: 'minecraft'
    Table: 'iConomy'
    MySQL:
    Username: 'root'
    Password: 'pass'
    Hostname: 'localhost'
    Port: 3306



    ....................................
    heres my backpack config yml
    LogTheSaves?: false
    PriceToUpgradeToThe45Backpack: 40.0
    KeyUsedToOpenTheBackpack: B
    EnableTheWorkbench?: true
    Widget:
    PositionY: 5
    PositionX: 3
    UseGroupManager?: false
    IntervalInMinutesBetweenEachSaving: 5
    UseWidget?: use
    NameOfTheBackpack: togo chest
    WorldsWhoShareInventories:
    - earth
    - earth_nether
    PriceToUpgradeToThe54Backpack: 50.0
    UsePermissionsBukkit?: true
    RegionsWhereBackpacksAreDisabled:
    - region1
    - region2
    PriceToUpgradeToThe27Backpack: 20.0
    PriceToUpgradeToThe18Backpack: 10.0
    UsePermissions?: true
    NeedsAWorkbenchInYourInventory?: true
    KeyUsedToOpenTheWorkbench: N
    SeparateInventories?: false
    PriceToUpgradeToThe36Backpack: 30.0

    ...................................................................
    plz help me

    email me help at robjhak16#gmail.com plz and post here plz i love your spout mod its why i made my server a spout server

    typo in email #=@

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 18, 2016
  14. Offline

    kolorafa


    Use dev build from Post #289. Latest is/was buggy.
     
  15. Offline

    NeatMonster

    Permissions != PermissionsEx.
    PermissionsEx isn't supported yet, but don't worry I'll add support soon.
     
  16. Offline

    MMZ_TimeLord

    kolorafa,

    I just tried that dev build. Same message when I try and perform a "/backpack upgrade" while in the "Admins" group. And, yes I changed the group names in the Backpack config.yml file to reflect my group names of "Admins", "Moderators", "Builders" and "default".

    The result was still "You've got the biggest Backpack for your permissions!".

    Does this even work with PermissionsEx?

    EDIT: Missed NeatMonster's post by about 1 minute... Guess I'll wait patiently. :D
     
  17. Offline

    NeatMonster

    Permissions file? Any error message?

    Little question, have your given to your users the backpack.upgradeXX permission?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 18, 2016
  18. Offline

    jonahverner

    I can't use it...
     
  19. Offline

    NeatMonster

    No really, are you serious? Provide more information if you want help!
     
  20. Offline

    jonahverner

    @NeatMonster :p anyway do you have to make all your players use spout for it to work? I just get internal errors when I do a command and when I press B nothing happens
     
  21. Offline

    NeatMonster

    You need Spout on the server and Spoutcraft the client. Post errors here if you want more support.
     
  22. Offline

    Wiernusz

    Would it be possible to implement the ability to open offline players backpacks?
     
  23. Offline

    NeatMonster

    Yep, it'll be in the 2.0 release version.
    But before releasing it I need feedback on upgrades and multiworld for the dev' version.
     
  24. Offline

    jonahverner

    I have spoutcraft and the server plugin but it still doesn't work for anybody
    error msg:

    15:11:02 [SEVERE] Could not pass event CUSTOM_EVENT to SpoutBackpack
    java.lang.NoSuchMethodError: com.nijiko.permissions.PermissionHandler.has(Ljava/
    lang/String;Ljava/lang/String;Ljava/lang/String;)Z
    at me.neatmonster.spoutbackpack.SpoutBackpack.canOpenBackpack(SpoutBackp
    ack.java:345)
    at me.neatmonster.spoutbackpack.SBInputListener.onKeyPressedEvent(SBInpu
    tListener.java:32)
    at org.getspout.spoutapi.event.input.InputListener.onCustomEvent(InputLi
    stener.java:28)
    at org.bukkit.plugin.java.JavaPluginLoader$88.execute(JavaPluginLoader.j
    ava:862)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    a:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    ava:338)
    at org.getspout.spoutapi.packet.PacketKeyPress.run(PacketKeyPress.java:5
    4)
    at org.getspout.spout.packet.CustomPacket.a(CustomPacket.java:99)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:89)
    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java
    :436)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    >
     
  25. Offline

    NeatMonster

    What permissions plugin are you using?
     
  26. Offline

    Wiernusz

    I've been a bit iffy on testing upgrades with my player base considering they all already have backpacks full of stuff.
     
  27. Offline

    NeatMonster

    Ok, I understand.
     
  28. Offline

    Wiernusz

    Should this work with the permbridge/superperms anyways?
     
  29. Offline

    NeatMonster

    The new version will work with PermissionsBukkit (with BP upgrades).
     
  30. Offline

    jonahverner

    I am using groupmanager (the essentials one)
     
  31. Offline

    MMZ_TimeLord

    NeatMonster,

    Originally I did not have those permissions in my "permissions.yml" file as you can see as I had posted the file contents in my previous post. I only had the "backpack.sizeXX" permission available.

    Another question about the sizeXX and upgradeXX permissions. Is it required to have ALL sizes up to the maximum size you want your players or groups to have? i.e. - If I want my players in group "Builders" to have 9, 18 and 27 size backpacks, do I have to include "backpack.size9, backpack.size18, backpack.size27, backpack.upgrade18 and backpack.upgrade27" all to that group's permissions section? or can I just put the two "backpack.size27 and backpack.upgrade27" only?

    When I tested it just now I did try both ways to no avail. I still get the message that I have the maximum size available for my permissions.

    I guess I'm confused as to how these permissions control this plugin. Documentation is a bit unclear in the OP, but once I understand how it works I'd be happy to write some clearer documentation for you. :D

    Thanks again!
     

Share This Page