[INACTIVE][MECH]CommandSigns v0.4 - Issue commands using signs [672]

Discussion in 'Inactive/Unsupported Plugins' started by Edward Hand, Feb 22, 2011.

  1. not to pester, but how close are we to having some sort of redstone activation available for testing? :D
  2. Offline


    Having some issues with this. I'm trying to get a player labled [Guest] to right click this sign switch their groups, and be teleported to a new area at the same time, but I keep getting "does not have access to command" or it returns command true and nothing happens.

    The guest has 'commandSigns.use' in permissions, and I'm using yeditor, and MyWarp for the permissions adding and warping.

    The sign looks like this..
    /yt add <NAME>
    /warp New Town

    I've also tried it with *'s after the /'s.

    This returns the statement as true, but nothing happens.

    Also the other sign that doesn't work is a broadcast sign from the essentials plugin.

    <NAME> has
    passed the test

    This returned the statement as does not have access to command, also tried this with a *, same thing.
  3. Offline

    Edward Hand

    You must use '/*' and also give the fictional user '/CommandSigns' enough permissions to run the commands.
  4. Offline


    I have absolutely nno idea what you mean "fictional user". Can you noob it down for me please?
  5. Offline

    Edward Hand

    It's all explained in the first post.
    When you put a * after the / it creates an imaginary user with the name '/CommandSigns' and makes that user run the command. The permissions plugin will then use /CommandSign's permission settings rather than those of the user clicking on the sign.
    Pretend there is a user called /CommandSigns (the / is just to make sure a real user can't share the same name) and add that user to your GroupManager/Permissions settings, giving them full rights to use whatever commands you need.
  6. Offline


    Please, add a money charge on sign usage, it would really help a lot on my server.
    anon likes this.
  7. Offline


    Ahh thanks edward that bit about the adding a user helped lol.

    A suggestion. Add a line somewhere on your OP that says, "Add a user named /CommandSigns with access to all commands ('*') or specific commands." The current explanation you have is a little vague.
  8. Offline


    I am having a issue with guests not being able to use the
    They can use the other ones
    We are running,
    bukkit build:b556
    We are using group manager for permissions of that helps and I put the command in there permissions.

    If it helps only moderators and admins can spawn items and ops can acess the free items signs.
  9. Offline


    So i've done my best to read the readme and a few pages of the post but i still need help.

    I know you can use /* to bypass permissions. How do you use the /give command when bypassing permissions?

    I'm trying

    /*give ???
    3 64

    How do you specify the person clicking the sign?

    Also is there a way to put the sign on a cooldown? Say for instance, it can't be right clicked again for 5 minutes.
  10. Offline

    Edward Hand

    Use <NAME>. Anywhere that appears in the sign it will be replaced by the name of the user clicking on it.

    There's no cool-down at the moment. I was thinking of adding it but signs don't have that much space on them for adding even more information :S

    Does the little thing in [brackets] at the top turn green?
    Do you get any errors?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  11. Offline


    The command turns green and the free turns blue... Everyone can use the command signs but only ops can use the free ones
  12. Offline

    Edward Hand

    It turns blue? Do you have some other plugin installed doing that? Nothing in CommandSigns will turn it blue...
  13. Offline


  14. Offline


    Yeah I can definantly understand that. I think it is totally worth adding though. In fact I think the original version of this mod for hmod had that feature. It would be necessary for my plans :)

    Thanks for the help :)
  15. Offline

    Edward Hand

  16. Offline


    its not me, its the other guy.... Probably his essentials plugin is confliction with yours, and he doesnt know that.
  17. Offline

    Edward Hand

    Oh sorry!
  18. Offline


    Hmm very nice mod! A great idea but I don't think I would need this plugin for now.. But I certainly will keep an eye on this one! Good job!
  19. Offline


    Seeing as you don't have Permissions inheritance in yet...why not add it? :)
  20. Offline

    Edward Hand

    Because it's not possible :p
    The permission plugin doesn't allow it currently.
  21. Offline


    You mean, it doesn't have any functions to aid with it? ;) I'll go do some research, and get back with you. Mind if I mess with your source for a bit? :p
  22. Offline


    Perhaps redstone signs could have something special like /** or something that indicates any redstone activation will run the command. These commands would ignore the .use permission.
  23. Offline


    i'm just not getting it.
    i have a command alias through commandhelper.

    if i make a sign [command] /tr <NAME> i can run it fine.
    if i make a sign [command] /*tr <NAME> i get unknown console command

    if i make a sign [command] /ta town Ravens_Refuge add <NAME> it works fine
    if i make a sign [command] /*ta town Ravens_refuge add <NAME> i get unknown console command

    with both /* i get
  24. Offline


    ?thanks load for this?
  25. Offline

    charlie k-j

    Please allow redstone input!!! :D :D [It would be a great addition to a great plugin ;)]
    anon likes this.
  26. Offline


    Theres sign with essentials? Theres no in fo in the config file... So I want to the builders and people who cant spawn items to get items.. What i was using before was,
    <id> I think thats essentials?
    So with command signs I would put it like this /*give id <name>
    Sorry about that mix up with essentials
    EDIT: do i have to add the commands.Signs permissions still
  27. Offline

    Edward Hand

    /*give <name> id amount

    To create that sign you need commandSigns.* permission

    For people to use it you need to make the non-existant player /CommandSigns an op

    (oh, and new version for the latest Recommended Build 602+)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  28. Offline



    Do you think it's possible to add in your ToDo the possibility to activate the sign via redstone. It's will be usefull for me ! This combinate with PhatLoot will be nice for refill my dungeon's chests.

    If it's not too hard for you ;)

    Thanks in advance ... and pardon me for this english !
  29. Offline


    Edward Hand:
    Thanks for this plugin. I am requesting if you could put up v 0.36 again, seeing nothing (expect craftbukkit 602 support) was updated in the latest version. I would love to have this plugin running right now, but I am not going to update craftbukkit immediatly, since I've got 10-15 plugins breaking on the new bukkit update.
  30. Offline

    Edward Hand

    Quite understandable.
    All versions can be found here: http://www.srcf.ucam.org/~eh392/minecraft/CommandSigns/

Share This Page