[INACTIVE] LockCraft v0.3.5 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Crash, Jun 3, 2011.

  1. Offline



    Attached Files:

    Norcis, woodzy, Flipp and 2 others like this.
  2. Offline


    Yeah I got v0.3 working out fine with all inventories except for player table which I think I got working.
  3. Offline


    Yeah my users are just spamming it till the get the tool at the min. so is version 0.3 up?
  4. Offline


    Ok I put v0.3 up see how that works for you.
  5. Offline


    They can still get the tool if they shift click when they first click it. Is there anyway for the furnace stuff not to dissapear but just be untakeable?
  6. Offline


    About the shift click : I'm not getting that.. give me your config file and tell me where they are crafting the items. Also make sure you gave them the list node.
    For the furnace idea, that wouldn't work because then you'd have an item stuck inside the furnace and you won't be able to get it out.
  7. Offline


    Ok, here is a video of it: http://www.youtube.com/watch?v=n2GeKP9PpGs
    Edit: Deleted the video as it has done its purpose.

    Here is my config.
    global-blacklist: []
        - 265
        - 267
        - 276
        - 277
        - 278
        - 279
        - 283
        - 284
        - 285
        - 286
        - 266
        - 292
        - 293
        - 294
        - 256
        - 257
        - 258
        - 306
        - 307
        - 308
        - 309
        - 310
        - 311
        - 312
        - 313
        - 314
        - 315
        - 316
        - 317
        - 42
        - 325
        - 230
        - 57
        - 45
        - 350
        - 354
        - 297
        - 320
        - 322
        - 282
        - 5
    Hope this helps.
  8. Offline


    How did you do the shift click part it looked like the window closed instantly.
    I was able to pull it off, but it appears the item disappears after you open another window.
    I think this can be fixed.
  9. Offline


    Yeah you do shift click then press the button to close it. But it can be used if you don't open a inventory screen
  10. good job- but can you make the chance to buy recipes with iconomy would be great!
  11. Offline


    Ok I fixed that but it appears some update for bukkit made it re-update the result slot so the result will still show up.

    That will be what I'll work on next :)
  12. Offline


    I hope this plugin doesn't become weighed down with extra features. Maybe keep a version with out iconomy separate that would be good.
  13. or a config file ;D
  14. Offline


    i get always the same error code althoug i clear the line ..


    can u help me ?

    // SOLVED
  15. Offline


    If some one takes out iron out a furnace it crashes there game and when they leave it crashes everyone elses.

    Edit it some how breaks the map.
  16. Offline


    hey i have a Question can you make

    a command

    lockcraft.bypass.name ??

    i need it for my RPG Server
    i have 3 Class

    Woodmaker,Forger and Normal Users
    Forger cant make Woodmaker's items and

    Normal Users cant craft anything


    I have Found a Bug

    You Can't blacklisting

    Wood Steps or Stone Steps !
    not going

    MFG Geuthur
  17. Offline


    I would use this plugin on our server but I can't. When I unzip it there is no jar...
  18. Offline


    I have a problem with that plugin:
    If users, who are not allowed to smelt raw porkchop try to smelt it they got kicked and i got this error:
    2011-06-21 20:51:48 [WARNING] Failed to handle packet: java.lang.NullPointerException
        at net.minecraft.server.ItemStack.d(ItemStack.java:95)
        at net.minecraft.server.ItemStack.f(ItemStack.java:103)
        at net.minecraft.server.InventoryPlayer.canHold(InventoryPlayer.java:126)
        at net.minecraft.server.EntityItem.b(EntityItem.java:130)
        at net.minecraft.server.EntityHuman.i(EntityHuman.java:218)
        at net.minecraft.server.EntityHuman.u(EntityHuman.java:210)
        at net.minecraft.server.EntityPlayer.u(EntityPlayer.java:281)
        at net.minecraft.server.EntityLiving.o_(EntityLiving.java:231)
        at net.minecraft.server.EntityHuman.o_(EntityHuman.java:96)
        at net.minecraft.server.EntityPlayer.a(EntityPlayer.java:197)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:286)
        at net.minecraft.server.Packet10Flying.a(SourceFile:126)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    And then they cant login and you have to delete the playerfile D:

    And some idea:
    Can you add the feature that users are not allowed to use, craft and break an item?
    like that:
    - 5:b:u:c
    - 270:c
    - 268:c:u
    u=use c=craft b=break

    Edit: Now i found the reason for the errors: If you cook with charcoal and if the plugin is enabled then i get an error :O
  19. Offline


    It happens for everything for me, This needs sorting...

    Are you hearing this?​

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  20. Offline


    Could you add an option so the blacklist is use as a whitelist
  21. are you working on this plugin so far?

    are you going to update it?
  22. Offline


    I don't know why I'm not getting this on 860. What version do you have
  23. Offline


    860 if some with out permission takes iron out the furnace it corrupts the map. Maybe a other plugin?
  24. Offline


    OK, so I put items into groups. Now, if I give someone that permission node does it mean they CANT craft it?
    I think a config file is needed for this, so you can switch between blacklist and whitelist... I only want to allow a few items per groups and I'm sure many others are the same (for the whole RPG thing) - I'm now having to add a tonne of items to each group :(

    the "..." throws out errors in the YAML parser:

    I thought they were weird as i've never seen them around before.. removed them and reloading to test now as it wasn't working with those in anyway.
  25. Hi all,

    I dont understand why this plugin dont work :(

    First, i place my nick in the permissions file
    Groups permissions:
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Default
                - 'iConomy.payment'
                - 'iConomy.access'
                - 'iConomy.rank'
                - 'iConomy.list'
                - 'iConomyChestShop.shop.buy'
                - 'iConomyChestShop.command.iteminfo'
                - 'iConomyChestShop.shop.sell'
                - 'jobs.join.*'
                - 'jobs.world.linux'
                - 'iConomyChestShop.shop.create'
                - 'mcmmo.ability.axes'
                - 'mcmmo.ability.excavation'
                - 'mcmmo.ability.swords'
                - 'mcmmo.ability.unarmed'
                - 'lwc.protect'
                - 'lwc.blockinventory'
                - 'tombstone.use'
                - 'tombstone.large'
                - 'tombstone.lwc'
                - 'tombstone.sign'
                - 'tombstone.quickloot'
                - 'lockcraft.blacklists.mineur'
                - 'vote.voteno.[votename]'
                - 'vote.startvote.[votename]'
    Next, in the Users file

           - mineur
            permissions: []
    And the last config in the Blacklists file from Lockcraft
    global-blacklist: []
        - 272
    272= Stone Sword

    I dont understand where is the prob, this is a restriction for the Groups 'mineur', the user 'magicbel' use this Groups and the 272 blacklisted.....

    Where is the bug?

    Tks a lot friends !
    (sry for the english, i'm french :) )

  26. what craftbukkit are you running?

    860 generally sends errors
  27. Version Info :
    2011-06-24 14:03:26 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-766-g3fc0460-b818jnks (MC: 1.6.6)
    2011-06-24 14:03:26 [INFO] This server is also sporting some funky dev build of Bukkit!

    EDIT : Oups, i found the prob, just a little error in the code. Tks Friends !
    Post closed for me :)
  28. Offline



    We have one player who keeps getting kicked with a plain black screen whenever he crafts something since installing this plugin. He insists it MUST be this, personally I reckon its his client (why wouldn't it happen to other players?) but I said I'd post here anyway. Anyone else getting a bug like this at all?

    (There is also one other player who gets the same thing from going through a Stargate portal to a specific place, but only that one portal...)

    Using Bukkit 928, lockcraft 0.3.5

    @Crash any news on this?
  29. If I followed the instructions, changing 'BukkitContrib' must also be installed on the client side?
    The problem with the client side is that it opens all the possibilities hack right? no?

    What do you think?

    There is not another way to make the change on the server only? like any otherstandard plugin...
  30. Offline


    This part of BukkitContrib doesn't need the client addon. The client addon is optional, and is for things like the custom player skins, capes and so on :)
  31. Offline


    For your issue when the player is crafting you can try disabling the plugin and see if crafting works then. Otherwise I have no idea why anybody would be crashing. It could be a bukkitcontrib bug I'm not sure.

Share This Page