[INACTIVE][INFO] FindItem v0.1.2 - Ore (and more) locator [Outdated]

Discussion in 'Inactive/Unsupported Plugins' started by ursa_arcadius, Feb 8, 2011.

  1. Offline


    FindItem - A radius based item finder:
    Version: v0.1.2

    Displays to user the number of a particular item that can be found within a specified radius. Searches in three dimensions, tallying the number. Does not report where they are or which direction, just the number (otherwise that would be cheating a little too much)

    Very useful for searching for diamond or other ores so you can tell if you are in the right area or if you should move along. Soon admins will be able to configure which items can be searched for.

    Supports Permissions. Please make sure that you have permissions installed before using this plugin.

    • Simple command based searching
    • Supports item Ids as well as item names
    • Configurable for which materials can be searched for (Coming Soon)
    • Maximum search radius of 30 blocks to prevent lag (Coming Soon - adjustable)
    • /finditem [item name|item ID] [radius]
    Please do not post bugs or feature requests in this thread! Discussion and simple questions are perfect to put in the forum thread. Issues should go in the issue tracker on github- afteryou've searched to see if it's already there.

    Issue Tracker on Github

    Before You Post an Issue

    • Please make sure you're running an up to date Craftbukkit. I test using jars from this common repository, and the most recent version I've tested with is always listed in the thread title.
    • If you're going to report a crash or bug, please check your server log for any errors or exceptions and paste them in the report.
    Future Plans:
    • Add configuration file for which items are searchable
    1. Copy Jar file to plugins folder
    2. Add FindItem.finditem to permissions configuration file
    Download Here
    Source Code

    Show Spoiler

    Version 0.1.2
    • Added support for Permissions. Now requires the permissions plugin.
    Version 0.1.1
    • Initial Release
  2. Offline


    I'm at a loss as to what the first spoiler is for :p
  3. Offline


    Haha it isn't supposed to be there.
    Fixed it.
  4. Offline


    Nice! Assuming precious stones get updated this would be a very useful tool for tracking down missing or hidden protection blocks.
  5. Offline


    What do you mean they get updated?
  6. Offline


    precious stones is another plugin.
  7. Offline


  8. Offline


    [SERVER] 2011-02-24 10:04:46 [WARNING] Using the stupidly long constructor com.bukkit.ursaarcadius.FindItem.FindItem(PluginLoader, Server, PluginDescriptionFile, File, File, ClassLoader) is no longer recommended. Go nag the plugin author of FindItem to remove it! (Nothing is broken, we just like to keep code clean.)
    FindItem v0.1.2
    CB #449
  9. Offline


    Yea I was looking into that and couldn't get it to work without it. I will try again this weekend
    --- merged: Feb 27, 2011 12:27 AM ---
    So I have tried updating this so that it works again. I am getting this error:

    2011-02-26 16:21:36 [SEVERE] Could not load plugins\FindItem-0.1.5.jar in plugins: null
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:85)
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:129)
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:94)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:58)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:187)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:174)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:120)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:227)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.ClassNotFoundException: com.bukkit.ursaarcadius.FindItem.FindItem
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:30)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Unknown Source)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:72)
            ... 8 more
    Anyone able to decipher what the problem is? The stack trace does not seem very helpful.
    The source is on github, linked in OP

Share This Page