[INACTIVE][ECON] DMWrapper v0.14 - a DynamicMarket wrapper adding locations [617]

Discussion in 'Inactive/Unsupported Plugins' started by Magik, Feb 18, 2011.

  1. Offline


    DMWrapper v0.14

    DMWrapper.jar (GitHub Source)
    DynamicMarket.jar ( 0.4.8.magik.28 ) (GitHub Source)
    DynamicMarket Thread ( slightly outdated, I forked it and have been maintaining my own version )

    Plugin Requirements
    • DMWrapper 0.14 was tested against Craftbukkit build #677
    • DynamicMarket ( 0.4.8.magik.28 - Shaniqua )
    • Permissions 2.7
    • iConomy 4.6.3 ( this is what DynamicMarket was compiled against )
    I wanted DynamicMarket to be able to be locked down so that it wasn't a "global" shop command. This plugin enables that functionality by adding some /shop location commands. Basically you get to set up some locations in the world as shops, and you can restrict usage of the /shop to only those places. The plugin utilizes DynamicMarket's wrapper mode allowing me to pass commands as necessary to DynamicMarket. This plugin is just restricting location manager addon for DynamicMarket.

    HaloInverse's plugin thread can be found here: http://forums.bukkit.org/threads/econ-dynamicmarket-v-0-4-3-dynamic-price-shop-plugin-343.3266/

    Note: this has been barely tested, use at your own risk. And please for god's sake back things up before you try this! Any suggestions/comments are welcome, please post in this thread ( or an issue on github's issue tracker ).

    And thanks a ton HaloInverse for the great plugin that is DynamicMarket!

    Commands and Usage (open)
    Commands and Usage
    • /shop location - prints out the Usage for the location commands
    • /shop location enable - enables location-restricted shops
    • /shop location disable - disables location-restricted shops - DynamicMarket will work like normal here with a global /shop command
    • /shop location set - begins the shop location selection process - this will ask you to right click 2 corners to set the boundary box
    • /shop location cancel - cancels the shop setting process
    • /shop location remove <ID> - removes the shop location with id ID
    • /shop location check - tells you the shop location ID that you are currently in ( for deleting )
    • /shop location list - lists all the IDs of the shop locations
    • /shop location tp <ID> - teleports to the shop ID location
    Permissions (open)
    Permission Nodes:

    dmwrapper.location - allows usage of the /shop location command
    dmwrapper.admin - locations will not apply to a group with this node
    Installation Instructions (open)
    Installation Instructions:
    • Ensure you have DynamicMarket already installed and working ( with my latest compiled version here )
    • Add the permissions node to whomever you would like to be able to access the "/shop location" commands
    • Download the .jar - put it in the plugins directory
    • Once in-game ( with the location permission node ):
      • /shop location enable
      • /shop location set
    Changelog (open)
    • 0.13
      • recompiled against CB#617 for Minecraft 1.4
    • 0.12
      • CB #602 update, as well as permissions/iConomy for that RB
    • 0.10
    • 0.09
      • added better integration into /shop help
    • 0.08
      • fixed command collisions with DynamicMarket ( also fixed in DynamicMarket 0.4.8.magik.18 )
    • 0.07
      • added debug-mode to config
    • 0.06
      • better player tracking for entering/leaving messages
    • 0.05
      • better world tracking
    • 0.04
      • fixed embarrassing stupid command error
      • fixed /shop location being ignored when locations disabled in shop.yml
    • 0.03
      • Updated to support newer DynamicMarket ( 0.4.8.magik.15 )
      • Craftbukkit Build #522
    • 0.02
      • minor command related bug fixes
      • tweaked intercept command code
    • 0.01
      • Initial Release
      • Added basic location based functionality to DynamicMarket
    To-do (open)
    • Add custom/configurable messages for everything
    • Color up the current messages
    • Find a way to show the location command when passing /shop help to DynamicMarket
    • Add ability to pass administrative commands ( list/add/remove/etc... ) and ignore locations for those
    • Add ability to pass all commands if admin permissions?
    • Better handling of worlds ( currently I am assuming one world, and thus, this will probably break if you someone tries some sneaky things like setting one corner of a shop in one world, and another corner in another world ).
    • Fix getCenterOfShop() function to return calculated center instead of returning one of the set corners
    • Remove hard-coded plugin name/version/paths
  2. Offline


    @kingmob @imaxorz

    well... before anything trying to figure out if it's a plugin conflict... The first thing you should do is try it with the least amount of plugins as possible.

    I would try loading the server with just DynamicMarket, DMWrapper, Permissions, and iConomy

    absolutely nothing else - and if it doesn't work there, then try removing DMWrapper

    this could possibly be a problem with either DynamicMarket or DMWrapper... so I'd love to see how it runs with just the plugins above running

    Could someone who is having problems with this plugin and getting it to listen to commands, can you try running this version:


    Please remember to rename it to DMWrapper.jar

    I've added some more debug output... mainly looking at the PREPROCESS event and seeing if the event is being cancelled or something weird like that....

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  3. Offline


    Same results. Here's the output.

    2011-03-18 04:03:04 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /dshop Canceled? No
    2011-03-18 04:03:07 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /shop Canceled? No
    2011-03-18 04:03:22 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /shop help Canceled? No
    2011-03-18 04:03:29 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /dshop help Canceled? No
    2011-03-18 04:04:00 [INFO] Unknown console command. Type "help" for help.
    2011-03-18 04:05:00 [INFO] Unknown console command. Type "help" for help.
    2011-03-18 04:05:22 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /shop Canceled? No
    2011-03-18 04:05:24 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /dshop Canceled? No
    2011-03-18 04:06:00 [INFO] Unknown console command. Type "help" for help.
    2011-03-18 04:07:00 [INFO] Unknown console command. Type "help" for help.
    2011-03-18 04:07:41 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /dshop Canceled? No
    2011-03-18 04:07:43 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /shop Canceled? No
    2011-03-18 04:07:46 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /shop help Canceled? No
    2011-03-18 04:07:49 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /shop 1 Canceled? No
    2011-03-18 04:07:55 [INFO] [DMWrapper] DMWrapperPlayerListener.onPlayerCommandPreprocess(): Player: Bombg msg: /dshop 1 Canceled? No
    2011-03-18 04:08:00 [SEVERE] java.net.SocketException: Connection reset
    2011-03-18 04:08:00 [SEVERE]     at java.net.SocketInputStream.read(SocketInputStream.java:185)
    2011-03-18 04:08:00 [SEVERE]     at java.net.SocketInputStream.read(SocketInputStream.java:199)
    2011-03-18 04:08:00 [SEVERE]     at java.io.FilterInputStream.read(FilterInputStream.java:83)
    2011-03-18 04:08:00 [SEVERE]     at net.minecraft.server.Packet.b(SourceFile:113)
    2011-03-18 04:08:00 [SEVERE]     at net.minecraft.server.NetworkManager.f(SourceFile:155)
    2011-03-18 04:08:00 [SEVERE]     at net.minecraft.server.NetworkManager.c(SourceFile:9)
    2011-03-18 04:08:00 [SEVERE]     at net.minecraft.server.NetworkReaderThread.run(SourceFile:62)
  4. Offline


    So I have DMWrapper.jar v0.04 and DynamicMarket.jar (Magik) in /plugins/. Whenever DMWrapper is enabled, /shop doesn't work. However, it works fine without. Help please? No errors or anything.

    Permissions 2.5.4 (My permissions are set to '*')
    iConomy 4.4.7

    EDIT: Oh, and I tried the old-school way where you drop DynamicMarket to DMWrapper folder. Still nothing.

    And you need to use onCommand bud, onPlayerCommand is deprecated.

    Okay, now I'm running only DMWrapper, Permissions 2.5.4 and DynamicMarket. /shop works with DMWrapper, but all /shop location commands are unknown.

    EDIT: iConomy 4.4.7, CB#531, still the same.

    20:52:26 [INFO] Starting minecraft server version Beta 1.3
    20:52:26 [INFO] Loading properties
    20:52:26 [INFO] Starting Minecraft server on *:25565
    20:52:26 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-516-
    gdf87bb3-b531jnks (MC: 1.3)
    20:52:26 [INFO] Preparing level "world"
    20:52:26 [INFO] Preparing start region
    20:52:27 [INFO] [Permissions] version [2.5.4] (Phoenix) was Initialized.
    20:52:27 [INFO] [DMWrapper] Version [0.04] (Botswana) enabled
    20:52:27 [INFO] [DynamicMarket] version [0.4.8.magik.17] (Shaniqua) enabled
    20:52:27 [INFO] [DMWrapper] Successfully linked with DynamicMarket
    20:52:27 [INFO] [iConomy] Logging is currently disabled.
    20:52:27 [INFO] [iConomy] v4.4 (Arcadia) loaded.
    20:52:27 [INFO] [iConomy] Developed by: [Nijikokun, Coelho]
    20:52:27 [INFO] [DynamicMarket] iConomy connected.
    20:52:27 [INFO] [Permissions] version [2.5.4] (Phoenix)  loaded
    20:52:27 [INFO] [DMWrapper] Successfully linked with Permissions
    20:52:27 [INFO] [DynamicMarket] Successfully linked with Permissions.
    20:52:27 [INFO] [iConomy] hooked into Permissions.
    20:52:27 [INFO] Done (0,161s)! For help, type "help" or "?"
    EDIT2: Tried 4.4.6, no luck. /shop help still says /shop location there.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  5. Offline


    can any of you guys having problems please try running the server with only DMWrapper, DynamicMarket, Permissions, and iConomy running?

    where am I using onPlayerCommand?

    hrm... in my DynamicMarket eh? hrm... but that's not being used, it's old code - DM uses onCommand

    ok, I think I may have finally figured out this issue - I think it's a conflict between DynamicMarket and DMWrapper trying to register the same commands. I'm going to look into this, but I may have an answer later today

    ok, so I believe I finally figured out the problem. I made the incorrect assumption that if multiple plugins have the same command in their plugin.yml that bukkit would just go down it's list of plugins that registered that command trying to get a true response from any of them. But that was incorrect. It looks like bukkit just accepts the last plugin that tries to register a command.

    So to work around this, I made DynamicMarket in control of the /shop or /dshop commands, and wrapper plugins for DynamicMarket will have to register their wrapper through DynamicMarket, passing itself to DynamicMarket, so DynamicMarket has something to call when it gets a command.

    So hopefully this fixes the issues you guys were having. I think the problem was with the order the plugins were being loaded on our different machines ( though I can't explain why 2 centOS boxes would do something like file/directory listing differently... ).

    But can you guys ( @Juze @Bombg @imaxorz @kingmob ) try these new versions out?


    Sadly, with the way bukkit handles command registering and how I had to implement this, this will make this version incompatible with Andreas' unless he implements a similar wrapper interface.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  6. Offline


    Testing right now, seems to be working, but I had to download from the first message, to one form your message is a 200k file =)
  7. Offline


    i believe they are the same links hahaha?

    i just downloaded them, DMWrapper weighs in at 14.2 kB and DynamicMarket is 65.7 kB

    but I hope to hear the success or failure of this version for you ;)
  8. Offline


    Don't know if I'm doing something wrong here, but when trying to add, import, reload, export (admin functions) get a messagem saying that I do not have permissions to do so.

    [DMWrapper] DMWrapper.onCommand(): Player kingmob_hm Command shop args: reset

    And from the console came this:

    [DMWrapper] DMWrapper.onCommand(): Player kingmob_hm Command shop args: resetsay Backing up world: 'world'

    This is from a script that saves the world hourly.
  9. Offline


    You likely don't have the correct permissions set up for DynamicMarket?

    What Permission group are you in, and what permission nodes are set?

    Maybe you can just pastebin your permissions config here?

    those lines of output are some debug statements that were accidentally left in - they will be removed in the next iteration
  10. Offline


    As an admin - '*'
  11. Offline


    I just downloaded this and tried on my server with another player. He is in the default group, with limited permissions for DynamicMarket, whereas I am an admin. I have tried changing my permissions myself and after a permissions -reload all it correctly seems to deny my commands that I don't have access to.

    I can only really think that you have something with your permissions setup wrong.... You say that your Admin - '*' - now are you sure the group isn't Admins? Because that's the default group name IIRC - not Admin

    What exactly does it say when you have an issue?

    Also, when you type /shop help - on the line that says "topics: " ( or was it "commands: " ) - what does it list?

    can you do these commands:
    /shop help
    /shop help add
    /shop help location
  12. Offline


    /shop help:

    "-- DynamicMarket (Shaniqua) ----------------------
    () Optional, <> Parameter
    /shop help (<topic/command>) - Show help
    /shop <id>:)<count>) - Show buy/sell info on an item.
    /shop <command> <params> - Use a shop command.
    Commands: list buy sell info
    Shortcuts: -? -l -b -s -i
    Other help topics: ids details about
    /shop location"

    /shop help add:

    "-- DynamicMarket (Shaniqua): add ----------
    Unknow help topic: add
    Use /shop help to list topics
    /shop location"

    /shop help location:

    "-- DynamicMarket (Shaniqua): location ----------
    Unknow help topic: location
    Use /shop help to list topics
    /shop location"

    and in the console:

    22:25:52 [INFO] [DMWrapper] DMWrapper.onCommand(): Player kingmob_hm Command shop args: help
    22:26:03 [INFO] [DMWrapper] DMWrapper.onCommand(): Player kingmob_hm Command shop args: help add
    22:26:14 [INFO] [DMWrapper] DMWrapper.onCommand(): Player kingmob_hm Command shop args: help location

    Permissions 2.5.4 and working.
  13. Offline


    yeah, that's definitely looking like you don't have permissions set up correctly

    that help screen is what you get if you have no permission nodes set

    can you ensure you are in the correct Admin group and that it isn't mispelled incorrectly or has an extra, or is missing an s?

    you mind posting your permissions file - I can check it for you if you like


    actually looking at that again more closely, it appears you have these commands enabled in your permissions nodes:
    Commands: list buy sell info
    if you had no dynamicmarket/dmwrapper nodes enabled, then you should only see:
    Commands: list info
    if you truly had *, then you should have seen:
    Commands:  list buy sell info add update remove reload reset exportdb importdb
    that's what you should see if you do it from the console as well

    so it looks like you have dynamicmarket.buy and dynamicmarket.sell permission nodes, but possibly not access or the rest of the admin ones ( dynamicmarket.admin, and all of the dynamicmarket.items.* ). So yeah I still think you are in your default group, and not the admin group?

    On another note, I removed the debug statements ( well... hide them with a debug config toggle ), and integrated location better into the /shop help. So here's a new version release:


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  14. Offline


    Wow did I miss a lot. I need to try these for sure asap.

    I've been busy battling a lag problem due to some plug in and a plyer with illegal_stance error.

    Sorry for not keeping up, I feel like I need to with all the help you provide :)
  15. Offline


    That's exactly what I did in the post above your post. I'll try the new versions now. :)

    EDIT: Works like a dream now, thank you!
  16. Offline


    nice, great to know it's working for at least one of you guys that it wasn't working for before!

    let me know if you run into any other issues
  17. Offline


    Thanks Magik,

    it is really strange, permissions works here for all other plugins, except Dynamicmarket... I'll try to figure out what's happening.
  18. Offline


    So, it's a known issue that even people in the admin group only get the default commands? Can't even add items to my own shop D:
  19. Offline


    @Hunt800 @kingmob
    that seems odd? can you show me your permissions file?

    the admin group doesn't default to anything? unless you mean you have '*' set as a node - you have to set every permission node for dynamic market on it's own
  20. Offline


    I can guarantee I'm an admin since I have access to every command (and I got a ton of plugins), but if you need proof, here's my config for the admin group: (using Yeditor, so my yml looks a little different)
            default: false
            info: {prefix: '&4[Admin]&f ', suffix: '', build: true}
            inheritance: null
            permissions: ['*']
    and then for me:
            group: Admins
            info: null
            permissions: []

    EDIT: I have console access, so I can add stuff, but I need permissions so people can buy things.
  21. Offline


    Magik, is there a way so I, as an admin unique user, could set multiple shops with different items in each one?

    (I'm using DM through console, could I send you my permissions file trough email?)
  22. Offline


    That feature is not yet added, I've been thinking about it. And I definitely will go that direction in the future, I just don't know how bug-free DynamicMarket's separate shop support is yet - and I will have to add the feature itself to DynamicMarket as well. The past couple of days after getting DynamicMarket and DMWrapper working for the first time somewhat stably, I've been working on another new plugin idea ( it should be ready for beta consumption soon ) - iConomy based land protection - mark off your own cuboids, buy them with iConomy, and then have that land protected from others. You can follow my progress @ http://github.com/magik/iConomyLand

    In the plugins/DMWrapper/ directory there should be a config.yml. Can you hand edit it and change debug: false to debug: true

    and then re-load the server, and do a couple of /shop commands - copy/paste the entire console output from boot up into a pastebin and post it here. Can I also get your Craftbukkit, iConomy, Permissions, DynamicMarket, and DMWrapper version #s ( though if you do the pastebin from the server start, that should show them in there ). To be able to fix your problem, you have to help me be able to see the problem on my end so I can debug the issue - and as of right now, everything works fine on my end... So you'll have to hold my hand and get me to the point where you are.
  23. Offline


    Bug report: I can set up the shop locations just fine. Imports the shopDB.csv just fine. Can't list items or I get this:

    [INFO] shop list
    2011-03-20 18:07:30 [SEVERE] [DynamicMarket]: Error executing query statement [org.sqlite.PrepStmt@9719f4] with sqlite: java.sql.SQLException: SQL logic error or missing database
    2011-03-20 18:07:30 [SEVERE] java.sql.SQLException: SQL logic error or missing database
    2011-03-20 18:07:30 [SEVERE]     at org.sqlite.DB.throwex(DB.java:288)
    2011-03-20 18:07:30 [SEVERE]     at org.sqlite.DB.exec(DB.java:68)
    2011-03-20 18:07:30 [SEVERE]     at org.sqlite.Conn.commit(Conn.java:172)
    2011-03-20 18:07:30 [SEVERE]     at com.gmail.haloinverse.DynamicMarket.SQLHandler.executeQuery(SQLHandler.java:128)
    2011-03-20 18:07:30 [SEVERE]     at com.gmail.haloinverse.DynamicMarket.DatabaseMarket.list(DatabaseMarket.java:246)
    2011-03-20 18:07:30 [SEVERE]     at com.gmail.haloinverse.DynamicMarket.iListen.parseCommand(iListen.java:967)
    2011-03-20 18:07:30 [SEVERE]     at com.gmail.haloinverse.DynamicMarket.DynamicMarket.wrapperCommand(DynamicMarket.java:196)
    2011-03-20 18:07:30 [SEVERE]     at com.gmail.haloinverse.DynamicMarket.DynamicMarket.wrapperCommand(DynamicMarket.java:200)
    2011-03-20 18:07:30 [SEVERE]     at com.gmail.haloinverse.DynamicMarket.DynamicMarket.wrapperCommand(DynamicMarket.java:204)
    2011-03-20 18:07:30 [SEVERE]     at me.slaps.DMWrapper.DMWrapperPlayerListener.onCommand(DMWrapperPlayerListener.java:109)
    2011-03-20 18:07:30 [SEVERE]     at me.slaps.DMWrapper.DMWrapper.onCommand(DMWrapper.java:118)
    2011-03-20 18:07:30 [SEVERE]     at com.gmail.haloinverse.DynamicMarket.DynamicMarket.onCommand(DynamicMarket.java:185)
    2011-03-20 18:07:30 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:31)
    2011-03-20 18:07:30 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    2011-03-20 18:07:30 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:183)
    2011-03-20 18:07:30 [SEVERE]     at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:619)
    2011-03-20 18:07:30 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:582)
    2011-03-20 18:07:30 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:576)
    2011-03-20 18:07:30 [SEVERE]     at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-03-20 18:07:30 [SEVERE]     at net.minecraft.server.NetworkManager.a(SourceFile:230)
    2011-03-20 18:07:30 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    2011-03-20 18:07:30 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-03-20 18:07:30 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    2011-03-20 18:07:30 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    2011-03-20 18:07:30 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-20 18:07:30 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'shop' in plugin DynamicMarket v0.4.8.magik.20
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:33)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:183)
        at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:619)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:582)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:576)
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(SourceFile:230)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.AbstractMethodError: org.sqlite.PrepStmt.isClosed()Z
        at com.gmail.haloinverse.DynamicMarket.SQLHandler.executeQuery(SQLHandler.java:135)
        at com.gmail.haloinverse.DynamicMarket.DatabaseMarket.list(DatabaseMarket.java:246)
        at com.gmail.haloinverse.DynamicMarket.iListen.parseCommand(iListen.java:967)
        at com.gmail.haloinverse.DynamicMarket.DynamicMarket.wrapperCommand(DynamicMarket.java:196)
        at com.gmail.haloinverse.DynamicMarket.DynamicMarket.wrapperCommand(DynamicMarket.java:200)
        at com.gmail.haloinverse.DynamicMarket.DynamicMarket.wrapperCommand(DynamicMarket.java:204)
        at me.slaps.DMWrapper.DMWrapperPlayerListener.onCommand(DMWrapperPlayerListener.java:109)
        at me.slaps.DMWrapper.DMWrapper.onCommand(DMWrapper.java:118)
        at com.gmail.haloinverse.DynamicMarket.DynamicMarket.onCommand(DynamicMarket.java:185)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:31)
        ... 12 more 

    Using CB493. Startup info.

    [INFO] [iConomy] v4.4 (Arcadia) loaded.
    2011-03-20 18:07:14 [INFO] [iConomy] Developed by: [Nijikokun, Coelho]
    2011-03-20 18:07:14 [INFO] LocalShops: Attached to iConomy.
    2011-03-20 18:07:14 [INFO] [DynamicMarket] iConomy connected.
    [DynamicMarket] version [0.4.8.magik.20] (Shaniqua) enabled
    2011-03-20 18:07:14 [INFO] [DynamicMarket] wrapper mode enabled by DMWrapper
    2011-03-20 18:07:14 [INFO] [DMWrapper] Successfully linked with DynamicMarket
    2011-03-20 18:07:14
    [INFO] [Permissions] version [2.5.4] (Phoenix)  loaded
    Plugins: Questioner, Pumpkin Diver, LocalShops, iMonster, AutoMessage, DMWrapper, SearchIds, Fluid Dispensers, BackupPlugin, BorderGuard Lite (Square), Vampire, Reserved, MonsterTamer, RemoteToolkitPlugin, DynamicMarket, Citizens, QuickBelt, iConomy, MultiVerse, Lottery, Cleaner, Lockette, Informant, CraftBookCommon, Towny, Permissions, ServerEvents, WorldGuard, Minequery, NoCheatPlugin, DwarfCraft, WormholeXTreme, WorldEdit, LWC, dynmap, TelePlus, HeroBounty, iAuction, SignEdit, HelpPages, MyHome
    Here's my VPS specs:
    JRE version: 6.0_17-b17
    # Java VM: OpenJDK Server VM (14.0-b16 mixed mode linux-x86 )
    # Derivative: IcedTea6
    # Distribution: Custom build (Wed Oct 13 13:04:40 EDT 2010)
    VM Arguments:
    jvm_args: -Xmx900M -Xms900M -Xmn225M -XX:+UseConcMarkSweepGC -XX:+UseParNewGC
    -XX:+CMSIncrementalMode -XX:CMSIncrementalDutyCycle=100 -XX:+UseAdaptiveGCBoundary -XX:ParallelGCThreads=7
    java_command: craftbukkit.jar
    Launcher Type: SUN_STANDARD
    OS:CentOS release 5.3 (Final)
    uname:Linux 2.6.18-194.32.1.el5xen #1 SMP Wed Jan 5 19:32:33 EST 2011 i686
    libc:glibc 2.5 NPTL 2.5 CPU:total 2 (4 cores per cpu, 1 threads per core) family 6 model 23 stepping 7, cmov, cx8,
    fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1
    Memory: 4k page, physical 1048576k, swap 1048568k
    vm_info: OpenJDK
    Server VM (14.0-b16) for linux-x86 JRE (1.6.0_17-b17), built on Oct 13 2010 13:16:32 by "mockbuild" with gcc 4.1.2
    20080704 (Red Hat 4.1.2-48)
    And I'll be sending you my entire server.log in a private message since im not positive what's in there.

    Love this. Hope you can resolve my issue!

    edit: The only obvious thing I have different is CB 493 instead of 556. If this can be resolved without having to change build, +1000 Internets to you. If not, I'll see what I can do ... but all my other plugins work on 493. It's always a lovely pain in the butt to upgrade builds.

    UPDATE: Was able to update to CB Build 556 with no problems. Unfortunately, it did not fix this issue with the shop list command. I have admin permissions:

            default: false
                prefix: ''
                suffix: '[Admin]'
                build: true
                - '*'
            group: Admins
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  24. Offline


    http://pastebin.com/mJQgiWq0 I imagine there's a ton there that doesn't matter, but that's the log. Suddenly, I was able to buy/sell, so I'm going to go and experiment with different group permissions and see if that's still possible. However, I had to add to the shop using the console. :/

    EDIT: Now it's even weirder. Guests (who have no dynamicmarket permissions) can buy and sell as well
  25. Offline


    The idea is to create specialized shops, 14 pages of shop items can be boring to look at =)

    I'm looking at the DM database trying to find a way to link items to shop location ids in DMW...
  26. Offline


    oh I already know how to do it, it's just not implemented, I believe halo called it shoplabel
  27. Offline


    Could you do it? =)

    Please? =)
  28. Offline


    DMWrapper and DynamicMarket work for you with no problem right now?

    I'm just trying to figure out why it seems some people have issues with the plugin
  29. Offline


    Nope, DynamicMarket seems to ignore my permissions as an admin. Some time ago, when I was testing a previous version I remember that I had to put "- 'dynamicmarket.*'" in the Admins group for it to work since "- '*'" wasn't doing anything, like now. But with this newest Permissions you can't put any extra permission when you have '*'.
  30. Offline


    I can't fix your problem if I can't see the problem... And right now I can't see your problem on my end. Can you show me what I need to configure my plugins for to make it like that?

    The only way we are going to fix this is if you guys help me help you. I need to be able to see this problem happen on my side, and right now, I don't see anything. So let's make our 2 sides as close as possible. On my server I run it with a shitload of other plugins and permissions and everything and it works fine. But let's just ignore that for now. I want you guys to run the plugin with only 4 plugins in the plugins folder. Permissions, iConomy, DynamicMarket, and DMWrapper.

    That's it - not a single thing else. And tell me if you still have this problem. If you still have this problem at that point. I want you to zip up your whole minecraft directory - I want everything except for the world/nether folders. Specifically I want the server logs, I want craftbukkit.jar, and the above 4 mentioned plugins.

    Please do this, so that I can help you. Because right now I can not replicate any of these problems you guys are experiencing =(
  31. Offline


    Hey Magik!

    I'm here to report finally. I've had lag issues then decided to get a dedicated server, so I've been busy.

    I finally got to try out your latest builds you posted on page 3 in post #84.

    It seems to be working properly. I've set a shopping area and users are only able to shop in that area. Buying and selling seem to work fine with no errors in the console.

    I can't comment on Guests being able to use the shop though. As soon as I get a chance to test that I will let you know.

    I can too confirm now that users in the default or "Guest" group in my case can still use the shop without needing permissions.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016

Share This Page