[INACTIVE][CHAT] QuickShout v0.1 - Chat shortcuts! [556]

Discussion in 'Inactive/Unsupported Plugins' started by Izze, Mar 22, 2011.

  1. Offline


    QuickShout v0.1 - Chat shortcuts!

    Have you ever tried to warn your friend for a Creeper that's behind them, but failed because of your slow reflex and writing speed? Have you ever wanted to shout "DIAMONDS!" the very second you find them? This plug-in will give you exactly this!

    • Use chat shortcuts!
    • Remove them if you want to!
    QuickShout enables each user to define certain chat shourtcuts with a /set-commando. When the user submits one of his/her set chat shortcuts, it will be replaced with what the shortcut is set to.

    To set a chat shourtcut you use the /set-commando like this:

    /set <shortcutName> <replacement string which can contain spaces>

    The shortcut name can be anything; letters, numbers or even words or other combinations that does not include any spaces. The replacement string can, however, include as many words and spaces as you whish.

    Here's an example. Let's say I use the set commando:
    /set 1 CREEPERS!

    If I then type "1" in the chat and send it, it will turn into "CREEPERS!".

    If you want to remove a chat shortcut you just write /set and the name of the command. Like this:
    /set 1
    This will remove the chat shortcut that is set for "1".

    Each player has an unlimited amount of chat shortcuts. They are saved in a file which is created the first time you use this plugin.

    Download QuickShout v0.1

    Change log:
    Version 0.1
    • Initial release
    Known bugs:
    • None so far
  2. Offline

    Mmm Octopie

    I dont think it works I set the thing and when I try to type 1 in chat it just pops up 1 not what I typed also I tryed /1 and it didnt do anything.
  3. Offline


    It works great for me with CB 556, awesome plugin! Now I can easily warn my friends for creepers :D
  4. Offline


    Which Craftbukkit build are you using? Does it say "Command '1' set to 'xxx'" when you use the set-command?
  5. Offline

    Mmm Octopie

    I am on 544 I just relised it was for 556 sorry :(

    ok just updated to 556 it works now

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  6. Offline


    Great! :)
  7. Offline


    Can you please update to CB 602? Thanks!~
  8. Offline


    It still works for me with the latest RB 617. Try to download that build :)
  9. Offline


    Will do, thanks!
  10. Offline


    Doesn't work for me; Latest Build
    ... I type /1 and it says "Unknown Command"
  11. Offline


    No /, just "1".
  12. Offline


    considered inactive

Share This Page