[INACTIVE][ADMN] SpawnMob v1.4.1

Discussion in 'Inactive/Unsupported Plugins' started by xmlns, Jan 23, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I used hey0's /spawnmob command a lot, and I haven't found /spawnmob for bukkit, so I created my own. This plugin uses nijikokun's Permissions plugin if you have it; otherwise, it uses ops.txt. Most plugins are built with bukkit.jar in the path, but SpawnMob is built with craftbukkit.jar so that it can call functions not in the API. Thanks to NathanWolf for saying to use world.a(e) because I was unable to get this to work until I saw his post. (This doesn't let me upload jarfiles so I put the plugin in a zip.) Source

    /spawnmob <mob name>[:<slime size> || ;<mob that is riding>] [amount of mobs]
    This syntax is probably confusing, so I'll give some examples:
    - /spawnmob Chicken;Giant 5 will spawn a giant riding a chicken
    - /spawnmob Slime:5 will spawn five huge slimes
    NOTE: Right now, you can't spawn slimes riding other mobs or vice versa.

    /mspawn <mob name>
    while looking at a mob spawner.

    Mob List:
    -Giant (not in /mspawn)
    -Slime (not in /mspawn)

    - spawnmob.spawnmob.<mob type || mob category (friendly || neutral || enemy)>
    - spawnmob.mspawn.<mob type>
    - spawnmob.spawnmob.neutral
    - spawnmob.mspawn.pig
    NOTE: Permissions is case-sensitive, so you have to type 'spawnmob.spawnmob.pig' and not 'spawnmob.spawnmob.Pig' or 'SpawnMob.spawnmob.pig'.

    Allow slimes to ride and be ridden.
    Allow the spawning of mobs riding other mobs.
    Allow the changing of mob spawner types.

    Now 1.4.1!
    -Attempted to fix a bug involving Permissions.
    -Fixed Giant spawning.

    -Mobs spawn at the pointer.

    -Updated to the newest version of Permissions. You have to update too.

    -Just another fix for a bug caused by my carelessness. The bug was that I didn't catch a NoClassDefFoundException when Permissions wasn't found.

    -I realized that I had never called the setupPermissions() method, causing the plugin to use ops.txt instead. Fixed.

    -Fixed PigZombie spawning.
    -Added the ability to spawn mobs riding other mobs.

    -Added /mspawn using toimelin's TargetBlock.java.
    -Changed Permissions.

    -Added variable slime sizes with "/spawnmob Slime:size" (any integer greater than one works)
    -Instead of saying "2 Pig(s) spawned." and "2 Sheep(s) spawned." it says "2 pigs spawned." and "2 sheep spawned."
    -Permissions are more customizable, i.e. "spawnmob.squid" or "spawnmob.neutral"

    Known bugs:
    -Slime size rendering
    -A mob spawner will continue to spawn pigs after its type is changed. The pigs will be invincible and will disappear on a chunk reload. This is similar to the mob spawner behavior on a server with animals off.

    New Project Link:


    Attached Files:

    Nick Foster and MationMac like this.
  2. Offline


    Hm. >:

    This boots up with an error and then breaks my Spells and WordEdit plugins.
  3. Offline


    Thank you for addressing the issue. I will be trying it out later today :)
  4. Offline


    What is the error message?
  5. Offline


    Check it.

    Attached Files:

  6. Offline


    Having problems. The mob spawners keeps spawning pigs that you can't kill and only sometimes spawns what it has been set too. Also, the rotating pig inside the spawner doesn't change to indicate what it should spawn.
  7. Offline


    Oh my goodness I apologize for missing the note. Sorry for wasting your time, I have a knack for missing key details in posts. xD

    I had just assumed that the plugin relied solely on Nijikokun's permissions plugin because it threw me an error regarding her permissions plugin on server start up.

    Here's the error:

    SEVERE: com/nijiko/Messaging (Is it up to date?)
    java.lang.NoClassDefFoundError: com/nijiko/Messaging
            at org.bukkit.xmlns.spawnmob.SpawnMob.setupPermissions(SpawnMob.java:35)
            at org.bukkit.xmlns.spawnmob.SpawnMob.onEnable(SpawnMob.java:49)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:135)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:60)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:45)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:153)
            at net.minecraft.server.MinecraftServer.c(MinecraftServer.java:140)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:104)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:177)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    Caused by: java.lang.ClassNotFoundException: com.nijiko.Messaging
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClassInternal(Unknown Source)
            ... 12 more
  8. Offline


    1.3.2 is out! It fixes the bug above.
    --- merged: Jan 26, 2011 3:53 AM ---
    Yeah, changing mob spawner types is glitchy for now.
  9. Offline


    I wouldn't suggest spawning slimes as of yet, The one i spawned seemed to be invincible, until i put it in a cuboid of lava, then built a glass box before removing lava....... Theres now 8 Invincibles...
  10. Offline


    You could've just exited then rejoined the server. The slimes would've disappeared if you did that. xD
  11. Offline


    I don't understand how this works... I put the .jar into my plugins folder, Nothing spawns when i use it so i search " nijikokun's Permissions plugin " i can't find the plugin and there is no link to it.. What am i meant to do..
    --- merged: Jan 26, 2011 5:50 AM ---
    Nvm fixed it
  12. Offline


    That didnt do anything, Its a mob server-wide not just on my screen, i relogged and it was larger.
    --- merged: Jan 26, 2011 6:38 AM ---
    And what are all mobtype names available, could i get a list of proper name format
  13. Offline


    You think it would be possible to find a way around that? I'd really like to spawn monsters without changing the monster setting of my server.
  14. Offline


    I will post that.
    --- merged: Jan 26, 2011 12:55 PM ---
    I'd need to do a full server mod for that, sorry.
  15. Offline


    any chance you are running on peaceful? i had this problem with the hey0 version of spawnmob. We still have a glass cage with lava in it, saying 'In case of INSANITY break glass'. (it used to be full of slimes).. they eventually died off while the server was empty/offline.
  16. Offline


  17. Offline


    ssem to be starting to die off, it died then became 8 little friendly slimes that could only push.
    --- merged: Jan 26, 2011 2:30 PM ---
    Anyluck with spawnlist
  18. Offline


    Sorry, I had forgotten about that. Just posted it.
  19. Offline


    when i try /spawnmob Slime 10 it says you cannot use this command i putted myself in the permisions config so why it doesent work?
  20. Offline


    Glad you read my post'"S"

    Theyre very unreliable, once they kill you they may grow shrink, go invisible, I wouldnt suggest it
  21. Offline


    Ok before you all start telling me to read all the posts. Let me just say I have read them all several times. I can't seem to get this to work with Permissions version 1.9 . I updated today to spawnmob version 1.3.2 my server loads with no errors. I have added the permissions to the admin group in my config.yml file :

    - 'spawnmob.spawnmob.*' with and without the single quotes with and without the * as a wild card and no matter what I put when I'm in game and type /spawnmob Chicken 1 I get an error that I'm not able to use that command and the server console displays that I tried to use an unknown command.

    if I just type /spawnmob I get a reply about the correct usage of /spawnmob <mobtype> (amount) so I think it's installed correctly. *note even though I get the reply the server still says I tried an unknown command*

    if I remove the permissions plugin and just use the ops.txt file, all is good.

    however, I would like this to work with the permissions plugin

    so can someone tell me what I'm doing wrong and how to get it working?
  22. Offline


    I just have - 'spawnmob.*' in there and it works fine with build #135

    You sure you have no tab in that line? Tabs are apparently bad.
  23. Offline


    thanks for the quick response. I'm looking to check my build # I downloaded the latest snapshot of craftbukkit just to make sure.
    I also thought I might have a tab in the file, so I re-downloaded the plugin to get a clean config.yml and retype everything. I did not copy and paste or use the tab key. so I'm at a loss. I've had that exact line - 'spawnmob.*' in my config.yml under the Admin: group and I still get the " not able to use that command" I will try again and see if I just did it wrong.

    also is there an easy way to find out what my build number is? when my server loads it says beta version 1.2_01
  24. Offline


    1.2_01 is your Minecraft client, not the Craftbukkit build, but I have no clue how you can find out which build you are using.
  25. Offline


    I found out how to get my version number you just type /version in game and it displays the server version and running plugins. I will attempt to upload mine.

    Attached Files:

  26. Offline


    I have the same version number and I'm pretty sure so does EVERYONE, no matter which build # they're using.

    Builds run from #1 to 150 at the moment and I'm using #135. You should learn what build you are using, but as I've said, I have no clue how.
  27. Offline


    1.3.3 is now out. It should fix this.

    BTW, I might not be online for a while; I have a huge history essay.
  28. Offline


    Thank you for making this plugin! I really need to try this out. Now I can get back to making my creeper carousel! lol

    Anyone else having trouble with spawners spawning pigs that aren't really there? They are only visible to you, can push you around, but you can't hit them. They disappear after a relog, but it's a terrible bug. It just keeps spamming these ghost pigs.
  29. Offline


    That's already in the "known bugs" section.
  30. Offline


    Thanks, and good luck on your essay. But when you get back online I just want to let you know after updating to 1.3.3 I'm still having the same issue.

    I would be happy to provide any information you would be willing to look at (logs, files)
  31. Offline


    It would be great if you could provide your Permissions config and your server log.
Thread Status:
Not open for further replies.

Share This Page