[INACTIVE][ADMN/SEC/WEB] DataLog - replaced by HawkEye [1000]

Discussion in 'Inactive/Unsupported Plugins' started by oliverw92, Apr 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Vaupell, Pinkpixels, Sleaker and 2 others like this.
  2. Ah. I never tried it when I didn't have one in my inventory, I just noticed that it didn't automatically replace the one in my hand like bb does.

    *tries it*

    Ok, it does just that, but doesn't take it back. I guess that if someone is trusted enough to have the ability to use it, they aren't going to abuse it to get infinite wood, ignoring the fact that it's not exactly the most efficient way to get unlimited wood. :)

    Thanks for the response!
  3. Offline


    If you like, I could make it swap the two items over so it moves the wood into your hand.
  4. Personally, now that I understand the reasons for the way you implemented it, I don't see any reason to change it. But that's me. :)
  5. Offline


    I'll see what I can come up with - what i mean by move it is simply move the wood to the slot that you are currently holding and the item that was in that slot to where the wood was.
  6. Ah, I understand now. Swapping the inventory slots back and forth might work.

    However, this approach brings up a new question, what happens if the player calls for the tool, doesn't have a log, and the inventory is full?
  7. Offline


    I already have a work around on that - it drops it infront of you
  8. Offline


    Downloading only the JAR file won't update (mc server) config file. Goddammit, i'm suprosed about these blacklist rules -that's just awesome! :)

    But tell me, u got this in ur wiki (in patterns):
    Are you sure that it will match hello world? It should match to infinity!
  9. I have a small problem with the webapp.
    While its working perfectly on my local machine, when i upload it on the server (after changing db user/pass etc), then it wont return any results.

    I search for something and results bar is loading forever.

    Its installed in a subdirectory, it doesnt matter does it ?

    Needs any specific php.ini settings ?

    Edit: My bad...had to update php and mysql ( i had 5.1.6 so json wasnt working...updated to 5.3 and everything is fine)
    Bronski likes this.
  10. Did something change on the latest update ?

    Cause i got this weird error:

    2011-07-08 11:08:05 [SEVERE] Error occurred while enabling DataLog v1.0.3 (Is it up to date?): Query threw SQLException:[SQLITE_ERROR] SQL error or missing database (no such table: INFORMATION_SCHEMA.COLUMNS) Query was:
    javax.persistence.PersistenceException: Query threw SQLException:[SQLITE_ERROR] SQL error or missing database (no such table: INFORMATION_SCHEMA.COLUMNS) Query was:
        at com.avaje.ebeaninternal.server.query.DefaultRelationalQueryEngine.findMany(DefaultRelationalQueryEngine.java:211)
        at com.avaje.ebeaninternal.server.core.RelationalQueryRequest.findList(RelationalQueryRequest.java:102)
        at com.avaje.ebeaninternal.server.core.DefaultServer.findList(DefaultServer.java:1519)
        at com.avaje.ebeaninternal.server.core.DefaultServer.findUnique(DefaultServer.java:1484)
        at com.avaje.ebeaninternal.server.querydefn.DefaultRelationalQuery.findUnique(DefaultRelationalQuery.java:89)
        at uk.co.oliwali.DataLog.DataLog.setupDatabase(DataLog.java:122)
        at uk.co.oliwali.DataLog.DataLog.onEnable(DataLog.java:73)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:857)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:264)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:151)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:136)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.sql.SQLException: [SQLITE_ERROR] SQL error or missing database (no such table: INFORMATION_SCHEMA.COLUMNS)
        at org.sqlite.DB.newSQLException(DB.java:383)
        at org.sqlite.DB.newSQLException(DB.java:387)
        at org.sqlite.DB.throwex(DB.java:374)
        at org.sqlite.NativeDB.prepare(Native Method)
        at org.sqlite.DB.prepare(DB.java:123)
        at org.sqlite.PrepStmt.<init>(PrepStmt.java:42)
        at org.sqlite.Conn.prepareStatement(Conn.java:404)
        at org.sqlite.Conn.prepareStatement(Conn.java:399)
        at org.sqlite.Conn.prepareStatement(Conn.java:383)
        at com.avaje.ebeaninternal.server.lib.sql.PooledConnection.prepareStatement(PooledConnection.java:426)
        at com.avaje.ebeaninternal.server.lib.sql.PooledConnection.prepareStatement(PooledConnection.java:396)
        at com.avaje.ebeaninternal.server.query.DefaultRelationalQueryEngine.findMany(DefaultRelationalQueryEngine.java:102)
        ... 16 more
    and i checked the inf_sctema....all tables and columns are there.
  11. Offline


    I get this err pls help:
    2011-07-08 19:26:47 [SEVERE] [DataLog] Error whilst attempting to get connection: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
  12. @sandbird: So running that SQL listed in the error (
    SELECT * FROM INFORMATION_SCHEMA.COLUMNS WHERE TABLE_NAME = 'datalog' AND COLUMN_NAME = 'plugin') does find something?

    @tombik: That's pointing to a problem talking to the SQL server. Verify that you can connect to the server using the username and password you set up in the datalog config.
  13. Offline


    i love your plugin...

    it helps me where logblock and bigbrother failed: in a simple way you let the plugin connect to my mysql db and its finally working ... i love the webpanel so much.

    all in all its almost perfect, except this:

    for unknown reasons, the group exceptions doesnt work.
    neither for me, an admin or anybody else.
    i use recent permissions.

    this is my rules segment:

            - block-break
            - block-place
            - item-drop
            - item-pickup
            pattern: \b(8|9|10|11|46|51)\b
            warn-message: '&cStop trying to use %MATCH% - it is an illegal item!'
            notify-message: '&c%PLAYER% &7is attempting to use illegal item &c%MATCH%&7'
                warn: true
                notify: true
                kick: false
                deny: true
            - Admins
            - Moderator
            - VIP
            - Member
    the blocking, warn and denying does work, but the excluding doesnt.
    any clue?
  14. Offline


    We dont' have any errors on startup or in general, but DataLog just stopped logging actions about 2 days ago. Could a corrupt table cause something like that? I know the rest of the DB is still functioning.
  15. Offline


    I got this bug one time. You have to repair the table with Phpmyadmin.
  16. Hmm... Around 7:30 this morning (my time), I found the following error on the console:
    07:27:34 [SEVERE] [DataLog] Error whilst attempting to get connection: com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Too many connections
    07:27:34 [SEVERE] Exception in thread "Timer-0"
    07:27:34 [SEVERE] java.lang.NullPointerException
    07:27:34 [SEVERE]       at uk.co.oliwali.DataLog.database.CleanseUtil.run(CleanseUtil.java:75)
    07:27:34 [SEVERE]       at java.util.TimerThread.mainLoop(Timer.java:512)
    07:27:34 [SEVERE]       at java.util.TimerThread.run(Timer.java:462)
    (Yes, I know what it means :) )

    It's 11:40AM now, and looking at the number of connections to the DB, I see 104 with 89 of them being datalog, all of them being in a sleep state. Is this amount of connections expected due to it potentially having to log multiple things at once? And does it recover from this state? I can always increase the number of connections allowed to the SQL, but this wasn't exactly expected either.
  17. Offline


    I'm getting error when i'm try use /dl tool. When i'm punch a block getting error:

    2011-07-09 21:22:31 [SEVERE] [DataLog] Error executing MySQL query: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND x = -124.0 AND y = 71.0 AND z = -55.0' at line 1
    What's wrong?


    OK, i'm solved this. It's just permissions error.
  18. Offline


    @oliverw92 I am using PermissionEX.
    Tried to add datalog.tool to Mod group I have but when they typ e /dl tool it says /dl help :/
    Tried to add datalog.* too - same problem.

    OPs have no issues. I think that the plugin don't support PermissionEX?
  19. Offline


    Just wanted to say thank you!!! My server would be utter chaos without this plugin! Pls keep it updated :), it would be so sad to see this go inactive!
  20. Offline


    Your changelog hasn't been updated to include what you have added since 1.2
  21. Offline

    The Wizard

    When I use lava to kill a player it doesn't log that lava as lava bucket.
  22. Offline


    Oops, typo :p

    Why are you on DataLog v1.0.3?

    Uhm that looks more like an issue with your database server. Is the database on the same computer as the minecraft server?

    Interesting, I will check it out. Thanks for the bug report.

    Interesting, are you running the latest version? I will look into it and monitor connection usage on my server.

    It definitely supports PermissionsEx - my server uses it fine. Make sure you are on the latest version for all. If this doesn't work, try setting up a server with just datalog and PermissionsEx to see if the issue is still there.

    Thankyou :) I have no plan for this to go inactive - my server uses it too much!

    Thanks, i'll fix that.

    So it logs the death as death by lava, but doesn't log you placing the lava?
  23. Offline

    The Wizard

    Yes :)
  24. Offline


    Does the plugin log you placing lava at all?
  25. Offline


    Did you find out what happened with my problem? Another recent griefer came along and did massive damage. I just want to rollback everything they did from the time they logged on.
  26. Offline


    Is it not fixed the latest version? I thought i fixed rolling back an entire player.
  27. Offline


    I mean when i type /dl rollback p:bruises it says attempting to rollback 0 results and stuff
  28. Offline


    Please try not to multi-post - use the edit button instead.

    I will check out if threading is working ok.
  29. Offline

    The Wizard

    Yes, also if I place lava under my feet the plugin logs it. But if i put lava over a player the plugin won't log it.
  30. Offline


    Interesting, I think I have an idea why.
  31. Offline


    I am having an issue where when I try to rollback anything more that about 1000 entries my server crashes.

    16gb of ram on the server, newest RB, newest datalog.

    Thanks =)
Thread Status:
Not open for further replies.

Share This Page