[INACTIVE][ADMN] IPGet v0.5 - Allows OPs to see the IP address of other players [860]

Discussion in 'Inactive/Unsupported Plugins' started by Yoharnu, Apr 4, 2011.

  1. Offline


    IPGet - IP Acquisition:

    Version: v0.5
    Allows OPs to see the IP address of other players. It's that simple. I created it to help ban players by IP.

    • /ip Player = returns Player's IP address
    • /ip = returns your IP address
    • Keeps logs of players login times and IP addresses
    To install, simply copy the IPGet.jar to your plugin directory and start CraftBukkit normally.

    Download The Plugin (.jar)
    Source Code


    • IPGet.self - player can get their own IP
    • IPGet.other - player can get the IP of another player
    To do:
    • Change Permissions to have a different permission for getting your own IP
    • See a player's last known IP if that player is offline
    • Implement "/ip ban <player>"
    • Alert OPs (or people with permission) when two players are logged in with the same IP
    • Find "known associates" of a player. "/ip ka Player1" displays "Player2 is a known associate of Player1" if they have ever logged in from the same IP
    Version 0.5 - June 16, 2011
    • Added ability to see a player's last known IP if that player is offline
    Version 0.4 - April 09, 2011
    • Changed Permissions
    • Added log to track players' login times and IPs
    Version 0.3 - April 09, 2011
    • Fixed a problem where servers without Permissions couldn't run the plugin
    Version 0.2 - April 08, 2011
    • Added support for Permissions
    • Add IPGet.* or IPGet.getIP to Permissions to be able to use /ip
    Version 0.1 - April 05, 2011
    • Initial Release
    Finer1, finchson, Wolf and 3 others like this.
  2. Offline


    I will try this. :)
  3. Offline


    Great job... works like a charm:cool:
  4. Offline


    Finally ! Someone created this. Great work
  5. Offline


    Hey, i was looking forward for a Plugin like this.

    But, could you please add Permissions support? :)
    As it is needed for Servers that use Authorize, AnjoAuth, xAuth and others.

  6. Offline


    Yeah, that's my next move. I'm new at this, so I have to figure out permissions, but I'll have it as soon as I can.

    Added Permissions support, and I plan to expand on it a bit in 0.3 (see "To do" in first post)
  7. Offline


    Okay, I am really annoyed. I have tried every plugin, but nothing is working for me. I put this in the plugins foler, started my server, and typed /ip and NOTHING HAPPEND!? As you can tell, I am new to this, but what am I doing wrong?
  8. Offline


    Thank you!
    Works for me.
    Feature request- A log file of players that have logged on with time and ip stamp.
  9. Offline


    Thank you, it is necessary. Good work

    MacVaultDweller, is my Ruby script that writes to a file from server.log IP for all players. Its not hard to transform into other languages​​, everything is done RegEx. Java supports a RegEx?

    My English is terrible ...
  10. Offline


    It should work after you've started your server with it in the plugins folder. Check the server logs to make sure it says "IPGet v0.2 is enabled" at startup
    Or if you're using permissions, make sure you've given yourself permission to use "IPGet.IPGet"
    Do you think it should keep a log of every time they log in? or just one log of everyone's login time and ip? (meaning, overwrite their time/IP every time they log in)
  11. Offline


    I think every time they log in time stamped and ip address would be very useful information.
    Overwriting would mean the loss of valuable info.
  12. Offline


    Okay. You can hope to see that in the next release
  13. Offline


  14. Offline


    sorry, just wondering if you have a version of your plugin that doesn't need Permissions plugin installed, I don't run it since I have a small server but would like to be able to IP look up.
  15. Offline


    My plugin doesn't require permissions. It just uses it if you have it.
  16. Offline


    I'm running RB 617 when I started the server I got this(posted below) and was concerned and when I try the command it says "internal error occurred while attempting to preform this command" just typed /ip

    23:53:23 [SEVERE] com/nijikokun/bukkit/Permissions/Permissions loading IPGet v0.2 (Is it up to date?)
    java.lang.NoClassDefFoundError: com/nijikokun/bukkit/Permissions/Permissions
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.JavaPluginLoader.getClassByName(JavaPluginLoader.java:145)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:32)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
        at org.yoharnu.IPGet.IPGet.onEnable(IPGet.java:34)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:514)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:216)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:94)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:72)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    Caused by: java.lang.ClassNotFoundException: com.nijikokun.bukkit.Permissions.Permissions
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
        ... 25 more
  17. Offline


    Thanks for bringing this to my attention. It should be fixed now.
  18. Offline


    Should I just re-download the plugin? n/m I just read the top post.
    Thanks for fixing the issue
  19. Offline


    It logs IPs now =]
  20. Offline


    Thanks just tried it out works fantastic!
  21. Offline


    One question, Doesn't the console command "ban <user>" ban users by IP? or basically prevent them from rejoining the server?
  22. Offline


    That just bans the name. For offline servers, the player can just rejoin under a different name.
  23. Offline


    Please enable the option to use this to ban ips. All of my plugins got rid of the ipban feature because it was useless, until now! =)
    (or some1 can tell me what still has ip ban option
  24. Offline


    There are plugins that REMOVE ban-ip?
    I don't know of any... are you SURE ban-ip doesn't work?
    (replace with the actual offender's IP)
  25. Offline


    Phantom I run with out any physical OPs. all Ops get permissions directly from permissions plugin. Which means they only have the commands plugins give, and over the past few updates all my plugins dropped "/banip, /ban-ip" support.
  26. Offline


    Download link is broken :p
  27. Offline


    I may add that. I will at least look into it.
    I just checked it, and it works for me.
  28. Offline



    I also tried to download whenn he posted it wasnt working and got the github error screen with the unicorn.
  29. Offline


    It works now, though, right? Problem with github, I guess
  30. Offline


    Yup, works now, thanks!

Share This Page