[INACTIVE][ADMN/INFO] BukkitUpdater v0.2.7.57 - Shows outdated plugins and more [1060]

Discussion in 'Inactive/Unsupported Plugins' started by zauberstuhl y33, Jul 19, 2011.

  1. Offline

    zauberstuhl y33

    wassilij and BadgerLove like this.
  2. Offline

    bartsmit41

    This looks nice gonna try it on my server tommro because I'm so sleepy now

    Good job

    Also if you wouldbe willing to develop a plugin for me that would involve a castle siege withacastle battlefield and a siege camp the point would be to kill every one in the castle who get 3 lives and the people in the castle try to kill the enemy it gets more complicated if you would like to hear more and do it for my rpg fantasy medieval server then post back and I can add you on Skype and we can talk


    That's a really nice plugin I will definitely use it tommro thanks in advance

    Bart
     
  3. Offline

    Mhalkyer

  4. Offline

    bartsmit41

    This one doesn't download new files at least I think that's the difference lol
     
  5. Offline

    zauberstuhl y33

    right! the plugin is under development for full update support.
    meaning: update plugins with one command from minecraft-gui

    at the moment the only feature is ...
    regards
     
  6. Offline

    VeryInsane

    Personally, I'd prefer this over CraftBukkitUpToDate because it's simple, and easy, not cluttered.
    I don't want everything CraftBukkitUpToDate has-- this is perfect for me. ;)
     
  7. Offline

    jeffreylec

    This is a cool idea. I like that it doesn't auto-update for you, just lets you know that there are updates. The commands are easy and the list is awesome.
     
  8. Offline

    Master_Rudik

    Looks awesome. Gonna give it a shot.
     
  9. Offline

    bartsmit41

    so are you interested in making that plugin for me?
     
  10. Offline

    Smex

    You should make the auto-updating than configurable, when you implemented it.
    Cause it's better when a server admin can test the new
    update of a plugin before it comes on the real server.
    anyways, it works great.

    Cheers
     
  11. Offline

    Maazias

    Thi with a disableable autoupdating feature = AMAZING!
     
  12. Great work! I can't wait to give it a good run through.
     
  13. Offline

    Oscarius

    How I'd like this plugin to act (and how CButD should):

    1. Random Plugin is updated.
    2. BukkitUpdater notifies an OP when he logs in
    3. OP does /bu update RandomPlugin
    4. New plugin is downloaded and moved to /plugins, old one is moved to /plugins/backup
    5. Done! All that's needed is a restart.

    Good plugin. Looking forward to future releases.
     
  14. Offline

    quickclay

    Cool plugin. Feature request would be to display the "local version" and "current version" of a plugin so we can see what version number to upgrade to, or why a plugin is reading out of date when our version number looks to be the highest. Thanks!
     
  15. Offline

    zauberstuhl y33

    This is it :) Im actually working on a plugin-static-link database after that it is possible to update the plugins the way you described.

    yes, will be added thanks

    cheers
     
  16. Offline

    Hamad

    Awesome, no more check my huge "plugin folder" for updates, really apreciated. Oh!!!! And could you upload supported plugin list text file at dropbox (i guess)
    Thanks,
    Hamad
     
  17. Offline

    noahwhygodwhy

    this is exactly what i need, but i installed it, and all the events suddenly couldn't be handled. and my server crashed...i would post the error, but i would have to replicate it, and it corrupted a chunk, downtown in a major city...
     
  18. Offline

    FoX_AaZzA

    are there any commands for this?
     
  19. Offline

    zauberstuhl y33

    which server version?

    this is not possible ;) my plugin has only some playerjoin-events and a web-request function.
    please assure you that no other plugin running amok with you

    Done the list is growing ;)

    /u2d
    /u2dreload

    but if there is a update the plugin shows you what command you need.

    cheers
     
  20. Offline

    Hamad

    Hello, Its working ok, when I typed u2d I got Updates from:
    MobArena
    LockPick
    Vampire
    So I downloaded them and updated them, it came out Vampire And Lockpick are the same version that I have, only mob arena has a new version, then I restarted my server, entered in, and said i have new updates:
    LockPick
    Vampire
    and I already updated them (which are same version I have), i typed u2dreload, still the same, I guess its a bug

    Hamad.
     
  21. Offline

    Cognito guy

    So who gets to see the plugin interface, and can use the commands? only ops or everyone?

    Also:
    strangely it says there's an update for bukkitupdater itself although there's not :s
    it also does this for regios
     
  22. Offline

    zauberstuhl y33

    i had a look at this and the problem is for the name vampire exists two plugins.
    i think you have the plugin version:
    [MECH/FUN] Vampire v3.3 - The horror continue on your server [766]

    thats a bug yes i'm working on it thanks.

    Lockpick should work well. can you post me the plugin version number which are displayed for lockpick on your server log?
    ty

    only op's can update and refresh the local database.
    also there is an update 0.2.0 :)
     
  23. Offline

    Hamad

  24. Offline

    Cognito guy

    Thanks!

    Can you also enable the command to run in the console?
     
  25. Offline

    V10lator

    +1

    But currently it's not running at all (for me):
    Code:
    2011-07-21 19:39:56 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'u2d' in plugin BukkitUpdater v0.2.0
    	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    	at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    	at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    	at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    	at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NullPointerException
    	at zauberstuhl.BukkitUpdater.BukkitUpdater.onCommand(BukkitUpdater.java:58)
    	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    	... 12 more
     
  26. Offline

    Cognito guy

    Ah I liked the green +++++++++++++++++++++++++++
     
  27. Offline

    LeonidasPL

    Great plugin!
    I really like it!
    And I have posted static plugin link with token (Report a static update-plugin-link).
    Working very well.
     
  28. Offline

    stkeroro

    same error here
     
  29. Offline

    Cognito guy

    Can you add the option to delete an update from the list when you are sure there is no update?
     
  30. Offline

    RobotGymnast

    When I was developing a script to filter the plugin list, I found it worked well to pair the plugin name with the plugin's author. The only exception to this is WheresMyBones by DerHeiligste, which has two separate threads.
     

Share This Page