[INACTIVE][ADMN] BackupPlugin v0.8.5 (Backups & Maps)

Discussion in 'Inactive/Unsupported Plugins' started by MysticX, Jan 17, 2011.

  1. Offline

    MysticX

    I finally managed to port my BackupPlugin to Bukkit.
    You can find the original thread at Hey0's forum

    There are some changes and issues with porting to Bukkit:
    Console commands won't work at all, also the plugin does not force a world save nor disables saving for the progress of backuping! This will be fixed when it's possible to access console commands with Bukkit.
    Also there are some new config options. As there is currently no user rights management, you need to specify all authorized users in the config. Also you now need to set your world name in there.

    All other parts of the plugin haven't changed (especially automatic backups and ingame commands are working), so expect the same bugs/issues! Feel free to modify my work if you want and can, because I can't actively develop for some weeks, so don't expect big updates from me. But I know there are other talented plugin developers out there :)


    BackupPlugin v0.8.5

    This plugin allows you to create world backups or to generate world maps automatically or via ingame command.

    Commands
    • /backup <force> (optional) - backups your world data
    • /map <force> (optional) - generates map(s) of your world
    • /breload - reloads BackupPlugin configuration file
    • /loglevel <level> - sets log level
    Valid arguments for force are true & false. Using a command with true will result in a forced cache rebuilt, useful if you want to avoid the cache-lifetime for any reason.
    Valid arguments for log level are FINEST, FINE, INFO, WARNING or SEVERE (case sensitive!), default is INFO. FINE & FINEST will generate debug output.
    Valid arguments for time unit are SECONDS, MINUTES, HOURS, DAYS (case sensitive!), default is MINUTES.


    Properties

    This plugin will generate a properties file in your server home (BackupPlugin.properties)
    Here are two examples:

    Standard properties file (for mcmap): here
    My properties file (for c10t): here


    Version History
    • v0.8.5
    • v0.8.4
      • fixed issues with user rights
    • v0.8.3
      • ported to Bukkit
      • added config option for world name
      • added config option authorized-users, separate names with semicolon
      • changed first-run pattern to HHmm (removed the colon!)
      • auto-save while doing backups won't work for now
      • console commands also won't work
    • full version history
    Future Updates
    Known Issues / Bugs
    • spaces in folder structure will lead to fail of mapping!
    • windows paths only work if double backslash is used (for example C:\\temp\\world-maps\\ )
    • 0 byte zips sometimes
    • fail of backup because of tmp_chunk.dat (will be fixed in a future bukkit version)
    If you find something that's not working, please set loglevel to FINEST and paste your server logs along with the BackupPlugin.properties here in this thread, or send it to me via pm. Also it would help to know your OS and java version. I'll probably look into it then!


    License

    [​IMG]
    BackupPlugin by MysticX is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License.

    Source codes are included in the jar file.


    Download

    As usual: This plugin is still beta and could behave unexpected or corrupt your world backups. So please do a manual backup of your world before using it!

    Plugin
    Recommended mapping tools
     
  2. Offline

    Pencil

    So do i have to use a mapping tool or can I use this for just backing up my entire world every x time (once it works) or via the ingame command?
     
  3. Offline

    MysticX

    Just set automap-period to 0 or give an invalid mapper path, and it will disable automatic mapping.
     
  4. Offline

    Pencil

    Sweet :D Gonna install it now :)

    EDIT:

    Okay :) Works nicely. Does what it's supposed to do.
     
  5. Offline

    SBD09

    Thanks works just fine keep up the good work
     
  6. Offline

    jududdar

    Works great! Finally have the server backing up to DropBox again. Thanks a million for this!

    Okay, here is the log from the server console(attached). I'm almost positive I've missed something, or "doing it wrong." I can't figure out what I am doing wrong, though. I will update this after next backup tries to run so I can get the log level to finest. Manually backing up works perfectly, and SUPER fast. When the auto-backup tried to run, it did create a properly named .zip file in the correct directory, but it was a zero byte file. Below is a paste of my properties file and some info about my server:

    OS: Windows Server 2000 Advanced
    Java: 1.6.0_23

    #BackupPlugin Config File
    #Mon Jan 17 15:09:16 EST 2011
    level-name=world
    automap-period=0
    time-unit=MINUTES
    mapper-executable=mcmap\\mcmap.exe
    backup-history=5
    authorized-users=jududdar
    use-latest=false
    log-level=FINEST (recently added this)
    map-path=world-maps
    map-options=-png -file $o $w;-night -png -file $o $w
    backup-path=C:\\BukkitTest\\world-backups\\Dropbox
    first-run=1200
    autobackup-period=120
    cache-lifetime=30
     

    Attached Files:

    Last edited by a moderator: May 6, 2016
  7. Offline

    MysticX

    I'm afraid this error will just happen some times until we can perform console commands with the Bukkit API. I think it's happening because the world is changing (or a world part hasn't been saved to disk yet) while the backup process is running. This could be prevented with the sequence "save-all" - "save-off" - backup - "save on", that's how I used to fix it in the version for Hey0's Mod.

    But sometimes there will be generated an invalid zip files anyway, didn't have the time to figure out what's going wrong there. Another reason why I should implement a backup integrity check sometimes..

    But thanks for your feedback =)
     
  8. Offline

    jududdar

    Sure, I'm fine with manually doing it for now. Not really a huge deal as we all play at the same time anyhow ;) Thanks for the quick reply!
     
  9. Offline

    TnT Retired Staff

    I love this plugin, and I hope I'm not being a jerk by asking, but is it possible to split up the two functions? I really like using the mapping feature, but I've already handled backups separately. I know the combination of the two isn't exactly overloading my server, but you know... efficiency and all that.
     
  10. Offline

    talbot

    so i'm confused. if console commands don't work at all then how can this function? if i want it to run every hour i just set "autobackup-period" to 60 and hope it works? and if it is set to 60 does that mean every hour at 00 minutes? or when the plugin was launched? or from the value in "first-run"?

    i know it's not your fault commands don't work right, and i'm not blaming you, just need some help understanding.
     
  11. Offline

    TnT Retired Staff

    From the value in "first-run" - for example, every 60 with a first-run of 1200, will give you backups at every hour, on the hour. Check your server console to see it working.
     
  12. Offline

    Starrk

    Omg. All these great plug-ins are coming out today. This is the day Bukkit evolves!

    Thanks!

    EDIT : I installed it and everything and do /backup but nothing happens. Any help?
     
  13. Offline

    mark_Dano_4936

    Update to latest BUKITT?
     
  14. Offline

    talbot

    commands don't work. he said so in the first post. you just have to rely on the config file. see his answer to my question.
     
  15. Offline

    Sharpiedew

    Your not a plugin dev.? theres like 5 plugin devs. for the website that havent released anything! Great plugin man. Not bashing on them just complementing you.
     
  16. Offline

    MysticX

    I originally wrote the plugin for myself, because there was no other backup plugin available. Then I also wanted to generate maps, so I included this function. Both Units (Mapping & Backup) depend on a "cache" (copy of your world), that's why I didn't bother to split them so far.
    It shouldn't be hard to make two standalone versions though. Maybe I feel like changing this when I find the time. But the plugin won't use any additional cpu power if you disable the automatic backups. It will take slightly more RAM then a standalone mapper, but this value should be really insignificant, as it is exactly one java object more. Maybe it's even easier just not to initialize the backup unit if the function is disabled, then there would be really no difference anymore.


    You got me wrong there. You can trigger the ingame commands (chat commands) just fine. You just can't trigger anything from within the server console, how it used to be in the Hey0 version. The backup itself is independent from any server commands (except save-all, save-off, save-on -> see post #8) and will run nevertheless.


    I need to see logs and your config, as stated in the original post. It's pretty difficult to help, if you have NO information at all.


    Works fine as of now.


    Thank you very much :)
    I don't even know how to get the title of a plugin developer.. well, actually I see myself as an plugin dev regardless of a title ;)
     
  17. Offline

    Galrath

    Like your plug-in, just a question about the mapping part: Is it possible to add more options to it? I'd really like pictures from all four directions made every time. Maybe it's possible already, but I'm too dumb to figure it out [​IMG]
     
  18. Offline

    MysticX

    Yes, thats possible. Have a look into my example configuration for c10t, I'm generating 4 different maps there. You can define as many mapping parameters as you want, just separate them by a semicolon!
    It's the same schema for any (commandline-)mapper you wish to use :)
     
  19. Offline

    talbot

    oh. crap, sorry about that. then i guess i should report the same issues as starrk. none of he commands worked in-game and didn't report any errors, i have the "unknown sources" messages off by default, and i'm looking through my logs but not seeing anything. i'll do a proper test tomorrow, my server is undergoing maintenance.
     
  20. Offline

    MysticX

    Ok, alright. Then please try again with newest bukkit version and a debug log level in your config (FINEST will do). Also, do you use any other plugins? Especially any chat plugins which could intercept the commands?
    And, have you specified your nickname in the authorized-users section of the config (case-sensitive!)?

    I've just tested it with the newest version with scrapbukkit, MinecartMania, SimpleHome and BackupPlugin enabled.
     
  21. Offline

    Jobsti

    Hi, thanks for one of my fav plugins.

    Plugins works on #80, BUT I can't trigger commands in the ingame-chat.
    Permissions are set in the cfg. My Name, no spaces etc...

    On Serverstart, console says: mapperunit next run:102 minutes... BUT I set it to 5 in the config.
    Backupunit too.

    Edit:
    Ohhhhh. wait.... it's any other plugin. I'll find it out!
     
  22. Offline

    MysticX

    Can you post the whole log and config?

    Loglevel FINEST and try to issue an ingame command. Then I can maybe see whats failing there
     
  23. Offline

    Jobsti

    It's NO other Plugin.
    Only one User to the "authorized-users" and no comma behind.
     
  24. Offline

    Galrath

    Thanks for the answer, but...which of those commands does that? :D
    I'm using mcmap, btw.
     
  25. Offline

    MysticX

    Ok, I did some more testing and the user rights seem to be bugged somewhere. Give me some minutes and i'll try to fix it.

    Try this:
    Code:
    map-options=-png -west -file $o $w;-png -east -file $o $w;-png -north -file $o $w;-png -south -file $o $w
     
  26. Offline

    Jobsti

    If you want, use GroupUsers.... would be nice.
     
  27. Offline

    MysticX

    Here is a version with GroupUsers support, but it is untested, as I can't log into minecraft atm: BackupPlugin v0.8.5

    It will (hopefully) fall back to the own config if it can't find the GroupUsers Plugin.
     
  28. Offline

    Jobsti

    I need coffee...

    If you (and me and all) can't log in, try "offline" mode in client and server.props. (If you have a LAN Server)
     
  29. Offline

    MysticX

    Yes, I just tested it locally and it seems to work fine with and without GroupUsers Plugin (v1.4.1)

    Coffee is an excellent idea. I'll grab some, and then i'm off to some real work ;)
     
  30. Offline

    Galrath

    Thank you very much, works fine :)
     

Share This Page