[INACTIVE] Administrate 1.3.2 - Invis/Vanish, NoPickup, God, Stealth, Fakelog, Teleport, Heal [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Sleaker, Jul 5, 2011.

  1. Offline


    Administrate just squelches the login messages that bukkit generates, it wont squelch anything that other plugins do.
  2. Offline


    great plugin, sadly it doesnt always seem to work, specially with TPing,.
  3. Offline


    It would be nice if you could add links for all the required plugins
  4. *nod* After talking with the dev for LoginMessage, I have a better understanding of how it all works. I'm told the next version should have a way to keep it from happening.
  5. Offline


    yo when i install amdinstrate.jar and vault.jar it doesnt seem to work, u type in a cmd in and it says the cmd u just typed in... cb version: git-bukkit-0.0.0-980-g43d23b1-b1060jnks
    perms: op.txt
  6. Offline


    doesn't this plugin support spout?
  7. Offline


    Same error. Is this something to do with having JRE 1.7? I haven't tested this yet, but I already posted an issue on github. That's my running theory. I'm not entirely sure how to downgrade java, but i've already tried the trio on a plain vanilla bukkit 1060 and I get the same error.

  8. Offline


    New update. I guess I wasn't running 1.7...i'm using 1.6.0_26. SHOULD i use 1.7?

    I went through your builds to see when the issue was...and it seems of all your 'starred' builds b20 seems to be the last one that will work without that error. Vault worked at every build up to 43 (in the zip package). I'm still trying to see which whosthere will work with b20
  9. Offline


    when i join the console shows this:
    Show Spoiler

    2011-09-04 22:27:45 [SEVERE] Could not pass event PLAYER_JOIN to Administrate
    java.lang.NoSuchMethodError: com.nijiko.permissions.PermissionHandler.has(Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;)Z
    at net.milkbowl.vault.permission.plugins.Permission_Permissions2.playerHas(Permission_Permissions2.java:98)
    at net.milkbowl.vault.permission.Permission.has(Permission.java:68)
    at net.milkbowl.administrate.AdminPermissions.has(AdminPermissions.java:41)
    at net.milkbowl.administrate.AdminPermissions.hasAny(AdminPermissions.java:54)
    at net.milkbowl.administrate.AdminPlayerListener.onPlayerJoin(AdminPlayerListener.java:52)
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:244)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:338)
    at net.minecraft.server.ServerConfigurationManager.c(ServerConfigurationManager.java:124)
    at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:97)
    at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:33)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    i cant exec any administrate cmd -.-
  10. Offline


    does it work with just the permissions.yml?
  11. Offline


    same here ...
  12. Offline


    WhosThere does not work if you do not use Perm2/3/GM/PEX - so no, it doesn't work with isOp or PermissionsBukkit. We're working on getting it fixed up but right now it's not fully in.
  13. Offline


    hello is this caused by this plugin?
    I can't teleport players via server console!
    09:47:05 [INFO] Console is not implemented for this command
    09:47:05 [INFO] /tp (playername | playername to playername | x y z )
  14. Offline


    Hmm, not working for me anymore, 1600 and 1.3.2. Any ideas?
  15. Offline


    The absence of a "toggle godmode on other users" function is a rather large problem with this plugin. Also, admin mode would best save the admin's inventory too, in case special administrative items need equipping before dishing out ownage on the populace.

    Otherwise, I think this plugin functions well, has good features (particularly love persistency between logins on the toggles) and is overall a great solution.
  16. Offline


    I agree.

    I hope this plugin is still supported, bcz I have problem with invisibility
    When I use /VANISH and I'll tepeleport to player he will see me (I think its happening when he is underground)
  17. Offline


    Hi, great plugin!

    Could you please get a NoPacket version working, there are WAY too many users that can see our staff that are using /vanish
    OR work with VanishNoPacket but keep the WONDERFUL ability to have /stealth /admin etc?

    Many Thanks!
  18. Offline


    this seems to be dead
  19. Offline


    IT worked fine until 1.8. Give him time to update. >.>

    Infact, there isn't even an RB of Bukkit yet.
  20. Offline


    Is it able to just move player into another group of Permissions?
  21. Offline


    kk is this plugin updated to 1.8?? now?
  22. Offline


    is this cool plugin gunna update to #1185 ? :)
  23. The current version seems to work fine for me on 1.8.1
  24. Offline


    I hear it works fine in 1185/1.8.1, but is there any plans to get an update out? :)

    EDIT: Just tried on my 1185 server. Got this error:
    15:29:33 [SEVERE] Could not load 'plugins\Administrate.jar' in folder 'plugins': Vault
    org.bukkit.plugin.UnknownDependencyException: Vault
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:133)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:213)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:136)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:138)
        at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:103)
        at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:52)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:136)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
  25. Per the first post:

    Download that bit and it will work.
  26. Offline


    Was not expecting a response that fast, haha. Thanks. I was to hooked on those AWESOME features.
  27. :) I just happened to be around the forum when you posted.

    And I know, this plugin is great. I don't know why so many people say it doesn't work with 1185, it's working just fine for me.
  28. Offline


    Are you planning to update it soon? I don't know what updating will bring but it would still be good, lol.

    Anyways, how do I set up Vault? It says I don't have the proper permissions for any of the commands and there is no Config for Vault.
  29. I would hope the dev will do so, if it's even needed. If nothing else, update the title to show that it does work with 1185 so the thread doesn't go inactive.

    As for the other question you removed:D, I just tested it and yes, if you go into stealth or admin mode, log out, and log back in, the game doesn't announce that you have logged back in.

    I didn't have to set up anything for Vault as all it did was add an API available for Administrate to use.
  30. Offline


    Haha, I hope so also.

    But yeah, when I try to use commands it says I don't have the right permissions.

Share This Page