[INACTIVE][ADMIN] MCStats v2.7 - Minecraft player statistics [868]

Discussion in 'Inactive/Unsupported Plugins' started by deltahat, Mar 15, 2011.

  1. Offline


    MCStats - Minecraft player statistics:
    Version: v2.7

    MCStats is a statistics plugin for the bukkit. MCStats periodically generates xml,
    json, js, and html files containing server statistics. Optionally, MCStats can also serve these files using an embedded web server. Using the embedded web server, the html stats report can be served directly from your Minecraft server. No need for messy apache installs.

    For group support to work you must also install and configure the Permissions plugin v2.5.4+.

    Please read the README - https://github.com/rmichela/MCStats2

    • Tracks many player statistics
    • Built in web server
    • Integrates with external systems using raw data feeds
    • Supports reading group affiliation from Permissions
    • Supports reporting iConomy account balances
    Download: https://github.com/rmichela/MCStats2/downloads
    Source: https://github.com/rmichela/MCStats2

    Changelog (open)

    Version 2.1
    • Initial port to bukkit
    Version 2.2
    • Fixed initial startup config issues. Now generates meaningful config when first initialized.
    • Fixed directory problems that forced files under Plugins directory
    Version 2.3
    Version 2.4
    • Added ignoreGroups config option
    Version 2.5
    • Fixed group name case problems
    • Created Ops group based on ops.txt
    • Only show groups player is explicitly assigned to
    • Embedded web server can now serve customized html report
    Version 2.5.1
    • Bukkit 602 support
    Version 2.6
    • Fixed bug where players in default group were erroneously ignored.
    • Fixed incompatibility with GroupManager FakePermission
    • Verified support with CB612, MC2.4, and Permissions 2.5.5
    Version 2.6.1
    • Fixed strange incompatibility with iConomy.
    Version 2.7
    • Fixed Permissions group loading bug
    • Fixed inaccurate step count bug
    • Added proper iConomy support
  2. Offline


    Remove the leading slash from resourceSaveDirectory in your config. As it stands, the plugin is trying to write to /var/www/, not plugins/MCStats2/var/www/. The leading slash makes the path an absolute path and not a path relative to the bukkit plugins directory.
  3. Offline


    Could you please update MCstats to Craftbukkit version 602? :)
  4. Offline


    MCStats v2.5.1 Released

    Compiled for 602. Will not work with pre 600 bukkit servers. No other fixes included. Those will come later.
  5. Offline


    Hehe :p Now I just need to wait for craftbukkit to support Minecraft 1.4
  6. Offline


    When removing the leading slash I got the following error.

    2011-03-31 13:42:16 [SEVERE] Illegal value for path or protocol loading MCStats2 v2.5 (Is it up to date?)
    java.lang.IllegalArgumentException: Illegal value for path or protocol
    at sun.net.httpserver.HttpContextImpl.<init>(HttpContextImpl.java:42)
    at sun.net.httpserver.ServerImpl.createContext(ServerImpl.java:174)
    at sun.net.httpserver.HttpServerImpl.createContext(HttpServerImpl.java:56)
    at sun.net.httpserver.HttpServerImpl.createContext(HttpServerImpl.java:21)
    at com.ryanmichela.MCStats2.StatsPlugin.onEnable(StatsPlugin.java:150)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:451)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:217)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:92)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:70)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246) at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)

    However when I typed the full path it got it working. Thanks a lot :)
  7. Offline


    You got that error because you changed the httpServerContextRoot. The quoted text above says only to change the resourceSaveDirectory. Your httpServerContextRoot was correct. Please check the README for more details on what each config option does.
  8. Offline


    Would it be possible for an option to display iConomy money?
  9. Offline


    deltahat, looks like your plugin will stick around with official stats being pushed back.

    I know you're most likely a busy busy man, but here's some suggestions that I'd like to see.

    * Updated to work on Minecraft 1.4 (if it doesn't already, can't upgrade to check yet)
    * Multiworld support, i can't run this plugin because we have a Nether world, and if anybody goes to the nether it lags the server out and dumps a HUGE amount of exceptions to the console, too much, too fast to even read!
    * Fixing the issues with new users not showing up, right now only users in our VIP and above groups show up, nothing in the "guests/default" group :(
  10. Offline


    I'll add them to my todo :)
  11. Offline


    Yes please do that! :D
  12. Offline


    i read that there is a posibility to post it to an url. please give me an example how i can do that.
  13. Offline


    MCStats 2.6 Released

    • Fixed MethodNotFoundError when using GroupManager instead of Permissions via FakePermission
    • Fixed players in default group not being added. Use the ignorePermissionlessPlayers to explicitly exclude them
    • Verified with CB 612, MC 2.5, and Permissions 2.5.5

    @CorneliousJD - I created a case on github for your issue with the Neither. I could not reproduce it. Can you please provide more details in the case?


    Set the httpPostUrl value in the config.yml. See the README for details.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  14. Offline


    yeah i read it else iwouldn't know it ;)
    but how do i get the post?
    i think there has to be a script which gets the data an saves it and i dont know how i can do that script
  15. I also have a problem with this plugin and the Nether. Running CB617 and MCStats 2.6. When I use a portal to travel to the Nether (I am using a custom fix of the plugin Nether) I get this message flash up.
    17:34:31 [INFO] NETHER_PLUGIN: BurnseyBoi used portal at (577, 105, -393) to NETHER world (73, 105, -50)
    17:34:32 [INFO] Loaded world: netherworld
    17:34:32 [SEVERE] Could not pass event PLAYER_MOVE to MCStats2
            at com.nijiko.permissions.Control.inSingleGroup(Control.java:545)
            at com.ryanmichela.MCStats2.service.GroupService.getGroups(GroupService.java:60)
            at com.ryanmichela.MCStats2.controller.StatsController.ignorePlayer(StatsController.java:168)
            at com.ryanmichela.MCStats2.controller.StatsController.travelAMeter(StatsController.java:74)
            at com.ryanmichela.MCStats2.controller.StatsPlayerListener.onPlayerMove(StatsPlayerListener.java:54)
            at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:205)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:255)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:128)
            at net.minecraft.server.Packet10Flying.a(SourceFile:126)
            at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    And then every time I move in the Nether it floods the console with cascades of this same message. This is my startup log.
    Minecraft Remote Toolkit V1.0_b18_3 ALPHA
    Loading toolkit properties...Done.
    Loading toolkit modules...Done.
    Wrapper is running on: Windows Server 2008 R2 6.1 amd64
    Starting wrapper...
    Starting UDP listen server on port 25561
    03-Apr-2011 17:32:25 net.wimpi.telnetd.net.PortListener run
    INFO: Listening to Port 25,561 with a connectivity queue size of 5.
    17:32:26 [INFO] Starting minecraft server version Beta 1.4
    17:32:26 [INFO] Loading properties
    17:32:26 [INFO] Starting Minecraft server on
    17:32:26 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-612-g4c7a9e7-b617jnks (MC: 1.4)
    17:32:26 [INFO] Preparing level "world"
    17:32:26 [INFO] Preparing start region
    17:32:27 [INFO] 144 recipes
    17:32:27 [INFO] Preparing spawn area: 20%
    17:32:29 [INFO] Starting Minequery server on
    17:32:29 [INFO] Invalid config file found and converted to proper name/format.
    17:32:29 [INFO] [Permissions] (Phoenix) was Initialized.
    17:32:29 [INFO] [MCStats] Loading MCStats
    17:32:29 [INFO] [MCStats] Restoring player statistics.
    17:32:29 [INFO] All items will be kept
    17:32:30 [INFO] [BBROTHER] BBData MySQL Driver r1 loaded!
    17:32:30 [INFO] [BBROTHER] refresh(): Environment#-1
    17:32:30 [INFO] [BBROTHER] Permissions enabled using: Permissions v2.5.5
    17:32:31 [INFO] [BBROTHER] 'Help' support enabled
    17:32:31 [INFO] [BBROTHER] BigBrother 1.7.2-SNAPSHOT enabled
    17:32:31 [INFO] [BukkitUp]: BukkitUp V.2.0 by Triii.ws, Now initialized & checking for updates....
    17:32:31 [INFO] [BukkitUp]: Server is up to date!
    17:32:31 [INFO] [Permissions] version [2.5.5] (Phoenix)  loaded
    17:32:31 [INFO] Loading map 'org.dynmap.flat.FlatMap'...
    17:32:31 [INFO] Loading map 'org.dynmap.kzedmap.KzedMap'...
    17:32:31 [INFO] Loading renderer 'org.dynmap.kzedmap.DefaultTileRenderer'...
    17:32:31 [INFO] Loading renderer 'org.dynmap.kzedmap.CaveTileRenderer'...
    17:32:31 [INFO] Activated world 'world' in Dynmap.
    17:32:31 [INFO] Loading map 'org.dynmap.flat.FlatMap'...
    17:32:31 [INFO] Loading map 'org.dynmap.kzedmap.KzedMap'...
    17:32:31 [INFO] Loading renderer 'org.dynmap.kzedmap.DefaultTileRenderer'...
    17:32:31 [INFO] Dynmap WebServer started on null:8123
    17:32:31 [INFO] [EpicZones] Created Zone [John's Arena]
    17:32:31 [INFO] [EpicZones] Created Zone [Treasure Room]
    17:32:31 [INFO] [EpicZones] Created Zone [Portal Hub]
    17:32:31 [INFO] [EpicZones] Created Zone [Leigh's House]
    17:32:31 [INFO] [EpicZones] Created Zone [Hell Hub]
    17:32:31 [INFO] [EpicZones] version 0.19 is enabled.
    17:32:31 [INFO] Loaded Essentials build 2.1.15 maintained by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    17:32:31 [INFO] plugins\Help\ExtraHelp\achievements.yml
    17:32:31 [INFO] plugins\Help\ExtraHelp\BigBrother.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\CraftBukkit.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\eadmin.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\echeats.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\eloc.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\emod.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\esocial.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\espawn.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\etele.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\stats.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\weclip.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\wegen.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\wehistory.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\wenav.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\wesel.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\wetool.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\weutil.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\worldedit.yml
    17:32:32 [INFO] plugins\Help\ExtraHelp\worldguard.yml
    17:32:32 [INFO] [HELP] 191 extra help entries loaded
    17:32:32 [INFO] [HELP] Permissions enabled using: Permissions v2.5.5
    17:32:32 [INFO] [HELP] Help 0.2.4 enabled
    17:32:32 [INFO] [HeroChat] HeroChat version 4.8.6 enabled.
    17:32:32 [INFO] [HeroChat] Permissions 2.5.5 found.
    17:32:32 [INFO] [HeroicDeath] enabled.
    17:32:32 [INFO] MCDocs - Permissions Detected!
    17:32:32 [INFO] MCDocs by Tazzernator (Andrew Tajsic) - version 5.2.4 is enabled!
    17:32:32 [INFO] [MCStats] Enabling MCStats
    17:32:32 [INFO] Memory max: 1069416448 bytes
    17:32:32 [INFO] Memory total: 116535296 bytes
    17:32:32 [INFO] Remote Toolkit Plugin V0.31b enabled!
    17:32:32 [INFO] Nether v1.3.2 enabled
    17:32:32 [INFO] Activated world 'netherworld' in Dynmap.
    17:32:32 [INFO] Nether: preloaded nether world [netherworld]
    17:32:32 [INFO] Done (0.630s)! For help, type "help" or "?"
    17:32:35 [INFO] [BBROTHER] Starting Cleanser thread...
    17:32:35 [INFO] [BBROTHER] Ending Cleanser thread...
    When I return to the normal world, the messages don't show up again until I return to the nether.
  16. Offline


    Yes. You need to write some software that can accept an HTTP post to the URL you provide.

    Make sure you are running the latest version of Permissions.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  17. Offline


    CB 620+ not work (
  18. Offline


    620+ aren't recommended builds yet :)

    I'll look into it. What error do you get?
  19. Offline


    I tried this:
    $data $_POST;
    $file fopen("mcstats.html","a+");
    but it doesn't work I get only a 1 and that all the time

    please help me
  20. I have Permissions 2.5.5 installed and I get no errors. Commands are allowed and denied as they should be.
  21. Offline


    So your problem with the Neither is fixed?
  22. Oh no, I meant that I have the latest Permissions installed and it doesn't throw any errors. Permissions work as expected in both worlds. But the console still gets flooded with those error messages every time someone moves in the Nether. Sorry for the confusion!
  23. Offline


  24. would be nice if this could show each players money (iConomy) (in the right currency)

    also, I use groupmanager (essentials version for now) with fakepermissions and on groups it only says ops on me and all others are empty :/
  25. Offline


  26. Offline


    Last edited by a moderator: May 12, 2016
  27. I fixed my problem I was having with the Nether spewing error messages. In the config file for my netherworld I had
            system: default
            copies: world
    which doesn't seem to have worked. So I copy-pasted the contents of world.yml into netherworld.yml and now it works fine :D Seems that either Permissions wasn't cloning the permissions, or wasn't reporting it properly. All sorted now through! Love this plugin! Extending my massive wall, so will be amusing to see how many blocks it takes!
  28. Offline


    Hi, i have a problem, i have not mcstats.config :\
  29. Offline


    Awesome! You should post a case in the Permissions thread with your problem and fix.

    MCStats generates a config.yml file in the Plugins/MCStats2 directory when you first start it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  30. Offline


    I'm getting masive dumps still... Running CB617 not 612 if it matters?

    I just get that OVER AND OVER again after a player logs in...
  31. Offline


Share This Page