I'm sorry, Dave, but I cannot let you do that.

Discussion in 'Bukkit Help' started by Wirsbo, Aug 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    The title says a line my bukkit-cmd keeps saying when I try to stop the server. Nobody could connect to the server (they could 10 minutes before I restarted the server and added the newest bukkit(1060)) so I tried to stop the server, but the cmd just said "I'm sorry, Dave, but I cannot let you do that."... This freaks me out, how should I now be able to play on my server with my friends? I really hope this will not affect the world and the plugins, as it took really long to set it up... How do I fix this? And why does this happen? Thanks. Oh, and also, weird stuff are going on in my server. Random sand-blocks spawns and animals attacks people, and people randomly sets on fire, does this have anything to do with it? If not, ignore the last lines xD


    EDIT: And my name is not Dave!
  2. Offline


    It means you're not an Op. It's happening to me too, but I don't use a console. This build seems a little buggy.
  3. Offline


    "I'm sorry Dave" is from the awesome movie 2001: A Space Odyssey. ^ do what that guy said.
  4. Offline


    Yeah, I've noticed a bit more...unusual command responses lately, especially in dev builds. Though your problem seems to be a bit more complex than that. Your world appears to be corrupt based off of the glimpse of an error at the top. Having any other issues with the server?
  5. Offline


  6. Offline


    Im trying to type "say something" from MCTelnet terminal and also got that. I cant talk from MCTelnet terminal anymore. Hope someone come with a fix.
  7. Offline


    I modified one of my singleplayer worlds with MCEdit and placed it in my bukkit directory, getting the same error messages....anyway to fix that?
  8. Offline


    im getting it to. Whenever i try to update my whitelist. using /whitelist add
    I am an op. I even try to do it in console and it doesnt let me
  9. Offline


    This bug is a bummer. I wouldn't recommend the latest recommended build (#1060), that is if you use any of the vanilla commands at all like say or whitelist.
  10. Offline


    same here
  11. Offline


  12. Offline

    G1R Productions

    This is stupid glitch ever i cant even stop my server. This error should be fixed asap as it is not something to be looked at lightly.
  13. Offline


    Guys this just means you dont have permission to use the command
  14. Offline


    no because I am an op, and ops have all permissions. I also gave myself all permissions in my permissions plugin. still no dice.
  15. Offline


    If the console has not the permission who has ?
  16. Offline


    Oh sorry didnt know you tried the console,well then i dont know because i dont have a problem with this sorry for false info
  17. Offline


    No problem, try to whitelist someone with the console, does this work ?
  18. Offline


    updating to build 1064 works and doesn't break any of the over 15 plugins that I use. problem solved.
  19. Offline


    I have this problem as well, but only for non-ops.. Ops and console works perfectly.
    However, it's plain embarrasing to have a message like that on a live server.

    I've tried both 1060 on which I first got it and also 1064 as suggested by Pirate43's.
    No difference between them.

    Any solution to this?
  20. Offline


    Also happens for some commands of my plugin on 1118 (1.8 build).

    Plugin checks if command sender is a player. If is, it will do player.hasPermissions check, otherwise it will always allow command.

    But i get this message even when typing commands from console. And I never print that text out and i doubt that bukkit itself should be printing it out for anything else than vanilla commands. And i same function for all commands, with only permission string changed. But still some commands work and some not,
Thread Status:
Not open for further replies.

Share This Page