Solved I'm Going Crazy Over This

Discussion in 'Plugin Development' started by Smeary_Subset, Oct 29, 2023.

Thread Status:
Not open for further replies.
  1. Offline

    Smeary_Subset

    The issue I am having makes absolutely no sense whatsoever. It's likely more an issue with the server than plugin development. So, I noticed recently that enemy mobs do not agro nor attack players, they just walk around like the players are not there. This happens in all the server's worlds.

    I did a ton of troubleshooting. I removed all my plugins. I took away my server.properties, Bukkit.yml, and spigot.yml and had it re-generate new ones. Only one thing worked: Changing the level world name from "lobby" to "world", which fixes the issue server wide.

    I have no idea how on earth this is possible, I am absolutely dumbfounded. It started when I was working on a minigame that involved custom path finders for Zombies (and only Zombies that spawn from the Minigame). These zombies are suppose to attack but they don't, and no enemies attack server wide. Again, I don't think this involves the plugin because, like I said before, I removed ALL my plugins and the issue persists.

    Does anyone have any ideas? I seriously have no idea how changing the level world has any bearing on this or what could have caused it in the first place. I haven't done any work in the server's files recently (like server.properties, Bukkit.yml or spigot.yml)

    Resolution: I cleared out my PlayerData folder. No idea why that worked.
     
    Last edited: Nov 9, 2023
  2. Offline

    timtower Administrator Administrator Moderator

  3. Offline

    Smeary_Subset

    im in survival
     
  4. Offline

    timtower Administrator Administrator Moderator

    Tried clearing the wold data? Or just make a second server in a different folder?
     
  5. Offline

    Smeary_Subset

    what part of the world folder should I delete?
     
  6. Offline

    timtower Administrator Administrator Moderator

    All of it
     
  7. Offline

    Smeary_Subset

    This seems to be happening on all my worlds, except when I generate new ones (I even tried generating a new world named "lobby"). So one of my plugins likely made some change en-mass to all the worlds. Are there any world configurations or game rules that would make this happen? I have tons of worlds I do not want to regenerate all of them.
     
Thread Status:
Not open for further replies.

Share This Page