I dont get it

Discussion in 'Bukkit Help' started by benthamanowns, Aug 7, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Full error:
    java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.kernel32
    at org.fusesource.jansi.internal.WindowsSupport.getConsoleMode<WindowsSupport.java:50
    at jline.WindowsTerminal.getConsoleMode<WindowsTerminal.java:176>
    at jline.WindowsTerminal.init<WindowsTerminal.java"80>
    at jline.TerminalFactory.create<Terminalfactory.java:93>
    at jline.TerminalFactory.get<TerminalFactory.java:151>
    at jline.console.ConsoleReader.<init><ConsoleReader.java:140>
    at jline.console.ConsoleReader.<init><ConsoleReader.java::126
    at net .minecraft.server.MinecraftServer.<init><MinecraftServer.java:94>
    at net.minecraft.server.MinecraftServer.main<MinecraftServer.java:624>
    at org.bukkit.craftbukkit.Main.main<Main:136>
    Press any key to continue . . .

    This error is caused by you not having Visual C++ 2008 Redistributable installed, or having the wrong version installed that matches your Java version.

    The version of Visual C++ 2008 Redistributable (x64 or x86) must match the version of Java you are using. If you are using Java x86 and have Visual C++ 2008 Redistributable x64 installed, it will not work. You must either use Java x64, or install Visual C++ 2008 Redistributable x86.

    Alternatively, add in the -nojline option which turns off jline.

    i tried your solution of making sure i have visual C++ and i even updated my java.
    i could run the craftbukkit-1.2.5-R1.0.jar just fine but it went bad after that update.
    any ideas?
  2. Offline


    Join the club, I used to be able to at least load the server with the new 1.3.1 but now I can't, I even tried their development builds and still nothing! what the heck is going on and why are we having so many problems?
  3. Offline


    i temporarily have the -nojline and it works.

    try this:
    @Echo OFF
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="64" "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xincgc -Xmx1024M -jar "craftbukkit-1.3.1-R1.0.jar" -nojline
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="86" java -Xincgc -Xmx1024M -jar "craftbukkit-1.3.1-R1.0.jar" -nojline

    other than doing that, idk what to do.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  4. Offline


    Doesn't work. :/ sorry.
  5. Offline


    works for me i was just letitng u know.
  6. Offline


    Hmm interesting... then I wonder if were just experiencing 2 different problems....
Thread Status:
Not open for further replies.

Share This Page