I can't connect to my server on my computer?(Time out)

Discussion in 'Bukkit Help' started by cole32547, Mar 5, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    cole32547

    Here's a play by play of what happens when I try to connect to my server off of the same computer it is running off of. I'm using the bukkit server on a mac.

    Screen Shot 2012-03-04 at 8.07.39 PM.png Screen Shot 2012-03-04 at 8.08.40 PM.png Screen Shot 2012-03-04 at 8.07.50 PM.png Screen Shot 2012-03-04 at 8.09.44 PM.png Screen Shot 2012-03-04 at 8.09.18 PM.png
     

    Attached Files:

  2. Offline

    nxgravity

    I'm getting the same error while trying to connect. It's a new server install with a fresh install of Windows 7 x64. I'm running from a client that is also Windows 7 x64. The Minecraft_Server.exe works fine, but when I try to run Bukkit, it errors out.
     
  3. Offline

    FXHNTR

    cole32547 & nxgravity

    Have you guys tried connecting via localhost?

    If you can connect with that and others can't connect via external IP, then it's an issue with the port-forwarding.

    If you can't connect with localhost, then please post a reply.
     
  4. Offline

    Exticede

    I can't connect via localhost.
    When logging in via the client, I see "Logging in" for about 30 seconds, the see "End of Stream".
    I've tried Opping myself as well.
    Is there something that needs to be done to my client in order to log in?
    I've tried using my local IP instead of 'localhost', does the same thing.
    Could it be that my Permissions file is empty still?

    Paste Server Log:

    2012-03-05 18:46:49 [INFO] This server is running CraftBukkit version git-Bukkit-1.1-R6-b1988jnks (MC: 1.1) (Implementing API version 1.1-R6)
    2012-03-05 18:47:02 [INFO] Done (13.223s)! For help, type "help" or "?"
    2012-03-05 19:01:08 [INFO] Reached end of stream
    2012-03-05 19:01:08 [INFO] /127.0.0.1:51639 lost connection
    2012-03-05 19:02:16 [INFO] Reached end of stream
    2012-03-05 19:02:16 [INFO] /127.0.0.1:51643 lost connection
    2012-03-05 19:02:21 [INFO] Reached end of stream
    2012-03-05 19:02:22 [INFO] /127.0.0.1:51646 lost connection
    2012-03-05 19:36:17 [INFO] CONSOLE: Stopping the server..
    2012-03-05 19:36:17 [INFO] Stopping server
    2012-03-05 19:36:17 [INFO] Saving chunks
     
  5. Offline

    FXHNTR

    Is your minecraft version 1.1 still?

    Can you post your server.PROPERTIES file?
     
  6. Offline

    Exticede

    #Minecraft server properties
    #Mon Mar 05 18:47:02 CST 2012
    allow-nether=true
    level-name=world
    enable-query=false
    allow-flight=false
    server-port=25565
    level-type=DEFAULT
    enable-rcon=false
    level-seed=
    server-ip=
    spawn-npcs=true
    white-list=false
    spawn-animals=true
    online-mode=true
    pvp=true
    difficulty=1
    gamemode=0
    max-players=20
    spawn-monsters=true
    generate-structures=true
    view-distance=10
    motd=A Minecraft Server

    2012-03-05 18:46:48 [INFO] Starting minecraft server version 1.1

    For those of us who have just started a server and cannot connect to it, most likely the problem is with our currnet Minecraft client build (1.2.3), and the current SUGGESTED Bukkit server build. (1.1) You need to go here to get the Bukkit 1.2.3 Server, but it's still in beta so be sure to back up your servers if you do in fact have anything to lose.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 24, 2016
  7. Offline

    FXHNTR

    And have you checked to make sure you have the same versions and that your ip's match and ports are forwarded correctly? that sounds like a port problem
     
  8. Offline

    ElDynamite

    In your first post it said the port was 25562, you might have changed that, but make sure it's 25565.
     
  9. Offline

    FXHNTR

    I was gonna say that too, but if you looked at his other snapshot, it shows that the port was open, so I figured it was okay.
     
  10. Offline

    Exticede

    From what I understand, the ports don't need to be forwarded if I'm connecting as local host, only if someone is using my external IP to try and connect to me.

    I found that the problem was a mix-match in versions. I had the most recent Minecraft Client 1.2.3 installed, and the Recommended build for Bukkit is 1.2, which is the one I quickly downloaded while in a hurry to set this thing up. I'm feeling kinda dumb right now. Thanks for the help guys.
     
Thread Status:
Not open for further replies.

Share This Page