Huge log spam about "Cant keep up..."

Discussion in 'Bukkit Help' started by Atomicbomb, Jan 2, 2013.

Thread Status:
Not open for further replies.
  1. Hi. My server is saying huge log of Cant keep up error:
    The same thing happend yesterday and i have increased the ram allocation also.

    My server is currently running on dedicated server (full root access for my self) with Ubuntu 12.04 Server LTS

    Intel i33.4+ GHz
    16gb RAM (Whole dedicated server)
    100/100 Internet speed
    My players are also lagging like hell so i need help badly :( (Server is 50 slot one)

    Here is also a copy of my start up script:
    Code:
    screen -S pe-minecraft java -Xmx5120M -Xms5120M -jar craftbukkit.jar
    
     
  2. Offline

    frdmn

    Take a look at this guide, perhaps this helps.
     
  3. Well i was hoping one for linux server...
     
  4. Offline

    frdmn

    It doesnt matter if Windows or if Linux... The arguments/parameters are the same.
     
  5. Still having some lag aprently and still getting same error.
     
  6. Offline

    frdmn

    Well, this "error" is actually pretty normal. Every server will have these entries somewhere in it's server.log as soon as there are some tick-delays... If it doesnt really "lag" i wouldnt worry about.
     
  7. Thank you very much! Wonderful guide, I am using this start up script now and it fixed my double java.exe problem! Also I noticed that the green signal bars on my users are almost all 100% filled, in comparison to the old setup where almost no one had a full bar. I just configured it, so I can't say much, but solving my problem is already good enough.
     
  8. Offline

    frdmn

    Glad i could help :)

    Just being curious: which parameters do you use now?
     
  9. Oops, messed up the post... Let's start over.

    After reading the breakdown of that script you linked, I decided I like all of it and just copied it. (except the garbage)

    It looks like this now:

    Code:
    @Echo OFF
    TITLE MINECRAFT-CRAFTBUKKIT
    START "MINECRAFT-CRAFTBUKKIT" /ABOVENORMAL /B java -server -Xmx6G -XX:PermSize=128m -XX:MaxPermSize=256m -XX:+DisableExplicitGC -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+UseNUMA -XX:+CMSParallelRemarkEnabled -XX:MaxGCPauseMillis=50 -XX:+UseAdaptiveGCBoundary -XX:-UseGCOverheadLimit -XX:+UseBiasedLocking -XX:SurvivorRatio=8 -XX:TargetSurvivorRatio=90 -XX:MaxTenuringThreshold=15 -XX:UseSSE=3 -XX:+UseLargePages -XX:+UseFastAccessorMethods -XX:+UseStringCache -XX:+UseCompressedStrings -XX:+UseCompressedOops -XX:+OptimizeStringConcat -XX:+AggressiveOpts -jar craftbukkit.jar nogui

    And this is how it used to look like with my old 'config':

    Code:
    @echo off
    java -Xmx30M -Xms30M -XX:MaxPermSize=40M -jar Minecraft_RKit.jar user:pass
    pause
    
    This linked to a plugin, using this config:

    Code:
    #Minecraft Remote Toolkit Properties File
    #Thu Jan 03 13:58:42 EET 2013
    forced-restart-delay=5m
    maximum-heap-size=4096M
    toolkit-autoshutdown-alerts=10m,5m,1m
    restart-on-severe-exception=false
    server-saveall-period=0
    extra-runtime-arguments=-Djline.terminal\=jline.UnsupportedTerminal
    force-save-on-restart=true
    server-heartbeat-threshold=1m
    server-restart-alerts=10m,5m,1m
    minecraft-server-jar=craftbukkit.jar
    initial-heap-size=1024M
    overridden-process-arguments=
    failed-heartbeat-restart-count=5
    filter-ansi-escape-codes=auto
    severe-exception-detection-level=1
    enable-jline=true
    server-arguments=--nojline,nogui
    toolkit-autoshutdown-delay=0
    server-restart-delay=5h
    import-properties=false
    

    Ignore the heap sizes, I tried changing them many times, eventually bugging it and having x2 java.exe processes.

    BTW, have you got an idea of how to apply auto restarts and saves w/o using any plugins? Can it be done in the .bat file?

    Oh, and the last strings for Java 6 optimization don't get used, I am with Java 7 and I believe they apply automatically.
     
  10. Offline

    ThedbCoders

    Already in the latests bukkit.yml
     
  11. Offline

    frdmn

    If you were on *nix you could use the inbuilt cronjobs to trigger a timed command to save or restart, but on windows i unfortunatly dont know how to do this with onboard utilties :/
     
  12. Got it working. I re-installed server and putted plugins what i need. Now it says like 1 timer day (due backup) but i can love with that :)
     
  13. Offline

    Kellamcraft

    Problem solved. Your not using 16gb or ram that you could use
    -Xms5120M In this line of code it is specifying that you only want to use 5120MB of ram not 16gb change is to 12g to fix you problem. Dont do 16 because you need a few to run the OS Hope this helps :)
     
  14. Offline

    LEOcab

    Wait a minute, actually. Some guru will pop up any moment now telling you not to use any of those extra parameters, with good reasons.
     
Thread Status:
Not open for further replies.

Share This Page